Subject: Re: [Nfvrg] Updated version of the NFVRG charter

From: <[email-masked]>
Date: Wed, 7 Jan 2015 07:29:33 +0000

I agree with this revision.
BC

De : Nfvrg [mailto:[email-masked]] De la part de DIEGO LOPEZ GARCIA
Envoyé : jeudi 25 décembre 2014 19:47
À : [email-masked]
Objet : [Nfvrg] Updated version of the NFVRG charter

Hi,

This is an updated version of the proposed NFVRG charter I shared with you a couple of weeks ago. I have tried to incorporate (and make compatible) all the comments received so far. Let me ask you again for an explicit agreement if you find this version acceptable, so we can hopefully start 2015 with a stable NFVRG.

Be goode and may the New Year be extremely goode to you all,

8<--

Network Function Virtualization Research Group (NFVRG)
Background
Network Function Virtualization (NFV) is a key emerging area for network operators, hardware and software vendors, cloud service providers, and in general network practitioners and researchers. This area requires exploring new directions and working collaboratively on how to create network services that utilize a virtualized infrastructure. Network functions that are traditionally implemented in dedicated hardware appliances will need to be decomposed and executed in software elements running on cloud-based infrastructures. One essential goal of this new approach is to reduce capital and operating expenditures for future deployments for networks and associated services. Another important goal is for the network operators to be able to offer value added cloud services to their customers. Finally, new business models will open for the provision of network services.
The technologies enabling the virtualization of network functions (NFs) are currently in an early stage, and they need researchers to develop new architectures, systems, and software, and to explore tradeoffs and possibilities for leveraging virtualized infrastructure to provide support for network functions. The Network Functions Virtualization Research Group (NFVRG) will bring together researchers and grow the community around the world in both academia and industry to explore this new research area. Beyond the direct activity through the IRTF collaboration tools it will organize research group meetings and workshops at premier conferences (such as IEEE ICC, IEEE Globecom) and inviting special issues in well-known publications.
The NFVRG will focus on research problems associated with NFV-related topics and on bringing a research community together that can jointly address them, concentrating on problems that relate not just to networking but also to computing and storage aspects in such environments. It is hoped that the outcome of the research will benefit research efforts in other groups within the IRTF (and especially the SDNRG) and standardization activities of IETF WGs (like the ones going in SFC). Specific results can also spawn activities via IRTF & IETF BoF meetings and/or provide useful input to other related efforts in the ETSI NFV ISG or other standards bodies.
Areas of Interest
* New network architectures based on virtualized network functions (VNFs), including NF building from virtualized components
* NFV challenges in various cloud architectures (e.g. VNF intra- and inter-cloud mobility)
* Network and service function chaining: architecture and implementation (e.g. automation of VNF chain building, chaining of VNFs and non-virtual NFs)
* Autonomous orchestration and optimization
* Requirements and mechanisms to ensure reliable virtual network functions and services, in particular in what relates to failure characterization and representation
* New operational models associated with NFV
* Infrastructure and NF description and programming (languages, APIs, frameworks for combined processing, network and storage programming, policy languages...)
* Coexistence with non-virtualized infrastructure and services
* Virtualized network economics and business modeling
* Security, trust and service verification
* Performance modeling
* Real-time big data analytics and data-centric management of virtualized infrastructure
* New application domains enabled by virtualized infrastructure and services, including use cases across heterogeneous infrastructures (wired, optical, cellular, satellite)
* End to end and system-wide optimization of compute, storage, network and energy efficiency
* Exploration of infrastructure and service abstractions enabled by virtualization
* Real-time and novel monitoring techniques (for performance guarantees, error and anomaly detection, smarter auto-scaling and optimization in general, etc.)
The group will report progress through its wiki and presentations at IETF and IRTF meetings. Relevant information and research developed by the research group will be submitted for publication as Experimental or Informational RFCs.
Near Term Work Items
The group shall focus on a concrete list of near-term work items. For each of the items mentioned below, the goal is to explore system architecture, optimization, and open interfaces across components, through experimental results, simulations, and/or real-world implementations.
1. Policy based Resource Management:
NFV Point of Presence (PoP) will be likely constrained in compute and storage capacity. Since practically all NFV PoPs are foreseen to be distributed, inter-datacenter network capacity is also a constraint. Additionally, energy is also a constraint, both as a general concern for NFV operators, and in particular for specific-purpose NFV PoPs such as those in mobile base stations. This work item will focus on optimized resource management and workload distribution based on policy.
2. Analytics for Visibility and Orchestration:
Network functions should be supportable on general purpose commodity hardware. Real-time monitoring and analytics providing insight into various components such as compute (e.g. dynamic CPU utilization), storage (e.g. dynamic capacity usage), network (e.g. dynamic bandwidth utilization), energy (e.g. dynamic power consumption) are key to not only providing visibility into the NFV infrastructure but also optimizing resource usage for the purposes of orchestration. This work item will contemplate techniques for the applicability of real-time analytics.
3. Virtual Network Function (VNF) Performance Modeling to Facilitate Transition to NFV:
When migrating from hardware network appliances, which are typically custom and monolithic, to virtualized software implementations running on commodity hardware a challenge which is often faced is the need for an equivalence model, especially in terms of performance. The work item will consider this modeling.
4. Service Verification w.r.t Security and Resiliency:
Reliability and security issues and relevant solutions related to the nature of VNFs are the objectives of this work item.
NFV configuration is expected to be dynamic especially in the edge NFV PoP where capacity is limited; a good example is the handling of viral events such as mobile gaming application. While autonomic networking techniques could be used to automate the configuration process including modular updates, one needs to take into account that incomplete and/or inconsistent configuration may lead to security and reliability issues.
Accidental failures or intentional events such as distributed denial of service (DDoS) attacks are 'familiar' threats that could compromise heavily the system, due to the dependency of NFV on a distributed infrastructure. Thus the use of VNFs may well introduce additional challenges to ensure the support of carrier grade reliability. In the event of network and/or service degradation or failure, there must be suitable coordination, fail-over, and recovery. These reliable NFV mechanisms will also need tools and mechanisms to deploy and manage capability, and close coordination with NFV resource management and performance analytics is also expected. Elasticity of VNFs entails dynamic scale up/down/out/in with awareness of the resiliency considerations, a new scope as compared to the monolithic implementation approach.
Furthermore, the envisaged deployment of arbitrary third-party VNF applications on the network infrastructure of service providers raises significant security concerns and poses challenges for VNF verification in terms of functionality, security and stability under well-defined procedures.
--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 14 Jan 2015 09:15:01 +0000

Hi,

one comment from the IAB/IESG discussion on chartering the RG was that it would be helpful if the charter text said something more about how the proposed research complements the current and future standardization plans of ETSI (rather than overlapping with them, which would be undesirable).

Many people are unclear about the differences between the IETF and the IRTF, and a new IRTF group on NFV might be misunderstood to be in conflict to ETSI, which is a perception that would be good to avoid and correct.

Lars

On 2014-12-25, at 19:46, DIEGO LOPEZ GARCIA <[email-masked]> wrote:
> • New network architectures based on virtualized network functions (VNFs), including NF building from virtualized components
> 
> • NFV challenges in various cloud architectures (e.g. VNF intra- and inter-cloud mobility)
> 
> • Network and service function chaining: architecture and implementation (e.g. automation of VNF chain building, chaining of VNFs and non-virtual NFs)
> 
> • Autonomous orchestration and optimization
> 
> • Requirements and mechanisms to ensure reliable virtual network functions and services, in particular in what relates to failure characterization and representation
> 
> • New operational models associated with NFV
> 
> • Infrastructure and NF description and programming (languages, APIs, frameworks for combined processing, network and storage programming, policy languages…)
> 
> • Coexistence with non-virtualized infrastructure and services
> 
> • Virtualized network economics and business modeling
> 
> • Security, trust and service verification
> 
> • Performance modeling
> 
> • Real-time big data analytics and data-centric management of virtualized infrastructure
> 
> • New application domains enabled by virtualized infrastructure and services, including use cases across heterogeneous infrastructures (wired, optical, cellular, satellite)
> 
> • End to end and system-wide optimization of compute, storage, network and energy efficiency
> 
> • Exploration of infrastructure and service abstractions enabled by virtualization
> 
> • Real-time and novel monitoring techniques (for performance guarantees, error and anomaly detection, smarter auto-scaling and optimization in general, etc.)
> 
> Accidental failures or intentional events such as distributed denial of service (DDoS) attacks are ‘familiar’ threats that could compromise heavily the system, due to the dependency of NFV on a distributed infrastructure. Thus the use of VNFs may well introduce additional challenges to ensure the support of carrier grade reliability. In the event of network and/or service degradation or failure, there must be suitable coordination, fail-over, and recovery. These reliable NFV mechanisms will also need tools and mechanisms to deploy and manage capability, and close coordination with NFV resource management and performance analytics is also expected. Elasticity of VNFs entails dynamic scale up/down/out/in with awareness of the resiliency considerations, a new scope as compared to the monolithic implementation approach.
> 
> http://people.tid.es/diego.lopez/ <http://people.tid.es/diego.lopez/>
> 
> e-mail: [email-masked]
> Tel:    +34 913 129 041
> Mobile: +34 682 051 091
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Wed, 14 Jan 2015 10:42:12 +0000

Hi,

On 14 Jan 2015, at 10:15 , Eggert, Lars <[email-masked]<mailto:[email-masked]>> wrote:

I agree this is a extremely relevant point. I have tried to address it in the following text (changes marked in red)

Be goode

The NFVRG will focus on research problems associated with NFV-related topics and on bringing a research community together that can jointly address them, concentrating on problems that relate not just to networking but also to computing and storage aspects in such environments. It is hoped that the outcome of the research will benefit research efforts in other groups within the IRTF (and especially the SDNRG) and standardization activities of IETF WGs, like the ones going in SFC. Specific results can also spawn activities via IRTF & IETF BoF meetings and/or provide useful input to other related efforts in other standard bodies. In particular, the NFVRG will contribute research findings to the standardization efforts in the ETSI NFV ISG, providing exploratory guidance and experimental evidence.

Dr Diego R. Lopez
Telefonica I+D