Subject: [Nfvrg] [Fwd: I-D Action: draft-bernardos-nfvrg-gaps-network-virtualization-01.txt]

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Mon, 13 Jul 2015 15:36:31 +0200

Hi guys,

We have submitted an I-D that tries to overview the different efforts
around network virtualization at IETF/IRTF, as well as identify gaps
that are worth being tackled.

Comments would be very much welcome! We are looking forward to
discussion before Prague (where we will also present the draft).

Thanks!

Carlos, on behalf of all the co-authors of the draft

Subject: I-D Action: draft-bernardos-nfvrg-gaps-network-virtualization-01.txt
From: [email-masked]
To: <[email-masked]>
Date: Mon, 06 Jul 2015 13:50:41 -0700
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Gap Analysis on Network Virtualization Activities
        Authors         : Carlos J. Bernardos
                          Akbar Rahman
                          Juan Carlos Zuniga
                          Luis M. Contreras
                          Pedro Aranda
	Filename        : draft-bernardos-nfvrg-gaps-network-virtualization-01.txt
	Pages           : 22
	Date            : 2015-07-06

Abstract:
   Network Function Virtualization (NFV) and Software Defined Networking
   (SDN) are changing the way the telecommunications sector will deploy,
   extend and operate their networks.  These new technologies aim at
   reducing the overall costs by outsourcing communication services from
   specific hardware in the operators' core to server farms scattered in
   datacenters (i.e. compute and storage virtualization).  In addition,
   the connecting networks are fundamentally affected in they way they
   route, process and control traffic(i.e. network virtualization).

   Virtualization is becoming a trend which is being adopted in many
   scenarios for different purposes.  This document overviews existing
   efforts around virtualization at the IETF/IRTF, focusing on those
   related to NFV and SDN.  These efforts are mapped to the most
   relevant architectures being defined outside IETF, namely at the ETSI
   NFV ISG, the ETSI MEC ISG and the ONF.

   The main goal of this document is to serve as a survey of the
   different efforts that have been taken and are currently taking place
   at IETF and IRTF in regards to network virtualization, putting them
   into context considering efforts by other SDOs, and identifying
   current gaps that can be tackled at IETF or researched at the IRTF.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-bernardos-nfvrg-gaps-network-virtualization/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-bernardos-nfvrg-gaps-network-virtualization-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-bernardos-nfvrg-gaps-network-virtualization-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Tue, 14 Jul 2015 16:01:03 +0200

Hi Carlos,
Thanks for compiling this review!
I think it is quite helpful and supportive in further discussion.
Some minor remarks though:

1.  Introduction
... some network operators are now following a cloud computing
   paradigm, enabling the reduction of the overall costs by outsourcing
   communication services from specific hardware in the operator's core
   to server farms scattered in datacenters 

=> I have been trying to find proofs for this common opinion for years but have not yet been successful so far. Do you have a reference for this? I would be fine with adding  "potentially" ;-)

2.  Terminology

=> Wouldn't it make sense to add a sentence also for OFP and vEPC such as

OFP: allowing vendor independent programming of control functions in network nodes
vEPC: control plane of 3GPPs EPC operated on NFV framework (as defined by https://tools.ietf.org/html/draft-bernardos-nfvrg-gaps-network-virtualization-01#ref-I-D.matsushima-stateless-uplane-vepc)   

3.  Background

=> You might add references for NFV and ONF here e.g. the well-known WP at https://portal.etsi.org/NFV/NFV_White_Paper2.pdf or similar ...

5.  Summary of Gaps

Potential Gap-8: => This may be deleted as it equals Potential Gap-4 ;-)

Potential Gap-10: => becoming Potential Gap-9 -  here you may add the "Traffic Engineering Architecture and Signaling (TEAS) WG" for consistency

... perhaps I might have missed something - let's discuss further in Prague ;-)

Thanks again for the effort to all authors!

Best Regards
Dirk 

----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
Sent: Montag, 13. Juli 2015 15:37
To: [email-masked]
Subject: [Nfvrg] [Fwd: I-D Action: draft-bernardos-nfvrg-gaps-network-virtualization-01.txt]

Hi guys,

We have submitted an I-D that tries to overview the different efforts around network virtualization at IETF/IRTF, as well as identify gaps that are worth being tackled.

Comments would be very much welcome! We are looking forward to discussion before Prague (where we will also present the draft).

Thanks!

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 14 Jul 2015 16:15:18 +0200

Hi Dirk,

Thanks a lot for your comments. Comments inline below...

On Tue, 2015-07-14 at 16:01 +0200, [email-masked] wrote:
> => I have been trying to find proofs for this common opinion for 
> years but have not yet been successful so far. Do you have a 
> reference for this? I would be fine with adding  "potentially" ;-)

[Carlos] :) :) :) :) Good point. As far as I know (maybe my co-authors
can also comment on this :D), many operators have very aggressive plans
on moving forward towards virtualization. But I think it is fine to add
"potentially".

> vEPC: control plane of 3GPPs EPC operated on NFV framework (as 
> defined by https://tools.ietf.org/html/draft-bernardos-nfvrg-gaps
> -network-virtualization-01#ref-I-D.matsushima-stateless-uplane-vepc) 
>   ;
> 

[Carlos] Yes, thanks. We'll add them in -02.

> 3.  Background
> 
> => You might add references for NFV and ONF here e.g. the well-known 
> WP at https://portal.etsi.org/NFV/NFV_White_Paper2.pdf or similar ...
> 

[Carlos] OK, good point. We'll do it.

> Potential Gap-8: => This may be deleted as it equals Potential Gap-4 

[Carlos] Ooooops, copy&paste error. Thanks!

> 
> Potential Gap-10: => becoming Potential Gap-9 -  here you may add the 
> "Traffic Engineering Architecture and Signaling (TEAS) WG" for 
> consistency

[Carlos] OK, good.

> ... perhaps I might have missed something - let's discuss further in 

Sure! thanks a lot for your comments.

Carlos

> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg

---

From: Rafa Marin Lopez <[email-masked]>
Date: Wed, 15 Jul 2015 19:13:39 +0200

Hi Carlos:

Thanks for this draft. This is a really interesting document since it provides a good overview about what could be done in different areas of work within the IETF/IRTF around NFV and SDN. At least it was of help for me. 

I have only two minor comments:

First is that it may be interesting for you to check the work done by ITU-T in the line of your draft and how your draft can complement this information.

http://www.itu.int/en/ITU-T/jca/sdn/Documents/deliverable/Free-download-sdn-roadmap.docx

Second is that you mention several times "mobile network virtualization (NFV)". Is that a typo or are you trying to refer something?

Best Regards.

El 13/07/2015, a las 15:36, Carlos Jesús Bernardos Cano <[email-masked]> escribió:

> De: [email-masked]
> Asunto: I-D Action: draft-bernardos-nfvrg-gaps-network-virtualization-01.txt
> Fecha: 6 de julio de 2015 22:50:41 GMT+2
> Para: <[email-masked]>
> Responder a: [email-masked]
> 
> 
> 

-------------------------------------------------------
Rafael Marin Lopez, PhD
Dept. Information and Communications Engineering (DIIC)
Faculty of Computer Science-University of Murcia
30100 Murcia - Spain
Telf: +34868888501 Fax: +34868884151 e-mail: [email-masked]
-------------------------------------------------------

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 16 Jul 2015 16:43:02 +0200

Hi Rafa,

Thanks a lot for your comments. Please see inline below.

On Wed, 2015-07-15 at 19:13 +0200, Rafa Marin Lopez wrote:
> Hi Carlos:
> 
> Thanks for this draft. This is a really interesting document since it 
> provides a good overview about what could be done in different areas 
> of work within the IETF/IRTF around NFV and SDN. At least it was of 
> help for me. 
> 
> First is that it may be interesting for you to check the work done by 
> ITU-T in the line of your draft and how your draft can complement 
> this information.
> 

[Carlos] Thanks for the pointer. We'll take a look at it.

> 
> Second is that you mention several times "mobile network 
> virtualization (NFV)". Is that a typo or are you trying to refer 
> something?

[Carlos] It is kind-of a typo. It is mainly caused because we plan to
use the case of a mobile network as an example to illustrate the gaps
that need to be addressed concerning network virtualization tools.
We'll fix this in the next revision of the draft.

Thanks!

Carlos