Subject: [Nfvrg] New near-term work items for NFVRG

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Mon, 20 Jun 2016 20:52:33 +0000

Hi,

As discussed in Buenos Aires, we’d like to formally propose to change the list of near-term items that NFVRG is considering into the following:

* Policy-based resource management
> NFV Points of Presence (PoPs) will be likely constrained in compute and storage capacity. Since practically all NFV PoPs are foreseen to be distributed, inter-datacenter network capacity is an additional constraint as well. Additionally, energy consumption needs to be bounded, both as a general concern for NFV operators, and in particular for specific-purpose NFV PoPs such as those in mobile base stations. Given these constraints and the highly complex and dynamic nature of the NFV environment, optimized resource management based on policy is a key factor for NFV deployments.

* Analytics for visibility and orchestration
> In the spirit of NFV, network functions should be supportable on general purpose commodity hardware. Real-time monitoring providing insight into various components such as compute, storage, network, energy, and issues related to the cross-interactions among the deployed VNFs are key to not only providing visibility into the NFV infrastructure but also optimizing resource usage for the purposes of orchestration, by means of techniques applying real-time analytics

* Security and service verification
> Driven by on-demand service offerings, NFV configuration is expected to be dynamic especially in the edge NFV PoP where capacity is limited. While autonomic networking techniques could be used to automate the configuration process including modular updates, it must be taken into account that incomplete and/or inconsistent configuration may lead to security and reliability issues. In the event of network and/or service degradation or failure, there must be suitable coordination, fail-over, and recovery. These reliable NFV mechanisms will also need tools and mechanisms to deploy and manage capability, and close coordination with NFV resource management and performance analytics is also expected. Elasticity of VNFs entails dynamic scale up/down/out/in that must be aware of general resiliency considerations. Finally, the envisaged deployment of arbitrary third-party VNF applications on the network infrastructure of service providers raises significant security concerns and poses challenges for VNF verification in terms of functionality, security and stability under well-defined procedures.

* Reliability and fault detection
> Fault detection and isolation is a complex problem in the well-known non-NFV network deployments, and it becomes of at least an additional order of magnitude by the introduction of additional root causes for possible faults (hypervisors, containers, underlying infrastructure network, multi-vendor hardware etc.) and the dynamic nature of the NFV environment. In addition to addressing these challenges, a re-interpretation of the current practices in existing infrastructures is necessary, so fault detection becomes effective in mixed NFV and non-NFV networks, that will be the most common deployment in the foreseeable future.

* Service orchestration and lifecycle aspects
> E2E service is the ultimate goal of any network technology, and NFV deployments must address these aspects to become part of the common practice of network programmers, designers and operators, leveraging commonalities with current cloud infrastructures. All aspects related to service operation and management must be considered, and in particular those that constitute the differentiation of NFV technologies  with respect to current non-NFV network deployments: descriptors and description artifacts, the integration with SDN design patterns, the applicability of DevOps and continuous integration, and the new FCAPS aspects induced by virtualization. Finally, the impact and advantages of new proposals around network management and operation, such as autonomic approaches and intent-based networking must be addressed as well.

* Real-time properties
> While there is sufficient evidence that VNFs can provide an acceptable performance in practically all environments in which their application has been considered, there are still significative challenges regarding the monitoring, enforcement and management of real-time services based on NFV (a couple of examples could be VoLTE or augmented reality), and how the orchestration of these services has to be performed in order to guarantee those properties,not only at the initial deployment, but during the whole lifetime of the service.

> While there is sufficient evidence that VNFs can provide an acceptable performance in practically all environments in which their application has been considered, there are still significant challenges regarding the monitoring, enforcement and management of real-time services based on NFV (a couple of examples could be VoLTE or augmented reality), and how the orchestration of these services has to be performed in order to guarantee those properties, not only at the initial deployment, but during the whole lifetime of the service.

The plan is to update the NFVRG description (specifically, the one under “Near-Term Work Items” in https://irtf.org/nfvrg) accordingly in one week’s time, once you have expressed your comments, concerns, and/or support.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: <[email-masked]>
Date: Sat, 25 Jun 2016 14:24:58 +0000

A gentle reminder for any comments.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Monday, June 20, 2016 1:53 PM
To: [email-masked]
Subject: [Nfvrg] New near-term work items for NFVRG

Hi,

* Real-time properties

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------