Subject: [Nfvrg] FW: New Version Notification for draft-natarajan-nfvrg-containers-for-nfv-03.txt

From: <[email-masked]>
Date: Fri, 8 Jul 2016 13:23:29 +0000

The latest draft discusses the applicability of multiple light-weight virtualization technologies, beyond containers, for NFV.

Looking forward to your comments.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 08, 2016 6:21 AM
To: [email-masked]; Krishnan, Ramki <[email-masked]>; Ashay Chaudhary <[email-masked]>; Dilip Krishnaswamy <[email-masked]>; Peter Willis <[email-masked]>; Felipe Huici <[email-masked]>; Sriram Natarajan <[email-masked]>; Anoop Ghanwani <[email-masked]>; Krishnan, Ramki <[email-masked]>
Subject: New Version Notification for draft-natarajan-nfvrg-containers-for-nfv-03.txt

A new version of I-D, draft-natarajan-nfvrg-containers-for-nfv-03.txt
has been successfully submitted by ram krishnan and posted to the IETF repository.

Name:		draft-natarajan-nfvrg-containers-for-nfv
Revision:	03
Title:		An Analysis of Lightweight Virtualization Technologies for NFV
Document date:	2016-07-08
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/internet-drafts/draft-natarajan-nfvrg-containers-for-nfv-03.txt
Status:         https://datatracker.ietf.org/doc/draft-natarajan-nfvrg-containers-for-nfv/
Htmlized:       https://tools.ietf.org/html/draft-natarajan-nfvrg-containers-for-nfv-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-natarajan-nfvrg-containers-for-nfv-03

Abstract:
   Traditionally, NFV platforms were limited to using standard
   virtualization technologies (e.g., Xen, KVM, VMWare, Hyper-V, etc.)
   running guests based on general-purpose operating systems such as
   Windows, Linux or FreeBSD. More recently, a number of light-weight
   virtualization technologies including containers, unikernels
   (specialized VMs) and minimalistic distributions of general-purpose
   OSes have widened the spectrum of possibilities when constructing an
   NFV platform. This draft describes the challenges in building such a
   platform and discusses to what extent these technologies, as well as
   traditional VMs, are able to address them.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Richard Cziva <[email-masked]>
Date: Mon, 18 Jul 2016 17:27:59 +0100

Hello Ramki (and all),

Having read this draft on lightweight virtualisation for NFV and listening to your talk today morning at IETF 96, I would like to comment and discuss a few new ideas.

Misunderstanding:

In “3.2. Continuity, Elasticity and Portability”,  the first paragraph ends with this sentence: “Some of the requirements that need consideration are:”. Do you mean “Some of the _challenges _that need consideration are:”?

Suggestion for addition:

In “3.1.1. Challenges”, the importance of NF chaining could be described. Similarly, in “4. Benchmarking Experiments” the chaining performance could also be measured and compared between different virtualisation methods. Just as an example, in [ClickOS] the authors showed that the throughput drops significantly from around 20Gbit/s to around 4 Gbit/s using 9 chained wire NFs. However in [GNF], the authors measured that by using containers (that only perform forwarding of packets) the throughput dropped from around 30 Gbit/s to 4 Gbit/s when using ~55 chained containers. 

I believe it is also important to emphasise that containers can be used on hosts / devices that lack of virtualization support or have limited resources (such as network edge devices [GNF-EDGE], capillary IoT gateways [CAPILLARY], standard VMs in public clouds [GNFC], etc). This could be explicitly mentioned in favour of containers at “3.2. Continuity, Elasticity and Portability”, as these NFV host devices will likely to emerge in future Internet architectures..

Considerations on energy efficiency: as by using containers we do not copy packets from kernel space, we save a lot of CPU work that translates to significant energy savings. This might be interesting to measure with the same setup.

References:

[CAPILLARY] Novo, Oscar, et al. "Capillary networks-bridging the cellular and IoT worlds." Internet of Things (WF-IoT), 2015 IEEE 2nd World Forum on. IEEE, 2015.

[GNF] Cziva, Richard, et al. "Container-based network function virtualization for software-defined networks." 2015 IEEE Symposium on Computers and Communication (ISCC). IEEE, 2015. 

[GNFC] Cziva, Richard, Simon Jouet, and Dimitrios P. Pezaros. "GNFC: Towards network function cloudification." Network Function Virtualization and Software Defined Network (NFV-SDN), 2015 IEEE Conference on. IEEE, 2015. 

[GNF-EDGE]  Cziva, Richard, Simon Jouet, and Dimitrios P. Pezaros. “Roaming edge vNFs using Glasgow Network Functions.” ACM SIGCOMM, 2016. (URL to the paper: http://richard.systems/research/pdf/ACM_SIGCOMM_GNF.pdf (before publication))

Thank you for reading this.

Kind regards,
Richard Cziva

—
Richard Cziva
PhD student
Networked Systems Research Laboratory
University of Glasgow
https://netlab.dcs.gla.ac.uk

> On 8 Jul 2016, at 15:23, [email-masked] wrote:
> 
> _______________________________________________
> Nfvrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nfvrg