Subject: [Nmlrg] Uses case for ML -- automating traffic prioritisation

From: grenville armitage <[email-masked]>
Date: Thu, 29 Oct 2015 19:42:34 +1100

I've joined a little late, but understand from the archives that you're looking for example use cases?

The following links may be of interest. Between ~2005 and ~2012 my group explored the application of machine learning to the task of classifying application flows. One of the specific use cases was to classify traffic that required different QoS treatment, and automate the subsequent configuration of bottleneck home gateways to achieve said QoS treatment.

Our top-level project page: http://caia.swin.edu.au/urp/diffuse/
A proof-of-concept implemented in OpenWRT: http://caia.swin.edu.au/urp/diffuse/openwrt/
(earlier work on statistical traffic classification: http://caia.swin.edu.au/urp/dstc)

Some academic papers that might be of interest:

Thuy T. T. Nguyen, Grenville Armitage, Philip Branch and Sebastian Zander.
Timely and Continuous Machine-Learning-Based Classification for Interactive IP Traffic
IEEE/ACM Transactions on Networking, vol. 20 no. 6 pp. 1880-1894, December 2012
http://dx.doi.org/10.1109/TNET.2012.2187305

Thuy Nguyen and Grenville Armitage.
A Survey of Techniques for Internet Traffic Classification using Machine Learning
IEEE Communications Surveys & Tutorials, vol. 10 no. 4 pp. 56-76, 2008
http://dx.doi.org/10.1109/SURV.2008.080406

cheers,
gja
-- 
Professor Grenville Armitage
Director, Centre for Advanced Internet Architectures
School of Software and Electrical Engineering
Faculty of Science, Engineering and Technology
Swinburne University of Technology, Australia
http://caia.swin.edu.au

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 29 Oct 2015 09:56:30 +0000

Hi, Grenville,

Yes, the proposed NMLRG is in the very initial stage. For the first step, we are solicit the use cases also the experience sharing. Your use case looks very interesting. Will you be in Yokohama next week? We will have the first proposed RG meeting on Tuesday morning.

Regards,

Sheng

>-----Original Message-----
>From: nmlrg [mailto:[email-masked]] On Behalf Of grenville armitage
>Sent: Thursday, October 29, 2015 4:43 PM
>To: [email-masked]
>Subject: [Nmlrg] Uses case for ML -- automating traffic prioritisation
>
>
>The following links may be of interest. Between ~2005 and ~2012 my group
>explored the application of machine learning to the task of classifying
>application flows. One of the specific use cases was to classify traffic that
>required different QoS treatment, and automate the subsequent
>configuration of bottleneck home gateways to achieve said QoS treatment.
>
>A proof-of-concept implemented in OpenWRT:
>http://caia.swin.edu.au/urp/diffuse/openwrt/
>_______________________________________________
>nmlrg mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/nmlrg

---

From: grenville armitage <[email-masked]>
Date: Fri, 30 Oct 2015 12:44:32 +1100

On 10/29/2015 20:56, Sheng Jiang wrote:
	[..]
> Will you be in Yokohama next week? We will have the first proposed RG meeting on Tuesday morning.

Yes, I plan to be there.

cheers,
gja

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 30 Oct 2015 02:24:42 +0000

You should really apply a time slot and share your use case in the meeting. Anyway, let's meet on site and you can participate the on-site discussion. And you can also share in our future meeting. We can also study your use case through mail list discussion,

Regards,

Sheng

>Sent: Friday, October 30, 2015 9:45 AM
>To: [email-masked]
>Subject: Re: [Nmlrg] Uses case for ML -- automating traffic prioritisation
>
>
>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 30 Oct 2015 02:50:49 +0000

Hi Grenville,

Thanks for sharing your use case. I think it is a valuable use case in networking.

> http://caia.swin.edu.au/urp/diffuse/openwrt/
Does it imply that your study was specific to home networks scenarios, and the algorithms were specifically designed to adapt those low performance embedded devices?
I personally expect your study was not limited in home network scenarios, because the flow classification is also an important use case in carrier networks.

Best regards,
Bing