Subject: [Nmlrg] Closedown of the proposed NMLRG and NMLRG mail list

From: Sheng Jiang <[email-masked]>
Date: Thu, 8 Dec 2016 02:56:05 +0000

Hi, all,

As you may already know, the IRTF management have reached the conclusion to close the proposed NMLRG and this mail list. It is mainly because we did not organize quality discussion in this new field. Although we have good numbers of participators for all our meetings, the topics were divergent and many questions/discussions showed we were in very early stage for applying the ML into network area. The community of Network Machine Learning needs more time to grow up. We are seeing more and more researches in this field. The closedown does not mean this work is dead. Oppositely, it actually means we need to do a lot more work in order to get the community ready for a new wave.

We are now in process to set up a new mail list soon. We have recorded all 277 subscribers in the mail list. We assume all the subscribers are also interested in the new mail list. Thence, by default, we will move all subscribers to the new mail list. If anyone does NOT want to be subscribed to the new mail list, please send me ([email-masked]) emails privately.

Many thanks for all of your involvement and support. Let's continue our efforts in this field together. With the belief in this direction, the next wave will not be far.

Best regards,

Sheng

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Thu, 8 Dec 2016 14:47:13 +0900

Hi,

Take the opportunity to express my sorrow for the discontinuation (or
actual non-formation) of the research group and my gratitude for all
contributors for trying to consolidate it. Moreover, setting up a new
mailing list is a really good alternative to continue our effort. Thank
you for managing it.

On the other hand, I would like to discuss about the extension of the
scope of this initiative as I see that ML is quite restricted term in
contrast to the variety of techniques and approaches presented in the
last IETF meeting. My actual proposal is to extend it to AI techniques
applied to network management (AINM?), and there we could reach some
consensus on the common concepts that would be useful for all research
efforts, including ML.

I do not know if you have discussed about this before but I would like
you to please let me know your opinion. Thank you very much.

Regards,
Pedro

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Yong Cui <[email-masked]>
Date: Thu, 8 Dec 2016 13:49:35 +0800

I think this is a very interesting topic.
Thank you, Sheng, for your great effort on the proposed NMLRG and organizing the valuable discussions! 

Yong Cui
Tsinghua University

> 在 2016年12月8日，10:56，Sheng Jiang <[email-masked]> 写道：
> 
> Hi, all,
>  
> Many thanks for all of your involvement and support. Let’s continue our efforts in this field together. With the belief in this direction, the next wave will not be far.
>  
> Best regards,
>  
> Sheng
>  
> _______________________________________________
> nmlrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmlrg

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 8 Dec 2016 06:28:43 +0000

Hi, Pedro,

I fully agree that AI is wider than ML although it is more difficult to give a definition or border of AI technologies. We can certainly extend our scope from ML to AI. On other side, our scope is actually wider than network management. We also targeted autonomic network controlling from the very beginning.

Regards,

Sheng

> -----Original Message-----
> From: Pedro Martinez-Julia [mailto:[email-masked]]
> Sent: Thursday, December 08, 2016 1:47 PM
> To: Sheng Jiang
> Cc: [email-masked]; Albert Cabellos; Eggert, Lars; Allison Mankin
> Subject: Re: [Nmlrg] Closedown of the proposed NMLRG and NMLRG mail list
> 
> Hi,
> 
> Take the opportunity to express my sorrow for the discontinuation (or actual
> non-formation) of the research group and my gratitude for all contributors for
> trying to consolidate it. Moreover, setting up a new mailing list is a really good
> alternative to continue our effort. Thank you for managing it.
> 
> On the other hand, I would like to discuss about the extension of the scope of
> this initiative as I see that ML is quite restricted term in contrast to the variety
> of techniques and approaches presented in the last IETF meeting. My actual
> proposal is to extend it to AI techniques applied to network management
> (AINM?), and there we could reach some consensus on the common concepts
> that would be useful for all research efforts, including ML.
> 
> I do not know if you have discussed about this before but I would like you to
> please let me know your opinion. Thank you very much.
> 
> Regards,
> Pedro
> 
> --
> Pedro Martinez-Julia
> Network Science and Convergence Device Technology Laboratory Network
> System Research Institute National Institute of Information and
> Communications Technology (NICT) 4-2-1, Nukui-Kitamachi, Koganei, Tokyo
> 184-8795, Japan
> Email: [email-masked]

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Thu, 8 Dec 2016 16:30:01 +0900

Hi,

> I fully agree that AI is wider than ML although it is more difficult
> to give a definition or border of AI technologies. We can certainly
> extend our scope from ML to AI. On other side, our scope is actually
> wider than network management. We also targeted autonomic network
> controlling from the very beginning.

I was tempted to mention "network control" but, from my point of view,
management is a broader term that can somehow include control. I agree
that Autonomic Networking (AN) would be a direct beneficiary of AI, and
therefore it gives more sense to the extended scope of the group.

Regarding the definition and border, from my point of view, they would
be naturally derived from the specific application of AI techniques to
network control and management. In fact, if we start defining the set of
concepts and relations I mentioned (more specifically, an ontology), it
would be clear where to establish the specific borders. However, almost
any AI technique could be useful in this context.

On the other hand, and maybe a bit against my own proposal, we have to
face the concerns (fears?) that many people have about AI mechanisms
taking decisions autonomously. We can begin with the definition of some
deployment plan (better name, please) that incrementally gives autonomy
to the final system, together with a set of rules (standard?) that must
be set to every AI-based management and control system. As a note, it
can follow the steps of the autonomous cars that are already being left
driving alone, also taking into account and learning from their flaws
and problems.

Finally, if many group members agree on extending the scope to AI, it
would be good to begin right now, with the creation of the new mailing
list, and (of course) set a proper name to it :-D.

Let's be in contact.

Regards,
Pedro

---

From: David Palma <[email-masked]>
Date: Thu, 8 Dec 2016 09:07:40 +0100

+1 for Autonomic Networking

—
David Palma

> On 08 Dec 2016, at 08:30, Pedro Martinez-Julia <[email-masked]> wrote:
>

---

From: "Natale, Bob" <[email-masked]>
Date: Thu, 8 Dec 2016 08:10:14 +0000

Very quick input ... won't be eloquent but I hope is reasonably intelligible:

- I agree with the value of expanding the scope to AI, writ large, possibly under a different name (but I don't shy away from the AI label myself).
- Following a path from Automation -> Autonomics -> Autonomy, where the path is bounded (i.e., Pedro's "borders") via "_instrumented_ governance" (by humans), is one way to ease fears and minimize risks.
- I agree with the need to include ontology ... mainly because that should enforce thinking up front about the kinds of reasoning operations that will facilitate trust in the borders and instrumented governance.

Avanti,
BobN

-----Original Message-----
From: nmlrg [mailto:[email-masked]] On Behalf Of Pedro Martinez-Julia
Sent: Thursday, December 08, 2016 2:30 AM
To: Sheng Jiang <[email-masked]>
Cc: [email-masked]; Albert Cabellos <[email-masked]>
Subject: Re: [Nmlrg] Closedown of the proposed NMLRG and NMLRG mail list

Hi,

> controlling from the very beginning.

I was tempted to mention "network control" but, from my point of view, management is a broader term that can somehow include control. I agree that Autonomic Networking (AN) would be a direct beneficiary of AI, and therefore it gives more sense to the extended scope of the group.

Regarding the definition and border, from my point of view, they would be naturally derived from the specific application of AI techniques to network control and management. In fact, if we start defining the set of concepts and relations I mentioned (more specifically, an ontology), it would be clear where to establish the specific borders. However, almost any AI technique could be useful in this context.

On the other hand, and maybe a bit against my own proposal, we have to face the concerns (fears?) that many people have about AI mechanisms taking decisions autonomously. We can begin with the definition of some deployment plan (better name, please) that incrementally gives autonomy to the final system, together with a set of rules (standard?) that must be set to every AI-based management and control system. As a note, it can follow the steps of the autonomous cars that are already being left driving alone, also taking into account and learning from their flaws and problems.

Finally, if many group members agree on extending the scope to AI, it would be good to begin right now, with the creation of the new mailing list, and (of course) set a proper name to it :-D.

Let's be in contact.

Regards,
Pedro

--
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory Network System Research Institute National Institute of Information and Communications Technology (NICT) 4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Jérôme François <[email-masked]>
Date: Thu, 08 Dec 2016 10:32:22 +0100

Dear all,

First thank you Sheng, Albert and all NMRG contributors for the effort
and tim given.

From my opinion:
- Network management should be also enough broad (FCAPS) but this raises
an issue regarding our positioning to NMRG.  An option is also to
propose a workshop series on AI to NMRG (In a similar way, I for example
participate regularily to flow management workshop series)
- But we should not focus on autonomic networking which is restrictive.
For example, data-mining for extracting knwolegde may not necessarily
lead to autonomic decisions but just reporting. So, then it depends if
data-mining is included in AI. In my opinion, it is but people may have
different ones.
- Another question: I understand from Sheng's email that main problem
with NMLRG is that the topics and discussion were too divergent. Thus,
does it make sense to have a broader scope?

best regards,
jerome