Subject: [nsc] Fwd: New Version Notification for draft-cao-nsc-rtg-update-00.txt

From: "Cao,Zhen" <[email-masked]>
Date: Mon, 21 Oct 2013 17:54:18 +0200

Hello, all

Comments welcome for this simple draft.

Best regards,
cz

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Mon, Oct 21, 2013 at 12:54 PM
Subject: New Version Notification for draft-cao-nsc-rtg-update-00.txt
To: Zehn Cao <[email-masked]>

A new version of I-D, draft-cao-nsc-rtg-update-00.txt
has been successfully submitted by Zhen Cao and posted to the
IETF repository.

Filename:        draft-cao-nsc-rtg-update
Revision:        00
Title:           Routing Update Mechanism for Network Service Chaining
Creation date:   2013-10-21
Group:           Individual Submission
Number of pages: 7
URL:
http://www.ietf.org/internet-drafts/draft-cao-nsc-rtg-update-00.txt
Status:          http://datatracker.ietf.org/doc/draft-cao-nsc-rtg-update
Htmlized:        http://tools.ietf.org/html/draft-cao-nsc-rtg-update-00

Abstract:
   This document proposes a mechanism of routing the packets through a
   series of (virtual) service functions.  The mechanism uses the
   existing IPv6 Mobility Header for routing advertisements, updates and
   acknowledgements.  Comparison with existing service chaining
   mechanisms is to be analyzed.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Wed, 30 Oct 2013 02:47:25 +0000

Hi,

I took a look at this draft and have the following comments:
1. It's a good idea to reuse the existing protocol. However, using IPv6 mobility Header may limit the scope. Is it possible to give a more general solution, e.g., IPv6 header instead, or even provide a paralleled IPv4 solution? IMHO, the main idea of this draft is hop by hop en/decapsulation and tunneling, so there should be solutions more general.

2. The hop by hop en/decapsulation is easy to implement. However, it seems that this is a pre-organized approach, meaning the controller handles everything at the beginning. How to treat the service flow that needs dynamical routing might be a issue.

Regards,
Shucheng LIU (Will)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cao,Zhen
> Sent: Monday, October 21, 2013 11:54 PM
> To: [email-masked]
> Subject: [nsc] Fwd: New Version Notification for
> draft-cao-nsc-rtg-update-00.txt
> 
> Hello, all
> 
> A new version of I-D, draft-cao-nsc-rtg-update-00.txt has been successfully
> submitted by Zhen Cao and posted to the IETF repository.
> 
> _______________________________________________
> nsc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsc