Subject: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

From: "Liushucheng (Will)" <[email-masked]>
Date: Fri, 11 Oct 2013 06:13:59 +0000

Folks,

We've uploaded the updated and renamed use case draft. Looking forward to your comments.

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

A new version of I-D, draft-liu-sfc-use-cases-00.txt
has been successfully submitted by Will(Shucheng) Liu and posted to the
IETF repository.

Filename:	 draft-liu-sfc-use-cases
Revision:	 00
Title:		 Service Function Chaining Use Cases
Creation date:	 2013-10-10
Group:		 Individual Submission
Number of pages: 14
URL:             http://www.ietf.org/internet-drafts/draft-liu-sfc-use-cases-00.txt
Status:          http://datatracker.ietf.org/doc/draft-liu-sfc-use-cases
Htmlized:        http://tools.ietf.org/html/draft-liu-sfc-use-cases-00

Abstract:
   The delivery of value-added services relies on the invocation of
   advanced Service Functions in a sequential order.  This mechanism is
   called Service Function Chaining (SFC).  The set of involved Service
   Functions and their order depends on the service context.

   This document presents a set of use cases of Service Function
   Chaining (SFC).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 15 Oct 2013 10:44:44 -0500

Hi Shucheng,

In the use cases draft, you say that

SFC are not per-subscriber.  In other words, this document assumes
      per-subscriber SFCs are not instantiated in the network.
      Deployments cases that would require per-subscriber SFCs are out
      of scope.

However you have at least three parental control use cases. How would it be
possible to have parental control not being per-subscriber?

Regards,

Behcet

On Fri, Oct 11, 2013 at 1:13 AM, Liushucheng (Will)
<[email-masked]>wrote:

> To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver);
> Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
> URL:
> http://www.ietf.org/internet-drafts/draft-liu-sfc-use-cases-00.txt
> _______________________________________________
> nsc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsc
>

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 17:34:28 +0000

It seems very unlikely that one would opt for a solution whereby a separate SFC is required per-subscriber; clearly millions of SFC's is not desirable no matter how you cut it. IMHO, the support of services that require per-subscriber policy are more likely to be realized using something like the solution described in draft-quinn-sfc-nsh.

From: Behcet Sarikaya <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 15, 2013 11:44 AM
To: "Liushucheng (Will)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Hi Shucheng,

However you have at least three parental control use cases. How would it be possible to have parental control not being per-subscriber?

Regards,

Behcet

On Fri, Oct 11, 2013 at 1:13 AM, Liushucheng (Will) <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
nsc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nsc

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 17:51:54 +0000

I don't think that is a foregone conclusion.

When you combine what is being done in IaaS environments for muti-tenant dynamic datacenters with what you can do with policy defined networking and IPv6, for an access provider to provision per-subscriber VAS LANs and default gateways takes away a lot of the big problems caused by aggregation that you're trying to solve with service chains.  More to the point, you don't need to disaggregate anything when you know that all the traffic belongs to a single customer, and that the default gateway of each node is the next hop in the service chain.  Solving the problem for 1 subscriber@1Gbps is trivial; what makes what we're talking about in this list hard is that you are trying to solve it for 10 million subscribers @100Gbps but in truth the only technology-based reason you do that is because of administrative challenges that the cloud world is solving (and may have solved before anything is produced in a WG) and that are squarely in the domain of things already proven to be better done by computers than people.

I tend to argue that per-subscriber provisioning of the access path triggered by identity-based authentication is the obvious and natural evolution of the technology being fielded today.

________________________________
From: [email-masked] [[email-masked]] on behalf of Jim Guichard (jguichar) [[email-masked]]
Sent: Tuesday, October 15, 2013 1:34 PM
To: [email-masked]; Liushucheng (Will)
Cc: [email-masked]
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 19:52:02 +0000

Hi Ian,
If by subscriber you mean per-tenant or per-subscriber-group then I will agree that SFC's will be built for these but that's a far cry from per-subscriber which implies to me an individual broadband or mobile client.

Sent from my iPhone

On Oct 15, 2013, at 1:51 PM, "Ian Smith" <[email-masked]<mailto:[email-masked]>> wrote:

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] on behalf of Jim Guichard (jguichar) [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, October 15, 2013 1:34 PM
To: [email-masked]<mailto:[email-masked]>; Liushucheng (Will)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 20:30:12 +0000

We do that already.

I'm talking about giving each /64 their own path from the IP anchor through the VAS LAN to the PE router tailored to their individual profile (which they probably have some control over through an app on their phone).  The fixed is easy and not far removed from giving each student in a dorm their own vlan - something I've seen done in the late 90s.  Mobile is a little more sophisticated, but still achievable if you are automating your provisioning system and have an elastic VAS infrastructure.

In both cases you are just taking the IaaS model and reversing the flow of traffic.

________________________________
From: Jim Guichard (jguichar) [[email-masked]]
Sent: Tuesday, October 15, 2013 3:52 PM
To: Ian Smith
Cc: [email-masked]; Liushucheng (Will); [email-masked]
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Hi Ian,

Sent from my iPhone

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 20:33:35 +0000

So you are saying each individual client sat on the end of some mobile device will get their own SFC?

Sent from my iPhone

On Oct 15, 2013, at 4:30 PM, "Ian Smith" <[email-masked]<mailto:[email-masked]>> wrote:

We do that already.

________________________________
From: Jim Guichard (jguichar) [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, October 15, 2013 3:52 PM
To: Ian Smith
Cc: [email-masked]<mailto:[email-masked]>; Liushucheng (Will); [email-masked]<mailto:[email-masked]>
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Hi Ian,

Sent from my iPhone

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ron Parker <[email-masked]>
Date: Tue, 15 Oct 2013 20:37:14 +0000

Ian,

>From my perspective, the vision for the SFC classifier is to not only be subscriber aware, but also flow aware.   This alleviates the bypass traffic problem that occurs when 100% of traffic at some granularity (network, APN, subscriber) is sent through a sequence of service nodes, as is done in today's topology-based mobile Gi-LAN architectures (i.e., TCP optimizer bypasses non-TCP).   Thus, the number of distinct chain sequences is somewhat orthogonal to the number of subscribers and is driven by subscriber-aware/flow-aware policy.

   Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ian Smith
Sent: Tuesday, October 15, 2013 4:30 PM
To: Jim Guichard (jguichar)
Cc: [email-masked]; [email-masked]; Liushucheng (Will)
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

We do that already.

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 20:45:03 +0000

Ron,

The granularity of what you describe as "subscriber" is important here; one could classify traffic as belonging to subscriber "android" or as belonging to "Jim who happens to be using an Android". The former is a lot less "subscribers" than the latter. In my world I tend to think of the former as the classification granularity. I certainly would not anticipate building an SFC just for the sole use of "Jim" (I'm really not that important ;) ).

Sent from my iPhone

On Oct 15, 2013, at 4:37 PM, "Ron Parker" <[email-masked]<mailto:[email-masked]>> wrote:

Ian,

>From my perspective, the vision for the SFC classifier is to not only be subscriber aware, but also flow aware.   This alleviates the bypass traffic problem that occurs when 100% of traffic at some granularity (network, APN, subscriber) is sent through a sequence of service nodes, as is done in today’s topology-based mobile Gi-LAN architectures (i.e., TCP optimizer bypasses non-TCP).   Thus, the number of distinct chain sequences is somewhat orthogonal to the number of subscribers and is driven by subscriber-aware/flow-aware policy.

   Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ian Smith
Sent: Tuesday, October 15, 2013 4:30 PM
To: Jim Guichard (jguichar)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Liushucheng (Will)
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

We do that already.

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 15 Oct 2013 15:45:12 -0500

I was talking about something like parental control.
Do you qualify such an SFC as each mobile client getting its own SFC?

I think it is more like per-subscriber-group. It could be per subscriber as
well but I can not think of an example at this moment.

On Tue, Oct 15, 2013 at 2:52 PM, Jim Guichard (jguichar) <[email-masked]
> wrote:

>  Hi Ian,
> If by subscriber you mean per-tenant or per-subscriber-group then I will
> agree that SFC's will be built for these but that's a far cry from
> per-subscriber which implies to me an individual broadband or mobile client.
>
> Sent from my iPhone
>
> On Oct 15, 2013, at 1:51 PM, "Ian Smith" <[email-masked]> wrote:
>
> When you combine what is being done in IaaS environments for muti-tenant
> dynamic datacenters with what you can do with policy defined networking and
> IPv6, for an access provider to provision per-subscriber VAS LANs and
> default gateways takes away a lot of the big problems caused by aggregation
> that you're trying to solve with service chains.  More to the point, you
> don't need to disaggregate anything when you know that all the traffic
> belongs to a single customer, and that the default gateway of each node is
> the next hop in the service chain.  Solving the problem for 1
> subscriber@1Gbps is trivial; what makes what we're talking about in this
> list hard is that you are trying to solve it for 10 million subscribers
> @100Gbps but in truth the only technology-based reason you do that is
> because of administrative challenges that the cloud world is solving (and
> may have solved before anything is produced in a WG) and that are squarely
> in the domain of things already proven to be better done by computers than
> people.
>
> I tend to argue that per-subscriber provisioning of the access path
> triggered by identity-based authentication is the obvious and natural
> evolution of the technology being fielded today.
>
>
>  ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of Jim
> Guichard (jguichar) [[email-masked]]
> *Sent:* Tuesday, October 15, 2013 1:34 PM
> *To:* [email-masked]; Liushucheng (Will)
> *Cc:* [email-masked]
> *Subject:* Re: [nsc] FW: New Version Notification for
> draft-liu-sfc-use-cases-00.txt
>
>   It seems very unlikely that one would opt for a solution whereby a
> separate SFC is required per-subscriber; clearly millions of SFC's is not
> desirable no matter how you cut it. IMHO, the support of services that
> require per-subscriber policy are more likely to be realized using
> something like the solution described in draft-quinn-sfc-nsh.
>
>   From: Behcet Sarikaya <[email-masked]>
> Reply-To: "[email-masked]" <[email-masked]>
> To: "Liushucheng (Will)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
>  However you have at least three parental control use cases. How would it
> be possible to have parental control not being per-subscriber?
>
>  Regards,
>
>  Behcet
>
>
> On Fri, Oct 11, 2013 at 1:13 AM, Liushucheng (Will) <
> [email-masked]> wrote:
>
>> Folks,
>>

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 20:46:51 +0000

Sure, but you are still having to classify all the traffic for all the subscribers.  And you have to deal with mid-flow changes to that classification.  I'm not saying that it can't be done, I'm just remarking that "no one will ever need more than 640K" problems shouldn't be dismissed too quickly.

________________________________
From: Ron Parker [[email-masked]]
Sent: Tuesday, October 15, 2013 4:37 PM
To: Ian Smith; Jim Guichard (jguichar)
Cc: [email-masked]; [email-masked]; Liushucheng (Will)
Subject: RE: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Ian,

   Ron

We do that already.

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 20:47:35 +0000

yeah.  I'm saying we shouldn't assume that isn't going to happen.

Sent: Tuesday, October 15, 2013 4:33 PM

Sent from my iPhone

We do that already.

Hi Ian,

Sent from my iPhone

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 20:47:52 +0000

No, to me this is most certainly a per-subscriber-group.

Sent from my iPhone

On Oct 15, 2013, at 4:45 PM, "Behcet Sarikaya" <[email-masked]<mailto:[email-masked]>> wrote:

I think it is more like per-subscriber-group. It could be per subscriber as well but I can not think of an example at this moment.

On Tue, Oct 15, 2013 at 2:52 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ian,
If by subscriber you mean per-tenant or per-subscriber-group then I will agree that SFC's will be built for these but that's a far cry from per-subscriber which implies to me an individual broadband or mobile client.

Sent from my iPhone

Hi Shucheng,

Regards,

Behcet

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ron Parker <[email-masked]>
Date: Tue, 15 Oct 2013 20:48:56 +0000

My intention was to convey subscriber as "Jim who happens to be using an Android."

   Ron

From: Jim Guichard (jguichar) [mailto:[email-masked]]
Sent: Tuesday, October 15, 2013 4:45 PM
To: Ron Parker
Cc: Ian Smith; [email-masked]; [email-masked]; Liushucheng (Will)
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Ron,

Sent from my iPhone

   Ron

We do that already.

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ron Parker <[email-masked]>
Date: Tue, 15 Oct 2013 20:51:15 +0000

I can't argue with that.    If chain-id appears on the wire as an (unsigned) integer, I'd suggest that it should be 32-bits, at least.

   Ron

Sent: Tuesday, October 15, 2013 4:48 PM

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 20:51:23 +0000

Conveying that classification is different than spinning up individual service functions into a chain that only my traffic can be forwarded into.

Sent from my iPhone

On Oct 15, 2013, at 4:49 PM, "Ron Parker" <[email-masked]<mailto:[email-masked]>> wrote:

My intention was to convey subscriber as “Jim who happens to be using an Android.”

   Ron

From: Jim Guichard (jguichar) [mailto:[email-masked]]
Sent: Tuesday, October 15, 2013 4:45 PM
To: Ron Parker
Cc: Ian Smith; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Liushucheng (Will)
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Ron,

Sent from my iPhone

   Ron

We do that already.

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ron Parker <[email-masked]>
Date: Tue, 15 Oct 2013 20:52:46 +0000

Agree that is the typical usage of policy.   And, the degenerate case is that the world is comprised of subscriber groups that have exactly 1 subscriber.   Probably not practical, but why prevent it?

   Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Tuesday, October 15, 2013 4:48 PM
To: <[email-masked]>
Cc: [email-masked]; Liushucheng (Will); Ian Smith
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 21:02:47 +0000

Sure but we should deal in reality driven by use cases and I have yet to see anyone suggest they will build an individual service chain for every client. In fact the complete opposite seems true.

Sent from my iPhone

On Oct 15, 2013, at 4:52 PM, "Ron Parker" <[email-masked]<mailto:[email-masked]>> wrote:

   Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Tuesday, October 15, 2013 4:48 PM
To: <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Liushucheng (Will); Ian Smith
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 21:11:21 +0000

what do you need to make this reality driven?
________________________________
From: Jim Guichard (jguichar) [[email-masked]]
Sent: Tuesday, October 15, 2013 5:02 PM
To: Ron Parker
Cc: <[email-masked]>; [email-masked]; Liushucheng (Will); Ian Smith
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Sent from my iPhone

   Ron

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 21:14:21 +0000

Use cases from real operators would be a start.

Sent from my iPhone

On Oct 15, 2013, at 5:11 PM, "Ian Smith" <[email-masked]<mailto:[email-masked]>> wrote:

Cc: <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Liushucheng (Will); Ian Smith

Sent from my iPhone

   Ron

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Ian Smith <[email-masked]>
Date: Tue, 15 Oct 2013 21:14:56 +0000

I'll see what I can do.

________________________________
From: Jim Guichard (jguichar) [[email-masked]]
Sent: Tuesday, October 15, 2013 5:14 PM
To: Ian Smith
Cc: Ron Parker; <[email-masked]>; [email-masked]; Liushucheng (Will)
Subject: Re: [nsc] FW: New Version Notification for draft-liu-sfc-use-cases-00.txt

Sent from my iPhone

Sent from my iPhone

   Ron

Sent from my iPhone

Sent from my iPhone

Hi Shucheng,

Regards,
Shucheng LIU (Will)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, October 10, 2013 3:42 PM
To: Liushucheng (Will); Jie Hu; Hongyu Li (Julio); Huangyong (Oliver); Mohamed Boucadair; Liushucheng (Will); Nicolai Leymann; Zhen Cao
Subject: New Version Notification for draft-liu-sfc-use-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 15 Oct 2013 17:11:03 -0500

Folks, I checked and found out that in the requirements draft
per-subscriber service issue is pretty clearly stated.

My suggestion is to remove the paragraph that starts with SFC are not
per-subscriber. It is confusing.

Regards,

Behcet

On Tue, Oct 15, 2013 at 4:14 PM, Ian Smith <[email-masked]> wrote:

> *From:* Jim Guichard (jguichar) [[email-masked]]
> *Sent:* Tuesday, October 15, 2013 5:14 PM
> *To:* Ian Smith
> *Cc:* Ron Parker; <[email-masked]>; [email-masked]; Liushucheng (Will)
>
> On Oct 15, 2013, at 5:11 PM, "Ian Smith" <[email-masked]> wrote:
>
> *From:* Jim Guichard (jguichar) [[email-masked]]
> *Sent:* Tuesday, October 15, 2013 5:02 PM
> *To:* Ron Parker
> *Cc:* <[email-masked]>; [email-masked]; Liushucheng (Will); Ian Smith
>   Sure but we should deal in reality driven by use cases and I have yet
> to see anyone suggest they will build an individual service chain for every
> client. In fact the complete opposite seems true.
>
> Sent from my iPhone
>
> On Oct 15, 2013, at 4:52 PM, "Ron Parker" <[email-masked]>
> wrote:
>
>   Agree that is the typical usage of policy.   And, the degenerate case
> is that the world is comprised of subscriber groups that have exactly 1
> subscriber.   Probably not practical, but why prevent it?
>
>
>
>    Ron
>
>
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Jim Guichard (jguichar)
> *Sent:* Tuesday, October 15, 2013 4:48 PM
> *To:* <[email-masked]>
> *Cc:* [email-masked]; Liushucheng (Will); Ian Smith
> On Oct 15, 2013, at 4:45 PM, "Behcet Sarikaya" <[email-masked]>
> wrote:
>
> I think it is more like per-subscriber-group. It could be per subscriber
> as well but I can not think of an example at this moment.
>
>
>
> On Tue, Oct 15, 2013 at 2:52 PM, Jim Guichard (jguichar) <
> [email-masked]> wrote:
>
>  Hi Ian,
>
> *From: *Behcet Sarikaya <[email-masked]>
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Tuesday, October 15, 2013 11:44 AM
> *To: *"Liushucheng (Will)" <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [nsc] FW: New Version Notification for