Subject: [nsc] Preliminary SFC BoF agenda for IETF88 in Vancouver.

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Wed, 9 Oct 2013 14:29:48 +0000

Greetings,

The following is a preliminary agenda for review/comment. Please note that we have 2 hours total for the SFC BoF and the times provided are subject to change. The BoF itself will be split into two  sections: 1) the core BoF, where we will discuss the problem statement, use cases, architecture/framework, and charter, as well as answer the more general question as to whether a WG is to be formed, followed by: 2) discussion of related drafts and how to organize the work going forward, assuming a WG gets formed. Please let Thomas or I know if you would like a slot to present a particular draft.

0.00 Introduction (BoF-chairs) - [10 minutes]
00.10 Problem statement discussion (BoF-chairs + presenter) - [20 minutes]

  *   Problem statement review (Navindra Yadav, Insieme Networks) - [10 minutes]

     *   http://datatracker.ietf.org/doc/draft-quinn-nsc-problem-statement

  *   Problem statement Q&A (open-mic) - [10 minutes]

00.30 SFC use case discussion (presenter + open-mic) - [20 minutes]

  *   SFC use cases (Hongyu Li, Huawei) - [10 minutes]

     *   http://datatracker.ietf.org/doc/draft-liu-service-chaining-use-cases

  *   Use case Q&A (BoF-chairs) - [10 minutes]

00.50 SFC architecture & framework discussion - [20 minutes]

  *   Architecture  & framework review (Ron Parker, Affirmed Networks & Paul Quinn, Cisco) - [10 minutes]

     *   http://datatracker.ietf.org/doc/draft-boucadair-sfc-framework

     *   http://datatracker.ietf.org/doc/draft-quinn-sfc-arch

  *   Architecture & framework Q&A (open-mic) - [10 minutes]

01.10 Charter text discussion (BoF-chairs) - [25 minutes]

  *   Charter text review (BoF-chairs) - [10 minutes]

     *   http://datatracker.ietf.org/wg/sfc/charter/

  *   Charter Q&A (open-mic) - [15 minutes]

For the  remainder of the time, we will assume the previous discussion (i.e., the  main BoF) went reasonably well and we are looking forward to what we would need to do if we were a chartered WG.

01.35 Evaluation of required & existing ID's (BoF-chairs + presenters) - [20 minutes]

01.55 Closing (BoF-chairs) - [5 minutes]

  *   Actions & Next Steps

Thanks, Jim & Thomas.

---

From: Ron Parker <[email-masked]>
Date: Fri, 11 Oct 2013 12:55:09 +0000

Jim,

Thanks for preparing the agenda.   If time permits, I would request a slot to present http://datatracker.ietf.org/doc/draft-boucadair-sfc-requirements/.    If agreed to, I might suggest to slot it after the use cases and before the framework, as the requirements arise from the use cases and the framework, hopefully, addresses the requirements.

   Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, October 09, 2013 10:30 AM
To: [email-masked]
Subject: [nsc] Preliminary SFC BoF agenda for IETF88 in Vancouver.

Greetings,

  *   Actions & Next Steps
Thanks, Jim & Thomas.

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 15 Oct 2013 08:21:44 +0000

Hi Jim,

Thank a lot for preparing the preliminary agenda. We've uploaded a new I-D http://www.ietf.org/internet-drafts/draft-jiang-sfc-arch-00.txt, which replaced the original draft-jiang-service-chaining-arch-00. We would like to see it being discussed in "SFC architecture & framework discussion", could you add it to the list in the agenda?

Best regards,
Yuanlong & Hongyu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, October 09, 2013 10:30 PM
To: [email-masked]
Subject: [nsc] Preliminary SFC BoF agenda for IETF88 in Vancouver.

Greetings,

  *   Actions & Next Steps
Thanks, Jim & Thomas.

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Tue, 15 Oct 2013 15:33:09 +0000

Hi Ron,

Thomas and I discussed your request and have allocated a 10 minute slot during the second half of the BOF for you to present your draft. We both felt that it was premature to include this discussion during the first half of the BOF as it would be a distraction from the core purpose of chartering the WG.

From: Ron Parker <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 11, 2013 8:55 AM
To: Jim Guichard <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [nsc] Preliminary SFC BoF agenda for IETF88 in Vancouver.

Jim,

   Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, October 09, 2013 10:30 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [nsc] Preliminary SFC BoF agenda for IETF88 in Vancouver.

Greetings,

  *   Actions & Next Steps
Thanks, Jim & Thomas.