Subject: [nsc] New Version Notification for draft-beliveau-sfc-architecture-00.txt

From: Andre Beliveau <[email-masked]>
Date: Wed, 16 Oct 2013 14:31:56 +0000

Hi, 

I’ve just uploaded a first version of my view of an architecture for Service Chaining at the link below. 
There are similarities with Paul's architecture draft.  I have already talked with Paul and we will be working to converge toward a single draft.

Looking forward to your comments.

/Andre Beliveau

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: October-16-13 10:22 AM
To: andre.beliveau@; Andre Beliveau
Subject: New Version Notification for draft-beliveau-sfc-architecture-00.txt

A new version of I-D, draft-beliveau-sfc-architecture-00.txt
has been successfully submitted by Andre Beliveau and posted to the IETF repository.

Filename:	 draft-beliveau-sfc-architecture
Revision:	 00
Title:		 Service Function Chaining Architecture
Creation date:	 2013-10-16
Group:		 Individual Submission
Number of pages: 10
URL:             http://www.ietf.org/internet-drafts/draft-beliveau-sfc-architecture-00.txt
Status:          http://datatracker.ietf.org/doc/draft-beliveau-sfc-architecture
Htmlized:        http://tools.ietf.org/html/draft-beliveau-sfc-architecture-00

Abstract:
   This document describes an architecture for Service Function
   Chaining.  It addresses operational aspects of Service Function
   Chaining such administration of Service Function Chains, network and
   forwarding principles.  It also covers architectural principles to
   support scale-in and scale-out of Service Functions.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 16 Oct 2013 09:58:23 -0500

Hi

Is there a document the describes the requirements of the service functions ? Something along the lines that the 

	service functions will need to accept packets with additional tag information ? 
	service functions will modify the service chain information ? or not ?
	service functions will need to support logical ingress and egress interfaces per chain ?

Regards
Snigdhendu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andre Beliveau
Sent: Wednesday, October 16, 2013 7:32 AM
To: [email-masked]
Subject: [nsc] New Version Notification for draft-beliveau-sfc-architecture-00.txt

Hi, 

/Andre Beliveau

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: October-16-13 10:22 AM
To: andre.beliveau@; Andre Beliveau
Subject: New Version Notification for draft-beliveau-sfc-architecture-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
nsc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsc

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 16 Oct 2013 15:01:50 +0000

Probably something along the lines of:

http://tools.ietf.org/html/draft-boucadair-sfc-framework-00

On 10/16/13 7:58 AM, "[email-masked]"
<[email-masked]> wrote:

>Hi
>
>Is there a document the describes the requirements of the service
>functions ? Something along the lines that the
>
>I¹ve just uploaded a first version of my view of an architecture for
>Service Chaining at the link below.
>There are similarities with Paul's architecture draft.  I have already
>talked with Paul and we will be working to converge toward a single draft.
>
>URL:             
>http://www.ietf.org/internet-drafts/draft-beliveau-sfc-architecture-00.txt
>Status:          
>http://datatracker.ietf.org/doc/draft-beliveau-sfc-architecture
>Htmlized:        
>http://tools.ietf.org/html/draft-beliveau-sfc-architecture-00
>
>
>Abstract:
>Please note that it may take a couple of minutes from the time of
>submission until the htmlized version and diff are available at
>tools.ietf.org.
>
>The IETF Secretariat
>

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Wed, 16 Oct 2013 15:02:52 +0000

Yes -> http://datatracker.ietf.org/doc/draft-boucadair-sfc-requirements.
However, this is still a work-in-progress document and further
requirements will no doubt be added or existing ones revised. I would
encourage you to review the document and contact the authors with specific
comments.