Subject: [nsc] Still tweaking the charter

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 9 Dec 2013 22:05:26 -0000

Hi,

The IESG discussed the draft charter and proposed a few changes.
You can see the latest version at
https://datatracker.ietf.org/doc/charter-ietf-sfc/

I'm in the process of verifying with them that these changes address their
concerns.

Your review *is* welcome, but please try to look at this to determine whether
you can live with the changes. Obviously something that is a big deal should
have a light shone on it, but let's beware of wordsmithing it to death - the
IESG is more than capable of doing that without your help!

Cheers,
Adrian

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Tue, 10 Dec 2013 19:04:06 +0000

Hi Adrian,

I do have one concern re: the suggested charter update.  

In the encap section, it states: "...indicates the sequence of service functions that make up the Service Function Chain through an identifier or by an explicit list".  This suggests implementation (i.e. ID vs. list) which seems too specific and inappropriate for the charter.  Furthermore, I think it's too early in the process to limit the path selection mechanism.

I suggest simply stating: "...indicates the sequence of service functions that make up the Service Function Chain".  That ensure that SFC selection is addressed, yet stays away from the "how" in the charter.

Thanks, and happy holidays!
Paul

On Dec 9, 2013, at 5:05 PM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> nsc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsc

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 10 Dec 2013 23:17:22 -0000

Yes Paul, I agree completely.

However, we ran into "indicates the sequence" being interpreted as precisely one
of "through an identifier" or "by an explicit list". So we had ADs saying "but
why have you excluded the other".

Maybe we could add "...or by any other means."

Adrian

> -----Original Message-----
> From: Paul Quinn (paulq) [mailto:[email-masked]]
> Sent: 10 December 2013 19:04
> To: <[email-masked]>
> Cc: [email-masked]; Jim Guichard (jguichar); Thomas Narten
> Subject: Re: [nsc] Still tweaking the charter
> 
> Hi Adrian,
> 
> In the encap section, it states: "...indicates the sequence of service
functions that
> make up the Service Function Chain through an identifier or by an explicit
list".
> This suggests implementation (i.e. ID vs. list) which seems too specific and
> inappropriate for the charter.  Furthermore, I think it's too early in the
process to
> limit the path selection mechanism.
> 
> I suggest simply stating: "...indicates the sequence of service functions that
make
> up the Service Function Chain".  That ensure that SFC selection is addressed,
yet
> stays away from the "how" in the charter.
>

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 11 Dec 2013 15:57:01 +0000

Agree with Paul's suggestion. 

Linda

> From: nsc [mailto:[email-masked]] On Behalf Of Paul Quinn (paulq)
> Sent: Tuesday, December 10, 2013 1:04 PM
> functions that make up the Service Function Chain through an identifier
> or by an explicit list".  This suggests implementation (i.e. ID vs.
> list) which seems too specific and inappropriate for the charter.
> Furthermore, I think it's too early in the process to limit the path
> selection mechanism.
> 
> I suggest simply stating: "...indicates the sequence of service
> functions that make up the Service Function Chain".  That ensure that
> SFC selection is addressed, yet stays away from the "how" in the
> charter.
>

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 11 Dec 2013 17:05:17 +0000

Adrian,

If we simply state "...indicates the sequence of service functions that make up the  Service Function Chain" we should cover all cases.  I don't understand the confusion: there's no implication of identifier vs. explicit list.

If they feel that indicates implies an ID, then perhaps: "denotes/conveys/carries the sequence of service functions that make up the Service Function Chain"?

Thanks
Paul

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Wed, 11 Dec 2013 18:07:41 +0000

We have also discussed in the past that this field should be made optional for cases where only metadata is of interest.

Maria 

> Sent: Wednesday, December 11, 2013 12:05 PM
> Cc: <[email-masked]>; Jim Guichard (jguichar); Thomas Narten
> If we simply state "...indicates the sequence of service functions that
> make up the  Service Function Chain" we should cover all cases.  I
> don't understand the confusion: there's no implication of identifier
> vs. explicit list.
> 
> If they feel that indicates implies an ID, then perhaps:
> "denotes/conveys/carries the sequence of service functions that make up
> the Service Function Chain"?
> 
> Thanks
> Paul
> 
> 
> >>> Your review *is* welcome, but please try to look at this to
> determine
> > whether

---

From: "Surendra Kumar (smkumar)" <[email-masked]>
Date: Wed, 11 Dec 2013 19:31:40 +0000

We agreed to defer the discussion until later, IIRC.

Surendra.

On 12/11/13 10:07 AM, "NAPIERALA, MARIA H" <[email-masked]> wrote:

>We have also discussed in the past that this field should be made
>optional for cases where only metadata is of interest.
>
>Maria 
>