Subject: RE: [NSIS] Proposed NSIS charter

From: [email-masked]
Date: Thu, 25 Oct 2001 11:59:55 +0300

Hi Jukka,

> 	1) I didn't quite understand, whether the WG would define a new
> signalling protocol or not? Would, for example, an enhancement /
> modification to RSVP be considered in or out of scope?

The intention is not to define a new protocol, but to enhance or
modify an existing one, such as RSVP.
 
> 	2) If the goals include some sort of new QoS signalling, would
> that include eg. bandwidth broker functionality, if needed, or just a
> signalling mechanism? So, more entities concerned by the 
> signalling than just routers and end hosts?

One goal is to define the architecture.  This may include signaling
to a proxy or to a bandwidth broker.

> 	3) Would the signalling be limited to a separate QoS signalling
> protocol, or could the QoS signalling be part data packets, 
> so be in-band, as the DSCP in DiffServ or the INSIGNIA scheme. A 
> new IPv6 extension header for QoS?

I think those could be possibilities.  One could (though I won't)
make a point that one result would be to create a use for the IPv6 
flow label.

> 	4) The text talks about mobility considerations to QoS? Is that
> the primary goal or would the QoS signalling question be as 
> important to solve in fixed networks and especially in ad hoc 
> networks?

I would not say it is the primary goal, but mobility & roaming do
present challenges to existing QoS Signaling Mechanisms, therefore
I do think that the output of the group will be useful to fixed
networks as well as ad-hoc networks.

cheers,
John

_______________________________________________
nsis mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/nsis

---

From: Kappler Cornelia <[email-masked]>
Date: Thu, 25 Oct 2001 11:14:22 +0200

Hi John, 

> networks as well as ad-hoc networks.
	Could you put this more concretely? Does the charter imply the resulting QoS signaling protocol would be designed such that it can easily (be extended to) inter-work with mobility?

	Thanks, Cornelia Kappler

---

From: "Chen, Weijing" <[email-masked]>
Date: Thu, 25 Oct 2001 19:33:16 -0500

Does it also include wireline beside wireless? e.g. Ethernet, DSL, etc
network.

Weijing Chen
SBC

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Thursday, October 25, 2001 4:00 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	RE: [NSIS] Proposed NSIS charter

Hi Jukka,

 

cheers,
John

---

From: [email-masked]
Date: Fri, 26 Oct 2001 09:11:08 +0300

Hi Weijing,

> Does it also include wireline beside wireless? e.g. Ethernet, DSL, etc

Yes.

John

---

From: Xiaoming Fu <[email-masked]>
Date: Tue, 30 Oct 2001 15:46:01 +0100

Hi John,

> modify an existing one, such as RSVP.

Could this "existing one" be interpreted as "approaches which have been 
already presented (perhaps under development)"? 

> to a proxy or to a bandwidth broker.

Do we have any "proxy" or "bandwidth broker" in existing protocols? IMO the 
answer depends on my previous question.

> make a point that one result would be to create a use for the IPv6

Fine with me. However I think taking advantage of IPv6 extension header option,
would be beneficial compared with only an IPv6 flow label since it can carry 
more information. In fact the ID 
www.ietf.org/internet-drafts/draft-ietf-mobileip-qos-requirements-01.txt 
did present such an approach.

Thanks

Xiaoming

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Tue, 30 Oct 2001 17:23:57 +0100

Hi Hemant

Before discussing possible modifications on 
RSVP, I think we should first discuss and 
agree on the charter.
In my opinion this charter is very much Mobile IP centric.
There are some other wireless QoS requirements that 
in my opinion should also be included in these discussions.
Such requirements are specified in:
http://search.ietf.org/internet-drafts/draft-westberg-rmd-cellular-issues-00.txt

Best regards,
Georgios

-----Original Message-----
From: Chaskar Hemant (NRC/Boston) [mailto:[email-masked]]
Sent: dinsdag 30 oktober 2001 16:19
To: [email-masked]
Cc: Loughney John (NRC/Helsinki); [email-masked]
Subject: RE: [NSIS] Proposed NSIS charter

> already presented (perhaps under development)"? 

    [HC] I was thinking as to what modifications to RSVP can actually be
done. For that,    	it may be worthwhile to look at some core RSVP
characteristics. There are as 	follows:

     1. One pass with advertisement approach,
     2. A way to define packet filter based on source and dest IP
addresses and port 	numbers,
     3. A way to define flow's traffic characteristics via RSVP
Flowspecs.
     4. Use of explicit refresh messages.

	Now modifying RSVP might account to 

	1. Allowing for forward reservations.
	2. Expanding the scope of defining packet filters by inclusion
of additional 	parameters + some optimizations based on IPv6 flow
label. For example, IPv6 flow 	label can be used to identify the flow
in the router. This will get rid of problems 	with chaning CoA in
Mobile IP.
	3. In addition to using RSVP Flowspecs to describe nitty gritty
details of flow, 	provide an option for describing some simple QoS
requirement, for example, QoS 	class and average rate.
      4. Arrival of flow's data packet at the router can be used as an
indication of live 	connection. This will avoid reliance on explicit
refresh messages.

	Are there any other core modifications to RSVP that we can think
of.

      May be we can create a list of possible modifications, evaluate
their need and  	elaborate on those which will be agreed upon by
the WG. That way, we can get the 	task of RSVP modifications
completed quickly. 

> did present such an approach.

	[HC] I think Xiaoming meant 

http://ietf.org/internet-drafts/draft-chaskar-mobileip-qos-01.txt. 

	Thanks.

      Hemant

---

From: "Zheng Haihong (NRC/Dallas)" <[email-masked]>
Date: Tue, 30 Oct 2001 13:55:08 -0600

Hi, Hemant,

> in the router. This will get rid of problems 	with chaning CoA in

The IPv6 Flow-label FILTER-SPEC Class that carries the source address
and flow label has already been defined in the current RSVP. However
this may not get rid of the problems related to changing CoA in MIP.
This is because a flow is supposed to be uniquely identified by the
combination of the source address and the non-zero flow label. Thus when
CoA is changed, the flow identifier is changed unless all the router has
been informed by the change of CoA. 

We had an ID
http://www.ietf.org/internet-drafts/draft-shen-rsvp-mobileipv6-interop-0
0.txt. which proposed to use home address carried in the home address
option in the destination option header to identify the source of a
packet. The combination of home address and flow label can always
uniquely identifies a flow.  

> requirement, for example, QoS 	class and average rate.

Agree. 

> indication of live 	connection. This will avoid reliance on explicit

Agree.

BR,

Haihong

---

From: [email-masked]
Date: Wed, 31 Oct 2001 08:07:21 +0200

Hi Georgios,

> In my opinion this charter is very much Mobile IP centric.

I'm sorry, but I don't see the Mobile IP centered-ness
of the charter.  We've been asked by members of the
IESG to consider one document as input to the discussion.

That being said, all parties are allowed & encouraged to
submit personal Internet Drafts for consideration. It might
be good if any drafts fit the first few work items:

Dec 01	Initial ID on Signaling Requirements.

Dec 01	Initial ID on Analysis of existing signaling protocols.

Mar 02 	Initial ID on 'Next Step QoS Signaling'.

I imagine that the 3rd work item would be some sort of framework
document.

best regards,
John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Wed, 31 Oct 2001 10:43:44 +0100

Hi John

Thank you very much for the reply. 
Please see my comments below.

[GK] = Georgios Karagiannis
[JL] = John Loughney

[GK] Before discussing possible modifications on 
[GK] RSVP, I think we should first discuss and 
[GK] agree on the charter.
[GK] In my opinion this charter is very much Mobile IP centric.

[JL] I'm sorry, but I don't see the Mobile IP centered-ness
[JL] of the charter. 
 
  Sorry John, but when I am  reading the following sentence,
  included in this charter, I really get the impression that 
  this charter is Mobile IP centric.

"As input to the working group, the Mobile IP QoS Requirements
document (draft-mobileip-qos-requirements) will be considered by the working
group."

[JL] We've been asked by members of the
[JL] IESG to consider one document as input to the discussion.

OK, but why then you have not considered the draft written 
by Scott Bradner and Allison Mankin entitled:
"Report of the Next Steps in Signaling BOF" and located at:      
http://search.ietf.org/internet-drafts/draft-bradner-nsis-bof-00.txt

This draft presents an initial set of
requirements for a next generation Internet signaling protocol.  
It is actually describing several requirements (briefly) 
presented by many people during the 50th IETF meeting.

Best regards,
Georgios

---

From: [email-masked]
Date: Wed, 31 Oct 2001 14:47:41 +0200

Hi Georgios,

> presented by many people during the 50th IETF meeting.

This hasn't come up in the chartering discussion with 
our ADs (Scott & Allison). I think that they are on the
list & they can speak up , if it would be good to consider
this as part of the WG effort.

John

---

From: Scott Bradner <[email-masked]>
Date: Wed, 31 Oct 2001 08:54:13 -0500 (EST)

a good point - that ID should be considered (that is why we wrote it)

Scott

---

From: "Chen, Weijing" <[email-masked]>
Date: Wed, 31 Oct 2001 10:53:50 -0600

John, Georgios,

If it is the case that NSIS is not limited to Mobile IP,  so we could
include signaling consideration for DSL, Ethernet on last mile, etc access
technology?

To simplifying the signaling protocol, we can focus on UNI function, which
could be independent of NNI function. For service provider point of view, we
see clearly need of separation of  UNI signaling and NNI signaling. Maybe
NSIS is the right platform for UNI only signaling?
 
--
Weijing Chen
SBC Technology Resources
9505 Arboretum Blvd.
Austin, TX 78759
512 372 5710
[email-masked]

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Wednesday, October 31, 2001 12:07 AM
To:	[email-masked]; [email-masked]
Subject:	RE: [NSIS] Proposed NSIS charter

Hi Georgios,

best regards,
John