Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling messages

From: "Geib, Ruediger" <[email-masked]>
Date: Tue, 5 Nov 2002 15:19:29 +0100

Hello Hannes

> if confidentiality
> protection is not considered at all then i argue that it is 
> hard to add.

Agreed. But I'd prefer to look at it as an option. I'm not 
sure whether encryption of signaling messages must be 
made mandatory.

> > Rüdiger
> > Or is it already the CSTP level
> > which must be encrypted?

> Hannes
> it always depends what information you deliver at each each 
> level/layer. the seperation between these layers is only 
> at a document level/logical and not physical!?
> providing different security mechanisms at different 
> layers is more difficult.

CASP suggests an omnivorous node, which, as far as I 
understood, may act as a kind of signaling relay 
(i.e. no upper level signaling protocol present locally).
This means, here's a physical separation of both layers. 
To me, a simple relay doesn't have to operate encryption.

Regards, Rüdiger
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Wed, 06 Nov 2002 10:30:04 -0500

> To me, a simple relay doesn't have to operate encryption.

The correct answer to any technical question is "it
depends," and I think it this case it comes down to
depending on how the application layer is split from the
transport layer, what information is contained in the
transport layer, and if the information that a relay would
need to forward the message correctly is itself encrypted.

My suspicion is that the information one might want to
protect from prying eyes will tend to be carried in the
application, and that any information that could be derived
from looking at transport layer daya could also be derived
from traffic analysis.

Melinda

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Thu, 7 Nov 2002 14:53:12 +0100

hi melinda,
hi ruediger!

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Wednesday, November 06, 2002 4:30 PM
> To: Geib, Ruediger
> Cc: [email-masked]; [email-masked]
> Subject: Re: [NSIS] Req-Draft: Open Issue 4: Confidentiality of
> signaling messages
>
>

basically we can not give a concrete answer to it. if you can clearly
specify what the function of a relay is then it might be easier to give an
answer for it.

for example:
if the only purpose of the relay is to forward the message without
processing nsis specific parts then there is no reason to have this entity
as a nsis node. if the relay might even modify the message then there is no
reason why not to treat it as a regular nsis entity.

> from looking at transport layer daya could also be derived

if someone want to apply security only at the application layer then
- you might restrict yourself to a limited number of security mechanisms
(cms would be a good choice)
- you will not receive protection for the transport relevant parts.

btw: ipsec even protects the transport layer vs. tls provides protection
above the transport layer (i.e. it does not protect the transport layer
header fields).

instead of discussing security at the transport or the application layer it
would suggest to consider the question of peer-to-peer vs. non peer-to-peer
protection first. if people think that there is need for non peer-to-peer
protection then some type of "application layer" security mechanisms have to
be introduced anyway.

ciao
hannes