Subject: RE: [NSIS] Updated Charter

From: "Hancock, Robert" <[email-masked]>
Date: Wed, 20 Nov 2002 02:22:58 -0000

Hi all,

I hope that the terminology discussion has not sown more confusion (assuming that's what is being referred to).

My understanding/opinion is the following:
1. there is no proposal anywhere on the table to have NSIS w.g. develop something which alters the routes that packets takes (either by distributing routes, fiddling with FIBs, or anything else).
2. it is certainly the case that the NTLP could never do this: it is simply responsible for moving signalling packets around, and in many (most?) cases will simply use normal IP routing to do this. (see also http://www.ietf.org/mail-archive/working-groups/nsis/current/msg02178.html.)
3. we can't rule out someone designing an NSLP some day which carries routing information, although doing this in a general sense seems not meaningful to me in the context of path-coupled signalling - how do you signal to set up a path in a path coupled way? (see also http://www.ietf.org/mail-archive/working-groups/nsis/current/msg01903.html.)

The reason for the terminology point being raised is that operation of the NTLP/NSLPs may be severely affected by the existence of 'policy forwarding' especially in NSIS-unaware (oops! invalid terminology) parts of the network. So, we wanted the term 'policy forwarding' as an unambiguous shorthand for the circumstances we are worried about.

Hope this helps,

Cheers,

Robert H.

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: 19 November 2002 17:31
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [NSIS] Updated Charter
> 
> 
> 
> I don't know about others, but the thought of
> having signaling alter forwarding decisions seems
> fairly scary. Treatment within the same queue
> seems fairly well understood, but having something
> outside of the well established routing protocols
> diddle with FIB's... well, let's say that the
> current crop of routing protocols were ironed
> out with much blood and sweat, and on a network
> long long ago, in a galaxy far far away.
> 
> [email-masked] writes:
>  > Hi Michael,
>  > 
>  > > So I'm somewhat confused about the earlier
>  > > exchange today about whether signaling to alter
>  > > the route packets take is in or out of scope, but
>  > > if it's in, it seems really odd to leave such a
>  > > large deliverable out of the charter. As in, I'd
>  > > imagine that a lot of the routing area folks would
>  > > probably be highly interested in such a thing, and
>  > > it wouldn't be very obvious that it was happening
>  > > here.
>  > 
>  > So, <chair hat off> I would prefer not to affect routing - any more
>  > than what RSVP currently does.  I'm not a routing expert, 
> so I worry 
>  > that this would be a big can of worms.  However, what does 
> the WG think 
>  > about this?  Do you have an opinion on what would be the 
> right thing to
>  > do Mike?
>  > 
>  > thanks,
>  > John
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 20 Nov 2002 09:06:27 -0500

Except that I'd use policy-based forwarding, since you're not forwarding 
the policy....

, although doing this in a general sense seems not meaningful to me in 
the context of path-coupled signalling - how do you signal to set up a 
path in a path coupled way? (see also 
http://www.ietf.org/mail-archive/working-groups/nsis/current/msg01903.html.)

---

From: Michael Thomas <[email-masked]>
Date: Thu, 21 Nov 2002 10:41:20 -0800 (PST)

Robert,

Can I make a general suggestion that terminology
which describes things that the wg isn't going to
address be elided? It's fairly easy to misconstrue
aims when time has gone into defining something
that could conceivably be worked on but that isn't
charter.

Or alternatively, you can tell me to pay more
attention.

		Mike

Hancock, Robert writes:
 > Registered Office: Roke Manor Research Ltd, Siemens House, Oldbury, Bracknell, 
 > Berkshire. RG12 8FZ
 > 
 > The information contained in this e-mail and any attachments is confidential to Roke 
 > Manor Research Ltd and must not be passed to any third party without permission. This 
 > communication is for information only and shall not create or change any contractual 
 > relationship.