Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling messages

From: "Geib, Ruediger" <[email-masked]>
Date: Fri, 8 Nov 2002 09:38:10 +0100

Hello Hannes

> for example:
> if the only purpose of the relay is to forward the message without
> processing nsis specific parts then there is no reason to 
> have this entity as a nsis node. if the relay might even 
> modify the message then there is no
> reason why not to treat it as a regular nsis entity.

My ideas:
The relay should be NSIS aware. It discovers NSIS CSTP neighbors. 
It forwards messages there. This may, but doesn't have to include 
a change in the next hop address. It has to be able to support all 
functions required to keep alive CSTP signaling relations to its 
neighbors (i.e. some operational features).
The relay is not involved into any service management.

Regards, Rüdiger 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Xiaoming Fu" <[email-masked]>
Date: Fri, 8 Nov 2002 10:47:16 +0100

Hi Rüdiger,

> > processing nsis specific parts then there is no reason to have this 
> > entity as a nsis node. if the relay might even modify the 
> message then 
> > there is no reason why not to treat it as a regular nsis entity.
> 
> My ideas:

I don't think a relay node should always be NSIS aware. My understanding
is a CSTP-speaking node before this relay node (along the data path) can
discovery next CSTP hop by its own discovery mechanism; the relationship
between CSTP signaling neighbors is maintained by themselves. Relay-only
node can simply forward the signaling message as a normal IP packet. 

Regards,
Xiaoming

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 8 Nov 2002 12:32:52 +0100

hi ruediger

if the relay is nsis aware then it terminates security. to forward signaling
messages to another node it again has to provide security processing. hence
it acts a regular nsis node. whether it actually performs for example qos
reservation is not relevant for nsis.

ciao
hannes

> -----Original Message-----
> From: Geib, Ruediger [mailto:[email-masked]]
> Sent: Friday, November 08, 2002 9:38 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of
> signaling messages
>
>
> Hello Hannes
>
> > for example: