Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling messages

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Tue, 5 Nov 2002 13:39:57 +0100

Hi Hannes

Combining the two bullets might be acceptable to me!

Best Regards,
Georgios

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: dinsdag 5 november 2002 12:11
To: Georgios Karagiannis (ELN); [email-masked]
Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of
signaling messages

hi georgios

i know your point of view. key management is also unfortunately associated
with cost. do we skip it only because it is difficult or expensive? maybe we
can agree on something like:
- in some enviroment confidentiality protection might not be required.
- "NSIS signaling messages MUST be possible to be confidentiality protected
between NSIS nodes."
(like john proposed)

ciao
hannes

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Georgios Karagiannis (ELN)
> Sent: Tuesday, November 05, 2002 11:07 AM
> To: [email-masked]
> Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of
> signaling messages
>
>
> Hi
>
> Hannes sorry, but I think that I agree with Bob on this!
>
> Best Regards,
> Georgios
>
> -----Original Message-----
> From: Bob Braden [mailto:[email-masked]]
> Sent: maandag 4 november 2002 18:26
> To: [email-masked]
> Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of
> signaling messages
>
>
>
>   *>
>   *> hi marcus
>   *>
>   *> i would agree to a stronger requirement for confidentiality
> protection of
>   *> signaling messages.
>   *>
>   *> how about:
>   *>
>   *> "NSIS signaling messages MUST be confidentiality protected
> between NSIS
>   *> nodes."
>   *>
>   *> ciao
>   *> hannes
>   *>
>   *>
>
> Whoa!!! Strong encryption has a cost, and it is by no means clear that
> very many users of your protocol are going to want or need to pay that
> cost in order to protect confidentiality of signaling.  Your version
> shifts from a requirement for support, which was reasonable, to
> a requirement for implementation and use, which is out of bounds.
>
> Bob Braden
>
>
>   *> > -----Original Message-----
>   *> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
>   *> > Marcus Brunner
>   *> > Sent: Friday, November 01, 2002 11:35 PM
>   *> > To: [email-masked]
>   *> > Subject: [NSIS] Req-Draft: Open Issue 4: Confidentiality
> of signaling
>   *> > messages
>   *> >
>   *> >
>   *> >
>   *> > Req-Draft: Open Issue 4: Confidentiality of signaling messages
>   *> > ---------------------------------------------------
>   *> >
>   *> > Proposal to change Req 5.7.8
>   *> > "The NSIS protocol MUST allow encryption of NSIS messages
> between NSIS
>   *> > nodes."
>   *> >
>   *> > Currently it says
>   *> >
>   *> > 5.7.8 Confidentiality of signaling messages
>   *> >
>   *> > Based on the signaling information exchanged between nodes
>   *> > participating in
>   *> > the signaling protocol an adversary may learn both the
> identities and the
>   *> > content of the signaling messages. To prevent this from happening,
>   *> > confidentiality of the signaling message in a hop-by-hop
> manner MAY be
>   *> > provided. Note that the protection can be provided on a
> hop-by-hop basis
>   *> > for most message payloads since it is required that entities
>   *> > which actively
>   *> > participating in the signaling protocol must be able to read and
>   *> > eventually
>   *> > modify the content of the signaling messages."
>   *> >
>   *> > --------------------------------------
>   *> > Dr. Marcus Brunner
>   *> > Network Laboratories
>   *> > NEC Europe Ltd.
>   *> >
>   *> > E-Mail: [email-masked]
>   *> > WWW:    http://www.ccrle.nec.de/
>   *> > Phone: +49 (0) 6221 905 11 29
>   *> > personal home page: http://www.brubers.org/marcus
>   *> >
>   *> >
>   *> > _______________________________________________
>   *> > nsis mailing list
>   *> > [email-masked]
>   *> > https://www1.ietf.org/mailman/listinfo/nsis
>   *>
>   *> _______________________________________________
>   *> nsis mailing list
>   *> [email-masked]
>   *> https://www1.ietf.org/mailman/listinfo/nsis
>   *>
>
>
> ----- End Included Message -----
>
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Tue, 05 Nov 2002 08:39:32 -0500

I'd tweak the English so that it's more idiomatic:

"It MUST be possible to confidentiality-protect signaling
messages between NSIS Entities."

[n.b. I changed it to "NSIS Entities" to match language in
the framework document, but there still seems to be some
slop around "Entities" and "Nodes" - I can live with either]

Melinda
[still catching up on old email]
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis