Subject: Re: [NSIS] Req-Draft: Open Issue 2: Independence of reservation identifier

From: Bob Braden <[email-masked]>
Date: Mon, 4 Nov 2002 17:53:55 GMT

*> 
  *> 
  *> Req-Draft: Open Issue 2: Independence of reservation identifier
  *> ----------------------------------------------------
  *> 
  *> - see thread on NSIS and mobility
  *> - is the req needed?
  *> - is it needed for a general NSIS base protocol? Or is it application 
  *> dependent?
  *> 
  *> 5.4.3 Independence of reservation identifier
  *> 
  *> A reservation identifier MUST be independent of the flow identifier (flow 

Actually, only trouble I have with this statement is capitalizing
MUST.  By its very definition, a reservation identifier is independent
of the flow identifier (otherwise, we wouldn't call it a reservation
identifier, we would call it a flow identifier, right?) Since the
independence is by definition, not de jure, there is no place for MUST
here -- there is no requirement.  The requirement (should it be agreed
upon), woudd simply be that the protocol MUST support a reservation
identifier.

HINT: The best list of requirements is the shortest list, not the
longest list.

Bob Braden

  *> end-points). Various scenarios in the mobility area require this 
  *> independence because flows resulting from handoff might have changed 
  *> end-points etc. but still have the same service requirement. Also several 
  *> proxy-based signaling methods profit from such as independence.
  *> 
  *> 
  *> --------------------------------------
  *> Dr. Marcus Brunner
  *> Network Laboratories
  *> NEC Europe Ltd.
  *> 
  *> E-Mail: [email-masked]
  *> WWW:    http://www.ccrle.nec.de/
  *> Phone: +49 (0) 6221 905 11 29
  *> personal home page: http://www.brubers.org/marcus
  *> 
  *> 
  *> _______________________________________________
  *> nsis mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/nsis
  *> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 05 Nov 2002 14:38:16 +0100

Bob,

Just for clarification. Is the emphesis on the independence the problem? Or 
is the reservation ID itself the problem?

So reformulating the requirement into "An NSIS protocol MUST support a 
reservation identifer" would solve the first one. The reservation 
identifier then can be the same as the flow id or can be something else.

Marcus

or are you
>   *> end-points etc. but still have the same service requirement. Also
> several    *> proxy-based signaling methods profit from such as
> independence.   *>
>   *>

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
personal home page: http://www.brubers.org/marcus