Subject: [NSIS] sender/receiver initiation (was: RE: Comments on framework draft)

From: "Hancock, Robert" <[email-masked]>
Date: Mon, 4 Nov 2002 19:58:34 -0000

Hi Melinda, all,

Now all deadlines are passed, some technical responses to your earlier comments. I'm trying to break these up to enable some conversational focus.

['>' = MS]
> 4.2 control primitives seem to assume sender-oriented
>     signaling (para 3).
[NB para 2 in -01.txt]
> 
> 4.3.2 depends entirely on whether sender-oriented or
>     receiver-oriented signaling is used.
> 

Actually, I'm not sure why this impression is given: the basic point is that there is no assumed relationship of NI/NR w.r.t. data sender or receiver. If the NI is at  (or near) the sender, 4.2 and 4.3.2 are describing sender-oriented signallng, but not if it is at the receiver. (Maybe it should be emphasised earlier?)

Of course, there's a group of *much* bigger questions this relates to:
*) Should NSIS concentrate on one (sender/receiver) paradigm or the other?
*) Do the concepts of NI/NR relate to the NTLP or NSLPs? (It was even quite hard to update the draft without knowing this.)
*) Indeed/alternatively, do the message types (4.3.2) expose themselves in the NTLP or NSLPs? For example, do we know already that for all time, all signalling applications will need the NTLP to send messages which 'request' or 'release' etc. things called 'reservations'? Or should we look at a thinner NTLP which just sends messages along the data path with or against the flow direction? (I think it's instructive to look at the evolution of AAA protocols in this respect.)

I don't pretend these are easy questions.

Cheers,

Robert H.

PS: I've tried to summarise some of these issues (and suggest a way forward), in what I hope is a non-partisan, protocol independent i-d, draft-hancock-sender-receiver-00.txt. The main issues seem to be the ones noted above.
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Tue, 05 Nov 2002 15:17:47 -0500

> Actually, I'm not sure why this impression is given: the
> basic point is that there is no assumed relationship of
> NI/NR w.r.t. data sender or receiver. If the NI is at (or
> near) the sender, 4.2 and 4.3.2 are describing
> sender-oriented signallng, but not if it is at the
> receiver. (Maybe it should be emphasised earlier?)

I think so - like it or not we do have an existing
understanding of "sender" and "receiver" that's based on
RSVP, and if we're going to use the terms differently that
difference needs to be described clearly.  This also
explains why I thought your definitions of receiver-
initiated and sender-initiated signaling were nuxied.

Melinda