Subject: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling messages

From: Marcus Brunner <[email-masked]>
Date: Fri, 01 Nov 2002 23:35:27 +0100

Req-Draft: Open Issue 4: Confidentiality of signaling messages
---------------------------------------------------

Proposal to change Req 5.7.8
"The NSIS protocol MUST allow encryption of NSIS messages between NSIS 
nodes."

Currently it says

5.7.8 Confidentiality of signaling messages

Based on the signaling information exchanged between nodes participating in 
the signaling protocol an adversary may learn both the identities and the 
content of the signaling messages. To prevent this from happening, 
confidentiality of the signaling message in a hop-by-hop manner MAY be 
provided. Note that the protection can be provided on a hop-by-hop basis 
for most message payloads since it is required that entities which actively 
participating in the signaling protocol must be able to read and eventually 
modify the content of the signaling messages."

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
personal home page: http://www.brubers.org/marcus

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Mon, 4 Nov 2002 18:11:45 +0100

hi marcus

i would agree to a stronger requirement for confidentiality protection of
signaling messages.

how about:

"NSIS signaling messages MUST be confidentiality protected between NSIS
nodes."

ciao
hannes

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Marcus Brunner
> Sent: Friday, November 01, 2002 11:35 PM
> To: [email-masked]
> Subject: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling
> messages
>
>
>