Subject: [NSIS] First bug in: draft-braden-2level-signal-arch-01.txt

From: Bob Braden <[email-masked]>
Date: Thu, 7 Nov 2002 18:31:02 GMT

----------
X-Sun-Data-Type: text
X-Sun-Data-Description: text
X-Sun-Data-Name: text
X-Sun-Charset: us-ascii
X-Sun-Content-Lines: 69

Hi.  We have found the first bug (;-)) in the revised 2level signaling
draft.  The bug is in the definitions of signaling messages xSig()
on page 17: all the messages that carry an SAPUid but NOT an SAPU
should carry a LIST of SAPUids ("SAPUid-list").  This is a signficant
efficiency hack.  It allows a single REFRESH message, in particular,
to refresh a whole boatload of state in one message.  Here is the
revised table of messages:

           xSig(NEW, h-src, SAPUid, SAPU, R)
           xSig(MOD, h-src, SAPUid, SAPU, old-SAPUid, R)
           xSig(TEAR, h-src, SAPUid-list)
           xSig(REFRESH, h-src, SAPUid-list, R)
           xSig(ACK, h-dest, SAPUid-list)
           xSig(NACK, h-src, SAPUid-list)
           xSig(INFO, h-src, SAPUid, SAPU)
           xSig(EVENT, h-src, SAPUid, SAPU)
           xSig(CHALLENGE, h-src, challenge-object)
           xSig(RESPONSE, h-src, challenge-object)
           xSig(ERROR, h-dest, SAPUid-list)

Bob Braden

----- Begin Included Message -----

---

From: [email-masked]
Date: Fri, 8 Nov 2002 10:17:25 +0200

Resending this to the list:

> -----Original Message-----
> From: ext Bob Braden [mailto:[email-masked]]
> Sent: 07 November, 2002 20:31
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [NSIS] First bug in: draft-braden-2level-signal-arch-01.txt

Bob Braden

----- Begin Included Message -----