Subject: [NSIS] Updated Charter

From: [email-masked]
Date: Tue, 19 Nov 2002 21:43:09 +0200

Hi all,

Here is the updated charter I presented at IETF55 today.  Please send comments.

John

Next Steps in Signaling (nsis) Charter

Chair(s):
J. Loughney <[email-masked]>

Transport Area Director(s):
S. Bradner <[email-masked]>
A. Mankin <[email-masked]>

Transport Area Advisor:
A. Mankin <[email-masked]>

Mailing Lists:
General Discussion: [email-masked]
To Subscribe: [email-masked]
In Body: (un)subscribe
Archive: www.ietf.org/mail-archive/working-groups/nsis/current/maillist.html

Description of Working Group:

The Next Steps in Signaling Working Group is responsible for standardizing an IP signaling protocol with QoS signaling as the use case for NSIS.  This working group will concentrate on a two-layer signaling paradigm.  The intention is to re-use, where appropriate, the protocol mechanisms of RSVP, while at the same time simplifying it and applying a more general signaling model.  

The existing work on the requirements, the framework and analysis of existing protocols will be completed and used as input for the protocol work. 

NSIS will develop a transport layer signaling protocol for the transport of upper layer signaling. In order to support a tool box or building block approach, the two-layer model will be used to seperate the transport of the signaling from the application signaling.  This allows for a more general signaling protocol to be developed to support signaling for different services or resources, such as NAT & firewall traversal and QoS resources.  The initial NSIs application layer will be an optimzed RSVP signaling.  Potential for a second NSIS application layer, in order to ensure a generic transport signaling protocol, will be considered in consultation with the Transport Area directors.

Security is a very important concern for NSIS. The working group will study and analyze the threats and security requirements for signaling. Compatibility with authentication and authorization mechanisms such as those of Diameter, COPS-PR, and RSVP-PR auth-session, will be addressed.

It is a non-goal of the working group to develop new resource allocation protocols. Resource reservation and traffic engineering are out of scope of this working group.  Additionally, third party signaling is out of scope of this working group.  Mobility protocols and AAA work are out of scope of the working group. The work produced in this Working Group should work with existing IETF mobility and AAA protocols, including (but not limited to) Mobile IP, SeaMoby Context also welcomes participation and expression of requirements from non-IETF standards organization members, for instance 3GPP, 3GPP2 and ITU-T. 

Goals and Milestones:

JAN 03	Submit "Requirements for Signaling Protocols" to IESG for publication as Informational RFC
MAR 03	Submit "RSVP Security Properties" to IESG as Informational RFC
APR 03	Submit "NSIS Threats" to IESG as Informational RFC
JUN 03	Submit "Analysis of Existing Signaling Protocols" to IESG as Informational RFC
AUG 03	Submit "Next Steps in Signaling: Framework" to IESG for publication as Informational RFC
MAR 04	Submit "NSIS Transport Protocol" to IESG for publication for Proposed Standard
MAR 04	Submit "NSIS QoS Application Protocol" to IESG for publication for Proposed Standard
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Michael Thomas <[email-masked]>
Date: Tue, 19 Nov 2002 13:47:05 -0800 (PST)

So I'm somewhat confused about the earlier
exchange today about whether signaling to alter
the route packets take is in or out of scope, but
if it's in, it seems really odd to leave such a
large deliverable out of the charter. As in, I'd
imagine that a lot of the routing area folks would
probably be highly interested in such a thing, and
it wouldn't be very obvious that it was happening
here.

		Mike