Subject: [NSIS] Comment : RSVP Analysis Draft

From: ICN Genesis Mose <[email-masked]>
Date: Thu, 7 Nov 2002 14:41:36 +0100

Hello Everyone,
I am currently doing my Master Thesis at Siemens AG, Munich under Dresden University of Technology and work focus is QoS on access networks which is related to the EU project AQUILA (http://www.ist-aquila.org/).

The thesis also comes up with a comparison between RSVP, YESSIR and Boomerang in access network scenarios and in my study I have come to the conclusion that RSVP in spite of its complex architecture can still be efficiently used in Access and some other architecture in the core network, like AQUILA. Though YESSIR presents a more efficient alternative to RSVP, but due to it being signaled over RTP, only multimedia traffic can be guaranteed QoS, and if traffic independent QoS is required then it does not serve the purpose. Though Boomerang offers a very efficient architecture but the wide support of RSVP on routers and OS plays towards its favor.  The major complexity of RSVP starts in the core where the number of flows increases drastically, but in access where the flows are limited, it can efficiently be used.

In the work I make relevant changes to terminate RSVP in the ingress access and start a AQUILA session on the edge router for core and then re-start RSVP on egress to complete edge to edge QoS. In further work I would try to prove that this solution is better than pure RSVP solution.
I think the work might be of interest to NSIS for further discussion.

Regards,
Sandeep Misra.

-------------------------------------------------------------------------
Sandeep Misra 
ICN WN CC NA A19 
Siemens AG
Hofmannstr. 51, 
D-81379 Munich. 
Tel(O) : +49 89 72258443 
Project AQUILA : http://www.ist-aquila.org
Core Team Member - Siemens InterGreat : http://intranet.icn.siemens.de/intergreat
--------------------------------------------------------------------------

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Fri, 8 Nov 2002 08:56:13 +0200

Hi,

> I am currently doing my Master Thesis at Siemens AG, Munich 
> under Dresden University of Technology and work focus is QoS 
> on access networks which is related to the EU project AQUILA 
> (http://www.ist-aquila.org/).
> 
> The thesis also comes up with a comparison between RSVP, 
> YESSIR and Boomerang in access network scenarios and in my 
> study I have come to the conclusion that RSVP in spite of its 
> complex architecture can still be efficiently used in Access 
> and some other architecture in the core network, like AQUILA. 
> Though YESSIR presents a more efficient alternative to RSVP, 
> but due to it being signaled over RTP, only multimedia 
> traffic can be guaranteed QoS, and if traffic independent QoS 
> is required then it does not serve the purpose. Though 
> Boomerang offers a very efficient architecture but the wide 
> support of RSVP on routers and OS plays towards its favor.  
> The major complexity of RSVP starts in the core where the 
> number of flows increases drastically, but in access where 
> the flows are limited, it can efficiently be used.
> 
> In the work I make relevant changes to terminate RSVP in the 
> ingress access and start a AQUILA session on the edge router 
> for core and then re-start RSVP on egress to complete edge to 
> edge QoS. In further work I would try to prove that this 
> solution is better than pure RSVP solution.

If you could comment on the current Analysis draft and suggest some
text, that would be very helpful.

thanks,
John

---

From: ICN Genesis Mose <[email-masked]>
Date: Fri, 8 Nov 2002 13:22:44 +0100

Hi,

Sure, I would try to come up in some time with some more comments on the draft which
might be helpful.

in response to some other queries that I got, probably points which were not clear from 
the first posting:

1.	as I am still writing the thesis so unfortunately at the moment no paper is 
available for further reading. I will be completing the thesis in a month or two and 
then I can send the work for reading. Till that time you may like to have a look at my 
thesis talk slides which would give a better idea of the work:
http://www-st.inf.tu-dresden.de/home/download/pdf/MasterTalk_SM.pdf

2.	there is a typo in the last para of my posting, kindly read it as "end to end QoS" 
instead of "edge to edge QoS", thanks for pointing out

3.	the thesis does study influencing factors like NAT but does not implement a 
solution, also no security issues are dealt with. These could be topics for further work 
though.

4.	the work could contribute to NSIS, in particular, contributing towards the 
Internet Draft on RSVP Analysis, and in general for a end to end QoS solution. The point 
that I wish to put forward is that it might be of interest to use RSVP on access and an 
diffserv enabled architecture in core (like AQUILA) to provide end to end QoS, instead 
of coming up with a altogether new protocol. Of course it is debatable.

Regards,
Sandeep

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Freitag, 8. November 2002 07:56
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] Comment : RSVP Analysis Draft

Hi,

thanks,
John