Subject: RE: nsis mobility interactions (was: RE: [NSIS] Some comments on draft-ietf-nsis-req-04.txt)

From: [email-masked]
Date: Mon, 4 Nov 2002 10:59:26 +0200

Hi Rüdiger,

What I take from Bob's mail is that an NSIS protocol may wish
to have a neighbor discovery process, so it knows what are
the NSIS hops around it.  This could be very useful when nodes
fail and things need to be re-routed / re-signaled.  This 
type of thing is not explicitly off-path signaling, so I think
it is within scope. This could be considered as part of the
building blocks of the protocol.

Additionally, what I think of as out of scope
is for NSIS endpoints to try to discover different services which
a network may provide.

Am I addressing your concern?

John
> -----Original Message-----
> From: ext Geib, Ruediger [mailto:[email-masked]]
> Sent: 31 October, 2002 10:26
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: nsis mobility interactions (was: RE: [NSIS] Some comments
> on draft-ietf-nsis-req-04.txt) 
> 
> 
> Hi John,
> 
> I support Bob's suggestion and would like to ask you about your
> and the AD's position.
> 
> Regards, Rüdiger
> 
> Bob Braden wrote:
> 
> There is a subtle difference between neighbor discovery and 
> routing.  Discovery allows a node to find all the neighbor 
> nodes to which signaling messages might be forwarded.
> Routing determines which actual next hops are used for 
> forwarding a particular signaling message.  Neighbor 
> discovery involves only local information,\ while routing 
> involves global information in general.
>  
> I can imagine that the new QoS signaling protocol [I refuse 
> to call it "NSIS", because I think that's a dumb name for 
> a protocol] might want to have a neighbor discovery 
> mechanism (roughly an "up/down" protocol), but it might 
> still want to route signaling packets using the same 
> routing that is used for data packets.  Note that if you 
> use "some different routing mechanism", you almost 
> certainly have times when data routing differs from 
> signal routing, which is busted.
> 
> Thanks,
> 
> Bob Braden
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 4 Nov 2002 14:25:34 +0100

Hi John,

As already mentioned, sounds good to me. What's the AD's view?

> John Loughney wrote:

---

From: Bob Braden <[email-masked]>
Date: Mon, 4 Nov 2002 16:50:50 GMT

*> 
  *> Hi Rüdiger,
  *> 
  *> What I take from Bob's mail is that an NSIS protocol may wish

may, or may not... it is an open technical question that needs
thought and debate.  RSVP did not need such a process, so there
is precedent for the CON side.  The PRO sides needs to provide
some convincing examples of where explicit neighbor discovery
is needed.

Bob Braden