Subject: RE: [NSIS] Req-Draft: Open Issue 4: Confidentiality of signaling messages

From: "Geib, Ruediger" <[email-masked]>
Date: Tue, 5 Nov 2002 09:13:52 +0100

Hannes,

I agree with Bob that encryption of signaling messages 
is an option, not a requirement. A security mechanism 
I'd like to see is a digest added to a message. That's 
message integrity, I assume as non security expert, 
and therefore another thread.

Regards, Rüdiger  

> i would agree to a stronger requirement for confidentiality 
> protection of signaling messages.
> 
> how about:
> 
> "NSIS signaling messages MUST be confidentiality protected 
> between NSIS nodes."

> > Req-Draft: Open Issue 4: Confidentiality of signaling messages
> > ---------------------------------------------------
> >
> > Proposal to change Req 5.7.8
> > "The NSIS protocol MUST allow encryption of NSIS messages 
> between NSIS
> > nodes."
> >
> > Currently it says
> >
> > 5.7.8 Confidentiality of signaling messages
> >
> > Based on the signaling information exchanged between nodes
> > participating in the signaling protocol an adversary may
> > learn both the identities and the content of the signaling
> > messages. To prevent this from happening,
> > confidentiality of the signaling message in a hop-by-hop 
> > manner MAY be provided. Note that the protection can be
> > provided on a hop-by-hop basis for most message payloads
> > since it is required that entities which actively
> > participating in the signaling protocol must be able to
> > read and eventually
> > modify the content of the signaling messages."
 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 5 Nov 2002 09:35:19 +0100

hi

i guess that there is no doubt that a signaling protocol like NSIS must at
least offer peer-to-peer protection. it was often mentioned that more than
peer-to-peer protection might also be required. should there be a
requirement which states something similar?

ciao
hannes

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 5 Nov 2002 09:35:19 +0100

hi ruediger.

> is an option, not a requirement.

what i would like to prevent is that a requirement for encryption is so
fuzzy that actually nobody applies it their protocol proposals. adding
confidentiality protection later to a protocol is often quite difficult.
protocol designers should consider it during the initial design.  an area
where is see a need for confidentiality protection is communication of
policy rules (midcom). providing protection against traffic analysis is also
a good goal to achieve looking at the increasing importance of privacy
issues.

> A security mechanism
yes, keyed message digest.

ciao
hannes

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 05 Nov 2002 15:05:13 +0100

I am not sure what we need to protect end-to-end can you give some example 
applications for other then peer-to-peer

Marcus

> requirement which states something similar?

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
Phone: +49 (0) 6221 905 11 29
personal home page: http://www.brubers.org/marcus

---

From: Melinda Shore <[email-masked]>
Date: Tue, 05 Nov 2002 14:51:07 -0500

> applications for other then peer-to-peer

It's possible - likely, even - that there are applications
in which a resource allocation decision depends on the
authenticated identity of the NSIS initiator or other
identity information in the packet, or requires that the
request be authenticated cryptographically using the key of
the originator.  In this case I would say that there's
likely to be a need to provide end-to-something protection,
where "protection" means "authentication."  This, however,
is almost certainly an NSIS application requirement and not
an NSIS transport layer requirement.

Melinda

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 6 Nov 2002 10:11:47 +0100

hi melinda!

from your text i read that you think that something like end-to-middle
authentication should be supported. i agree with you that it is applicable
to the nsis application level - not to the transport.

ciao
hannes