Subject: RE: [NSIS] consensus probe on one aspect of NTLP operation

From: [email-masked]
Date: Fri, 21 Feb 2003 11:53:27 +0200

Rudiger,

> From a carrier point of view, reliability in signaling 
> transport is a must. If packets get lost during phases of 
> congestion, the added load on systems having to cope with 
> these losses must be minimised. Congestion frienliness may be 
> helpful. I guess, the lower the layer dealing with the issue, 
> the better. a) therefore is the preferred choice. 
> 
> I didn't say "transport must be TCP". I just listed some 
> requirements. It may be helpful if we first discuss 
> requirements and continue with solutions later. 

Is a soft-state refresh sufficient for reliability, or do you
think guarenteed delivery to be important?

thanks,
John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Michael Thomas <[email-masked]>
Date: Fri, 21 Feb 2003 12:14:32 -0800 (PST)

Something that I think has gotten a bit of the
short-shrift in the discussions from what I can
tell is the inherent problems with messaging and
mobility. The current cellular/pstn infrastructure
is highly optimized not only for bandwidth which
is often trotted out as a forcing function, but
more importantly IMO for handoffs. The march of
progress, IMO, will address the former, but I'm
not as convinced that latencies will advance at
nearly the pace. 

Part of the problem here is a somewhat systemic
problem within IETF which stovepipes problems and
doesn't do "architectures". While I have a great
deal of respect for that approach, I suspect that
the physics of fast mobility is going to be harder
to ignore: the PSTN, after all, only does a barely
adequate job of handoffs, and it's a customized
network for a customized application... unlike the
internet which is neither.

For NSIS in particular, I don't recall anybody
asking what the cost of establishing and
reestablishing connection state is in the face of
the longer term goal of wanting to provide real
time mobility for, oh say, VoIP. RSVP is
essentially a command/response kind of protocol
whereas TCP/SCTP requires a *prior* threeway
handshake before anything useful gets done. For
things that aren't moving, maybe that doesn't make
much difference. For things that are... I suspect
that the total message count -- and how localized
those messages are -- will make a tremendous
difference. This problem is certainly not NSIS's
alone, but every bit counts.

	   Mike