Subject: AW: [NSIS] Transport functionality in the NTLP

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 19 Feb 2003 09:13:55 +0100

Dear all,

the transport protocol must ensure that signaling messages aren't lost or corrupted. Further, NTLP is expected to deal with route changes. I don't think that an unreliable transport is best possible solution supporting this task. Congestion avoidance is a benefit to users and operators, that's why it must be present too. To me, a) seems to be reasonable option.

Regards, Rüdiger

| a) yes the protocol must always guarantee this feature explicitly

| 1. Congestion control (NTLP must protect the local network 
| from signalling overload) - suggest (a)
| 2. High probability of delivery to the next NE even in the 
| face of packet drops - I suggest (a)
| 3. Guaranteed delivery to next NSLP node with feedback on 
| success - I suggest (d)
| 4. Bundling of small messages - I suggest (c), doing it has 
| only local significance
| 5. Segmentation to avoid link/path MTU limits - I suggest 
| (a), or (b) if you know all your links up to the next NE can 
| be engineered to have a big enough MTU
| 6. In order delivery and duplicate detection/removal - I 
| suggest (a) (maybe (c), if you are prepared to put it back 
| locally in adjacent hops)
| 7. Framing (supporting message boundaries) - I suggest (a)
| 8. Flow control - not sure about this one. Maybe (c)
| 9. Security (confidentiality, integrity protection) - I 
| suggest (a) or (b)
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Lars.Westberg" <[email-masked]>
Date: Wed, 19 Feb 2003 11:28:09 +0100

The transport protocol may have these function, but I do not see that it is neccessary in all applications. Un-reliable transport is a must in this protocol.
Make the NTLP as a minimum set of functions.

Regards Lasse