Subject: RE: AW: [NSIS] Transport functionality in the NTLP

From: "Naidu, Venkata" <[email-masked]>
Date: Thu, 20 Feb 2003 16:53:57 -0500

Ping,

-> Ping Pan writes:
->  One TCP session is established between RSVP neighbors. 
 
  I can see some practical implications with my previous 
  experience. Consider a scenario where multiple parallel
  links are between neighbors. The RSVP requirement as of today 
  (with QoS restrictions) is that, some messages Path, Resv etc
  must follow the exact interface on which the Resource 
  Reservation has to happen. 

  AFAIK, with TCP we can't open a socket bound to an interface.
  We can force a packet out an interface with SO_DONTROUTE
  (ie IP_ROUTETOIF) socket option, but that option sets
  TTL to 1 which is not desired for RSVP.

  For example take LDP with per interface label space, then
  we should have multiple TCP sessions to the neighbor (one
  per each link - label space - connected to the neighbor).

  There are some such small implementation nits we have to
  consider when moving a protocol transport mechanism from one
  to the other. It is very hard to imagine all such hidden
  low level details, but some are definitely tied to the
  protocols (here, RSVP) core design. Thanks!

Venkata.
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Ping Pan <[email-masked]>
Date: Thu, 20 Feb 2003 14:21:59 -0800

Naidu, Venkata wrote:
>   links are between neighbors. 

Not a problem. By definition, each RSVP neighbor is associated with the 
interface IP address. If there are multiple links in between, first, not 
sure the network should be config'ed that way. If it is, GMPLS has this 
unnumber-interface support. :-)

> The RSVP requirement as of today 

Yes.

>   per each link - label space - connected to the neighbor).

:-) Glad you bring this up. In LDP, there could be multiple TCP 
sessions. But there is only one is used for peering. Once the peering is 
established (with all that client-service figured out), cannot two nodes 
start to exchanged reservation information directly? You are right, we 
need to deal with the interface-binding more carefully.

>   protocols (here, RSVP) core design. Thanks!

Or start to read LDP. LDP's label merging stuff gives me stomachache, 
but its transport layer is pretty clean, IMHO. :-)

- Ping