Subject: RE: [NSIS] AD Review comments on draft-ietf-nsis-req-07.txt

From: [email-masked]
Date: Tue, 17 Jun 2003 07:00:40 +0300

Hi Attila,

> I do not completely understand your argument for MUST 
> implementation of hop-by-hop security. 'Must be implemented 
> but not must use' means that there is the possibility to use 
> hop-by-hop security in any NE but it has to be implemented 
> even if it is never used. 'SHOULD be supported' means that it 
> has to be implemented except in particular cases. I think it 
> is strong enough. 

We are designing this for the Internet (see the 'I' in the 
IETF).  This being so, security is extremely important and
is needed to ensure a robust protocol that is resistant
to DoS attacks; protects infrastructure, etc.  In this
way:

 Channel security between signaling entities MUST be implemented.

seems perfectly reasonable.  Sysadmins, etc., can decide if
it needs to be turned on or not.

John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 17 Jun 2003 10:07:04 +0200

> to DoS attacks; protects infrastructure, etc.  In this

You are right, but there are situations where security can be provided,
without adding additional functionality into the protocol.

For example, the security threats within a trusted administrative domain are
different then
the security threats in a inter-domain communication. Therefore, the
security features
required in these two situations are different.

Best Regards,
Georgios