Subject: RE: [NSIS] framework: proposal on fragmentation

From: "Daniel Warren" <[email-masked]>
Date: Thu, 5 Jun 2003 15:41:51 +0100

I'm still not entirely getting this.  Where exactly is the 'optionality'?
If a connection has an MTU size set that is huge, then there may never be a
need to segment, but that isn't an option, other than a configuration option
on that link.  It says nothing about whether segmentation is implemented or
not, it just means segmentation is never an issue.

If you have an option to implement segmentation in the true sense of an
option, then if you don't implement and messages exceed the size that allows
them to fit within the MTU, they will get dropped or errored.  Surely thats
not the option you want to enable...?

Dan

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]]
Sent: 05 June 2003 15:33
To: Melinda Shore
Cc: [email-masked]
Subject: Re: [NSIS] framework: proposal on fragmentation 

Hi Melinda

I agree with your proposal! Actually this is also what I meant in my
previous e-mails, i.e.,  optional use of fragmentation at the NTLP layer!

Best regards,
Georgios

----- Original Message -----
From: "Melinda Shore" <[email-masked]>
To: "Hancock, Robert" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 05, 2003 3:41 PM
Subject: Re: [NSIS] framework: proposal on fragmentation

> I'd really like to see optional (probably optional-to- use,
> mandatory-to-implement) support for fragmentation, and I
> think it's pretty clear that the only reasonable place to
> put it is in the NTLP.  I don't think it's healthy to be
> inflexible about layer separation but this is a case in
> which it would be a lot messier to do it anywhere but in the
> NTLP, because it's the NTLP that "knows" what the actual
> packet sizes are.  (Note also that relying on IP layer
> fragmentation can cause NAT failures).  I'm very much in
> agreement.
>
> Melinda
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 5 Jun 2003 16:58:59 +0200

RE: [NSIS] framework: proposal on fragmentationHi Daniel

There are different ways of applying the NTLP feature as optional, for example:

* some nodes do not implement the NTLP fragmentation at all;
* any NSLP should be able to require from the NTLP to fragment its messages or not.

Best regards,
Georgios

  ----- Original Message ----- 
  From: Daniel Warren 
  To: 'Georgios Karagiannis' ; Melinda Shore 
  Cc: [email-masked] 
  Sent: Thursday, June 05, 2003 4:41 PM
  Subject: RE: [NSIS] framework: proposal on fragmentation 

  I'm still not entirely getting this.  Where exactly is the 'optionality'?  If a connection has an MTU size set that is huge, then there may never be a need to segment, but that isn't an option, other than a configuration option on that link.  It says nothing about whether segmentation is implemented or not, it just means segmentation is never an issue.

  If you have an option to implement segmentation in the true sense of an option, then if you don't implement and messages exceed the size that allows them to fit within the MTU, they will get dropped or errored.  Surely thats not the option you want to enable...?

  Dan 

  -----Original Message----- 
  From: Georgios Karagiannis [mailto:[email-masked]] 
  Sent: 05 June 2003 15:33 
  To: Melinda Shore 
  Cc: [email-masked] 
  Subject: Re: [NSIS] framework: proposal on fragmentation 

  Hi Melinda 

  Best regards, 
  Georgios