Subject: RE: [NSIS] framework: proposal on fragmentation

From: [email-masked]
Date: Fri, 6 Jun 2003 12:33:21 +0300

Hi Georgios,

If an application that uses a NSLP can solve the problem of fragmentation by 
its own  then you do not need to activate the fragmentation/reassembly features.
By activate I mean that you initiate these features without really using them.
 
This can be solved very easily; the sender NSLP, by using the NSLP/NTLP API, 
will inform the NTLP protocol to swicth off the fragmenation option.
 
Yes, but how do you know that intermediate notes have not fragmented?  Or even worse,
because of some network changes, packets are routed differently through a link with a very
small MTU that causes fragmentation?
 
John

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 6 Jun 2003 11:44:48 +0200

RE: [NSIS] framework: proposal on fragmentationHi John

First of all the NTLP protocol has to use some information, e.g., a fragmentation bit, to specify that 
fragmentation is allowed or not. 
Now, if the sender NSLP (NI) informs its NTLP instance to switch off the fragmentation, then this NTLP instance 
will switch off the fragmentation bit. In this way all the intermediate NTLP nodes will know that fragmentation is 
not allowed.

Best regards,
Georgios
  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Friday, June 06, 2003 11:33 AM
  Subject: RE: [NSIS] framework: proposal on fragmentation

  Hi Georgios,

     
    John

---

From: "Lars.Westberg" <[email-masked]>
Date: Fri, 06 Jun 2003 17:10:16 +0200

Comments below:

[email-masked] wrote:

> Hi Georgios,
>
>      If an application that uses a NSLP can solve the problem of
>      fragmentation byits own  then you do not need to activate
>      the fragmentation/reassembly features.By activate I mean
>      that you initiate these features without really using
>      them. This can be solved very easily; the sender NSLP, by
>      using the NSLP/NTLP API,will inform the NTLP protocol to
>      swicth off the fragmenation option. Yes, but how do you know
>      that intermediate notes have not fragmented?  Or even
>      worse,because of some network changes, packets are routed
>      differently through a link with a verysmall MTU that causes
>      fragmentation?John
>

If we have an IP-network, the IP-layer may fragment/reassembly the
packets.  For me, it does not mean that the NTLP must perform
fragmentation.

If we have an NSLP that want to have an certain transport service from
the NTLP. Can't that choose a proper level of operation by the API ?

If the knowledge of a NSLP-instance does not exist in the router, the
router could probably forward the packet in the same way it has rececied
them without performing bundeling,  fragmentation.....

Regards Lasse

---

From: Roland Bless <[email-masked]>
Date: Tue, 10 Jun 2003 15:06:30 +0200

Hi Lasse,

I don't think you can rely on IP fragmentation features in this case, as
John already mentioned earlier: IPv6 will only fragment/reassemble
packets in an end-to-end fashion. In this case reassembly/fragmentation
will only work if an NTLP node is the destination/source of the IP
packet conveying the signaling message, which is not always true for
path-coupled signaling messages.

> them without performing bundeling,  fragmentation.....
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis