Subject: RE: [NSIS] yet another attempted summary of fragmentation discussion

From: [email-masked]
Date: Wed, 18 Jun 2003 17:58:59 +0300

Hi Attila,

> I agree that NTLP has to have responsibility for 
> fragmentation generally. However, the cost of 'do not 
> fragment' is 1 bit, which makes it possible that an NSLP that 
> do not want fragmentation in underlying layers get an error 
> message and do fragmentation itself or do something else to 
> solve the problem. I would not exclude this option, so I 
> propose to include DF bit.

A short note - I think that the DF bit is out of scope of the 
Framework draft - it is a solution ...

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 19 Jun 2003 10:11:21 +0200

Hi John

I agree with you!

What about the following proposal that could  be introduced in the framework
draft:

"The NTLP does fragmentation when it is needed. However, there might be
situations
where the NSLP can request from the NTLP not to do fragmentation.
In these situations the NSLP is aware that fragmentation errors can occur
and therefore,
several solutions could be applied. For example, configuration of the
network such that
fragmentation will not occur, fragmentation at IP layer or fragmentation at
NSLP layer."

Best regards,
Georgios

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 18, 2003 4:58 PM
Subject: RE: [NSIS] yet another attempted summary of fragmentation
discussion