Subject: RE: [NSIS] Reliable Transport for NTLP

From: [email-masked]
Date: Thu, 17 Jul 2003 10:30:52 +0300

Hi Marcus,

> >>Is an adaption to an underlying L2 technology the relevant 
> decision criterion. 
> > 
> > 
> > In my mind, it is hard to say, I do feel uncomfortable about adapting layer 3
> > 4/5 protocols based upon layer 2 considerations - I am not sure if we have
> > any good ways to do this & I am not sure it is in our charter to invent them.
> >
> 
> For the NTLP this might turn into a configuration capability on each 
> single node/interface. Whether this is a good idea or not I have not 
> made up my mind. And you do not need to invent something, but we have to 
> talk about the knobs and where they are placed, and which entity control 
> the knob anyway.

This sounds more & more like operational issues with the protocols or 
issues how the protocol can be run over specific layer-2s or in 
special deployments.  I think, but I could be wrong, that these
belong best outside of the protocol document, but in an operational
doc, deployment doc, applicability statement, bcp-type document,
for example.

> Also in Melindas approach there are quite a number of knobs per 
> interface (e.g. time out for various mechnisms etc.)

Well, protocols always need to define to have time-outs, etc.  I
would have to re-read Melinda's document to see what you are refering
to, but I was not thinking of Melinda's document what I suggested
what I did.

> >>Then there is the question which entity is allowed to 
> overrule another entities 
> >>request.
> > 
> > 
> > Agreed, however, I have a tendency to think that the end-points should have the 
> > ultimate say in this ...
> 
> Can you give an argument, which makes you think the end-point is a good 
> idea? Given it is the end-point. Is it the NSLP on the end-point, the 
> user(application) using the protocol, or the NTLP based on 
> information about L2 access technology.

The end-user is requesting service, s authorized for the service and is 
in the best position to know what is his expectations for the service.
I have an allergic reaction to the suggestion that the network better
understands my wants / my needs as an enduser than I do.  However,
I could be mis-interpretying your comments.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 17 Jul 2003 10:44:19 +0200

> doc, deployment doc, applicability statement, bcp-type document,

Sure they partly are. But some of the knobs might be turned using the 
NTLP protocol, thats where we need decisions.

> I could be mis-interpretying your comments.

So do you want to specify as a user whether we should use reliable NTLP 
or not?

Marcus

---

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 17 Jul 2003 13:54:50 +0000 (GMT)

dear all,

I confess to being a bit confused by this conversation.

The performance attributes that the NTLP should achieve for
any particular message are selected by the NSLP instance
on the node where it is generated. But, that node may
be anywhere in the network along the path, and may have
no relationship with the initiating NSLP and certainly
not the user. And the attributes typically invoked may
vary wildly along the path, even for a single application
and a single flow. (Just like RSVP, in fact.)

The NTLP specification needs to be powerful enough that
it can provide these performance attributes (when
requested) in a wide range of environments (including
different link types). But the NSLP (and especially the
user) has no idea and doesn't care how this is done (as
we have discussed and agreed on this list several times).
[To make an analogy: in an ideal world, users/applications
would rely on strong e2e checksums to provided e2e data
integrity, regardless of the mechanisms used to move
messages on interior links.]

I definitely agree that NTLP-over-foo/NTLP-in-bar-environments
information should be in separate documents. But, if the
NTLP base specification lacks the necessary capabilities,
such documents would be hard to write.

John, Marcus - have I just violently agreed with both
of you, or is there a real issue here?

cheers,

r.

On Thu, 17 Jul 2003, Marcus Brunner wrote:

> Date: Thu, 17 Jul 2003 10:44:19 +0200
> From: Marcus Brunner <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [NSIS] Reliable Transport for NTLP
>
>
>

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 17 Jul 2003 17:21:50 +0200

Robert,
> such documents would be hard to write.

Basically the question I have is who makes the decisions on what mode of 
operation the NTLP is running on, and what are the criterions.

> of you, or is there a real issue here?

As far as I understood John he is not willing to let the network decide 
on that.

Marcus