Subject: [NSIS] ntlp drafts differences

From: Kappler Cornelia <[email-masked]>
Date: Mon, 28 Jul 2003 23:15:56 +0200

Dear all, 

I tried analysing Hennings and Melindas NTLP drafts in order to find the fundamental differences. No doubt others have also done this; I would like to compare notes.

- what transport protocol to use, if any.
the most hotly debated difference. I don't dare going into details ;-)

- Whether a NE know its next hop peer. 
In Melindas NTLP, the NE just knows its previous peer. The next NE peer is discovered by a PATH-like message and subsequently addressed implicitly. 
In Hennings NTPL, the NE may request to be informed of the next NE peer's address. 
To my knowledge, knowing the address of the next NE peer is necessary for channel security which we require to at least be possible (Requirements ID 5.7.5). So to me this looks like a necessary feature.

And that's it...!?

There was one more difference, because in Melindas draft, each PATH-like message must be replied to by a RESERVE-like message (Sec. 3.1). However at the nsis meeting, Melinda agreed there is no reason for the RESERVE message to be issued, so it could be dropped. 

There are a couple of what I believe are minor (i.e. not fundamental) differences, or may be rather the level of detail provided differs between the two drafts. I think they can be sorted out without too much problem - such as:

- do we need a Logical Interface Handle?
- Message bundling and Summary Refresh is only detailed in Melindas draft
- According to Henning it is possible to not leave any state behind (set-up and tear-down in same message). However no details are given.
- etc.

I would be interested to know if others (incl the authors) arrived at the same conclusion, resp what I overlooked. 

Best regards, Cornelia.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Thanh Tra LUU" <[email-masked]>
Date: Tue, 29 Jul 2003 11:03:42 +0200

hi Cornelia,

> I tried analysing Hennings and Melindas NTLP drafts in order to find
the fundamental differences. No doubt others have also done this; I
would like to compare notes.
> the most hotly debated difference. I don't dare going into details
;-)

:o)

> In Melindas NTLP, the NE just knows its previous peer. The next NE
peer is discovered by a PATH-like message and subsequently addressed
implicitly.
> To my knowledge, knowing the address of the next NE peer is
necessary for channel security which we require to at least be
possible (Requirements ID 5.7.5). So to me this looks like a necessary
feature.
> And that's it...!?

It is possible that a NE does not know the next node to send a
message. By examining the RSVP-HOP (previous hop) object and INTEGRITY
object, a NE can know which NE has sent this message and which key is
used (following the security association between them). Maybe I don't
understand clearly what you mean " next NE peer is necessary for
channel security ".

> There was one more difference, because in Melindas draft, each
PATH-like message must be replied to by a RESERVE-like message (Sec.
3.1). However at the nsis meeting, Melinda agreed there is no reason
for the RESERVE message to be issued, so it could be dropped.

I think it is up to NSLP.

> There are a couple of what I believe are minor (i.e. not
fundamental) differences, or may be rather the level of detail
provided differs between the two drafts. I think they can be sorted
> - do we need a Logical Interface Handle?

LIH is used for multicast session. According to me, it is not used if
we don't mind multicast signaling applications.

Nary Tra
ENST, Paris