Subject: RE: [NSIS] Review of NTLP proposals

From: [email-masked]
Date: Mon, 14 Jul 2003 10:41:11 +0300

Hi Robert,

> Up to now I think we have been discussing multihoming rather implicitly,
> as something which - along with IP or higher layer mobility - can cause
> the general problem that the relationship between application-layer session 
> and [micro]flow to be more than just a simple 1:1 relationship. That's what
> the session identifier functionality is about.
> 
> However, I don't see that the NTLP should have a role in trying to 'solve'
> the multihoming problem, because the correct solution almost certainly 
> depends on the demands of the signalling application (at the moment, the
> framework assumes that handling IP address change is a signalling application
> responsibility, essentially for the same reason). The NTLP should think
> in terms of single flows defined by fixed N-tuples, and anything cleverer has to
> be pushed upstairs, IMHO.

I agree.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Charles Q. Shen" <[email-masked]>
Date: Mon, 14 Jul 2003 10:37:45 -0400

Hi John,

The text conferencing does not seem to be running. Could you please put
the presentation slides online?

Thanks.

Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, July 14, 2003 3:41 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] Review of NTLP proposals
> 
> 
> Hi Robert,
> 
> > Up to now I think we have been discussing multihoming rather 
> > implicitly, as something which - along with IP or higher layer 
> > mobility - can cause the general problem that the 
> relationship between 
> > application-layer session and [micro]flow to be more than just a 
> > simple 1:1 relationship. That's what the session identifier 
> > functionality is about.
> > 
> > However, I don't see that the NTLP should have a role in trying to 
> > 'solve' the multihoming problem, because the correct 
> solution almost 
> > certainly depends on the demands of the signalling 
> application (at the 
> > moment, the framework assumes that handling IP address change is a 
> > signalling application responsibility, essentially for the same 
> > reason). The NTLP should think in terms of single flows defined by 
> > fixed N-tuples, and anything cleverer has to be pushed 
> upstairs, IMHO.
> 
> I agree.
> 
> John
>

---

From: "Charles Q. Shen" <[email-masked]>
Date: Mon, 14 Jul 2003 10:38:52 -0400

Hi John,

Thanks.

Charles