Subject: RE: [NSIS] Reliable Transport for NTLP

From: [email-masked]
Date: Thu, 17 Jul 2003 00:11:35 +0300

Hi Marcus,

Clipping part of your text out for further discussion:

> It might raise issues on is the end system/NSLP initiator know what he needs. 

I take it you are proposing a few questions to study, for example:

> Is an adaption to an underlying L2 technology the relevant decision criterion. 

In my mind, it is hard to say, I do feel uncomfortable about adapting layer 3
4/5 protocols based upon layer 2 considerations - I am not sure if we have
any good ways to do this & I am not sure it is in our charter to invent them.

> Then there is the question which entity is allowed to overrule another entities 
> request.

Agreed, however, I have a tendency to think that the end-points should have the 
ultimate say in this ...

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 17 Jul 2003 09:18:06 +0200

John,

> any good ways to do this & I am not sure it is in our charter to invent them.

For the NTLP this might turn into a configuration capability on each 
single node/interface. Whether this is a good idea or not I have not 
made up my mind. And you do not need to invent something, but we have to 
talk about the knobs and where they are placed, and which entity control 
the knob anyway.

Also in Melindas approach there are quite a number of knobs per 
interface (e.g. time out for various mechnisms etc.)

> Agreed, however, I have a tendency to think that the end-points should have the 

Can you give an argument, which makes you think the end-point is a good 
idea?
Given it is the end-point. Is it the NSLP on the end-point, the 
user(application) using the protocol, or the NTLP based on information 
about L2 access technology.

Marcus