Subject: RE: [NSIS] Modeling of mobility?

From: [email-masked]
Date: Tue, 15 Jul 2003 16:32:08 +0300

Hi Paulo,
 
There seems to have been misunderstanding between what Xiaoming was trying to say.  I thought he was trying to suggest tying NSIS signaling with some MIP signaling, which is out of scope for NSIS.  NSIS should be concerned with the data path after handovers have occured, so it should be generic and not tied to any mobility signaling.
 
At present, since much of MIP related signaling is still preliminary, I don't think we should be considering this like HMIP, FMIP, etc. yet in NSIS, but rather stick with general mobility.  I believe the discussion up until now has been captured in the Framework document.  As the framework is nearing completion, perhaps if you have comments on that section, it would be good to send them to the list.
 
thanks,
John

-----Original Message-----
From: ext mendes [mailto:[email-masked]]
Sent: 15 July, 2003 12:51
To: Loughney John (NRC/Helsinki)
Cc: [email-masked]; [email-masked]
Subject: Re: [NSIS] Modeling of mobility?

Hi John,

I don't understand what you want to transmit with the sentence below. If I'm correct, MIPv6 Signaling and Handoff Optimization BOF is chartered to study HMIP and Fast-Handover issues only, in order to improve MIP performance.This BOF does not consider anything especific to signaling protocols like NSIS..

I think the question is not to change the MIPv6 Signaling and Handoff Optimization BOF to include QoS signalinfg specific issues, but to allow the future signaling transport protocol (read it NSIS) to be used in mobile environments. 

Just for clarify this issue: Are you saying that NSIS should not consider mobility? This is, are you assuming that the future Internet, for which NSIS is being made, will not have suficient mobile devices to justify a mobile-aware signaling transport protocol?

Paulo

[email-masked] wrote:

Hi Xiaoming,

You may like to bring this up at the MIPv6 Signaling and 

Handoff Optimization BOF on Wednesday, as this sounds 

somewhat out of scope for NSIS.

John

-----Original Message-----

From: ext Xiaoming Fu [ mailto:[email-masked]]

Sent: 14 July, 2003 21:53

To:  [email-masked]

Subject: [NSIS] Modeling of mobility?

Hi all,

Do you think it is useful to have a general modeling of data path 

features caused by (or, "related to") mobility? Examples:

- independence of specific mobility protocols

- IP-in-IP encasulation/tunnel

- local repair & synchronization

- even, anticipated handovers

Cheers,

Xiaoming

PS. I've made the slides "mobility support in NSIS" online at:

http://user.informatik.uni-goettingen.de/~fu/nsis/IETF-fu-nsis

-mobility.pdf

_______________________________________________

nsis mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/nsis

_______________________________________________

nsis mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/nsis

---

From: mendes <[email-masked]>
Date: Wed, 16 Jul 2003 10:08:41 +0200

[email-masked] wrote:

> Hi Paulo,
>  
> There seems to have been misunderstanding between what Xiaoming was 
> trying to say.  I thought he was trying to suggest tying NSIS 
> signaling with some MIP signaling, which is out of scope for NSIS.  
> NSIS should be concerned with the data path after handovers have 
> occured, so it should be generic and not tied to any mobility signaling. 

I completely agree with keeping the goal on generic mobility. Although 
the framework speaks about mobility, I had my doubts about if the 
generic mobility issues were going to be considered in NTLP and in some 
QoS related NLSP. Now, this issue is clear to me :).

Cheers
Paulo

> At present, since much of MIP related signaling is still preliminary, 
> I don't think we should be considering this like HMIP, FMIP, etc. yet 
> in NSIS, but rather stick with general mobility.  I believe the 
> discussion up until now has been captured in the Framework document.  
> As the framework is nearing completion, perhaps if you have comments 
> on that section, it would be good to send them to the list. 

thanks,

>     *From:* ext mendes [mailto:[email-masked]]
>     *Sent:* 15 July, 2003 12:51
>     *To:* Loughney John (NRC/Helsinki)
>     *Cc:* [email-masked]; [email-masked]
>     *Subject:* Re: [NSIS] Modeling of mobility?
>
>     Hi John,
>
>     I don't understand what you want to transmit with the sentence
>     below. If I'm correct, MIPv6 Signaling and Handoff Optimization
>     BOF is chartered to study HMIP and Fast-Handover issues only, in
>     order to improve MIP performance.This BOF does not consider
>     anything especific to signaling protocols like NSIS..
>
>     I think the question is not to change the MIPv6 Signaling and
>     Handoff Optimization BOF to include QoS signalinfg specific
>     issues, but to allow the future signaling transport protocol (read
>     it NSIS) to be used in mobile environments.
>
>     Just for clarify this issue: Are you saying that NSIS should not
>     consider mobility? This is, are you assuming that the future
>     Internet, for which NSIS is being made, will not have suficient
>     mobile devices to justify a mobile-aware signaling transport protocol?
>
>     Paulo
>
>>>From: ext Xiaoming Fu [mailto:[email-masked]]