Subject: RE: [NSIS] Proposed draft "Mobility Support in NSIS"

From: Tschofenig Hannes <[email-masked]>
Date: Mon, 7 Jul 2003 09:55:47 +0200

hi charles,

thanks for pointing to your draft. i haven't actually noticed that you
submitted a draft. i will take a look at it as soon as possible.  

ciao
hannes

> -----Original Message-----
> From: Charles Q. Shen [mailto:[email-masked]]
> Sent: Monday, July 07, 2003 2:09 AM
> To: [email-masked]
> Subject: RE: [NSIS] Proposed draft "Mobility Support in NSIS"
> 
> 
> Hi,  
> 
> I think having such a draft discussing mobility issues with NSIS is
> helpful and inline with the WG charter. I started a similar 
> effort in an
> earlier draft last July
> http://www.ee.columbia.edu/~charles/publication/draft-shen-nsi
> s-mobility
> -fw-00.txt.  
> 
> Fu's draft incorporated some recent issues including NSLP/NTLP
> interaction, Discovery, peer-to-peer addressing etc. It would 
> be good to
> elaborate those parts when they become clearer in the WG discussion. 
> 
> Disscussion of tunneling/non-optimized routing is also useful, but it
> would be beneficial to refer to RFC2746 which provides a very good
> example of solving tunneling issues in the case of RSVP. 
> 
> Some issues may also be grouped together. Basically there are cases of
> sender mobility and receiver mobility (The protocol itself could be
> either sender initiated or receiver initated). Handoff causes
> appropriate signaling actions in three segments of the network: the
> intact path, the new path and the obsoleted path. (This 
> applies to both
> optimized/non-optimized routing, and possibly involves tunneling.) The
> handoff process would further impact subsequent regular soft-state
> refresh which has to be considered.
> 
> Best regards,
> 
> Charles
> 
> ---
> Charles Q. Shen
> Department of Electrical Engineering
> Columbia University
> Email: [email-masked]
> Phone: +1 212 853 8475
> http://www.ee.columbia.edu/~charles
> 
> 
> -------- Original Message --------
> Subject: [NSIS] Proposed draft "Mobility Support in NSIS"
> Date: Sat, 28 Jun 2003 23:43:09 +0200
> From: Xiaoming Fu <[email-masked]>
> To: [email-masked]
> 
> Hi all,
> 
> Here is a new Internet Draft that we propose as a problem 
> statement and
> proposed mechanisms to extend NSIS for mobility support:
> http://www.ietf.org/internet-drafts/draft-fu-nsis-mobility-00.txt or
> http://www.ietf.org/internet-drafts/draft-fu-nsis-mobility-00.pdf
> 
> Following previous work (Michael Thomas, Cedric 
> Westphal/Hemant Chaskar,
> Charles Shen, and many others), this Draft aims to provide an 
> extensive
> view on mobility support related issues that will be of broad general
> use.
> 
> We welcome your comments. We are also especially interested in other
> open issues and studying how they may be addressed by future 
> versions of
> the Draft.
> 
> Regards,
> Xiaoming
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Charles Q. Shen" <[email-masked]>
Date: Mon, 7 Jul 2003 15:49:48 -0400

> From: Tschofenig Hannes [mailto:[email-masked]] 
> Sent: Monday, July 07, 2003 3:56 AM
> To: 'Charles Q. Shen'; [email-masked]
> thanks for pointing to your draft. i haven't actually noticed 
> that you submitted a draft. i will take a look at it as soon 
> as possible.  
> 
> ciao
> hannes
> 

Thank you Hannes. 

That draft is also an attempt to generalize the topic from RSVP-Mobility
to NSIS Mobility. The experience from a working RSVP-MIP test-bed should
be helpful when looking into NSIS-mobility. (Drafts and these related to
our RSVP-MIP work are available through my homepage.). It is now also
important to reflect the most current WG progress in such a document. 

Best regards
Charles
---
Charles Q. Shen	http://www.ee.columbia.edu/~charles