Subject: [NSIS] Crossover node discovery issue

From: "Seong Ho Jeong" <[email-masked]>
Date: Thu, 7 Aug 2003 12:19:55 +0900

SGkgUm9iZXJ0LA0KDQpJbiBTZWN0aW9uIDUuMi4yIChMb2NhbGl6ZWQgUGF0aCBSZXBhaXIpIG9mIHRoZSBmcmFtZXdvcmsgZG9jdW1lbnQsIA0KSSB0aGluayBpdCB3b3VsZCBiZSBnb29kIHRvIGdpdmUgYSBnZW5lcmFsIGRlc2NyaXB0aW9uIG9mIGhvdyB0byBkaXNjb3ZlciB0aGUgDQpjcm9zc292ZXIgbm9kZSBpbiBhIGxpdHRsZSBtb3JlIGRldGFpbC4gRm9yIGV4YW1wbGUsIGFzIGRpc2N1c3NlZCBiZWZvcmUsIGEgc2Vzc2lvbiBJRCwgDQphIGZsb3cgSUQsIGFuZC9vciBhIG1vYmlsaXR5IG9iamVjdCBjYW4gYmUgdXNlZCBmb3IgdGhlIGNyb3Nzb3ZlciBub2RlIGRpc2NvdmVyeS4gDQpJbiB0aGlzIGNhc2UsIHdlIG1heSBhbHNvIG5lZWQgdG8gY2hlY2sgd2hldGhlciBvciBub3QgdGhlIHVzZSBvZiB0aG9zZSBmaWVsZHMgaXMgDQpzdWZmaWNpZW50IGJlY2F1c2Ugc29tZSBzb3J0IG9mIGF1dGhvcml6YXRpb24gYW5kIGRldGVybWluYXRpb24gb2Ygc2Vzc2lvbiBvd25lcnNoaXAgbWF5IGJlIA0KbmVjZXNzYXJ5Li4uSG93IGFib3V0IGFkZGluZyBhIGdlbmVyYWwgZGVzY3JpcHRpb24gb2YgdGhlIGNyb3Nzb3ZlciBub2RlIGRpc2NvdmVyeSANCmFuZCByZWxhdGVkIHNlY3VyaXR5IGlzc3VlcyB0byB0aGUgZnJhbWV3b3JrIGRvY3VtZW50Pw0KDQpSZWdhcmRzLCANCg0KU2VvbmcgSmVvbmc=_______________________________________________nsis mailing [email-masked]://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 29 Aug 2003 09:36:20 +0100

hi Seong Jeong,

thanks for the comment and apologies for the slow response.

in the framework document, i would prefer to look purely at a
definition of what the crossover router is rather than mechanisms
for how to discover it (which would be more of a protocol issue).

i think my current definition of x-over router would be:
the NSLP aware node which, for a given session id, has one neighbour
NE in one direction but two neighbour NEs in the other, and
this situation may be transient (re-routing case) or long-term
(multihoming case). this would probably require more wordsmithing.

on the security issues, i think these are important to discuss, but
at the moment I think they are more signalling application specific
than NSIS generic so all we can do is talk generally. what I would
really like to see is some discussion on this list of hannes' draft
on the issue, 
http://www.ietf.org/internet-drafts/draft-tschofenig-nsis-sid-00.txt
(which is very short and easy to read!)

cheers,

robert h.

> -----Original Message-----
> From: Seong Ho Jeong [mailto:[email-masked]]
> Sent: Thursday, August 07, 2003 05:20
> To: Hancock, Robert
> Cc: [email-masked]; Sung Hycuk Lee; [email-masked];
> [email-masked]
> Subject: Crossover node discovery issue
> 
> 
> Hi Robert,
> 
> In Section 5.2.2 (Localized Path Repair) of the framework document, 
> I think it would be good to give a general description of how 
> to discover the 
> crossover node in a little more detail. For example, as 
> discussed before, a session ID, 
> a flow ID, and/or a mobility object can be used for the 
> crossover node discovery. 
> In this case, we may also need to check whether or not the 
> use of those fields is 
> sufficient because some sort of authorization and 
> determination of session ownership may be 
> necessary...How about adding a general description of the 
> crossover node discovery 
> and related security issues to the framework document?
> 
> Regards, 
> 
> Seong Jeong
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis