Subject: RE: [NSIS] Reliable Transport for NTLP

From: [email-masked]
Date: Thu, 7 Aug 2003 05:30:09 +0300

Hi Rüdiger,

> As I mentioned in another mail, I think reliablbe transport isn't required 
> if there's a "low" amount of signaling to be processed. If NSIS will be 
> designed to prevent a "high" signaling load in backbones, I guess I 
> won't have a problem. Besides RSVP TE (and DiffServ aware TE) there's also 
> RFC 3175 ( aggregated RSVP). Both aim on rather stable state in the 
> backbone by flow aggregation. 

So, what I suspect what you are saying, that in the presences of multiple
different NLSPs between two NSIS peers, aggregation is needed.  Flows
which are aggregated should be congestion-friendly, etc.  I think that
this is the direction which Henning aiming for with NTLP.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 7 Aug 2003 09:57:21 +0100

john,

even between two adjacent NSLP peers, there are really two questions
(which are nearly independent):

1. what's the best layer to provide a guarantee that a message has
got from one to the other.

2. what's the best layer to detect and recover from a message loss
within the network.

i'm still finishing off my reliability analysis draft at the moment.
but my current feeling is that there are really at least two aspects
to reliability
- making sure the message arrives in the face of congestion, corruption
and so on, and retransmitting rapidly if not (the NTLP is best place to
do this but intermediate NTLP-only nodes shouldn't take part in
the process)
- making sure that a message has been processed and acted on correctly,
and this has to be an NSLP responsibility.

and, overall reliability at the 'e2e' level, e.g. between source and
destination, has to be an NSLP responsibility also (e.g. our QoS-NSLP 
had a confirmation request object for this purpose).

r.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, August 07, 2003 03:30
> To: Hancock, Robert; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [NSIS] Reliable Transport for NTLP
> 
> 
> Hi Robert,
> 
> > However, even if we agree that a signalling application
> > needing reliability needs it between (say) adjacent NSLP
> > peers rather than simply end-to-end, there is still the 
> > question of which layer it should be provided at (NTLP
> > or within each application).
> 
> The question could be put another another way, can a NSLP 
> 'reliably' rely on a multi-hop NTLP providing reliability?
> Will an NSLP need to augment NTLP-layer reliability with
> reliability at the NSLP layer (such as explicit acks, 
> retransmission timers, etc)?
> 
> John
>