Subject: RE: [NSIS] Session in NSIS

From: "Elena Scialpi" <[email-masked]>
Date: Thu, 19 Feb 2004 15:14:07 +0100

---------- Initial Header -----------

From      : [email-masked]
To          : "Elena Scialpi" [email-masked],"nsis" [email-masked]
Cc          : 
Date      : Thu, 19 Feb 2004 13:01:40 +0100
Subject : RE: [NSIS] Session in NSIS

> hi elena, 
> 
> in nsis the concept of a session is separated from the flow identifier. the
> advantage of this approach is also visible in many of the nsis mobility
> drafts. you can find the latest version (a merge of previous drafts) at:
> http://www.tschofenig.com/drafts/draft-manyfolks-signaling-protocol-mobility
> -00.txt
> 
> you might also want to take a look at :
> http://www.tschofenig.priv.at/drafts/draft-tschofenig-nsis-sid-00.txt
> 
> this draft describes alternative ways to create the session id with security
> properties.  
> 
> as a summary, the session id allows you to change the flow identfier
> - during the lifetime of a session (e.g., due to mobility, IPv6
> privacy,...),
> - somewhere along the path and 
> - to group different flows together
> 
> does this answer your question? 

I haven't understand very well the concept of session. 
I think that a session is between two specific nodes (sender and receiver of signaling)  while in 
RSVP it consider only one node.
Is it right?

Thanks for your reply,
Elena

> 
> ciao
> hannes
> 
> 
> > -----Original Message-----
> > From: Elena Scialpi [mailto:[email-masked]]
> > Sent: Thursday, February 19, 2004 12:15 PM
> > To: nsis
> > Subject: [NSIS] Session in NSIS
> > 
> > 
> > 
> > 
> > Hi all,
> > 
> > In RFC 2205 (http://ietf.org/rfc/rfc2205.txt?number=2205) a 
> > RSVP session is defined as "a data 
> > flow with a particular destination and transport-layer 
> > protocol" and it "is defined by the triple: 
> > (DestAddress, ProtocolId [, DstPort])"
> > 
> > NSIS framework 
> > (http://www.ietf.org/internet-drafts/draft-ietf-nsis-fw-05.txt
> > )  defines session as 
> > "application layer flow of information for which some network 
> > control state information is to be 
> > manipulated or monitored".
> > 
> > Session_ID is a random number but which parameters can be 
> > used to represent a session?
> > 
> > 
> > Regards,
> > Elena 
> > 
> > 
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> > 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Thanh Tra LUU" <[email-masked]>
Date: Thu, 19 Feb 2004 15:55:55 +0100

hi,

elena, if there is no change of address, flow-id is enough to globally
identify an signaling session. to help a signaling entity recognize a
session, something is required other than flow-id.

hannes, the session-id can be randomly created, however, do you think which
signaling entity should do it (NI, NR or other entities).  i  read your sid
draft, but it did not answer completely me.

Nary Tra
ENST, Paris.