Subject: RE: [NSIS] Re: Session in NSIS

From: Tschofenig Hannes <[email-masked]>
Date: Fri, 20 Feb 2004 13:08:48 +0100

hi all, 

a small comment: the session ownership problem does not only appear in a
mobility environment. based on a discussion with ruediger we got the
impression that the same problem can actually appear with rsvp as well.
maybe i should send a summary of our discussions. 

what could be a motivation for the nr to create the session id? 

i am very much in favor of separating nslp authorization decisions from the
session id. in the past peopled had the tendency to mix, for example qos
authorization, with session ownership. michael richardson commented our
threats draft and he also made the comment that the user could authenticate
to all intermediate nsis nodes. this would solve the session ownership
problem even if most intermediate nodes do not need (or are even unable) to
authorize the end host. the solution would, however, raise some further
issues (but that's another story).

ciao
hannes

> -----Original Message-----
> From: Thanh Tra LUU [mailto:[email-masked]]
> Sent: Friday, February 20, 2004 11:39 AM
> To: Cheng Hong
> Cc: 'nsis'
> Subject: Re: [NSIS] Re: Session in NSIS
> 
> 
> hi Cheng Hong,
> 
> > It is not necessary that the NI always be the mobile. Also, 
> wouldn't the
> > computation cost just an implementation issue? If it is 
> that computational
> > intensive, could it be placed into certain hardware, e.g. 
> some smart card?
> >
> > Another issue for NR generating the id would mean that the 
> first message
> > sent from NI would not carry the SID information. Does this have any
> impact
> > on the design of the protocls?
> 
> i think it maybe a problem. Seeing NAT/FW, NI and NR can 
> initiate its own
> session
> 
>  NI ---> NAT/FW_I ----> Internet---->NAT/FW_R---->NR.
> 
> NR can initiate the signaling session and some states are 
> established on
> NAT/FW_R to permit NI can send signaling message to it. This 
> session-id is
> sent by SIP or other means.
> 
> Nary Tra,
> ENST, Paris.
> 
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Thanh Tra LUU" <[email-masked]>
Date: Fri, 20 Feb 2004 13:46:53 +0100

hi hannes,

> maybe i should send a summary of our discussions.

i totally agree.

> authorization, with session ownership.

i agree. in any case, session-id does not give enough information for
authentication, authorization. however, how to use the session-id for
re-authentication and re-authorization is not clear now :o)

Nary Tra,
ENST, Paris