Subject: Re: Re: [NSIS] Draft for pre CRN discovery and fast state installation

From: "Yuming Wang" <[email-masked]>
Date: Thu, 19 Feb 2004 17:41:37 +0800

Hi Takako Sanda,

The comments inline:

>Hi Yuming Wang,
>
>Thank you for your comment.
>
>My explanation in the draft seems to make some confusion.
>The answers are inline.
>
>
>> "MN cannot directly initiate resource reservation signaling on 
>>  candidate new paths before it actually moves."
>> 
>> Why cannot? you mean the MN cannot connect to the NAR?
>> When the MN is at the overlap of OAR and NAR, it can connect to
>> the NAR and initiate resource reservation signaling on candidate
>> new paths.
>
>The meaning of "candidate new path" is "the path that is expected to be
>established when MN moves to other network".
>Assume that MN is currently connected to AR0, and "path0" is established
>between MN and CN via AR0. And AR1 is one of neighboring ARs of AR0.
>If the MN moves to AR1, a new path "path1" will be established between
>MN and CN through AR1.
>This path1 is candidate paths.
>But, MN cannot directly establish path1 when it is still connected to
>AR0.
>
>This is the meaning of "MN cannot directly initiate resource reservation
>signaling on candidate new paths before it actually moves."
>
IMO, If the MN still cannot communicate with the AR1 (because AR1 is too
far from the MN, and the signaling strength is so weak), path1 should not
be the candidate path.
Assume that MN is currently connected to AR0, and AR1 & AR2 are neighboring ARs
of AR0, but MN can only get signaling strength of AR0 and AR2, that means, it
can only communicate with AR0 and AR2, then, path2 will be the candidate path
and path1 will not be necessary to be.
Now that the MN can communicate with AR2, so, why it cannot directly initiate
resource reservation signaling on path2?
I don't know whether I am right.

>
>> Is it proper to initiate resource reservation signaling on the
>> candidate new paths before the MN can connect to the NAR? because
>> it's not easy to decide who is the next NAR.
>
>For example, if MN and network support FMIP and CARD, it can decide NAR
>when it is still connected to current AR.
>Or, as I mentioned in my Internet draft, if MN has "a table" locally, MN
>can decide NAR even without FMIP or CARD support.
>
>Do I answer your questions?
>
>BR,
>Takako Sanda
>
>
>
>
>.
Thanks,
Yuming
2004-02-19
---------------- Yuming Wang -----------------
NGIT Research Group, ITEC R&D Center, EI Dpt.,
HuaZhong University of Science and Technology.
Email:     [email-masked]
Home Page: http://itec.hust.edu.cn/wym.htm
TEL: +86-27-87453207  FAX: +86-27-87456436
----

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Takako Sanda <[email-masked]>
Date: Fri, 20 Feb 2004 10:21:11 +0900

Hi Yuming Wang,

Please see inline.

> and path1 will not be necessary to be.

What do you mean "signal strength of AR0 and AR2"?
Is it radio signal, such as beacon, from APs connecting to AR0 or AR2?

> I don't know whether I am right.

If my understanding for your "signal strength of AR0 and AR2" is correct,
MN cannot communicate with AR2 in this stage because MN does not
complete even L2 level association to AP connecting to AR2.

If you are assuming that MN has multiple radio interfaces and can
connect to multiple ARs at the same time, it is out of scope of my I-D.

--Takako