Subject: Re: [NSIS] Draft for pre CRN discovery and fast state installation

From: "Yuming Wang" <[email-masked]>
Date: Thu, 19 Feb 2004 10:19:07 +0800

Hi Takako Sanda,

In chapter 2, you've mentioned:

"MN cannot directly initiate resource reservation signaling on 
 candidate new paths before it actually moves."

Why cannot? you mean the MN cannot connect to the NAR?
When the MN is at the overlap of OAR and NAR, it can connect to
the NAR and initiate resource reservation signaling on candidate
new paths.
Is it proper to initiate resource reservation signaling on the
candidate new paths before the MN can connect to the NAR? because
it's not easy to decide who is the next NAR.

>Hi John and all,
>
>I submitted the following Internet Draft.
>
>http://www.ietf.org/internet-drafts/draft-sanda-nsis-mobility-qos-proxy-01.txt
>
> Title:   "Pre CRN discovery from proxy on candidate new path"
> File Name: draft-sanda-nsis-mobility-qos-proxy-01.txt
> Abstract:
>     NSIS WG has been discussing the ways to minimize/avoid QoS 
>     interruption during handover. One solution is to install new 
>     path before MN's move (fast state installation).  
>     This document proposes a procedure of pre CRN discovery for fast 
>     state installation by using proxies on candidate new paths. An 
>     example of fast state installation is shown. 
>
>
>Any comments are welcome.
>
>Best Regards,
>Takako Sanda and Toyoki Ue
>
>_______________________________________________
>nsis mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/nsis
>
>

Yuming
2004-02-19
---------------- Yuming Wang -----------------
NGIT Research Group, ITEC R&D Center, EI Dpt.,
HuaZhong University of Science and Technology.
Email:     [email-masked]
Home Page: http://itec.hust.edu.cn/wym.htm
TEL: +86-27-87453207  FAX: +86-27-87456436
----

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Takako Sanda <[email-masked]>
Date: Thu, 19 Feb 2004 16:37:39 +0900

Hi Yuming Wang,

Thank you for your comment.

My explanation in the draft seems to make some confusion.
The answers are inline.

> the NAR and initiate resource reservation signaling on candidate

The meaning of "candidate new path" is "the path that is expected to be
established when MN moves to other network".
Assume that MN is currently connected to AR0, and "path0" is established
between MN and CN via AR0. And AR1 is one of neighboring ARs of AR0.
If the MN moves to AR1, a new path "path1" will be established between
MN and CN through AR1.
This path1 is candidate paths.
But, MN cannot directly establish path1 when it is still connected to
AR0.

This is the meaning of "MN cannot directly initiate resource reservation
signaling on candidate new paths before it actually moves."

> it's not easy to decide who is the next NAR.

For example, if MN and network support FMIP and CARD, it can decide NAR
when it is still connected to current AR.
Or, as I mentioned in my Internet draft, if MN has "a table" locally, MN
can decide NAR even without FMIP or CARD support.

Do I answer your questions?

BR,
Takako Sanda