Subject: Re: [NSIS] GIMPS connection mode and intermediaries

From: Xiaoming Fu <[email-masked]>
Date: Mon, 02 Feb 2004 18:38:32 +0100

Hi Robert,

Hancock, Robert wrote:
>> ...
>>>this is not my assumption. in a sane world
>>>*) a GIMPS unaware NAT should not change the flow ID at all,
>>>since it is just payload data.
>>>[i am aware of NATs which look for things like IP addresses
>>>in arbitrary payloads and attempt to rewrite them; I regard
>>>being broken by such a NAT as a feature, not a bug ;-).]
>>>but then the next GIMPS peer should detect the presence of
>>>the NAT (see above) and then try to work out what to do about
>>>it (as discussed a bit in Cedric's document).
>>>
>>
>>yes. Does GIMPS keep the previous nodes IP address in its payload?
> 
> 
> that's not currently defined, but there would not be a problem
> to do so e.g. in D mode. (it's not there currently because the
> need only seems to arise in this NSIS-unaware NAT traversal case
> which we have not really gone into yet).

NAT traversal can need this. Furthermore, even in traditional IntServ, 
it may still require readjust of your reservations in the former hops 
for a d-mode message passed. This was not a problem for RSVP which is
receiver-initiated and the receive knows exactly how much the path can
accommodate, but is for source-initiated signaling with GIMPS. Either we
rely on another time of e2e d-message refresh (where an e2e or error
response is needed to trigger) *soon* after the first attempt, or still
maintain PHOP also in GIMPS d-mode.

Xiaoming

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 3 Feb 2004 10:38:36 -0000

hi xiaoming,

the [original] question about peer addresses is totally
independent of the question about nhop/phop maintenance.

GIMPS already (by default) records the phop and (often)
the nhop for all signalling sessions it knows about.

the question is whether it discovers the phop/nhop from
1) addressing information carried at the IP level
2) addressing information carried in the packet payload
3) both (probably needed for the NSIS unaware NAT 
traversal case)

my suspicion these days is probably (2) or (3) is the
right answer for D mode, but people might like to consider
the question in more detail (see also draft section 8.3).

r.

> -----Original Message-----
> From: Xiaoming Fu [mailto:[email-masked]]
> Sent: Monday, February 02, 2004 17:39
> To: Hancock, Robert
> Cc: [email-masked]'; Nsis (E-mail)
> Subject: Re: [NSIS] GIMPS connection mode and intermediaries
> 
> 
> Hi Robert,
> 
> Hancock, Robert wrote:
> >> ...