Subject: RE: [NSIS] RE: QoS NSLP open issue on region scoping

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 27 Feb 2004 13:47:33 -0000

hi,

> -----Original Message-----
> From: Geib, Ruediger [mailto:[email-masked]]
> Sent: Friday, February 27, 2004 10:58
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: RE: [NSIS] RE: QoS NSLP open issue on region scoping
> 
> 
> 
> Robert,
> 
> |Which ones would those be?
> 
> Assume one of those to be stacked - seriously,
> I think the aspect of missing QoS models 
> applies whether you assume there to be just 
> one or a bunch of them.

that's quite right - however, if you insist on
no stacking and the ability to have end to end
qos signalling (without suffering from arbitrary
rewriting) then the likelihood of a missing qos
model becomes larger (a more serious and hard-to-
recover-from-problem), unless you believe there
will be one QoS model for the whole internet
(which I don't).

> 
> |(And I assume you mean "globally well defined
> |and universally supported".)
> 
> "Globally well defined" will do. 

if it's not supported then it's as good as being
not defined (so far as the requesting node being
able to signal for something useful is concerned).
you still need to be able to reject an un-supported
model, for example.

> I'm happy to 
> deploy NSIS in a single domain and learn how to 
> operate it before I go for interworkings, 
> mappings and such things. And I doubt 
> that other carriers will have a different view.

that's perfectly reasonable. 

if you want to do trials and experiments and even
real deployments in a single network where you can
enforce the policy that each node uses the same
QoS model, then the complexity imposed by the QoS
model flexibility has very little actual effect on
you. (all you need to be able to do is to examine the
first element of a list, rather than examine a single
field.) and if you want to do work with other carriers
you still won't have to do anything especially clever -
provided you can persuade them to use the same QoS 
model that you do. once that stops being possible,
I believe that that extensibility allowed for in the
design will make life much easier.

the basic point is maybe that we should aim to minimise
the additional cost of the stacking complexity for
people who don't want to use it. i'd rather approach
the question from *that* angle (rather than removing the
facility completely). hence the discussion on error
cases - what we seem to be converging on is that 
error cases should be handled the same whether or not
it applies to a stack of qos models or just a single one.
there may be other cases which need similar analysis.

r.

> Regards, Rüdiger

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 27 Feb 2004 14:55:31 +0100

Hello Robert and Ruediger

> there may be other cases which need similar analysis.

I totally agree with Robert, see above!

Best regards,
Georgios