Subject: RE: [NSIS] NATFW issue 39: REA-PROXY race condition between RESPONSE and requested CREATE

From: [email-masked]
Date: Fri, 14 Oct 2005 10:09:29 +0300

I agree.

John 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of ext Martin Stiemerling
>Sent: 13 October, 2005 12:34
>To: nsis
>Subject: [NSIS] NATFW issue 39: REA-PROXY race condition 
>between RESPONSE and requested CREATE
>
>Hi,
>
>I suggest to close issue 39 (REA-PROXY race condition between 
>RESPONSE and requested CREATE, 
><https://kobe.netlab.nec.de/roundup/nsis-natfw-nslp/issue39>).
>
>Proposed text is:
>There is a possible race condition between the RESPONSE 
>message to the REA- PROXY and the CREATE message generated by 
>the edge-NAT.  The CREATE message can arrive earlier than the 
>RESPONSE message. An NI+ MUST accept CREATE messages generated 
>by the edge-NAT even if the RESPONSE message to the REA-PROXY 
>request was not received.
>
>Note: The NI+ is able to recognize an edge-NAT generated 
>CREATE through the presence of the NATFW_NONCE object. The 
>NATFW_NONCE object echoes a value chosen by the NI+.
>
>The proposed text has been already included in draft -07 of 
>the NATFW NSLP.
>
>  Martin
>
>_______________________________________________
>nsis mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/nsis
>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 17 Oct 2005 11:10:36 +0200

Hi John and all,

The issue has been closed.

  Martin

--On Freitag, 14. Oktober 2005 10:09 Uhr +0300 [email-masked] 
wrote:

| I agree.
|
| John
|
|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]] On
|> Behalf Of ext Martin Stiemerling
|> Sent: 13 October, 2005 12:34
|> To: nsis
|> Subject: [NSIS] NATFW issue 39: REA-PROXY race condition
|> between RESPONSE and requested CREATE
|>
|> Hi,
|>
|> I suggest to close issue 39 (REA-PROXY race condition between
|> RESPONSE and requested CREATE,
|> <https://kobe.netlab.nec.de/roundup/nsis-natfw-nslp/issue39>).
|>
|> Proposed text is:
|> There is a possible race condition between the RESPONSE
|> message to the REA- PROXY and the CREATE message generated by
|> the edge-NAT.  The CREATE message can arrive earlier than the
|> RESPONSE message. An NI+ MUST accept CREATE messages generated
|> by the edge-NAT even if the RESPONSE message to the REA-PROXY
|> request was not received.
|>
|> Note: The NI+ is able to recognize an edge-NAT generated
|> CREATE through the presence of the NATFW_NONCE object. The
|> NATFW_NONCE object echoes a value chosen by the NI+.
|>
|> The proposed text has been already included in draft -07 of
|> the NATFW NSLP.
|>
|>  Martin
|>
|> _______________________________________________
|> nsis mailing list
|> [email-masked]
|> https://www1.ietf.org/mailman/listinfo/nsis
|>