Subject: [NSIS] probably new open issue

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 11 Oct 2005 11:14:11 +0200

Hi Robert

I have a problem with section A.4.4.5 in the GIST draft, see below, and in 
particular related to
the way of how a GIST-DATA message is treated by a stateless GIST responding 
node.
It will be good to clarify what it is meant, in Section A.4.4.5, by the term 
unexpected Data message.

Please note that a stateless  GIST responding node MUST be able to receive a 
GIST DATA
message without that this will generate an error situation.

-------------------------

A.4.4.5.  No Routing State

   Class:              Protocol-Error
   Code:               5
   Additional Info:    None

   This message is sent if a node receives a message for which there is
   no matching routing state (and therefore no appropriate Q/R-SM).
   This can occur either at a Querying node which receives an unexpected
   Response message, or at a Responding node which receives an
   unexpected Data message.

------------------------------

Best regards,
Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 11 Oct 2005 11:00:41 +0100

hi georgios,

i've added this (and a couple of other points) as a new issue:
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue73

basically, the error message means "There is no routing state
*when there should be*" and the text needs to be updated to say that.

r.

> -----Original Message-----
> From: Georgios Karagiannis [mailto:[email-masked]] 
> Sent: 11 October 2005 10:14
> To: Hancock, Robert
> Cc: Nsis (E-mail)
> Subject: probably new open issue
> 
> 
> Hi Robert
> 
>