Subject: RE: [NSIS] remove packet_classifier object from QoS-NSLP

From: "Kappler, Cornelia" <[email-masked]>
Date: Tue, 11 Oct 2005 13:26:07 +0200

Hi Georgios, 

when including two or more packet filters, how do we make sure that for
a single QoS NSLP  session, it is always the same set of packets which
is receiving the reservation benefits?

If filtering is based on DSCP/source address in one domain, and based on
the flow ID in another domain, it might well happen that a specific
packet receives QoS only in one domain. 

Do we want that? Or am I missing something?

Cornelia

> -----Original Message-----
> From: Georgios Karagiannis [mailto:[email-masked]] 
> Sent: Dienstag, 11. Oktober 2005 11:55
> To: Kappler, Cornelia
> Cc: [email-masked]
> Subject: Re: [NSIS] remove packet_classifier object from QoS-NSLP
> 
> 
> Hi Cornelia
> 
> Please see in line!
> 
> ----- Original Message ----- 
> From: "Kappler, Cornelia" <[email-masked]>
> To: "Georgios Karagiannis" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, October 11, 2005 11:42 AM
> Subject: FW: [NSIS] remove packet_classifier object from QoS-NSLP
> 
> 
> > Hi Georgios,
> >
> > if indeed the packet classifier is QSPEC / QoS Model 
> dependent, and we
> > would need stacked packet classifiers as well as stacked 
> QSPECs it would
> > make sense to include it in the QSPEC.
> >
> > However I dont understand why you would use separate packet 
> classfiers
> > for stacked QSPECs (one of them e.g. e2e QSPEC, the other a
> > domain-specific RMD QSPEC). The packet classfier specifies 
> what packets
> > receive the treatment described in the QSPEC.
> 
> Georgios: Please note that this does not apply to RMD.
> Regarding the packet classifier, the packet classifier should 
> know what kind
> of filtering should use on the user data packets.
> For example:
> *  in a Intserv based model, the flow ID will be used to 
> filter the user
> data packest and associate them with the
> Intserv based RMF reservation state
> * in another QoS model, the combination of IP source address 
> and DSCP might 
> be
> used to filter the user data
> packets and associate them with the RMF reservation state
> 
> The packet classifier can get this knowledge by:
>  *  local policy, configuring the node to associate the RMF 
> reservation
> state with all user data packets that are filtered
> based on a predefined and configured rule
> * using signaling, where the QNE that activates the signaling 
> related to a
> QoS model, for example QoS model A,
> and if needed stacks a QSPEC (for QoS model A,
> is also including the type of the filter that all QNE's using 
> the QoS model
> A, will have to use!
> 
> 
> > I'd rather expect that for
> > a given QoS NSLP message, the packets being singled out for 
> treatment
> > are always the same (no matter what QoS Model is used to reserve
> > resources).
> >
> > Can you make your example more concrete?
> 
> 
> Georgios: The filtering/packet classification of the user data packets
> depends on the QoS model used, see above!
> When for the same session, a e2e QoS model is used in 
> combination with a
> local QoS model,
> that use stacking of QSPECs, a problem will ocuur
> if the PACKET_CLASSIFIER will either not be stacked or 
> included in the QSPEC
> (it this way relating each QSPEC to one PACKET CLASSIFIER).
> 
> Best regards,
> Georgios
> 
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 11 Oct 2005 14:52:49 +0200

Hi Cornelia

Please see in line!

----- Original Message ----- 
From: "Kappler, Cornelia" <[email-masked]>
To: "Georgios Karagiannis" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 11, 2005 1:26 PM
Subject: RE: [NSIS] remove packet_classifier object from QoS-NSLP

> is receiving the reservation benefits?

Georgios: In a domain that supports a QoS model we should use only one 
filter/packet classifier.

> packet receives QoS only in one domain.

Georgios: this occurs in the case when during an end to end path more than 
one heterogeneous
QoS models are used.
If a QoS model supports aggregation and another does not then a different 
type of filtering/packet classification
must be used.

This means that different filters/packet classifiers should be used per QoS 
model!

Best Regards,
Georgios