Subject: RE: [NSIS] RE: PACKET_CLASSIFIER in QSPEC

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Mon, 24 Oct 2005 05:50:38 -0500

Hi John, Georgios, All,

It appears that the packet_classifier could be done either in QoS-NSLP
or QSPEC.  However, Cornelia had concerns about putting it in QSPEC so I
think we should hear from her again on this (I believe she is away at
the moment).  Robert also expressed some concerns I believe.

It still seems to me that the packet_classifier identifies 'what'
reservation is being made, and does not identify 'how much stuff' is
reserved.  By that distinction, it belongs in QoS-NSLP (this is John's
and Robert's logic also).  I also don't understand why putting the
packet_classifier in QoS-NSLP is any more complex or prone to errors
than putting it in QSPEC.

We listed it as an open issue in the latest QSPEC-07 update (to be
announced).  Hopefully we can resolve the issue prior to IETF-64.

Thanks,
Regards,
Jerry 

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]] 
Sent: Monday, October 24, 2005 5:43 AM
To: [email-masked]; Ash, Gerald R (Jerry), ALABS; [email-masked]
Cc: Ash, Gerald R (Jerry), ALABS
Subject: Re: [NSIS] RE: PACKET_CLASSIFIER in QSPEC

Hi John

I am not sure what was the conclusion?
Jerry do you agree to include the Packet classifier in the QSPEC?

Best Regards,
Georgios

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, October 24, 2005 11:23 AM
Subject: RE: [NSIS] RE: PACKET_CLASSIFIER in QSPEC

> Georgios,
> 
> Do you feel that this is now resolved?  It looks like you and Jerry
> have come to an agreement.
> 
> John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Mon, 24 Oct 2005 15:01:04 +0200

Hi Jerry,

> than putting it in QSPEC.

And Georgious point was that the packet classifier depends
probably on the QoS model or is at least somehow related to
it. So if put into QoS NSLP you possibly end up with a stack
of packet classifiers in addition to the QSPEC stack.
Integrating packet classifiers into QSPECs would remove the need
to support also a separate stack of packet classifiers.
If thinking about it from a DiffServ perspective I would support
the view that a packet classifier is probably QoS model dependent.
However, in DiffServ you also need additional elements like markers
or droppers for a useful traffic conditioning mechanism.

Regards,
 Roland