Subject: RE: [NSIS] WGLC on QoS NSLP

From: "Cheng Hong" <[email-masked]>
Date: Tue, 11 Jul 2006 11:08:17 +0800

Hi Andrew,

Thanks for your reply. 

Am I correct in reading it as following:
- PACKET_CLASSIFIER shall only be set by the initiator; 
- If there needs to be a change in PACKET_CLASSIFIER, the QSPEC stacking
should not be allowed. In stead, method in section 4.6 should be used. 

cheers

Cheng Hong

> -----Original Message-----
> From: Andrew McDonald [mailto:[email-masked]] 
> Sent: Monday, July 10, 2006 10:18 PM
> To: Cheng Hong
> Cc: [email-masked]; Georgios Karagiannis; Jukka MJ 
> Manner; [email-masked]
> Subject: Re: [NSIS] WGLC on QoS NSLP
> 
> Hi,
> 
> Cheng Hong wrote:
> > Sorry for a late comment on the draft. I have gone through it, and 
> > quite like the way it is.
> 
> Thanks for reviewing it.
> 
> > However, I got a question regarding one of the message format 
> > definition. For the Reserve (also the QUERY) message, it is 
> defined in 
> > section 5.1.2.1 as:
> > 
> >    RESERVE = COMMON_HEADER
> >              RSN [ RII ] [ REFRESH_PERIOD ] [ *BOUND_SESSION_ID ]
> >              [ [ PACKET_CLASSIFIER ] [ QSPEC ] [ QSPEC ] ]
> > 
> > As I read it, there could be multiple QSPEC stacked in the message, 
> > however there is only one PACKET_ClASSIFIER object allowed. 
> Shouldn't 
> > this be [ [ PACKET_CLASSIFIER ] [ QSPEC ] 
> [PACKET_CLASSIFIER] [ QSPEC 
> > ] ] instead? (because the PACKET_CLASSIFIER would depend on the QoS 
> > Model
> > used)
> > 
> > I remember there were some discussion regarding the issue 
> around the 
> > Nov meeting time last year. But, I could not remember how 
> this is resolved.
> > Could you provide a pointer to the resolution?
> 
> I do remember discussing this before. The conclusion was:
> We should only have a single PACKET_CLASSIFIER. The reasoning 
> being that allowing for multiple classifiers means that the 
> reservation may apply to different sets of packets along 
> different path segments. The initiator then doesn't know 
> whether the reservation along some part of the path actually 
> applies to the packets it asked for the reservation for. This 
> generally sounds like a bad idea.
> 
> If you do need to have different PACKET_CLASSIFIERs then you 
> can always use parallel signalling sessions (e.g. this is the 
> way RMD handles this).
> 
> regards,
> 
> Andrew
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Andrew McDonald <[email-masked]>
Date: Tue, 11 Jul 2006 14:11:23 +0100

> should not be allowed. In stead, method in section 4.6 should be used. 

Yes, that is a correct summary.

Andrew