Subject: [NSIS] QoS NSLP WGLC ended

From: Jukka MJ Manner <[email-masked]>
Date: Mon, 10 Jul 2006 17:30:57 +0300 (EEST)

Dear all,

The WGLC on the QoS NSLP ended July 7th, and there was only one comment, a 
typo with QNI and QNR being mixed. Thus, the WG seems happy with the spec 
as it is.

Yet, I'd would suggest one functionality to be added, the Proxy Mode.  
There were emails exchanged on the list end of April - beginning of May,
and there seemed to be support for it. I didn't take it into the draft
then, but it seems I perhaps should have. The reasons are:

1) Support in the WG
2) NAT/FW NSLP also has the same functionality
3) TSVWG is considering this issues for RSVP currently

Proxy Mode would allow a QNE to operate on-behalf of an end-host to reply 
to QoS NSLP signaling messages. This would allow to set up reservations 
for outgoing and incoming flows. Not any QNE may operate as proxy, it must 
be a previously configured node.

The changes required would be

1) One Generic Flag bit to indicate a message is part of a Proxy Mode 
   session.
2) One Message Flag bit to indiate a QUERY is meant to trigger a RESERVE 
   for an incoming flow.
3) Updates here and there to add discussion and message processing rules 
   for the Proxy Mode.

The Proxy Mode will probably be my main (only?) issue for the time slot at
the meeting. We basically have two options:

a) Take the Proxy Mode into the NSLP spec now, or

b) Wait a bit and see how we finalize the parallel work in TSVWG goes, and
   then write a separate spec that adds the Proxy Mode for the QoS NSLP.

You can comment now on the mailing list, or at the meeting (or catch me in 
the hallways).

Jukka

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: <[email-masked]>
Date: Mon, 10 Jul 2006 17:34:11 +0300

Additionally, I'd appreciate people speaking up that they have read
the draft & that their open issues have been resolved.  You have until
Wednesday AM!

John 

>-----Original Message-----
>From: ext Jukka MJ Manner [mailto:[email-masked]] 
>Sent: 10 July, 2006 10:31
>To: [email-masked]
>Subject: [NSIS] QoS NSLP WGLC ended
>
>
>Dear all,
>
>The WGLC on the QoS NSLP ended July 7th, and there was only 
>one comment, a typo with QNI and QNR being mixed. Thus, the WG 
>seems happy with the spec as it is.
>
>There were emails exchanged on the list end of April - 
>beginning of May, and there seemed to be support for it. I 
>didn't take it into the draft then, but it seems I perhaps 
>should have. The reasons are:
>
>1) Support in the WG
>Proxy Mode would allow a QNE to operate on-behalf of an 
>end-host to reply to QoS NSLP signaling messages. This would 
>allow to set up reservations for outgoing and incoming flows. 
>Not any QNE may operate as proxy, it must be a previously 
>configured node.
>
>The Proxy Mode will probably be my main (only?) issue for the 
>time slot at the meeting. We basically have two options:
>
>You can comment now on the mailing list, or at the meeting (or 
>catch me in the hallways).
>
>Jukka
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 10 Jul 2006 16:35:14 +0200

I supported the idea of adding proxy support already during the 
discussion in April.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 10 Jul 2006 16:40:28 +0200

Hi John,

you raised a good point. I have read draft-ietf-nsis-qos-nslp-10.txt and 
faxed my comments to the authors.
I haven't read draft-ietf-nsis-qos-nslp-11.txt because of the submission 
deadlines. I therefore haven't had the possibility to verify whether my 
comments actually got addressed.

I plan read the -11 version and to post comments.

Ciao
Hannes

---

From: Xiaoming Fu <[email-masked]>
Date: Mon, 10 Jul 2006 10:43:08 -0400

I am in support of proxy mode in QoS NSLP
Xiaoming

---

From: Jukka MJ Manner <[email-masked]>
Date: Mon, 10 Jul 2006 18:08:47 +0300 (EEST)

Most comments were from Rob, Hannes, Roland and us authors (and various
smaller comments from others). I can say I have included pretty much all
suggested changes. Can't remember any major comment that would not have
been included.

Jukka