Subject: AW: [NSIS] NSIS next steps

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 6 Jul 2006 16:38:51 +0200

Hi Marcus, 

I was also impressed when I saw the MRM pattern presentation given by Martin. This is certainly something interesting to take a closer look at. 

I wonder whether you have some applications that make use of these patterns in mind as well.

Ciao
Hannes

> -----Ursprüngliche Nachricht-----
> Von: Marcus Brunner [mailto:[email-masked]] 
> Gesendet: Donnerstag, 6. Juli 2006 16:27
> An: Hancock, Robert; [email-masked]
> Betreff: RE: [NSIS] NSIS next steps
> 
> Robert, all,
>  
> > secondly, i'd like to register interest for the 'MRM patterns'
> document, although this is clearly a longer term activity. 
>  
> Glad to hear your interrest. You might be right with that it is longer
> term, however, I think depending on how serious you are about 
> GIST being
> generalized you have to down that path. AS we have seen that two NSLPs
> defined used a slightly different way, other signalling applications
> might have some different requirements as well.
> 
> Mrcus
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: mendes <[email-masked]>
Date: Thu, 06 Jul 2006 18:19:27 +0200

Hi Marcus and all,

I would like to express interest on the MRM pattern (I had already done
it in Dallas after Martin's presentation).

As for Hannes question about applications that may make use of this MRM,
I can mention one: a different type of interDomain-QoSM as the one that
will be presented in Montreal (draft-zhang-nsis-interdomain-qosm-02):
- the draft to be presented in Montreal makes use of the new off-path
MRM to break the end-to-end QoS signaling into inter-domain and
intra-domain.
- with the MRM pattern the inter-domain signaling may be done in a
different way, starting by the QoS-controller that triggers the
navigation pattern. For instance:
     - one QoS-controller may explore/monitor the capacity of neighbour
networks (QoS-controllers) with a TTL defined in the query message and
use the returned information to dimension its network.
     - one QoS-controller may announce its own capability to its
neighbours with a TTL defined in the query, and to collect the interest
of other networks to make use of that capability.

Another application may be to configuration over dispersed nodes, such
as sensors, and to collect sensing information.

Cheers
Paulo

---

From: <[email-masked]>
Date: Mon, 10 Jul 2006 17:45:49 +0300

Paulo,

>I would like to express interest on the MRM pattern (I had 
>already done it in Dallas after Martin's presentation).
>
>As for Hannes question about applications that may make use of 
>this MRM, I can mention one: a different type of 
>interDomain-QoSM as the one that will be presented in Montreal 
>(draft-zhang-nsis-interdomain-qosm-02):
>- the draft to be presented in Montreal makes use of the new 
>off-path MRM to break the end-to-end QoS signaling into 
>inter-domain and intra-domain.
>- with the MRM pattern the inter-domain signaling may be done 
>in a different way, starting by the QoS-controller that 
>triggers the navigation pattern. For instance:
>     - one QoS-controller may explore/monitor the capacity of 
>neighbour networks (QoS-controllers) with a TTL defined in the 
>query message and use the returned information to dimension 
>its network.
>     - one QoS-controller may announce its own capability to 
>its neighbours with a TTL defined in the query, and to collect 
>the interest of other networks to make use of that capability.

Very interesting - I'd be very interested in seeing this written up.

>Another application may be to configuration over dispersed 
>nodes, such as sensors, and to collect sensing information.

That would be another use - though a bit more experimental ...

John

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 10 Jul 2006 13:34:56 -0400

Hi all,

Nice to see such a big interest about the "Additional Communication  
Patterns
for NSIS" (draft-stiemerling-nsis-mrm-patterns-00.txt).

To get to the roots of those additional communication patterns:
The base idea originated in distributed network management, where you
try to find other managed stations in your vicinity.

If people are interested, we could meet for a chat after the  
presentation.

Thanks,

   Martin

---

From: mendes <[email-masked]>
Date: Thu, 13 Jul 2006 11:01:47 +0200

Hi John

I'll be very interested in contributing to describe a different type on
interDomain-QoSM based on a pattern MRM. But before that I would like to
see you else is interested in this. Moreover, all this work depends on
the evolution of the pattern MRM itself. At this point in time, I would
say that would be interesting to explore a Echo pattern to allow QoS
controllers to locate other peers in its (network) vicinity.

Paulo

---

From: <[email-masked]>
Date: Thu, 27 Jul 2006 02:18:00 +0300

OK, my advice for next steps would be to write this up in a draft - so
interested parties should discuss this.

John 

>-----Original Message-----
>From: ext mendes [mailto:[email-masked]] 
>Sent: 13 July, 2006 05:02
>To: Loughney John (Nokia-NRC/Helsinki)
>Cc: [email-masked]; [email-masked]; 
>[email-masked]
>Subject: Re: AW: [NSIS] NSIS next steps
>
>Hi John
>
>I'll be very interested in contributing to describe a 
>different type on interDomain-QoSM based on a pattern MRM. But 
>before that I would like to see you else is interested in 
>this. Moreover, all this work depends on the evolution of the 
>pattern MRM itself. At this point in time, I would say that 
>would be interesting to explore a Echo pattern to allow QoS 
>>> I would like to express interest on the MRM pattern (I had already 
>>> done it in Dallas after Martin's presentation).
>>>
>>> As for Hannes question about applications that may make use of this 
>>> MRM, I can mention one: a different type of interDomain-QoSM as the 
>>> one that will be presented in Montreal
>>> neighbour networks (QoS-controllers) with a TTL defined in 
>the query 
>>> message and use the returned information to dimension its network.
>>> neighbours with a TTL defined in the query, and to collect the 
>>> interest of other networks to make use of that capability.
>>>     
>>
>>> Another application may be to configuration over dispersed nodes, 
>>> such as sensors, and to collect sensing information.
>>>     
>>