Subject: RE: [NSIS] Legacy NAT traversal for NSIS

From: <[email-masked]>
Date: Sat, 1 Jul 2006 08:25:09 +0300

Hi Saikat,

You're observations are right - if we want, we can run GIST over
any 'standard' NAT traveral mechanisms (TERADO, STUN, TURN). 

I think working through this would be a useful exercise.

John

>On Mon, 2006-06-19 at 15:22 +0200, Pashalidis, Andreas wrote:
>> Is anyone interested to make NSIS work through legacy NATs ?? (i.e.
>> NSIS-unaware NATs)
>> 
>> Under the following link a preliminary document (in I-D format) can
be 
>> found that describes a solution approach.
>> 
>http://www.tschofenig.priv.at/TEMP/draft-pashalidis-nsis-gist-legac
>ynats-00.
>> txt
>> 
>> In an exremely small nutshell: the idea is to tunnel both signalling 
>> and data traffic over a single UDP NAT binding.
>
>I haven't gone through the document throughly, but the 
>underlying transport you propose reminds me of TEREDO (which 
>is <any transport> over IPv6 over UDP over IPv4, where the UDP 
>over IPv4 is punched through legacy NATs with the help of 
>STUN/TURN/ICE etc.) One could potentially run GIST over TEREDO 
>and keep the signaling and data channel separate in
>IPv6 land even though they use the same NAT binding in IPv4 land.
>
>Alternatively, TURN (public-data-relay protocol for traversing 
>the worst of NATs) now has some lightweight framing 
>capability; the framing in TURN could potentially be extended 
>to carry any in-band signals including GIST. 
>
>--
>Saikat
>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Jul 2006 21:31:31 +0200

Hi John,
Hi Saikat,

thanks for the feedback. I definitely think that we should explore the 
usage of these protocols in context with GIST for legacy NAT traversal.

Ciao
Hannes