Subject: [NSIS] Receiver Initiated Reservation - Teardown

From: Bernd Schloer <[email-masked]>
Date: Tue, 04 Jul 2006 00:30:24 +0200

Hi Jukka,

RSVP has two types of teardown-messages: PathTear and ResvTear. The QoS NSLP is 
only allowed to send a RESERVE towards the QNR. How can a receiver initiated 
reservation be torn down? The QNR is not allowed.

Section 5.4.2, p. 61:

3576    Note that QUERY messages with the RESERVE-INIT flag set MUST be
3577    answered by the QNR.

Isn't this the QNI who should answer the QUERY, since the QNR is the sender?

Thanks,
Bernd

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Elena Scialpi" <[email-masked]>
Date: Wed, 5 Jul 2006 17:46:42 +0200

Hi Bernd,

I would want to know if you have received a private answer to this mail.
Please see below for  my opinion.

> Hi Jukka,
>
> RSVP has two types of teardown-messages: PathTear and ResvTear. The QoS 
> NSLP is only allowed to send a RESERVE towards the QNR. How can a receiver 
> initiated reservation be torn down? The QNR is not allowed.

I think that a reservation can be torn down by a RESERVE message ( with TEAR 
flag set) from both, QNI and QNR, entity.
Only RESERVE for resource reservation MUST travel from QNI to QNR and not in 
the opposite direction.

> Isn't this the QNI who should answer the QUERY, since the QNR is the 

Section  5.1.2.2.

   RESERVE-INIT (R) - when this is set, the QUERY is meant as a trigger
   for the recipient to make a resource reservation by sending a
   RESERVE.

Then, when a QNI receive QUERY with a RESERVE-INIT set it responds with a 
RESERVE message.

   Note that QUERY messages with the RESERVE-INIT flag set MUST be
   answered by the QNR. This feature may be used, e.g., following
   handovers, to set up new path state in GIST, and request the other
   party to send a RESERVE back on this new GIST path.

It could be an exceptional  case?

> Bernd

------------ 
LIIS
Laboratorio per l'Internetworking
e l'Interoperabilita' tra i Sistemi
http://liis.unile.it
http://www.campusdelsalento.it
Office: (+39) 0832-297310
c/o Palazzo di Ingegneria
Via per Monteroni
I-73100 Lecce LE, Italy

---

From: Bernd Schloer <[email-masked]>
Date: Wed, 05 Jul 2006 18:56:55 +0200

Hi Elena,

please see inline.

Bernd

> Please see below for  my opinion.
No, I haven't. Yours is the first reply.

> 
>> Hi Jukka,
>>
>> RSVP has two types of teardown-messages: PathTear and ResvTear. The 
>> QoS NSLP is only allowed to send a RESERVE towards the QNR. How can a 
>> receiver initiated reservation be torn down? The QNR is not allowed.
> 
> 
> 
> I think that a reservation can be torn down by a RESERVE message ( with 
> TEAR flag set) from both, QNI and QNR, entity.
> Only RESERVE for resource reservation MUST travel from QNI to QNR and 
> not in the opposite direction.
> 
That would make sense. But section 5.4.1 says:

    RESERVE messages MUST only be sent towards the QNR.

In my opinion this includes also RESERVE messages with set T-Flag.

> Then, when a QNI receive QUERY with a RESERVE-INIT set it responds with 
> a RESERVE message.
> 
> 

    1537     QNR        QNE        QNE        QNI
    1538    sender                          receiver
    1539      |          |          |          |
    1540      | QUERY    |          |          |
    1541      +--------->|          |          |
    1542      |          | QUERY    |          |
    1543      |          +--------->|          |
    1544      |          |          | QUERY    |
    1545      |          |          +--------->|
    1546      |          |          |          |
    1547      |          |          | RESERVE  |
    1548      |          |          |<---------+
    1549      |          | RESERVE  |          |
    1550      |          |<---------+          |
    1551      | RESERVE  |          |          |
    1552      |<---------+          |          |
    1553      |          |          |          |
    1554      | RESPONSE |          |          |
    1555      +--------->|          |          |
    1556      |          | RESPONSE |          |
    1557      |          +--------->|          |
    1558      |          |          | RESPONSE |
    1559      |          |          +--------->|
    1560      |          |          |          |
    1561
    1562 Figure 8: Basic Receiver Initiated Reservation
    1563

I have this figure from section 4.3 in mind. The QNR is the sender of the QUERY. 
And section 5.4.2. says that the QNR must answer the QUERY with set RESERVE-INIT 
flag. You mean the exception could be the handover? Are the roles of QNR and QNI 
changed after a handover?

> ------------ LIIS

---

From: Jukka MJ Manner <[email-masked]>
Date: Wed, 5 Jul 2006 20:42:12 +0300 (EEST)

Hi,
you may be right. I'll need to re-check the text and our terminology. ;)

Jukka

On Tue, 4 Jul 2006, Bernd Schloer wrote:

> Hi Jukka,
> 
> RSVP has two types of teardown-messages: PathTear and ResvTear. The QoS NSLP
> is only allowed to send a RESERVE towards the QNR. How can a receiver