Subject: RE: [NSIS] WGLC on QoS NSLP

From: "Cheng Hong" <[email-masked]>
Date: Mon, 10 Jul 2006 16:45:46 +0800

Dear all,

Sorry for a late comment on the draft. I have gone through it, and quite
like the way it is.

However, I got a question regarding one of the message format
definition. For the Reserve (also the QUERY) message, it is defined in
section 5.1.2.1 as:

   RESERVE = COMMON_HEADER
             RSN [ RII ] [ REFRESH_PERIOD ] [ *BOUND_SESSION_ID ]
             [ [ PACKET_CLASSIFIER ] [ QSPEC ] [ QSPEC ] ]

As I read it, there could be multiple QSPEC stacked in the message,
however there is only one PACKET_ClASSIFIER object allowed. Shouldn't
this be [ [ PACKET_CLASSIFIER ] [ QSPEC ] [PACKET_CLASSIFIER] [ QSPEC ]
] instead? (because the PACKET_CLASSIFIER would depend on the QoS Model
used) 

I remember there were some discussion regarding the issue around the Nov
meeting time last year. But, I could not remember how this is resolved.
Could you provide a pointer to the resolution?

cheers

Cheng Hong

> -----Original Message-----
> From: Jukka MJ Manner [mailto:[email-masked]] 
> Sent: Monday, June 26, 2006 6:59 PM
> To: [email-masked]
> Subject: Re: [NSIS] WGLC on QoS NSLP
> 
> 
> Hi all,
> 
> The wdiff tool does not like changes in section headings, so 
> below is a page-by-page diff. It's not as nice as what wdiff 
> produces, but shows the main things. 
> 
> There were a lot of editorial fixes and some text was 
> re-arranged, many clarifications, but not that many technical 
> changes. Some of the main technical things were removal of 
> the peer ack-feature, fixes in the error codes, added error 
> source identifier coding, add a new flag to RESERVE, etc.
> 
> http://www.cs.helsinki.fi/u/jmanner/draft-ietf-nsis-qos-nslp-1
> 1-from-0.diff.html
> 
> 
> Jukka
> 
> 
> On Mon, 26 Jun 2006 [email-masked] wrote:
> 
> > Hi all,
> > 
> > Jukka has submitted the QoS NSLP draft.  It should be 
> released today.
> > Until it is announced, you can find a copy of it here:
> > 
> http://www.cs.helsinki.fi/u/jmanner/papers/draft-ietf-nsis-qos-nslp-11
> > .t
> > xt
> > 
> > The WGLC will run until July 7th.  After that, Jukka can 
> summarize all 
> > issues and we will discuss them at the next IETF meeting in 
> Montreal.
> > 
> > Jukka, do you have a diff file or a summary of the changes made?
> > 
> > thanks,
> > John
> > 
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> > 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Andrew McDonald <[email-masked]>
Date: Mon, 10 Jul 2006 15:17:56 +0100

Hi,

> Sorry for a late comment on the draft. I have gone through it, and quite

Thanks for reviewing it.

> Could you provide a pointer to the resolution?

I do remember discussing this before. The conclusion was:
We should only have a single PACKET_CLASSIFIER. The reasoning being that 
allowing for multiple classifiers means that the reservation may apply 
to different sets of packets along different path segments. The 
initiator then doesn't know whether the reservation along some part of 
the path actually applies to the packets it asked for the reservation 
for. This generally sounds like a bad idea.

If you do need to have different PACKET_CLASSIFIERs then you can always 
use parallel signalling sessions (e.g. this is the way RMD handles this).

regards,

Andrew