Subject: Re: [NSIS] draft-qosmodel-controlledload-04

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Jul 2006 22:22:52 +0200

Hi all,

I should have read the latest QSPEC draft version before I sent this 
mail. The most recent draft talks about this aspect and it says in 
Section 4.7:
"
A QOSM specification MUST define how the mandatory parameters are to
    be mapped onto the QSPEC parameters used by the QOSM, however the
    mapping MAY result in slight modification to the intended
    specification when an exact mapping is not possible.
"

Attila, you did this for the token bucket parameter and described that 
it can be mapped to the bandwith parameter.

Now, the only question remains whether a QOSM also have to define a 
mapping for all mandatory parameters. This would address the case 
mentioned below: The QOSM does not make use of all mandatory parameters 
listed in the QSPEC.

Ciao
Hannes

Hannes Tschofenig wrote:
> Hi Attila,
> 
> Attila Báder (IJ/ETH) wrote:
> 
>> Hi Bernd, This is the case in RMD as well. In RMD domain resource
>> reservation is based on one parameter: Bandwidth. If, for example,
>> the resource request arriving to the Edge is a token bucket, it
>> should be translated to a single Bandwidth parameter. This may be a
>> peak value, or an effective value.
> 
> 
> I guess Bernd's question was focusing on a different aspect. What 
> happens if you receive a request that contains the parameter 'Y.1541 QoS 
> Class with the value set for Class 0?
> 
> Ciao
> Hannes
> 
> 
>>
>> Best regards, Attila
>>
>>
>>> -----Original Message----- From: Bernd Schloer
>>> [mailto:[email-masked]] Sent: Thursday, June 29,
>>> 2006 3:01 PM To: [email-masked] Subject: [NSIS]
>>> draft-qosmodel-controlledload-04
>>>
>>>
>>> Hi,
>>>
>>> the first open issue in the appendix B is about what to do with
>>> mandatory QSPEC parameters which are not needed for CLS.
>>>
>>> Does a QOSM have to understand (and provide information about) all
>>> mandatory parameters, even if they are not used? The QSPEC-draft
>>> says in section 5 that all parameters listed in the next sections
>>> are mandatory. The QSPEC-draft also says in section 4.1 that "a
>>> given QOSM defines which of the mandatory and optional parameters
>>> it uses, ..."
>>>
>>> Are there any specific parameters which makes the open issue B.1.1.
>>> clearer? Following the QSPEC-draft there doesn't seem to be a 
>>> conflict, if nothing is done with the unneeded parameters.
>>>
>>> Thanks, Bernd
>>>
>>>
>>>
>>> _______________________________________________ nsis mailing list 
>>> [email-masked] https://www1.ietf.org/mailman/listinfo/nsis
>>>
>>
>>
>> _______________________________________________ nsis mailing list 
>> [email-masked] https://www1.ietf.org/mailman/listinfo/nsis
>>
>>
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Sun, 2 Jul 2006 19:02:14 -0500

Hi Hannes,

See below. 

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Saturday, July 01, 2006 4:23 PM
> To: Hannes Tschofenig
> Cc: [email-masked]; "Attila Báder (IJ/ETH)"
> Subject: Re: [NSIS] draft-qosmodel-controlledload-04
> 
> Hi all,
> 
> it can be mapped to the bandwidth parameter.
> 

As stated in the QOSM specification requirements in Section 4.7, if a QOSM remaps a mandatory parameter, the remapping must be defined in the QOSM specification document.  If no such remapping is defined, the default behavior is that the QOSM must strictly interpret the mandatory parameter, as defined in Section 5.1:

  "Here the terminology 'strictly interpret' means that
   the parameter is implemented according to the commonly accepted
   definition and/or as specified by references given for each QSPEC
   parameter."

Thanks,
Jerry