Subject: [NSIS] QoS NSLP -- INFO_SPEC

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 15 Jul 2007 14:33:59 +0200

Section 5.1.3.6 defines the INFO_SPEC object.
The object format is garbled and it is difficult to figure out how long 
the fields are.

   Object Value Info:

   0 1 2 3 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0
   1 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ |
   Rsvd | Real Object Length | Offset |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   //                           Object                            //
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

How long are the individual fields?

Ciao
Hannes

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Bernd Schloer <[email-masked]>
Date: Thu, 19 Jul 2007 18:17:42 +0200

Hi Hannes,

sorry for the late reply. In draft v.13 'Real Object Length' was 12
bit and 'Offset' was 16 bit long. 'Object' contains one or more
erroneous objects.

   Object Value Info:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | Rsvd  |  Real Object Length   |            Offset             |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   //                           Object                            //
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Best regards,
Bernd

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 20 Jul 2007 18:25:19 +0200

Hi Hannes

Thank you very much for the comment!
We will take care of it!

Best Regards,
Georgios

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: zondag 15 juli 2007 14:34
> To: [email-masked]
> Subject: [NSIS] QoS NSLP -- INFO_SPEC
> 
> The object format is garbled and it is difficult to figure 
> out how long the fields are.
> 
> 
>    Object Value Info:
> 
>    1 
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ |