Subject: [NSIS] QSPEC Extensibility Question

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 07 Aug 2007 17:14:10 +0200

Reading through the QSPEC draft I have a question:

Is it allowed to define new QoS parameters without defining a QOSM?

Ciao
Hannes

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Attila Báder (IJ/ETH) <[email-masked]>
Date: Wed, 8 Aug 2007 10:57:57 +0200

Hi Hannes, 

I assume not. My understanding is that if you want to use a new parameter with NSIS you need to specify how to interprete it in different conditions, which is actually a QOSM. On the other hand you need a parameter ID from IANA, that should be specified in also this doc.

Best regards, Attila

>-----Original Message-----
>From: Hannes Tschofenig [mailto:[email-masked]] 
>Sent: Tuesday, August 07, 2007 5:14 PM
>To: [email-masked]
>Subject: [NSIS] QSPEC Extensibility Question
>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 08 Aug 2007 14:56:31 +0200

Hmm. 

I wonder what other WG members think. 

Strictly speaking, the QSPEC document also defines QoS parameters without being a QOSM. 

My question, however, is more from the background of the current work in DIME and the usage of the QSPEC there. 

It would be very helpful for me to have a very clear answer to this question since it will have an impact on the DIME documents since we envision extensions being defined that do not have any relationship to NSIS as well. 

Ciao
Hannes

-------- Original-Nachricht --------
Datum: Wed, 8 Aug 2007 10:57:57 +0200
Von: "Attila Báder (IJ/ETH)" <[email-masked]>
An: "Hannes Tschofenig" <[email-masked]>, [email-masked]
Betreff: RE: [NSIS] QSPEC Extensibility Question

> Hi Hannes, 
> 
> I assume not. My understanding is that if you want to use a new parameter
> with NSIS you need to specify how to interprete it in different conditions,
> which is actually a QOSM. On the other hand you need a parameter ID from
> IANA, that should be specified in also this doc.
> 
> Best regards, Attila
>

---

From: David R Oran <[email-masked]>
Date: Wed, 8 Aug 2007 09:30:41 -0400

> Strictly speaking, the QSPEC document also defines QoS parameters  
What seems relevant is what you have to do from a standardization and  
interoperability point of view to extend NSIS, in this case by adding  
QoS parameters. I think the intent is that you have to write a  
standards-track RFC to add QoS parameters or make other extensions to  
a QSPEC. Whether doing so constitutes a new or modified QOSM seems of  
secondary importance, and is possibly irrelevant (depending on one's  
opinions on the importance of QOSMs to the NSIS design).

> My question, however, is more from the background of the current  
> work in DIME and the usage of the QSPEC there.
>
> It would be very helpful for me to have a very clear answer to this  
> question since it will have an impact on the DIME documents since  
> we envision extensions being defined that do not have any  
> relationship to NSIS as well.
>
> Ciao
> Hannes
>
>