Subject: [NSIS] The QSPEC draft violates the QoS NSLP

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 12 Aug 2007 20:56:43 +0200

Strictly speaking the QSPEC document with the currently defined QSPEC 
hiding procedure violates the QoS NSLP draft:

The QoS NSLP draft defines the RESERVE and the RESPONSE as follows:

      RESERVE = COMMON_HEADER
                RSN [ RII ] [ REFRESH_PERIOD ] [ *BOUND_SESSION_ID ]
                [ SESSION_ID_LIST [ RSN_LIST ] ]
                [ MSG_ID / BOUND_MSG_ID ] [ INFO_SPEC ]
                [ [ PACKET_CLASSIFIER ] QSPEC ]

 RESPONSE = COMMON_HEADER
                 [ RII / RSN ] INFO_SPEC [SESSION_ID_LIST [ RSN_LIST ] ]
                 [ QSPEC ]

I assume that the QSPEC hiding is applicable for the QUERY and the 
NOTIFY message as well.

The QSPEC may appear 0 or 1 times.

With the QSPEC hiding it would be correct to indicate for the RESERVE 
and the RESPONSE that the object may appear 0 to 2 times.

Ciao
Hannes

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Kappler, Cornelia" <[email-masked]>
Date: Thu, 23 Aug 2007 14:37:31 +0200

I agree, the QoS NSLP draft should be updated to specify that the QSPEC can appear several times as Hannes described below. 

Cornelia

> -----Ursprüngliche Nachricht-----
> Von: ext Hannes Tschofenig [mailto:[email-masked]] 
> Gesendet: Sonntag, 12. August 2007 20:57
> An: [email-masked]
> Betreff: [NSIS] The QSPEC draft violates the QoS NSLP
>