Subject: [NSIS] Status update about GIST

From: "Martin Stiemerling" <[email-masked]>
Date: Wed, 28 May 2008 03:36:19 +0200

Hi all,

It has been a bit silent the last weeks about what is actually happening with GIST. You might still remember that GIST go sent to the IESG and underwent the IESG review and discussion. 

The GIST spec got quite an amount of ABSTAINS during the IESG review and therefore is blocked. Most of the IESG members have had concerns about GIST and this led to the ABSTAINS. 

However, to get things progressed, Magnus initiated a joint telechat between the IESG, Robert, Henning and me to discuss the ABSTAINS. The call took place on Thursday, May 15, 5:30 pm CEST. Here is brief summary (that reassembles my memory): 

The discussion with the IESG centered around the Router Alert Options in IPv4 but also touching IPv6. The general concern about thiss is that NSIS could lead to a flood of IP packets including IP RAO options and that this could effect existing RSVP-TE deployments, plus all current routers (as IP options go to the slow path), and finally that packets with RAO options are anyhow filtered at the edges of the Internet. This cause most of the ABSTAINS and the call for GIST being pushed to the experimental track instead the standards track. 

The issues associated with RAO were discussed for quite some while (I remember 1 hours or so) and we couldn't find any agreement for the IESG on staying with RAO as part of the GIST spec AND going for standards track. The envisioned solutions to this is, revert to packet filtering mechanism (e.g. 5-tuple) to intercept GIST packets, instead of RAO, in the GIST specification. This would be allowed to go GIST as standard track. The RAO part will be cut out of the GIST spec and pushed to a separate document. This new document will go on experimental track. 

This splitting will also effect the NSLPs, as they are also definin RAO usage. 

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: <[email-masked]>
Date: Tue, 27 May 2008 21:19:12 -0500

Martin,

Does this mean that the use RAO is basically thought of as a bad thing
by the IESG?

John

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Martin Stiemerling
Sent: Tuesday, May 27, 2008 6:36 PM
To: nsis
Subject: [NSIS] Status update about GIST

Hi all,

It has been a bit silent the last weeks about what is actually happening
with GIST. You might still remember that GIST go sent to the IESG and
underwent the IESG review and discussion. 

The GIST spec got quite an amount of ABSTAINS during the IESG review and
therefore is blocked. Most of the IESG members have had concerns about
GIST and this led to the ABSTAINS. 

However, to get things progressed, Magnus initiated a joint telechat
between the IESG, Robert, Henning and me to discuss the ABSTAINS. The
call took place on Thursday, May 15, 5:30 pm CEST. Here is brief summary
(that reassembles my memory): 

The discussion with the IESG centered around the Router Alert Options in
IPv4 but also touching IPv6. The general concern about thiss is that
NSIS could lead to a flood of IP packets including IP RAO options and
that this could effect existing RSVP-TE deployments, plus all current
routers (as IP options go to the slow path), and finally that packets
with RAO options are anyhow filtered at the edges of the Internet. This
cause most of the ABSTAINS and the call for GIST being pushed to the
experimental track instead the standards track. 

The issues associated with RAO were discussed for quite some while (I
remember 1 hours or so) and we couldn't find any agreement for the IESG
on staying with RAO as part of the GIST spec AND going for standards
track. The envisioned solutions to this is, revert to packet filtering
mechanism (e.g. 5-tuple) to intercept GIST packets, instead of RAO, in
the GIST specification. This would be allowed to go GIST as standard
track. The RAO part will be cut out of the GIST spec and pushed to a
separate document. This new document will go on experimental track. 

This splitting will also effect the NSLPs, as they are also definin RAO
usage. 

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited |
Registered Office: NEC House, 1 Victoria Road, London W3 6BL |
Registered in England 2832014
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Wed, 28 May 2008 13:40:37 +0100

john, 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: 28 May 2008 03:19
> To: [email-masked]; [email-masked]
> Subject: Re: [NSIS] Status update about GIST
> 
> Martin,
> 

my interpretation of the discussion is that: 

IF your protocol
* uses RAO, and
* has any likelihood of significant deployment on the Internet
  (where "significant" is defined as "more than RSVP for QoS")
THEN 
* it will be experimental

... at least for IPv4. the IPv6 case is (at least to me) much
less clear cut: theoretically/architecturally they should be
the same, but the practical/engineering issues are quite different.

one of the routing ADs is going to write a draft explaining this.

robert h.

---

From: <[email-masked]>
Date: Wed, 28 May 2008 08:30:51 -0500

... now they tell us. 

>From: ext Hancock, Robert [mailto:[email-masked]] 
>Sent: 28 May, 2008 05:41
>To: Loughney John (Nokia-OCTO/PaloAlto); 
>[email-masked]; [email-masked]
>Subject: RE: [NSIS] Status update about GIST
>
>john, 
>
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of [email-masked]
>> Sent: 28 May 2008 03:19
>  (where "significant" is defined as "more than RSVP for QoS") THEN
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of ext Martin Stiemerling
>> It has been a bit silent the last weeks about what is actually 
>> happening with GIST. You might still remember that GIST go 
>sent to the 
>> IESG and underwent the IESG review and discussion.
>> 
>> The GIST spec got quite an amount of ABSTAINS during the IESG review 
>> and therefore is blocked. Most of the IESG members have had concerns 
>> about GIST and this led to the ABSTAINS.
>> 
>> call took place on Thursday, May 15, 5:30 pm CEST. Here is brief 
>> summary (that reassembles my memory):
>> 
>> The discussion with the IESG centered around the Router 
>Alert Options 
>> in
>> with RAO options are anyhow filtered at the edges of the Internet. 
>> This cause most of the ABSTAINS and the call for GIST being 
>pushed to 
>> the experimental track instead the standards track.
>> 
>> remember 1 hours or so) and we couldn't find any agreement for the 
>> IESG on staying with RAO as part of the GIST spec AND going for 
>> standards track. The envisioned solutions to this is, revert 
>to packet 
>> filtering mechanism (e.g. 5-tuple) to intercept GIST 
>packets, instead 
>> of RAO, in the GIST specification. This would be allowed to 
>go GIST as 
>> standard track. The RAO part will be cut out of the GIST spec and 
>> pushed to a separate document. This new document will go on 
>> experimental track.
>> 
>> NEC Laboratories Europe - Network Research Division NEC 
>Europe Limited 
>> | Registered Office: NEC House, 1 Victoria Road, London W3 6BL |

---

From: Lars Eggert <[email-masked]>
Date: Wed, 28 May 2008 11:48:30 -0400

> ... now they tell us.

If it's any consolation, your ADs weren't aware of these apparent  
issues with RAO either, given that prior IESGs had OK'ed NSIS' use of  
RAO. But it looks like we've found a way forward that appeases the  
current IESG, which is a goot thing IMO.

Lars