Subject: [NSIS] Status of the WG (January 2009)

From: "Martin Stiemerling" <[email-masked]>
Date: Mon, 26 Jan 2009 14:56:13 +0100

Dear all,

Just some general information where we are right now with our milestones.

We have submitted these drafts to our AD/IESG:
- GIST
- QoS NSLP
- NATFW NSLP
- Y.1541
- QSPEC

These milestones are still open
Sep 2008	  	Submit 'Applicability Statement of NSIS Protocols in Mobile Environments' to the IESG as an Informational RFC
Sep 2008	  	Submit 'RMD-QOSM - The Resource Management in Diffserv QOS Model' to the IESG for publication as an Informational RFC
Nov 2008	  	Submit 'GIST State Machine' to the IESG for publication as an Informational RFC
Nov 2008	  	Submit 'NSIS Operation Over IP Tunnels' to the IESG for publication as an Informational RFC
Dec 2008	  	Submit 'NSIS Extensibility Model' to the IESG for publication as an Informational RFC

and the  GIST over SCTP draft.

We need to finish those documents better sooner than later!

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: Gerald Ash <[email-masked]>
Date: Mon, 26 Jan 2009 10:50:18 -0800 (PST)

Thanks a lot Martin for the update and for moving things along in NSIS.
 
It looks like Magnus has a backlog of documents to review, some have been in his queue for months.  It would be good to get these documents reviewed so they can move forward to the IESG.
 
Jerry

--- On Mon, 1/26/09, Martin Stiemerling <[email-masked]> wrote:

From: Martin Stiemerling <[email-masked]>
Subject: [NSIS] Status of the WG (January 2009)
To: [email-masked]
Date: Monday, January 26, 2009, 8:56 AM

Dear all,

These milestones are still open
Sep 2008	  	Submit 'Applicability Statement of NSIS Protocols in Mobile
Environments' to the IESG as an Informational RFC
Sep 2008	  	Submit 'RMD-QOSM - The Resource Management in Diffserv QOS
Model' to the IESG for publication as an Informational RFC
Nov 2008	  	Submit 'GIST State Machine' to the IESG for publication as
an Informational RFC
Nov 2008	  	Submit 'NSIS Operation Over IP Tunnels' to the IESG for
publication as an Informational RFC
Dec 2008	  	Submit 'NSIS Extensibility Model' to the IESG for
publication as an Informational RFC

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3
6BL | Registered in England 2832014

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 27 Jan 2009 11:11:46 +0100

Gerald Ash skrev:
> It looks like Magnus has a backlog of documents to review, some have
> been in his queue for months.  It would be good to get these documents
> reviewed so they can move forward to the IESG.

Hi,

Most of NSIS documents hasn't really been touched by me yet. The reason
is that I really like to see GIST approved before processing the other
documents. If we can't get GIST approved the rest of the documents has
little value. Therefore I have been sitting on them.

I hope we can get an updated version of GIST soon so that we really can
go forward. I hope the update I am waiting for will be sufficient to get
this approved. However, with this document I will not promise anything.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: Gerald Ash <[email-masked]>
Date: Tue, 27 Jan 2009 09:03:43 -0800 (PST)

Magnus,

> this approved. However, with this document I will not promise anything.
 
I fail to see the logic in waiting for GIST to be approved before progressing other NSIS documents.  IMO we should make the assumption that GIST will be approved after DISCUSS's are addressed to the IESG's satisfaction.  Waiting for GIST completion to progress other NSIS documents just further delays these documents from getting into the IESG queue and prolongs the NSIS WG from completing its work (which has gone on too many years now).  The NSIS authors/editors are doing their part in progressing their documents.  I urge you to do your part in meeting the WG milestones (some of which are almost a year overdue).
 
Thanks,
Jerry

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 28 Jan 2009 10:24:52 +0100

Hi Magnus

So what you are really saying is that the WG should focus and do its best 
to update the GIST draft as soon as possible!

I think that I agree with you! 

What are the comments of IESG on GIST?

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Magnus Westerlund
> Sent: dinsdag 27 januari 2009 11:12
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [NSIS] Status of the WG (January 2009)
> 
> Gerald Ash skrev:
> Most of NSIS documents hasn't really been touched by me yet. 
> The reason is that I really like to see GIST approved before 
> processing the other documents. If we can't get GIST approved 
> the rest of the documents has little value. Therefore I have 
> been sitting on them.
> 
> I hope we can get an updated version of GIST soon so that we 
> really can go forward. I hope the update I am waiting for 
> will be sufficient to get this approved. However, with this 
> document I will not promise anything.
> 
> Cheers
> 
> Magnus Westerlund
>

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 28 Jan 2009 11:53:29 +0100

Gerald Ash skrev:
> I fail to see the logic in waiting for GIST to be approved before
> progressing other NSIS documents.  IMO we should make the assumption
> that GIST will be approved after DISCUSS's are addressed to the IESG's
> satisfaction.  Waiting for GIST completion to progress other NSIS
> documents just further delays these documents from getting into the IESG
> queue and prolongs the NSIS WG from completing its work (which has gone
> on too many years now).  The NSIS authors/editors are doing their part
> in progressing their documents.  I urge you to do your part in meeting
> the WG milestones (some of which are almost a year overdue).
>  

Gerald,

after having participated in over 2 years of discussion around GIST I
think it will be published without any more significant changes. But
until I have seen the others in IESG abandon their Abstain positions  I
am not certain of it. The fact that these changes does affect the NSLP
documents have made me put of this review until I have seen clear
progress of GIST.

I fully agree that all NSIS work has gone on too long. But me spending
too much time reviewing the documents that may need to change isn't
productive. I will continue with my AD reviews of the NSIS documents
when I cleared out the others that I know can make progress.

Best Regards

Magnus Westerlund

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Thu, 29 Jan 2009 20:34:17 +0200

I have to agree with Jerry. 
 
Given that it takes a long time for documents to find their way through
various queues I would publish them ASAP. 

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf
Of Gerald Ash
	Sent: 27 January, 2009 19:04
	To: Magnus Westerlund
	Cc: [email-masked]
	Subject: Re: [NSIS] Status of the WG (January 2009)

			Magnus,

	> I hope we can get an updated version of GIST soon so that we
really can
	 
	I fail to see the logic in waiting for GIST to be approved before
progressing other NSIS documents.  IMO we should make the assumption that
GIST will be approved after DISCUSS's are addressed to the IESG's
satisfaction.  Waiting for GIST completion to progress other NSIS documents
just further delays these documents from getting into the IESG queue and
prolongs the NSIS WG from completing its work (which has gone on too many
years now).  The NSIS authors/editors are doing their part in progressing
their documents.  I urge you to do your part in meeting the WG milestones
(some of which are almost a year overdue).
	 
	Thanks,
	Jerry

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 30 Jan 2009 09:58:14 +0100

Hi Magnus

But which actions could the NSIS WG take in order to help
some of the IESG members to abandon their abstain positions?

Best regards,
Georgios

> Sent: woensdag 28 januari 2009 11:53
> To: [email-masked]
> Cc: [email-masked]
> >>> been in his queue for months.  It would be good to get these 
> >>> documents reviewed so they can move forward to the IESG.
> >> Most of NSIS documents hasn't really been touched by me yet. The 
> >> reason is that I really like to see GIST approved before 
> processing 
> >> the other documents. If we can't get GIST approved the rest of the 
> >> documents has little value. Therefore I have been sitting on them.
> >>
> >> I hope we can get an updated version of GIST soon so that 
> we really 
> >> can go forward. I hope the update I am waiting for will be 
> sufficient 
> >> to get this approved. However, with this document I will 
> not promise anything.
> >  
> > documents just further delays these documents from getting into the 
> > IESG queue and prolongs the NSIS WG from completing its work (which 
> > has gone on too many years now).  The NSIS authors/editors 
> are doing 
> > their part in progressing their documents.  I urge you to 
> do your part 
> > in meeting the WG milestones (some of which are almost a 
> year overdue).
> >  
> 
> Gerald,
> 
> after having participated in over 2 years of discussion 
> around GIST I think it will be published without any more 
> significant changes. But until I have seen the others in IESG 
> abandon their Abstain positions  I am not certain of it. The 
> fact that these changes does affect the NSLP documents have 
> made me put of this review until I have seen clear progress of GIST.
> 
> I fully agree that all NSIS work has gone on too long. But me 
> spending too much time reviewing the documents that may need 
> to change isn't productive. I will continue with my AD 
> reviews of the NSIS documents when I cleared out the others 
> that I know can make progress.
> 
> Best Regards
> 
> Magnus Westerlund
>

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 30 Jan 2009 11:33:49 +0100

> some of the IESG members to abandon their abstain positions?

A good question to which I don't have a good answer. After the last
discussion my tally was that it will be publishable after the next
update that take cares of the RTG ADs complaint about the interception
text. But it will be with no margin in this case.

Actually I don't understand Chris and Lisa's abstain position as I think
the document is no longer than many other base specifications nor that
the quality is lacking. But they haven't been swayed by any discussion
either.

I can say that the fallback plan is experimental status as then several
of the abstainies would move to no-obj. But I still hope to avoid that.

Cheers

Magnus Westerlund

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 30 Jan 2009 11:47:19 +0100

Hi,

It has been brought to my attention that I missed that Chris already is
no-obj.

Cheers

Magnus

-- 

Magnus Westerlund

---

From: Roland Bless <[email-masked]>
Date: Fri, 30 Jan 2009 16:29:25 +0100

Hi Magnus,

> the quality is lacking. But they haven't been swayed by any discussion

I don't understand Lisa's comment:
"I do not feel it has the quality we expect on the standards track."

Could she back up this a little bit further? This is a rather generic
but strong statement. One could turn any specific criticism
probably even into a constructive one, but this is a little coarse.

What about the IETF credo "running code"?
The doc is fine enough to get more than a hands full of interoperable
implementations (which is required not until going to draft standard
BTW). In the past there were also comments that it's too complex to
implement, but the available implementations should be proof enough
that this really isn't the case.
IMHO the GIST spec is well written, understandable and has a consistent
protocol definition, which isn't weird or flawed. Any path-coupled
signaling protocol will have to do very similar things and currently
I don't see a better way how to do it. Furthermore, all NAT stuff
makes things worse, which wasn't even considered for RSVP.
We are now in the 8th year, guys. Let's get this thing off the table...

Regards,
 Roland