Subject: [NSIS] QoS NSLP flags

From: Roland Bless <[email-masked]>
Date: Fri, 23 Jan 2009 14:51:57 +0100

I've got two questions:
1) would it be good to let any unknown flags intact instead of resetting
   them? Current text says:
   "The set of appropriate flags depends on the particular message being
   processed.  Any bit not defined as a flag for a particular message
   MUST be set to zero on sending and MUST be ignored on receiving."
   If I understand the text correctly, an additional flag cannot pass a
   QNE, or does "set to zero" apply only to the QNI?

2) We suggest that the QUERY gets an additional bit in the message
   flags. Sometimes it might be useful to elicit a RESERVE with the R=1
   bit set (in the RESERVE, i.e., a REPLACE bit) and sometimes not. So
   it would be good to have a bit in a QUERY that provides information
   at the far end on how to the the REPLACE bit in the corresponding
   RESERVE. Does this make sense?

Regards,
-- 
Roland Bless -- WWW: http://www.tm.uka.de/~bless
Institute of Telematics, University of Karlsruhe, Germany
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: Jukka Manner <[email-masked]>
Date: Mon, 26 Jan 2009 13:52:40 +0200

Hi Roland,

For Q1, I think the text meant that the QNI should set to zero, but if 
it didn't, then a QNE probably should be resetting the bit to zero, so 
let it go through.

For Q2, I agree, this would be kind of useful to have. The NSLP is with 
the AD now, so we have to wait for his review. But still, I'd like to 
get other people's reaction to these, as well.

Cheers,
Jukka

Roland Bless wrote:
> Hi,

---

From: "Martin Stiemerling" <[email-masked]>
Date: Mon, 26 Jan 2009 14:49:30 +0100

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Roland Bless
> Sent: Friday, January 23, 2009 2:52 PM
> To: [email-masked]; Jukka MJ Manner; Georgios Karagiannis; Andrew
> McDonald
> Subject: [NSIS] QoS NSLP flags
> 
> Hi,
> 
> 
> I've got two questions:

This reads like common practice, i.e., ignore on receiving but set them right on sending. Any good reason to change this?

>    RESERVE. Does this make sense?

I'm not sure whether this is required but in any case this would mean a hard change to the specification and not just an editing of it. 

I don't see this as a bug but it is optional, i.e, no change required.

  Martin

> Regards,

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: Martin Röhricht <[email-masked]>
Date: Mon, 26 Jan 2009 15:04:00 +0100

On 01/26/2009 02:49 PM Martin Stiemerling wrote:
>> 1) would it be good to let any unknown flags intact instead of
>> resetting them? Current text says: "The set of appropriate flags
>> depends on the particular message being processed.  Any bit not
>> defined as a flag for a particular message MUST be set to zero on
>> sending and MUST be ignored on receiving." If I understand the text
>> correctly, an additional flag cannot pass a QNE, or does "set to
>> zero" apply only to the QNI?
> 
> This reads like common practice, i.e., ignore on receiving but set 
> them right on sending. Any good reason to change this?

I must admit that I was confused by this section, too. From my point of 
view it wouldn't hurt to add a few words clarifying this case, at least 
to prevent us from running into a RAO-like confusion.
For example something like this:
»Any bit not defined as a flag for a particular message MUST be set to 
zero on sending, MUST be ignored on receiving, and MUST be forwarded 
unchanged.«

Bye,
Martin

---

From: "Martin Stiemerling" <[email-masked]>
Date: Mon, 26 Jan 2009 15:07:33 +0100

> zero on sending, MUST be ignored on receiving, and MUST be forwarded

Isn't this reading contradicting? An QoS NSLP node that forwards a message, must anyhow first receive it. So, does this mean to change or leave the bit?

  Martin

---

From: Roland Bless <[email-masked]>
Date: Mon, 26 Jan 2009 15:48:00 +0100

Hi Martin and all,

Martin Stiemerling wrote:
>> confusion. For example something like this: »Any bit not defined as
>> a flag for a particular message MUST be set to zero on sending,
>> MUST be ignored on receiving, and MUST be forwarded unchanged.«
> 
> Isn't this reading contradicting? An QoS NSLP node that forwards a
> message, must anyhow first receive it. So, does this mean to change
> or leave the bit?

I guess that he meant to leave the bit intact, but you're correct
that the third statement contradicts the first. Leaving unknown bits
intact would allow for easier extensibility. For message objects we have
the the A/B flag mechanism, but for message flags this won't work.
The Postel principle actually would propose to ignore unknown
bits on receipt and reset unknown bits to zero for outgoing messages.
Leaving unknown bits intact would require to save the unknown flags
for the outgoing message thus making implementations a little bit more
complex. But as far as I can see resetting or leaving bits are both
problematic to the same extent, depending on the bits meaning.
If a new bit is used to signal some kind of node capability, then
leaving bits intact would be problematic. If the new bit is used to
signal a special meaning to the far end node, then leaving bits intact
would be nice. So currently, if we need to introduce extra bits, we
require a new NSLP protocol version, right?

Regards,
 Roland