Subject: [ntpwg] ***SPAM*** Re: Error in new draft of Offset calculation

From: mayer at ntp.isc.org (Danny Mayer)
Date: Sun, 25 Mar 2007 14:36:59 -0400

Dave,

In responding to a new bug report it looks like the new draft for ntp V4
has the wrong calculation for offset:

   theta = T(B) - T(A) = 1/2 * [(T2-T1) + (T4-T3)]

as I recall from our discussions (below) this should actually read:

   theta = T(B) - T(A) = 1/2 * [(T2-T1) + (T3-T4)]

Having finally convinced myself the latter was correct this other
version popped back up in the draft. This is on Page 30 (Section 8) of
the draft.

Danny

David L. Mills wrote:
> Danny,
> 
> I'm glad somebody else proofs the copy. The equations (4) and (5) in the 
> original report are correct. There are errors in the draft, apparently 
> committed in translation. See below:
> 
> Dave
> 
> Danny Mayer wrote:
> 
>> Dave,
>>
>> I have been reading the NTP v4 protocol draft and it appears that the
>> expression used to calculate the offset theta is incorrect. Can you
>> confirm this? If so, your report (on which the document is based is also
>> wrong. The calculation as appears on page 28 of the IETF draft document
>> says:
>>
>> theta = T(B) - T(A) = 1/2*(T_2-T_1)+(T_3-T_4)
>>
>  >>>> Mmissing brackets. Should be
>         theta = T(B) - T(A) = 1/2*[(T_2 - T_1) + (T_3 - T_4)]
> 
>> However that seems to be a measure of the asymmetry in the offset. This
>> is a copy of your equation (4) in your report TR 06-6-1 on Page 15.
>> Shouldn't this read
>>
>> theta = T(B) - T(A) = 1/2*(T_2-T_1)+(T_4-T_3)
>>
>  >>>> This is wrong. You can see this by considering each term 
> separately and losing the 1/2.
> 
>> which then reflects the average offset, i.e. T_3 and T_4 are reversed?
>>
>> Danny
> 
> 
> _______________________________________________
> ntpwg mailing list
> ntpwg at lists.ntp.isc.org
> https://lists.ntp.isc.org/mailman/listinfo/ntpwg
>

---

From: jim at daedelus.com (Jim Martin)
Date: Mon, 26 Mar 2007 01:38:32 +0200

Danny,
	I've made this fix in the latest draft. We expect to send it to the  
ID editor later this week....

	- Jim

---

From: mayer at ntp.isc.org (Danny Mayer)
Date: Mon, 26 Mar 2007 02:36:20 -0400

> ID editor later this week....

Thanks. I hope to start reviewing the whole document this week.

Danny

---

From: mills at udel.edu (David L. Mills)
Date: Mon, 26 Mar 2007 15:58:21 +0100

Danny,

You are absolutely correct; it is a typo. Amazing that such a simple 
thing can get through multiple reviews. It happened on RFC 2030 and typo 
reports kept coming in for years. Thanks for the bag.

Dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070326/8c1f6634/attachment.html