Subject: [ntpwg] NTPv4 Client / NTPv3 Server

From: Helen.Y.Chen at motorola.com (Chen Helen-A12587)
Date: Wed, 25 Apr 2007 18:05:27 -0400

Hi Dave,
 
Does the NTPv4 client send an NTPv4 request regardless of the server's
NTP version? Will the NTPv3 server handle an NTPv4 request properly from
a client (due to ALL NTPv4 fields being optional) or must the
NTPv4-capable client send an NTPv3 request to the server?  If the
latter, how does the client know which version to send?
 
Thanks,
Helen 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070425/5f7baf9d/attachment.html

---

From: stenn at ntp.isc.org (Harlan Stenn)
Date: Wed, 25 Apr 2007 22:40:10 +0000

Helen,

The one who talks first send the highest version it can handle.

The other side responds with whichever is less, the sender's version or
the "local" version.

>From then people behave according to that version.

H

---

From: Helen.Y.Chen at motorola.com (Chen Helen-A12587)
Date: Wed, 25 Apr 2007 18:54:34 -0400

Harlan,

Thanks. Isn't it always the client who talks first though, since it's
requesting the time or authentication?

Helen 

-----Original Message-----
From: Harlan Stenn [mailto:stenn at ntp.isc.org] 
Sent: Wednesday, April 25, 2007 5:40 PM
To: Chen Helen-A12587
Cc: David L. Mills; ntpwg at ntp.isc.org
Subject: Re: [ntpwg] NTPv4 Client / NTPv3 Server 

Helen,

H

---

From: tglassey at earthlink.net (todd glassey)
Date: Wed, 25 Apr 2007 16:52:56 -0700

Only in Unicast Events. 

Todd 
----- Original Message ----- 
From: "Chen Helen-A12587" <Helen.Y.Chen at motorola.com>
To: "Harlan Stenn" <stenn at ntp.isc.org>
Cc: <ntpwg at ntp.isc.org>
Sent: Wednesday, April 25, 2007 3:54 PM
Subject: Re: [ntpwg] NTPv4 Client / NTPv3 Server

> _______________________________________________
> ntpwg mailing list
> ntpwg at lists.ntp.isc.org
> https://lists.ntp.isc.org/mailman/listinfo/ntpwg

---

From: mills at udel.edu (David L. Mills)
Date: Thu, 26 Apr 2007 17:06:19 +0000

Helen,

The ntp client sends in the configured version from 1 through the client 
version. The ntp server responds with the version specified by the 
client, but not greater than the server version. Thus, a NTPv4 server 
responds to any version up to version 4, while a NTPv3 server responds 
to any version up to version 3.

Dave

---

From: mills at udel.edu (David L. Mills)
Date: Thu, 26 Apr 2007 17:28:19 +0000

Helen,

The client ordinarily sends its compiled version; however, an option can 
be specified to send in any other version.

---

From: mayer at ntp.isc.org (Danny Mayer)
Date: Sun, 29 Apr 2007 13:00:27 -0400

> requesting the time or authentication?

Not always. If the server is a broadcast or multicast server sendimg
broadcast packets the server will talk first.

Danny