Subject: [ntpwg] questions about current NTP protocol draft

From: timothy.plunkett at navy.mil (Plunkett, Timothy R CIV NSWCDD, W13)
Date: Wed, 4 Apr 2007 16:01:59 -0500

I am currently editing the XML version of the latest NTPv4 protocol
draft.  I noticed the following two things that I was hoping that
someone could clarify for me.

1.  Should the equation for capepsilon in section 10 be for a variable
called EPSILON instead?  I know that there has been an effort to remove
all the "cap" variables and I think this is a leftover.

2.  Should the equation for PSI in section 11.2.3 have a square root
function in it?  Seems like PSI should equal SQRT [(PSI_s)^2 +
(PSI_p)^2].  If preferred I could also raise it to the one half power as
well.

Thanks,

Tim

***********************************************************
Timothy R. Plunkett
NSWC-DD, Code W13
Building 1500 Room A122A
17214 AVENUE B SUITE 100
DAHLGREN, VA 22448-5147

(540) 653 - 1090 (phone at Dahlgren)
(540) 653 - 8673 (fax at Dahlgren)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070404/d09985c1/attachment.html

---

From: GDowd at symmetricom.com (Greg Dowd)
Date: Wed, 4 Apr 2007 14:22:10 -0700

I'm honestly not EXACTLY sure what version is what in the xml domain but
I'll vote.
 
1) I don't see capepsilon in the non xml version.  Can you quote the
string or equation here?  In any case, capepsilon is root dispersion.
If the notes or context allows you to determine that the variable in
question is indeed root dispersion then EPSILON would be correct in the
latest version.
 
2) Yes, sqrt of the sum of the squares.  

Greg Dowd 
gdowd at symmetricom dot com (antispam format) 
Symmetricom, Inc. 
www.symmetricom.com 
"The current implementation is non-obvious and may need to be improved."

________________________________

From: ntpwg-bounces+gdowd=symmetricom.com at lists.ntp.isc.org
[mailto:ntpwg-bounces+gdowd=symmetricom.com at lists.ntp.isc.org] On Behalf
Of Plunkett, Timothy R CIV NSWCDD, W13
Sent: Wednesday, April 04, 2007 2:02 PM
To: ntpwg at lists.ntp.isc.org
Subject: [ntpwg] questions about current NTP protocol draft

Thanks, 

Tim 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070404/23811da8/attachment.html

---

From: karen.odonoghue at navy.mil (Odonoghue, Karen F CIV NSWCDD, W13)
Date: Wed, 4 Apr 2007 16:55:35 -0500

I asked Tim to check the reformatted xml to make sure nothing got corrupted in the process. 
The equation in question is: 
 
Karen
 
   In the next step the shift register stages are copied to a temporary
   list and the list sorted by increasing delta.  Let i index the stages
   starting with the lowest delta.  If the first tuple epoch t_0 is not
   later than the last valid sample epoch p.t, the routine exits without
   affecting the current peer variables.  Otherwise, let epsilon_i be
   the dispersion of the ith entry, then
                     i=n-1
                     ---     epsilon_i
      capepsilon =    \     ----------
                      /        (i+1)
                     ---     2
                     i=0

   is the peer dispersion p.disp.  Note the overload of epsilon, whether
   input to the clock filter or output, the meaning should be clear from
   context.

From: ntpwg-bounces+karen.odonoghue=navy.mil at lists.ntp.isc.org on behalf of Greg Dowd
Sent: Wed 4/4/2007 4:22 PM
To: Plunkett, Timothy R CIV NSWCDD, W13; ntpwg at lists.ntp.isc.org
Subject: Re: [ntpwg] questions about current NTP protocol draft

I'm honestly not EXACTLY sure what version is what in the xml domain but I'll vote.
 
1) I don't see capepsilon in the non xml version.  Can you quote the string or equation here?  In any case, capepsilon is root dispersion.  If the notes or context allows you to determine that the variable in question is indeed root dispersion then EPSILON would be correct in the latest version.

Greg Dowd 

From: ntpwg-bounces+gdowd=symmetricom.com at lists.ntp.isc.org [mailto:ntpwg-bounces+gdowd=symmetricom.com at lists.ntp.isc.org] On Behalf Of Plunkett, Timothy R CIV NSWCDD, W13
Sent: Wednesday, April 04, 2007 2:02 PM
To: ntpwg at lists.ntp.isc.org
Subject: [ntpwg] questions about current NTP protocol draft

I am currently editing the XML version of the latest NTPv4 protocol draft.  I noticed the following two things that I was hoping that someone could clarify for me.

1.  Should the equation for capepsilon in section 10 be for a variable called EPSILON instead?  I know that there has been an effort to remove all the "cap" variables and I think this is a leftover.

2.  Should the equation for PSI in section 11.2.3 have a square root function in it?  Seems like PSI should equal SQRT [(PSI_s)^2 + (PSI_p)^2].  If preferred I could also raise it to the one half power as well.

Thanks, 

Tim 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070404/81a8d033/attachment.html

---

From: GDowd at symmetricom.com (Greg Dowd)
Date: Wed, 4 Apr 2007 15:09:31 -0700

That's peer dispersion epsilon, as opposed to root dispersion
capepsilon.    The text in the graphic shows the correct epsilon.

Greg Dowd 

From: Odonoghue, Karen F CIV NSWCDD, W13
[mailto:karen.odonoghue at navy.mil] 
Sent: Wednesday, April 04, 2007 2:56 PM
To: Greg Dowd; Plunkett, Timothy R CIV NSWCDD, W13;
ntpwg at lists.ntp.isc.org
Subject: RE: [ntpwg] questions about current NTP protocol draft

I asked Tim to check the reformatted xml to make sure nothing got
corrupted in the process. 
The equation in question is: 
 
Karen

From: ntpwg-bounces+karen.odonoghue=navy.mil at lists.ntp.isc.org on behalf
of Greg Dowd
Sent: Wed 4/4/2007 4:22 PM
To: Plunkett, Timothy R CIV NSWCDD, W13; ntpwg at lists.ntp.isc.org
Subject: Re: [ntpwg] questions about current NTP protocol draft

 

Greg Dowd 

Thanks, 

Tim 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070404/ec825b6c/attachment-0001.html

---

From: timothy.plunkett at navy.mil (Plunkett, Timothy R CIV NSWCDD, W13)
Date: Wed, 4 Apr 2007 17:16:51 -0500

Greg,

But what I am saying is that 

                     i=n-1
                     ---     epsilon_i

should be changed to be instead

                     i=n-1
                     ---     epsilon_i
         EPSILON =    \     ----------
                      /        (i+1)
                     ---     2
                     i=0
or maybe the capepsilon should only be epsilon, but I am sure that
"capepsilon" should no longer be there.  There are no other variables in
the document that start with "cap".  They have been replaced with an ALL
CAPS version of them.

Tim

-----Original Message-----
From: Greg Dowd [mailto:GDowd at symmetricom.com] 
Sent: Wednesday, April 04, 2007 18:10
To: Odonoghue, Karen F CIV NSWCDD, W13; Plunkett, Timothy R CIV NSWCDD,
W13; ntpwg at lists.ntp.isc.org
Subject: RE: [ntpwg] questions about current NTP protocol draft

Greg Dowd 

 
Karen

 

Greg Dowd 

Thanks, 

Tim

---

From: GDowd at symmetricom.com (Greg Dowd)
Date: Wed, 4 Apr 2007 15:56:47 -0700

I understand the question.  You should replace capepsilon with epsilon.
I was focused on the why.  I should have clearly stated the what first.

                     i=n-1
                     ---     epsilon_i
      epsilon    =    \     ----------
                      /        (i+1)
                     ---     2
                     i=0

Greg Dowd

-----Original Message-----
From: Plunkett, Timothy R CIV NSWCDD, W13
[mailto:timothy.plunkett at navy.mil] 
Sent: Wednesday, April 04, 2007 3:17 PM
To: Greg Dowd; Odonoghue, Karen F CIV NSWCDD, W13;
ntpwg at lists.ntp.isc.org
Subject: RE: [ntpwg] questions about current NTP protocol draft

Greg,

                     i=n-1
                     ---     epsilon_i

                     i=n-1
                     ---     epsilon_i
         EPSILON =    \     ----------
                      /        (i+1)
                     ---     2
                     i=0

Tim

-----Original Message-----
From: Greg Dowd [mailto:GDowd at symmetricom.com]
Sent: Wednesday, April 04, 2007 18:10
To: Odonoghue, Karen F CIV NSWCDD, W13; Plunkett, Timothy R CIV NSWCDD,

Greg Dowd
gdowd at symmetricom dot com (antispam format) Symmetricom, Inc. 
www.symmetricom.com
"The current implementation is non-obvious and may need to be improved."

 
Karen

 

Greg Dowd 

Thanks, 

Tim

---

From: mills at udel.edu (David L. Mills)
Date: Fri, 06 Apr 2007 04:23:05 +0100

Tim,

The XML I posted on the NTP Project Page had no capepsilon. Neither does 
the RFC that was made from it. What's going on?

Dave

Plunkett, Timothy R CIV NSWCDD, W13 wrote:

> ------------------------------------------------------------------------
>
> _______________________________________________
> ntpwg mailing list
> https://lists.ntp.isc.org/mailman/listinfo/ntpwg

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070406/9a5e64da/attachment.html

---

From: mills at udel.edu (David L. Mills)
Date: Fri, 06 Apr 2007 04:26:53 +0100

Greg,

Ths history as I know it started from the XML document I posted on the 
NTP project page. Harlan took that and produced the RFC. I purposely 
removed the XML here so as not to confuse the markup. So far as I know, 
Harlan has the only XML copy. I'm sure he would be hapy to give it up; 
maybe he already has. However, if you see a capepsilon, you have the 
wrong document.

Dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070406/fa26a785/attachment.html

---

From: mills at udel.edu (David L. Mills)
Date: Fri, 06 Apr 2007 04:29:41 +0100

Guys,

It may be useful to compare the equation variables with the tables of 
variables. You should not see capepsilon anywhere. I continue to believe 
this is the wrong XML document.

Dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ntp.isc.org/pipermail/ntpwg/attachments/20070406/7e2b5d87/attachment.html