Subject: Re: [ntpwg] ntpwg Updated NTPv4 Protocol Specification/timestamp location

From: "STUART VENTERS" <[email-masked]>
Date: Tue, 5 Feb 2008 10:18:45 -0600

Dave,

>> Where's the beef?

Fair enough.

I think it's in 2 places, one technical and one philosophical.

We appear to be in agreement the Media Herbie and Driver Sue (much better names, thanks) built spec compliant implementations.
If we connect them together with a zero length cable and assume Sue and Herbie's time references are aligned, 
then consider what happens when Sue's client sends a request to Herbie's server.

Sue's T1 timestrike is at the end of packet, Herbie's T2 is at the start of packet.  This makes T2 happen about 1 packet time before T1.
So T2-T1 is about minus 1 packet.

Now for the response.
Herbie's T3 is at the start of packet,  Sue's T4 is at the end.  This makes T4 happen about 1 packet time after T3.
So T4-T3 is about plus 1 packet.

In other words, the reciprocal delay is mismatched by about 2 packet times.

Regards,

Stuart

ps,  The other beef is in your first 3 words (All three citizens).  Pesky should not be included in the list of folks who have to read the spec and sweat over matching the delays.

pps,  The above is a CP1 story.  There is a similar story for CP2.

ppps, You're right, life is much easier in the fpga.  It lets me put the whole implementation in one place.  I'm very impressed at what you have been able to achieve especially considering the variety of platforms that ntpd runs on.

_______________________________________________
ntpwg mailing list
[email-masked]
https://lists.ntp.org/mailman/listinfo/ntpwg

---

From: "David L. Mills" <[email-masked]>
Date: Wed, 06 Feb 2008 02:36:12 +0000

Stuart,

That's the beauty of it. Herbie and Sue don't care. The delays are still 
reciprocal and the fact Sue's delays are one packet longer doesn't matter.

Dave

UART VENTERS wrote:

> We appear to be in agreement the Media Herbie and Driver Sue (much 
> better names, thanks) built spec compliant implementations.
> If we connect them together with a zero length cable and assume Sue 
> and Herbie's time references are aligned,
> Sue's T1 timestrike is at the end of packet, Herbie's T2 is at the 
> start of packet. This makes T2 happen about 1 packet time before T1.
> Herbie's T3 is at the start of packet, Sue's T4 is at the end. This 
> makes T4 happen about 1 packet time after T3.
> ps, The other beef is in your first 3 words (All three citizens). 
> Pesky should not be included in the list of folks who have to read the 
> spec and sweat over matching the delays.
>
> ppps, You're right, life is much easier in the fpga. It lets me put 
> the whole implementation in one place. I'm very impressed at what you 
> have been able to achieve especially considering the variety of 
> platforms that ntpd runs on.
>
>