Subject: [ntpwg] Meeting of interest to the NTP working group

From: Rob Seaman <[email-masked]>
Date: Tue, 2 Aug 2011 14:17:16 -0700

Hi,

A workshop has been organized to discuss the implications of the proposed redefinition of Coordinated Universal Time (UTC).  See details below.  We would welcome the opportunity to consider contributions from the NTP community.  Ceasing leap seconds would have implications.  These implications have yet to be considered in detail.  The intent of the meeting is to begin to do so.

This topic has a broad natural community (http://davasobel.com/blog/?p=131), even if most stakeholders are unaware of it.  In addition to the astronomy and astronautics talks, there will be presentations such as on the vision and architecture of the 10,000 year clock (http://longnow.org/clock/) by one of their project engineers.  We will also have a talk and tour of the grand Analemmatic Sundial at Longwood Gardens (http://bit.ly/omBqrE) following the meeting.  Ken Seidelmann provided its accurate calibration; the ITU's redefinition of Coordinated Universal Time would render calibration rather a moot issue for this and all sundials.

Please forward this announcement as may seem appropriate.

Thanks!

Rob Seaman
NOAO
--

The chairs of "Decoupling Civil Timekeeping from Earth Rotation" encourage contributions to this upcoming meeting in Exton, PA (near Philadelphia) on October 5-6, 2011:

	http://futureofutc.org/

There will be a final vote at the International Telecommunication Union assembly in Geneva in January 2012 whether to cease issuing leap seconds. This will have significant implications for the astronomical and astronautical communities among others.  For more details the International Earth Rotation Service has circulated the announcement:

	http://data.iers.org/products/2/14839/orig/message_191.txt

Luminaries like Daniel Gambis (who oversees the leap seconds) and Ken Seidelmann (editor of the Explanatory Supplement to the Astronomical Almanac) will be speaking.

For context, see the article in the current issue of American Scientist magazine:

	http://www.americanscientist.org/issues/feature/2011/4/the-future-of-time-utc-and-the-leap-second
	(preprint: http://arxiv.org/abs/1106.3141)

Rob Seaman
National Optical Astronomy Observatory
Tucson, AZ

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: todd glassey <[email-masked]>
Date: Tue, 02 Aug 2011 15:26:27 -0700

On 8/2/2011 2:17 PM, Rob Seaman wrote:
> Hi,
>
> A workshop has been organized to discuss the implications of the 
> proposed redefinition of Coordinated Universal Time (UTC).  See 
> details below.  We would welcome the opportunity to consider 
> contributions from the NTP community.  Ceasing leap seconds would have 
> implications.  These implications have yet to be considered in detail. 
>  The intent of the meeting is to begin to do so.
>
> This topic has a broad natural community 
> (http://davasobel.com/blog/?p=131), even if most stakeholders are 
> unaware of it.  In addition to the astronomy and astronautics talks, 
> there will be presentations such as on the vision and architecture of 
> the 10,000 year clock (http://longnow.org/clock/) by one of their 
> project engineers.  We will also have a talk and tour of the grand 
> Analemmatic Sundial at Longwood Gardens (http://bit.ly/omBqrE) 
> following the meeting.  Ken Seidelmann provided its accurate 
> calibration; the ITU's redefinition of Coordinated Universal Time 
> would render calibration rather a moot issue for this and all sundials.
>

Rob how does this pertain to the upcoming meeting at BIPM in October 2011?

todd
> The chairs of "Decoupling Civil Timekeeping from Earth Rotation" 
> encourage contributions to this upcoming meeting in Exton, PA (near 
> Philadelphia) on October 5-6, 2011:
>
> http://futureofutc.org/
>
> There will be a final vote at the International Telecommunication 
> Union assembly in Geneva in January 2012 whether to cease issuing leap 
> seconds. This will have significant implications for the astronomical 
> and astronautical communities among others.  For more details the 
> International Earth Rotation Service has circulated the announcement:
>
> Luminaries like Daniel Gambis (who oversees the leap seconds) and Ken 
> Seidelmann (editor of the Explanatory Supplement to the Astronomical 
> Almanac) will be speaking.
>

-- 
Todd S. Glassey
This is from my personal email account and any materials from this account come with personal disclaimers.

Further I OPT OUT of any and all commercial emailings.

---

From: Rob Seaman <[email-masked]>
Date: Tue, 2 Aug 2011 15:55:47 -0700

Hi Todd,

> Rob how does this pertain to the upcoming meeting at BIPM in October 2011?

Hmm - lots of meetings.  For BIPM I see from:

	http://www.bipm.org/en/practical_info/diary/

two meetings in October, the 100th meeting of the CIPM and the 24th General Conference on Weights and Measures.  Are you referring to one of these?

Our meeting is sponsored by various organizations, but isn't a meeting of any of them if you get my drift.  We plan a discussion of engineering issues, not politics.  It seems about time (take the pun any way you like) to talk about impacts and remediation, requirements and risks, funding and infrastructure.  We'll publish the talks online and the proceedings via an established press.  The discussion to date (including the current Metrologia, free for the nonce at http://iopscience.iop.org/0026-1394/48/4), has been remarkably short on details of logistics, software, systems engineering and other pragmatic realities.

NTP is how time is delivered.  What kind of time will that be?

Rob Seaman
http://futureofutc.org

---

From: todd glassey <[email-masked]>
Date: Tue, 02 Aug 2011 17:15:28 -0700

On 8/2/2011 3:55 PM, Rob Seaman wrote:
> two meetings in October, the 100th meeting of the CIPM and the 24th General Conference on Weights and Measures.
Yep - that's the one.
> Are you referring to one of these?
There is a motion to change several of the standards  definition up 
before the 24th and an ad hoc petition to qualify a new type of timing 
operations laboratory...

Todd

---

From: Rob Seaman <[email-masked]>
Date: Tue, 2 Aug 2011 19:06:59 -0700

On Aug 2, 2011, at 5:15 PM, todd glassy wrote:

> There is a motion to change several of the standards definition up before the 24th and an ad hoc petition to qualify a new type of timing operations laboratory...

Yes, I had heard something about that.  Are there links to said motion or petition?

That said, the CFP describing our meeting is at:

	http://www.cacr.caltech.edu/futureofutc/callforpapers.cfm

We welcome submissions related to NTP.  For instance, I rely on NTP to attach a UTC tag on thousands of astronomical images nightly from 30 or so singular cameras on a dozen telescopes on three remote mountaintops in both the northern and southern hemispheres.  It matters for a number of contingent use cases, both simple and esoteric, that UTC is actually Universal Time.

Rob Seaman

---

From: todd glassey <[email-masked]>
Date: Wed, 03 Aug 2011 09:19:39 -0700

On 8/2/2011 7:06 PM, Rob Seaman wrote:
> We welcome submissions related to NTP.  For instance, I rely on NTP to attach a UTC tag on thousands of astronomical images nightly from 30 or so singular cameras on a dozen telescopes on three remote mountaintops in both the northern and southern hemispheres.
Cool - I used to write code for nuclear event imaging and analysis at 
SLAC so this application is one which is near and dear to my heart...  
We  used to need to tag the images to within picoseconds to properly 
simulate the events in the analysis system (for both the 40" Hydrogen 
Bubble Chamber and the SPEAR collider).
>   It matters for a number of contingent use cases, both simple and esoteric,
You mean "of legal nature" or more esoteric than that?
> that UTC is actually Universal Time.
I agree - I am working with several governmental groups outside of NIST 
to ensure reliable time is available for securities and banking.  But 
what you are really looking for is a TIMESTAMPING SOLUTION WHICH USES A 
REFERENCE CLOCK INSTEAD OF THE HOST OS... this would allow for the 
timestamping of the images from a centralized location including across 
International Borders.

We have NTP running as a time-stamp server now if you want more info. We 
also have this code running in a a vanilla nVidia GPU - as in "an 
off-the-shelf graphics card" and the performance smokes.

This is important since I am now locked in a patent fraud litigation 
with Symmetricom which if they lose likely makes them a wholly owned 
division of "my fat arse", but either way means there shareholders are 
likely to carve their board a new rectum in the process.

Todd

---

From: Danny Mayer <[email-masked]>
Date: Wed, 03 Aug 2011 13:28:19 -0400

> This is important since I am now locked in a patent fraud litigation

Please keep this offlist. This needs to be handled by the lawyers from
both sides and a judge. It has no place here.

Danny

---

From: Rob Seaman <[email-masked]>
Date: Wed, 3 Aug 2011 12:20:08 -0700

On Aug 3, 2011, at 9:19 AM, todd glassey wrote:

> Cool - I used to write code for nuclear event imaging and analysis at SLAC so this application is one which is near and dear to my heart...  We  used to need to tag the images to within picoseconds to properly simulate the events in the analysis system (for both the 40" Hydrogen Bubble Chamber and the SPEAR collider).

High precision is only one possible class of requirement.  Accurate agreement with an external standard (in this case the orientation of the Earth) is another.  Some projects need both, for instance radio interferometers or neutrino telescopes.

> You mean "of legal nature" or more esoteric than that?

Legal issues don't bear (much) on pure scientific research such as astronomy.  We do timestamp images to control proprietary access, generally for something like an 18-month period.  Rather the interpretation of observational data depends on the specification of the location of the observer as well as the target.  Both ground-based and space-based telescopes are themselves in motion.  Universal Time is embedded in endless ways in the software and logistics.  UTC provides a convenient way to get UT.  NTP provides a convenient way to get UTC.

For instance we relied on NTP in the mid-90s for an asteroseismological (good scrabble word if it fits on the board) experiment that extended over several months such that the light travel correction varied from night-to-night due to the motion of the Earth.  The entire set of 40,000 spectra is locked to a 60s heliocentric cadence with about 0.01s precision/accuracy.  NTP tamed the system clock and UTC provided both the precision of an atomic timescale and the accuracy needed for Earth orientation.

That said, civil timekeeping is responsive to much broader requirements, legal, historical, cultural, logistical, navigational, etc, that themselves may derive from mean solar time and thus impact UTC as currently known.

> I agree - I am working with several governmental groups outside of NIST to ensure reliable time is available for securities and banking.  But what you are really looking for is a TIMESTAMPING SOLUTION WHICH USES A REFERENCE CLOCK INSTEAD OF THE HOST OS... this would allow for the timestamping of the images from a centralized location including across International Borders.

Well, no.  I'm perfectly happy with NTP.  For one thing these many cameras on remote mountaintops were built by different institutions at times stretching back more than a quarter of a century.  The data acquisition systems run on something like 10 different operating systems and legacy hardware (eg, SunOS Sparcs with S11W cards emulating even older DEC interfaces).  NTP is one of the few tools I can count on being supported on all platforms.  It is typically the case that each camera itself has its own reference clock as you describe.  These break in weird and wonderful ways (one camera needs to be reset every three days or there's a clock buffer overflow) and the host/NTP timestamp is instrumental in detecting and correcting the issues and in tying these very different systems together into a coherent system of systems passing calendar date and epoch tokens back to the central data archive.

Since telescope time is a valuable resource and since network access to remote locations in the Andes will always remain fragile (consider earthquakes in Chile), it is also a requirement that a clock local to the telescope dome be used.  NTP is robust against network downtime - meaning I have never needed to worry about the strata sorting themselves out when the network comes back up.  Even if the commercial power is down to half the mountain, a particular camera can take useful on-sky or calibration data as long as the instrument and data acquisition computer can run off the generator (even if the GPS clock - and central data archive - in some other building is down, for instance).

NTP is swell.

Rob Seaman