Subject: [ntpwg] Solicit comments for draft-wu-ntp-ntp-cfg-00

From: "Wunan (Eric)" <[email-masked]>
Date: Tue, 21 Jul 2015 09:13:54 +0000

Hi Guys,

I noticed there is one draft related to NTP presented in RTGWG at Prague IETF93.

https://datatracker.ietf.org/doc/draft-rtgyangdt-rtgwg-device-model/

It seems the co-authors of this draft wishing to augment and define NTP YANG model in their next version.

Frankly speaking, if NTP YANG is going to be defined, I think it will be more reasonable to define it in NTPWG, since all NTP experts are here, what is more, NTP MIB is also define here.

To do that, I abosutely need the help from this working group.

Please help us if you guys think this makes sense.

Thank you.

Regards

Eric

________________________________

 [ntpwg] Fw: New Version Notification for draft-wu-ntp-ntp-cfg-00.txt

________________________________

  *   From: "Wunan (Eric)" <eric.wu at huawei.com<mailto:[email-masked]>>
  *   To: "ntpwg at lists.ntp.org<mailto:[email-masked]>" <ntpwg at lists.ntp.org<mailto:[email-masked]>>, "odonoghue at isoc.org<mailto:[email-masked]>" <odonoghue at isoc.org<mailto:[email-masked]>>
  *   Cc: "Anil Kumar S N \(VRP Network BL\)" <anil.sn at huawei.com<mailto:[email-masked]>>
  *   Date: Thu, 29 Jan 2015 07:49:57 +0000

________________________________

Hi folks,

We have submitted a draft on YANG data model for NTP.
Through this draft we hope the NTP YANG discussion may be introduced in NTPWG since we believe it is a good time to start to do it now.
Since this draft is the only individual one in NTPWG, I may want to ask the chair whether it is the proper place to do it, after all YANG data model is not in current charter.
Wish this mail can reach the chair:)

And we would like to know if there are people interested in this work, IMHO, maybe one design team can be used to promote NTP's YANG data model.
Anyway, any discussion and comments are welcomed.

Regards
Eric & Anil

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Danny Mayer <[email-masked]>
Date: Wed, 22 Jul 2015 14:34:27 -0400

Frankly I have never understood the point of this draft. It seems to
have been introduced in a vacuum. ntpq on the reference implementation
already handles everything needed and uses ntp mode 6 packets. Is there
something I didn't understand?

Danny

On 7/21/2015 5:13 AM, Wunan (Eric) wrote:
> Frankly speaking, if NTP YANG is going to be defined, I think it will be
> more reasonable to define it in NTPWG, since all NTP experts are here,
> what is more, NTP MIB is also define here.
> 
> ------------------------------------------------------------------------
> 
> ------------------------------------------------------------------------
> 
>   * /From/: "Wunan (Eric)" <eric.wu at huawei.com
>     <mailto:[email-masked]>>
>   * /To/: "ntpwg at lists.ntp.org <mailto:[email-masked]>" <ntpwg
>     at lists.ntp.org <mailto:[email-masked]>>, "odonoghue at
>     isoc.org <mailto:[email-masked]>" <odonoghue at isoc.org
>     <mailto:[email-masked]>>
>   * /Cc/: "Anil Kumar S N \(VRP Network BL\)" <anil.sn at huawei.com
>     <mailto:[email-masked]>>
>   * /Date/: Thu, 29 Jan 2015 07:49:57 +0000 
> 
> ------------------------------------------------------------------------
> 
> Hi folks,
> 
> We have submitted a draft on YANG data model for NTP. Through this
> draft we hope the NTP YANG discussion may be introduced
in NTPWG since we believe it is a good time to start to do it now.
> Since this draft is the only individual one in NTPWG, I may want to
ask the chair whether it is the proper place to do it, after all YANG
data model is not in current charter.
> And we would like to know if there are people interested in this
> work,
IMHO, maybe one design team can be used to promote NTP's YANG data model.
> Anyway, any discussion and comments are welcomed.>
> Regards
> Eric & Anil
> 
> 
>

---

From: "Wunan (Eric)" <[email-masked]>
Date: Wed, 22 Jul 2015 22:38:46 +0000

Hi Danny,

Thank you for the frankness.

Yes, ntpq supports mode 6, but does it mean mode 6 is mandatory feature that must be supported on all ntp release?
Actually there are lots of ntp release that don't support mode 6, especially in carriers' networks.

NTP YANG as a protocol-neutral module, will give people one more option to deploy and manage ntp feature.

Regards
Eric
________________________________________
发件人: Danny Mayer [[email-masked]]
发送时间: 2015年7月23日 2:34
收件人: Wunan (Eric); [email-masked]
主题: Re: [ntpwg] Solicit comments for draft-wu-ntp-ntp-cfg-00

Danny

---

From: Harlan Stenn <[email-masked]>
Date: Thu, 23 Jul 2015 02:50:58 +0000

Eric,

On the one hand, if somebody isn't going to implement mode 6 if they go
to the trouble to implement their own version of NTP, and they're not
going to use the wildly portable reference implementation from NTF, why
would they decide to implement the Yang model instead?

But I do see value in common management tools, since we already have
SNMP support as well.

Has your proposal been implemented yet?

H

---

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 23 Jul 2015 09:14:05 +0200

>>> Harlan Stenn <[email-masked]> schrieb am 23.07.2015 um 04:50 in Nachricht
> would they decide to implement the Yang model instead?

I think the problem with "mode 6" is the lack of specification: As long as there is no standard for the names and syntax of variables reported (not to talk about the status (like "required" or "optional"), there cannot be universal tools to use "mode 6".
IMHO reading via mode 6 should be "strongly suggested", while configuration changes via mode 6 should be "recommended".  OF course today confidentiality and integrity are very important when exchanging such messages, because they may reveal information that cannot be seen otherwise.

Regards,
Ulrich

---

From: "Wunan (Eric)" <[email-masked]>
Date: Thu, 23 Jul 2015 08:22:34 +0000

Harlan,

I didn't mean to offense people on mode 6 importance, of couse mode6 has its own value.
What I meant is that it will be better to have another tool in the toolbox, since one more choice available.

And to be honest, usually we use SNMP&MIB to monitor status instead of deloying and configuring. Especially when you face a network with 2000 nodes which need to enable ntp.

We did implement this NTP YANG in our central controller, it will be encoded in SouthBound Interface transport protocol and decoded at router-systems or devices.

Regards

Eric

________________________________________
发件人: Harlan Stenn [[email-masked]]
发送时间: 2015年7月23日 10:50
收件人: Wunan (Eric)
抄送: [email-masked]; [email-masked]
主题: Re: [ntpwg] Solicit comments for draft-wu-ntp-ntp-cfg-00

Eric,

H

---

From: Miroslav Lichvar <[email-masked]>
Date: Thu, 23 Jul 2015 10:50:47 +0200

> I think the problem with "mode 6" is the lack of specification: As long as there is no standard for the names and syntax of variables reported (not to talk about the status (like "required" or "opt…

I'm not sure how useful a specification for the ntpd mode 6 protocol
would be. There is a lot of internal state exposed which would make
little sense in other NTP implementations and the management part is
mostly a subset of the ntp.conf language. In other implementations it
would basically be an ntpd simulator if fully implemented.

Also, the protocol has a problem with traffic amplification, which
would likely require an incompatible change to fix.

-- 
Miroslav Lichvar

---

From: Harlan Stenn <[email-masked]>
Date: Thu, 23 Jul 2015 15:59:05 -0700

On 7/23/15 1:22 AM, Wunan (Eric) wrote:
> Harlan,
> 
> I didn't mean to offense people on mode 6 importance, of course mode6
> has its own value.

No worries on my account.

> What I meant is that it will be better to have
> another tool in the toolbox, since one more choice available.

I hope you're right.  It will be more work, and more code in the
distribution.  But for the reference implementation, we can certainly
offer this as a choice when the code is built.

> And to be honest, usually we use SNMP&MIB to monitor status instead
> of deploying and configuring. Especially when you face a network with
> 2000 nodes which need to enable ntp.

Are you using the reference implementation anywhere?  If so, are you
happy with its SNMP implementation?

> We did implement this NTP YANG in our central controller, it will be
> encoded in SouthBound Interface transport protocol and decoded at
> router-systems or devices.

OK.  I'm happy to see it get added to the reference implementation as
well, and for that we'll need either a volunteer to submit code or some
funding to pay a developer to write it.

H
--
> Regards
> 
> Eric
> 
> 
> 
> 
> ________________________________________ 发件人: Harlan Stenn
> [[email-masked]] 发送时间: 2015年7月23日 10:50 收件人: Wunan (Eric) 抄送:
> [email-masked]; [email-masked] 主题: Re: [ntpwg] Solicit
> comments for draft-wu-ntp-ntp-cfg-00
> 
> Eric,
> 
> On the one hand, if somebody isn't going to implement mode 6 if they
> go to the trouble to implement their own version of NTP, and they're
> not going to use the wildly portable reference implementation from
> NTF, why would they decide to implement the Yang model instead?
> 

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: Danny Mayer <[email-masked]>
Date: Thu, 23 Jul 2015 22:40:05 -0400

On 7/22/2015 6:38 PM, Wunan (Eric) wrote:
> Yes, ntpq supports mode 6, but does it mean mode 6 is mandatory
feature that must be supported on all ntp release?
> Actually there are lots of ntp release that don't support mode 6,
especially in carriers' networks.

That's their choice. It's available for them to use. In the meantime
milions of servers DO support mode 6 packets while you have 0 servers
that currently handle this proposal. It's easier to set up those servers
to handle mode 6 packets than get them to do something else.

> NTP YANG as a protocol-neutral module, will give people one more
option to deploy and manage ntp feature.

Well no. It's protocol neutral until you actually have to build this and
then you have to have something build into the NTP server to support it
and then it's no longer protocol neutral.

You then have a number of choices.

1) Interface your model with the NTP Server using mode 6 packets and
since it's already built into the reference implementation you get to
support millions of servers with it without making any changes to those
servers. None reference implementations would need to add mode 6 packets
and know what do with the requests that come in;

2) Build a Yang interface into NTP directly in which case you don't use
the NTP protocol at all and use TCP to do this. We have discussed doing
a separate management interface in the Reference implementation and it
would use TCP for this.

I have no idea what your intentions are. Have you also looked at the MIB
RFC for NTP? RFC5907 I think.

Danny

---

From: Danny Mayer <[email-masked]>
Date: Thu, 23 Jul 2015 23:05:14 -0400

H
--
> Regards
> 
> Eric
> 
> 
> 
> 
> ________________________________________ ·¢¼þÈË: Harlan Stenn
> [[email-masked]] ·¢ËÍÊ±¼ä: 2015Äê7ÔÂ23ÈÕ 10:50 ÊÕ¼þÈË: Wunan (Eric) ³ËÍ:
> [email-masked]; [email-masked] Ö÷Ìâ: Re: [ntpwg] Solicit

---

From: Harlan Stenn <[email-masked]>
Date: Fri, 24 Jul 2015 09:06:49 +0000

Another benefit to implementing this as ntpd-yang (or something) is that
one could pretty easily use that for older versions of ntpd, too.
-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg