Subject: [ntpwg] WGLC on NTS: Server seed key refresh

From: Sharon Goldberg <[email-masked]>
Date: Tue, 5 Apr 2016 13:39:19 -0400

Just to follow up on my comment during the IETF'95 wg meeting right now:
 NTS requires a server-seed refresh, and uses the 5th and 6th message of
the KE protocol to do this.  What is the use case for server seed key
refresh?

Thanks,
Sharon

-- 
Sharon Goldberg
Computer Science, Boston University
http://www.cs.bu.edu/~goldbe
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: [email-masked]
Date: Tue, 5 Apr 2016 20:48:57 +0200

The  periodic server refresh have been introduced because of Sec 5.6.1 of RFC 7384.

This already had been commented by Florian Weimar (if I remember the name correctly). He suggested not to refresh the server seed during NTPD's operation. The argument was, as far as I remember, that if the applied primitives are sound a refresh of the underlying server seed will not necessary. At that time we decided to stick with the periodic key refresh, mainly because the requirement mentioned above. But yes, if we refrain from the periodic refresh we could merge the second and third round in the key exchange and additionally we would not have the situation that all clients need to refresh their cookie because the server refreshed the server seed. But, of course, we would need to explain why we neglect the must requirement in RFC 7384.

Dieter

-----"TICTOC" <[email-masked]> wrote: -----

>To: NTP Working Group <[email-masked]>, [email-masked]
>From: Sharon Goldberg 
>Sent by: "TICTOC" 
>Date: 04/05/2016 18:40
>Subject: [TICTOC] WGLC on NTS: Server seed key refresh
>
>Just to follow up on my comment during the IETF'95 wg meeting right
>now:  NTS requires a server-seed refresh, and uses the 5th and 6th
>message of the KE protocol to do this.  What is the use case for
>server seed key refresh? 
>Thanks,Sharon
>-- 
>Sharon Goldberg
>TICTOC mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tictoc
>

---

From: Harlan Stenn <[email-masked]>
Date: Tue, 05 Apr 2016 19:16:25 +0000

ntp associations can last for a very long time.

H