Subject: [Ntp] Antw: I-D Action: draft-ietf-ntp-mac-02.txt

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 02 Nov 2017 09:10:20 +0100

Hi!

After a quick browse I realized that the draft does not specify how to detect that AES-CMAC was used instead of an MD5 Digest. Both are 128 bits long.

Regards,
Ulrich

>>> <[email-masked]> schrieb am 30.10.2017 um 20:48 in Nachricht
<[email-masked]>:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Network Time Protocol WG of the IETF.
> 
>         Title           : Message Authentication Code for the Network Time 
> Protocol
>         Authors         : Aanchal Malhotra
>                           Sharon Goldberg
> 	Filename        : draft-ietf-ntp-mac-02.txt
> 	Pages           : 4
> 	Date            : 2017-10-30
> 
> Abstract:
>    RFC 5905 [RFC5905] states that Network Time Protocol (NTP) packets
>    should be authenticated by appending a 128-bit key to the NTP data,
>    and hashing the result with MD5 to obtain a 128-bit tag.  This
>    document deprecates MD5-based authentication, which is considered to
>    be too weak, and recommends the use of AES-CMAC [RFC4493] as a
>    replacement.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-ntp-mac/ 
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-ntp-mac-02 
> https://datatracker.ietf.org/doc/html/draft-ietf-ntp-mac-02 
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ntp-mac-02 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/ 
> 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Harlan Stenn <[email-masked]>
Date: Thu, 2 Nov 2017 01:44:48 -0700

Ulrich,

The algorithm used is part of the symmetric key file.

It's a feature that we don't say what algorithm is used in the packet.

People can use whatever algorithm they want, including MD5.

This document simply says that a conforming implementation MUST support
AES-128-CMAC, and that associations should stop using DES, and start
using AES-128-CMAC instead.

Again, they can also use any other algorithms they want to.

H

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 2 Nov 2017 12:03:17 +0200

Hi,

A couple of comments:

- The "Security Considerations" section is missing.
- It would be great if there was some text that discusses interoperability
with previous versions of NTP (that use the legacy MAC).

Thanks,
Tal.