Subject: [Ntp] WG: Re: NTP Virtual interim meeting, Thursday 18 Oct @ 1600 UTC

From: [email-masked]
Date: Thu, 18 Oct 2018 18:35:37 +0200

----- Weitergeleitet von Kristof Teichel/PTB am 18.10.2018 18:35 -----

Von:    Kristof Teichel/PTB
An:     "Neta R S" <[email-masked]>
Datum:  18.10.2018 16:38
Betreff:        Re: [Ntp] NTP Virtual interim meeting, Thursday 18 Oct @ 
1600 UTC

Hey Neta,

as far as I'm aware, the client in NTS does not save all server messages. 
For replay protection (actually, also injection protection) in 
client-server-mode, it should instead keep a list of its currently open 
(as in unanswered) requests and only accept answers to questions it 
actually has a record of asking.

Best regards,
Kristof

Von:    "Neta R S" <[email-masked]>
An:     "Karen O'Donoghue" <[email-masked]>
Kopie:  [email-masked], [email-masked], [email-masked]
Datum:  18.10.2018 16:33
Betreff:        Re: [Ntp] NTP Virtual interim meeting, Thursday 18 Oct @ 
1600 UTC
Gesendet von:   "ntp" <[email-masked]>

Hi,

Regarding the draft-ietf-ntp-using-nts-for-ntp-13 I think it's important 
that the requirement from the client to save all server messages (for 
replay protection) won't limit the number of servers that can be 
communicated with each time (even if it's tens of servers).

Unfortunately, I can't attend the NTP interim meeting today but would be 
happy if my concern will be considered.

Thanks a lot,
Neta

On Tue, Oct 2, 2018 at 4:19 PM Karen O'Donoghue <[email-masked]> 
wrote:
Folks,

The NTP working group will have a virtual interim meeting on Thursday, 18 
October 2018 @ 1600 UTC (0900 PDT, 1200 EDT, 1800 CEST). The meeting is 
scheduled for 1.5 hours. 

The very drafty agenda is below. Please send any additional comments or 
requests. Please note that current working group work items will take 
priority as we try to make progress. 

1.  Administrative and Agenda Bashing

2.  TICTOC quick document status (documents we hopefully won?t need to 
discuss)

3. NTP quick document status (documents we hopefully won?t need to 
discuss)

4. Next steps for NTP BCP

5. NTS for NTP 

6. Planning for NTS interoperability testing

7. Looking beyond NTS for time security 

8. Additional possible agenda items depending on status and updates? 
NTP Data Minimization
Guidelines for Defining Packet Timestamps 
NTP Interleaved Modes
REFIDs 
NTP Correction Field

8.  AOB 

The meeting will be held on Zoom. You can join via the link or by calling 
in using the provided phone numbers. 

Topic: NTP Virtual Interim Meeting 
Time: Oct 18, 2018 4:00 PM GMT

Join from PC, Mac, Linux, iOS or Android: https://isoc.zoom.us/j/857543887

Or iPhone one-tap :
    US: +16699006833,,857543887#  or +16465588656,,857543887# 
Or Telephone:
    Dial(for higher quality, dial a number based on your current 
location): 
        US: +1 669 900 6833  or +1 646 558 8656 
    Meeting ID: 857 543 887
    International numbers available: https://zoom.us/u/ad78dvE7Px

_______________________________________________
ntp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ntp
_______________________________________________
ntp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ntp

---

From: Harlan Stenn <[email-masked]>
Date: Thu, 18 Oct 2018 10:43:34 -0600

How does the basic protocol provide insufficient replay protection?

Sent from my iPhone. Please excuse brevity and typos.

> On Oct 18, 2018, at 10:35 AM, [email-masked] wrote:
> 
> Betreff:        Re: [Ntp] NTP Virtual interim meeting, Thursday 18 Oct @ 1600 UTC 
> 
> 
> Hey Neta, 
> 
> For replay protection (actually, also injection protection) in client-server-mode, it should instead keep a list of its currently open (as in unanswered) requests and only accept answers to questions it actually has a record of asking. 
> 
> Best regards, 
> Kristof 
> 
> 
> 
> 
> Betreff:        Re: [Ntp] NTP Virtual interim meeting, Thursday 18 Oct @ 1600 UTC 
> Regarding the draft-ietf-ntp-using-nts-for-ntp-13 I think it's important that the requirement from the client to save all server messages (for replay protection) won't limit the number of servers that can be communicated with each time (even if it's tens of servers). 
> 
> Unfortunately, I can't attend the NTP interim meeting today but would be happy if my concern will be considered. 
> 
> Thanks a lot, 
> Neta 
> 
> 
> On Tue, Oct 2, 2018 at 4:19 PM Karen O'Donoghue <[email-masked]> wrote: 
> Folks,
> 
> The NTP working group will have a virtual interim meeting on Thursday, 18 October 2018 @ 1600 UTC (0900 PDT, 1200 EDT, 1800 CEST). The meeting is scheduled for 1.5 hours. 
> 
> The very drafty agenda is below. Please send any additional comments or requests. Please note that current working group work items will take priority as we try to make progress. 
> 
> 2.  TICTOC quick document status (documents we hopefully won’t need to discuss)
> 
> 3. NTP quick document status (documents we hopefully won’t need to discuss)
> 
> 8. Additional possible agenda items depending on status and updates… 
> NTP Data Minimization
> The meeting will be held on Zoom. You can join via the link or by calling in using the provided phone numbers. 
> 
>     Dial(for higher quality, dial a number based on your current location): 
> https://www.ietf.org/mailman/listinfo/ntp_______________________________________________
> ntp mailing list
> [email-masked]