Subject: [Ntp] NTS Draft - nits

From: Hal Murray <[email-masked]>
Date: Wed, 27 Mar 2019 02:35:26 -0700

The top of page 8 says:

>                     servers MUST accept requests of at least 1024 octets and
> clients SHOULD accept responses of at least 65536 octets. 

1K seems reasonable.  65K seems unreasonably large.  Cookies are ballpark of 
100 bytes, maybe closer to 200 if you use AES_SIV_CMAC_512.  8*200 fits in 2K.

Do we want to specify a max length for the Server Negotiation?

-- 
These are my opinions.  I hate spam.

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 27 Mar 2019 11:09:53 +0100

>>> Hal Murray <[email-masked]> schrieb am 27.03.2019 um 10:35 in
>> clients SHOULD accept responses of at least 65536 octets. 

I guess the intention was "Do not arbitrarily limit the size of requests being
accepted" for future extensions. It says SHOULD, not MUST.

> ‑‑ 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp