Subject: Re: [Ntp] New rev of the NTP port randomization I-D (Fwd: New Version Notification for draft-gont-ntp-port-randomization-01.txt)

From: "[email-masked]" <[email-masked]>
Date: Wed, 29 May 2019 14:06:05 +0300

Possibly. If the Cliet has a policy interface which can trigger alarms on being attacked, then yes.  If not its possibly just a feature which will get little use. 

Still there are cases where it could be interesting.

Sent from my HTC, so please excuse any typos.

----- Reply message -----
From: "Harlan Stenn" <[email-masked]>
To: "[email-masked]" <[email-masked]>, <[email-masked]>
Subject: [Ntp] New rev of the NTP port randomization I-D (Fwd: New Version Notification for draft-gont-ntp-port-randomization-01.txt)
Date: Wed, May 29, 2019 09:06

On 5/28/2019 10:58 PM, [email-masked] wrote:
> Yes Harlen if you know you are being attacked the server can set itself
> as unavailable or untrustable until it recertifies. Information
> integrity is key for historical auditing of timestamps 

What about attacks against the client?

Is there benefit to the client knowing it is being attacked?

H
--
> //tsg
> 
> Sent from my HTC, so please excuse any typos.
> 
> ----- Reply message -----
> From: "Harlan Stenn" <[email-masked]>
> To: <[email-masked]>
> Subject: [Ntp] New rev of the NTP port randomization I-D (Fwd: New
> Version Notification for draft-gont-ntp-port-randomization-01.txt)
> Date: Wed, May 29, 2019 08:20
> 
> On 5/28/2019 9:37 PM, Fernando Gont wrote:
>> On 28/5/19 23:20, Majdi S. Abbas wrote:
>>> Fernando,
>>>
>>>     Randomizing the source port is pointless.  As Danny has noted, t1 already acts as a 2^64 nonce on each client mode chime request.  This sufficiently hardens the unauthenticated case to an off path attacker.  If additional security is required, authentication (via classic PSK, or NTS modes) should be used.
>>>
>>>     Per session randomization doesn't resolve these issues -- the stated rationale for both the draft and filed CVE is hardening to off path attacks, which we've just covered.
>>>
>>>     "Because it's best practice" isn't a reason -- it's a crutch to save a draft that was filed due to an insufficient understanding of RFC 5905 and current implementations of NTPv4.  
>> 
>> Oh, by the way. While you enlighten me why you need a fixed well-known
>> port number for the client, and how necessary this is, please also
>> elaborate on how I'm running multiple NTP clients behind a NAT box.
> 
> Nobody seems to be saying there is benefit to *only* using the
> well-known port number when sending a client request.  People are saying
> that requiring this in all cases doesn't buy any significant benefit.
> 
> Of course it's fine if NTP client goes thru a NAT gateway.
> 
> So here's a related question for you:
> 
> Is there benefit to knowing if you are being attacked?
> 
>> Thanks,
> 
> -- 
> Harlan Stenn, Network Time Foundation
> http://nwtime.org - be a Member!
> 
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
> 

-- 
Harlan Stenn, Network Time Foundation
http://nwtime.org - be a Member!

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 29 May 2019 14:07:41 +0300

No problem. It might also be interesting to propose ports as well as part of the request. 

//tsg

----- Reply message -----
From: "Fernando Gont" <[email-masked]>
To: "[email-masked]" <[email-masked]>, "Majdi S. Abbas" <[email-masked]>
Cc: <[email-masked]>, "Gary E. Miller" <[email-masked]>
Subject: [Ntp] New rev of the NTP port randomization I-D (Fwd: New Version Notification for draft-gont-ntp-port-randomization-01.txt)
Date: Wed, May 29, 2019 09:57

On 29/5/19 01:56, [email-masked] wrote:
> Port randomization is used to block port spoofing mitm attacks as part
> of a larger audit framework. 
> 
> It is part of a delivery based assurance process not an informatioin
> integrity process like a whopping nonce is. 
> 
> Keeping the components of the trust model separate has value. 

As noted elsewhere, it also allows for other things such as filtering
attack packets in the network (stateful filtering).

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 30 May 2019 20:35:52 +0300

Depends on how you do logging. If you log events from server side as part of a bidirectional trust model then you care a lot.

----- Reply message -----
From: "Hal Murray" <[email-masked]>
To: "Harlan Stenn" <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Subject: [Ntp] Antw: Re: Antw: Re: New rev of the NTP port randomization I-D (Fwd: New Version Notification for draft-gont-ntp-port-randomization-01.txt)
Date: Wed, May 29, 2019 15:20

[email-masked] said:
> One that would prevent a friendly server from knowing how far off the
> client's time really is. 

Why does a server care about the time on a client?

-- 
These are my opinions.  I hate spam.