Subject: [Ntp] Question regarding RFC 2030 for Time synchronization over SNTP and It's Accuracy

From: Puneet Tambi <[email-masked]>
Date: Tue, 11 Jun 2019 09:09:49 +0000

Hello.

We have some queries for betting understanding w.r.t. to RFC2030, as some of our IEC61850 device are designed to follow the RFC2030 for Time synchronisation over SNTP .

Q1.  How to interpret the poll interval from RFC 2030 and what is the operative word for the polling interval w.r.t. defined in RFC 2030?

Poll Interval: This is an eight-bit signed integer indicating the maximum interval between successive messages, in seconds to the nearest power of two. The values that can appear in this field presently range from 4 (16 s) to 14 (16284 s); however, most applications use only the sub-range 6 (64 s) to 10 (1024 s).

Q2. Can Poll interval be set as completely arbitrary value  if yes the what shall be the minimum value  set ?

Q3. What can be the impact/difference in time stamping of events from the same inputs on 2 different SNTP clients (A & B) having the different poll interval (e.g. A having 10s and B having 64s) in a same network ?

Q4. How the different poll interval can affect the time accuracy of two devices in similar network?

 Looking forward to hear from you.

Best Regards

Puneet Tambi
+919687660324

***********************

DISCLAIMER: The information contained in this electronic message and any other attachment to this message  are intended solely for the addressee and may contain information that is confidential, privileged and exempt from disclosure under applicable law. If you are not the intended recipient, you are hereby formally notified that any use, copying or distribution of this e-mail, in whole or in part, is strictly prohibited. Please immediately notify the sender by return e-mail and delete all copies of this e-mail and any attachments from your system. Any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.

WARNING: Computer viruses can be transmitted via email. The recipient should check this email and any attachments for the presence of viruses. Adani Group accepts no liability for any damage caused by any virus transmitted by this email.

---

From: Martin Burnicki <[email-masked]>
Date: Thu, 13 Jun 2019 11:56:09 +0200

Hello Puneet Tambi,

Puneet Tambi wrote:
> Hello.
> 
> We have some queries for betting understanding w.r..t. to RFC2030, as
> some of our IEC61850 device are designed to follow the RFC2030 for Time
> synchronisation over SNTP .

It is very important that you understand that the resulting accuracy at
the client side mostly depends on the *client* software, and the
network. Please see:
https://kb.meinbergglobal.com/kb/time_sync/time_synchronization_accuracy_with_ntp

Maybe you also want to have a look at this article:
https://kb.meinbergglobal.com/kb/time_sync/ntp/ntp_basics

> Q1.  How to interpret the poll interval from RFC 2030 and what is
> the***operative word for the polling interval w.r.t. defined in RFC 2030?*

Generally, "polling" means that the client sends a request to the
server, and receives and evaluates the response from the server.

The polling interval is the time interval from one polling to the next,
and how often this is done depends strongly on the stability of the
system clock at the client side.

> Poll Interval: This is an eight-bit signed integer indicating the
> maximum interval between successive messages, in seconds to the nearest
> power of two. The values that can appear in this field presently range
> from 4 (16 s) to 14 (16284 s); however, most applications use only the
> sub-range 6 (64 s) to 10 (1024 s).

Full featured NTP implementations like ntpd poll each server in certain
intervals and do quite some statistics on the replies, e.g. do some
filtering of the results to determine the network jitter, the client's
current time offset, and how the time offset evolves, i.e. how fast the
client's clock drifts.

The polling interval is then usually adjusted between certain limits,
depending on the stability of the client's clock. For ntpd the default
limit are 2^6 s to 2^10, i.e. 64 to 1024 s.

> what shall be the minimum value  set ?

If you run your own NTP server you can generally use any interval you
want. If you use public servers you should not use an interval less than
64. Doing so is usually considered abusive by the server operators.

And you should *never* use a hard-coded IP address or host name of a
public server. That would be considered a denial-of-service attack.

> Q3. What can be the impact/difference in time stamping of events from
> the same inputs on 2 different SNTP clients (A & B) having the different
> poll interval (e.g. A having 10s and B having 64s) in a same network ?
> 

As said above, this depends strongly on your network and the
implementation of the client software.

Writing an NTP client software is *not* just sending NTP packets to a
server, and evaluating the response. If you want to have the client time
adjusted as accurately as possible you have to do a lot of filtering,
implementing a control loop to discipline the system time, etc., in your
client implementation.

Or just use one of the existing full-featured clients.

By the way, a better forum to discuss this could be the NTP questions
mailing list:
https://lists.ntp.org/listinfo/questions

This mailing list is dedicated to discussion standards used for future
versions of the NTP protocol.

Regards,

Martin
-- 
Martin Burnicki

Senior Software Engineer

MEINBERG Funkuhren GmbH & Co. KG
Email: [email-masked]
Phone: +49 5281 9309-414
Linkedin: https://www.linkedin.com/in/martinburnicki/

Lange Wand 9, 31812 Bad Pyrmont, Germany
Amtsgericht Hannover 17HRA 100322
Geschäftsführer/Managing Directors: Günter Meinberg, Werner Meinberg,
Andre Hartmann, Heiko Gerstung
Websites: https://www.meinberg.de  https://www.meinbergglobal.com
Training: https://www.meinberg.academy