Subject: [Ntp] NTP WG virtual interim -- Thursday, 17 September 2020, 1530 - 1700 UTC

From: Karen O'Donoghue <[email-masked]>
Date: Fri, 28 Aug 2020 17:42:03 +0000

NTP working group participants,

The NTP WG will have a virtual interim meeting on 17 September 2020 from 1530 - 1700 UTC. 

The draft agenda is:
1.  Administrative and Agenda Bashing
2.  NTP WG Document Status Review/Update
3. WGLC results/discussion on draft-ietf-ntp-port-randomization
4. Call for Adoption results/discussion on draft-mlichvar-ntp-alternative-port
5. <Other documents with updates>
6.  Any updates on NTS Development, Measurement and Testing
7.  Any updates on NTP v5 requirements and next steps
8. TICTOC WG Document Status Review/Update
9.  AOB

Please get your comments in on existing drafts, and authors/editors please update documents in progress. 
Send any agenda requests to Dieter and I, and we will update the agenda accordingly. 

Regards,
Karen and Dieter

Karen ODonoghue is inviting you to a scheduled Zoom meeting.

Topic: NTP WG meeting
Time: Sep 17, 2020 03:30 PM GMT

Join Zoom Meeting
https://isoc.zoom.us/j/98075462723?pwd=SFRYTk84ZjRUMFZmb0FEUXQ1SjdFZz09

Meeting ID: 980 7546 2723
Passcode: 518939
One tap mobile
+13126266799,,98075462723# US (Chicago)
+16465588656,,98075462723# US (New York)

Dial by your location
        +1 312 626 6799 US (Chicago)
        +1 646 558 8656 US (New York)
        +1 301 715 8592 US (Germantown)
        +1 346 248 7799 US (Houston)
        +1 669 900 6833 US (San Jose)
        +1 253 215 8782 US (Tacoma)
Meeting ID: 980 7546 2723
Find your local number: https://isoc.zoom.us/u/adJCnuTstr

---

From: Hal Murray <[email-masked]>
Date: Fri, 28 Aug 2020 15:36:05 -0700

> 7.  Any updates on NTP v5 requirements and next steps

Crazy thought dept...  Can we combine those?  Can we quickly come up with a 
packet format for v5 that has few enough changes so we can implement it 
quickly and also has room/hooks for everything we want to do tomorrow?

--------

> 6.  Any updates on NTS Development, Measurement and Testing

I think we are beyond testing-- mostly waiting for the RFC to come out so we 
have a flag to wave.

What sort of measurements would be helpful?  I have a couple of servers in the 
pool.

The biggest surprise to me was the amount of crap the NTS-KE server gets on 
port 123.  I assume it's bad guys probing.  See the bottom 2 lines below.

uptime:                 165729

NTS client sends:            36399
NTS client recvs good:       35948
NTS client recvs w error:    0
NTS server recvs good:       36938
NTS server recvs w error:    11595
NTS server sends:            36938
NTS make cookies:            127470
NTS decode cookies:          47970
NTS decode cookies old:      554
NTS decode cookies too old:  0
NTS decode cookies error:    0
NTS KE probes good:          28
NTS KE probes_bad:           5
NTS KE serves good:          9984
NTS KE serves_bad:           13374

-- 
These are my opinions.  I hate spam.

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 31 Aug 2020 08:45:42 +0200

>>> Karen O'Donoghue <[email-masked]> schrieb am 28.08.2020 um 19:42 in
Nachricht <[email-masked]>:

...
> 4. Call for Adoption results/discussion on
draft‑mlichvar‑ntp‑alternative‑port
...

I wonder: If adopted, how would it be implemented most likely? When done at
network/transport level at some gateway:
If incoming traffic to TDB is redirected to port 123 _if_ it's not mode 6 or
mode 7, then the filtering could be done right on port 123. Likewise for
outgoung traffic.

Is this RFC basically for:

Inability of firewall firmware to do proper filtereing?
Inability of network administrators to apply the correct filters ("Don't
panic", but they still do)?

Seeing that firewalls try deep packet inspection, I wonder whether the RFC is
needed, specifically: How long will it take to have a significant effect? If
you assume port 123 is blacklisted on some sites, it may be effective when all
the NTP software had been updates, but when allowable ports are whitelisted,
then the lack of port 123 being allowed doesn't help for the alternate port...

Regards,
Ulrich