Subject: Re: [Ntp] [Technical Errata Reported] RFC5905 (6550)

From: Erik Kline <[email-masked]>
Date: Sun, 18 Apr 2021 21:26:23 -0700

All,

Any objection to me marking this as "verified" (or, since it's in appendix
code, an argument for "held for document update" might be made, I suppose).

Thanks,
-ek

On Sat, Apr 17, 2021 at 4:39 AM RFC Errata System <[email-masked]>
wrote:

> The following errata report has been submitted for RFC5905,
> "Network Time Protocol Version 4: Protocol and Algorithms Specification".
>
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6550
>
> --------------------------------------
> Type: Technical
> Reported by: Perry Lorier <[email-masked]>
>
> Section: A.5.2
>
> Original Text
> -------------
>         for (i = 0; i < NSTAGE; i++) {
>                 p->disp += f[i].disp / (2 ^ (i + 1));
>                 p->jitter += SQUARE(f[i].offset - f[0].offset);
>         }
>
> Corrected Text
> --------------
>         for (i = 0; i < NSTAGE; i++) {
>                 p->disp += f[i].disp / (1 << (i + 1));
>                 p->jitter += SQUARE(f[i].offset - f[0].offset);
>         }
>
> Notes
> -----
> ^ is the xor operator in C, not the exponent operator.  2 xor (i+1) will
> be zero when i == 1, causing a division by zero error.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC5905 (draft-ietf-ntp-ntpv4-proto-13)
> --------------------------------------
> Title               : Network Time Protocol Version 4: Protocol and
> Algorithms Specification
> Publication Date    : June 2010
> Author(s)           : D. Mills, J. Martin, Ed., J. Burbank, W. Kasch
> Category            : PROPOSED STANDARD
> Source              : Network Time Protocol
> Area                : Internet
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Harlan Stenn <[email-masked]>
Date: Sun, 18 Apr 2021 21:39:05 -0700

FWIW, no objection here.

On 4/18/2021 9:26 PM, Erik Kline wrote:
> All,
> 
> Any objection to me marking this as "verified" (or, since it's in
> appendix code, an argument for "held for document update" might be made,
> I suppose).
> 
> Thanks,
> -ek
> 
> On Sat, Apr 17, 2021 at 4:39 AM RFC Errata System
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Reported by: Perry Lorier <[email-masked] <mailto:[email-masked]>>
> 
>     Section: A.5.2
> 
>     Original Text
>     -------------
>     ^ is the xor operator in C, not the exponent operator.  2 xor (i+1)
>     will be zero when i == 1, causing a division by zero error.
> 
>     Instructions:
>     -------------
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
> 

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!