Subject: [Ntp] Antw: [EXT] I‑D Action: draft‑ietf‑ntp‑update‑registries‑00.txt

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 02 Aug 2021 07:53:36 +0200

Hi!

IMHO the title should absolutely contain the word "NTP" or "Network Time
Protocol".

Regards,
Ulrich Windl

>>> <[email-masked]> schrieb am 30.07.2021 um 17:52 in Nachricht
<[email-masked]>:

> A New Internet‑Draft is available from the on‑line Internet‑Drafts
directories.
> This draft is a work item of the Network Time Protocol WG of the IETF.
> 
>         Title           : The update registries draft
>         Author          : Rich Salz
> 	Filename        : draft‑ietf‑ntp‑update‑registries‑00.txt
> 	Pages           : 11
> 	Date            : 2021‑07‑30
> 
> Abstract:
>    The Network Time Protocol (NTP) and Network Time Security (NTS)
>    documents define a number of assigned number registries, collectively
>    called the NTP registries.  Some registries have wrong values, some
>    registries do not follow current common practice, and some are just
>    right.  For the sake of completeness, this document reviews all NTP
>    and NTS registries.
> 
> Discussion Venues
> 
>    This note is to be removed before publishing as an RFC.
> 
>    Source for this draft and an issue tracker can be found at
>    https://github.com/richsalz/draft‑rsalz‑update‑registries.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft‑ietf‑ntp‑update‑registries/ 
> 
> There is also an HTML version available at:
> https://www.ietf.org/archive/id/draft‑ietf‑ntp‑update‑registries‑00.html 
> 
> 
> Internet‑Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet‑drafts/ 
> 
> 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 2 Aug 2021 15:29:09 +0000

Protocol".

Excellent point.  Does this seem okay?
-title: The update registries draft
+title: Updating the NTP Registries

---

From: "Ulrich Windl" <[email-masked]>
Date: Tue, 03 Aug 2021 10:07:46 +0200

>>> "Salz, Rich" <rsalz=[email-masked]> schrieb am 02.08.2021 um
17:29
in Nachricht <[email-masked]>:
> ‑title: The update registries draft

Yes, much better ;-)

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 3 Aug 2021 13:07:57 +0000

>    Yes, much better ;-)

Push to the github repo, but I didn't bother posting a new draft.  Once we resolve the standard/reserved stuff in the registry tables we can call this done, I think.

---

From: Miroslav Lichvar <[email-masked]>
Date: Tue, 3 Aug 2021 16:03:29 +0200

On Fri, Jul 30, 2021 at 04:19:18PM +0000, Salz, Rich wrote:
> I think the 1023 stuff is reminiscent of "reserved ports" from BSD.  But I do not care very much, and if the WG agrees then I will remove that change. My reasons were that after a couple of years as one of the TLS experts, everything as "spec required" seems okay, we have a large number space, IETF review is a very high burden, and there's nothing special about those low numbers except vanity. :)

I don't have an opinion either way. Both is fine with me.

Overall, the document looks good to me. I just noticed few typos in
the acknowledgements. RedHat should be Red Hat, Harlen should be
Harlan. The popcorn seems out of place.

Thanks,

-- 
Miroslav Lichvar

---

From: Daniel Franke <[email-masked]>
Date: Thu, 5 Aug 2021 09:51:45 -0400

I agree there's no technical reason for the distinction, but there's a
good social reason beyond just vanity. The split communicates useful
information. Whenever I'm trying to get an overview of the "world" of
an IETF protocol and its historical development, the IANA registries
are always my first stop. The split into low-numbered codepoints that
require IETF consensus and high-numbered ones that don't leads to a
good chronological presentation of how the IETF has evolved the
protocol over time, separated from and followed by a catalog of
third-party work which may or may not be important, of good quality,
or relevant outside a single organization.

On Fri, Jul 30, 2021 at 12:19 PM Salz, Rich
<rsalz=[email-masked]> wrote:
>         Filename        : draft-ietf-ntp-update-registries-00.txt
>         Pages           : 11
>         Date            : 2021-07-30
>     https://datatracker.ietf.org/doc/draft-ietf-ntp-update-registries/
>
> In this draft I removed the distinctions that are currently in the NTS registries.  For example,
> Range   Registration Procedures
>         0-1023  IETF Review
>         1024-16383      Specification Required
>         16384-32767     Private or Experimental Use
>
> I am curious what the WG thinks, and nudge Daniel to post.
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Aug 2021 14:40:21 +0000

I see Daniel's point, although I don't hold it as strongly, but I think it was wrong for a "cleanup" document to make the changes I did.

I will revert them and publish a new draft.