Subject: Re: [nvo3] Paris IETF

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Tue, 6 Mar 2012 11:30:32 +0100

Hi Thomas,

I'd like to request a slot to present the following NVO3 framework draft:

http://www.ietf.org/id/draft-lasserre-nvo3-framework-00.txt

Thanks,
Marc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Friday, February 17, 2012 3:43 PM
To: [email-masked]
Subject: [nvo3] Paris IETF

Hi.

I requested a meeting slot for the Paris meeting to followup on the
NVO3 session we had in the L2VPN WG in Taipei.

A second problem statement document
(draft-kreeger-nvo3-overlay-cp-00.txt) focussed on "Network
Virtualization Overlay Control Protocol Requirements" has also been
out for a couple of weeks now. Have folk had a chance to look at it?
Any comments?

If anyone else is considering putting together a document, please let
me (or the list) know.

Finally, I have put together a strawman WG charter for this effort
which I'll post separately.

Thomas

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Balus, Florin Stelian (Florin)" <[email-masked]>
Date: Mon, 12 Mar 2012 14:15:18 -0500

Hi Thomas,

We just submitted version 01 for draft-lasserre-nvo3-framework. Please use http://www.ietf.org/id/draft-lasserre-nvo3-framework-01.txt for the agenda so that people read this version.
We received quite a bit of comments so there are significant updates that improved in our opinion readability and content. 

Florin

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> LASSERRE, MARC (MARC)
> Sent: Tuesday, March 06, 2012 2:31 AM
> To: Thomas Narten; [email-masked]
> Subject: Re: [nvo3] Paris IETF
> 
> Hi Thomas,
> 
> Virtualization Overlay Control Protocol Requirements" has also been out
> for a couple of weeks now. Have folk had a chance to look at it?
> Any comments?
>

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 23 Mar 2012 10:02:01 +0000

Hi Florin,

I have two comments on this draft for your consideration:

1) in section 4.2.3, the application scenarios for ingress replication mode and core multicast tree mode are well mentioned. In the end, it said "A possible trade-off is to use shared multicast trees in the core as opposed to dedicated multicast trees." IMHO, an ideal precondition of this shared-tree usage is that multiple tenants using a shared multicast tree have the same or similar distribution of VMs, which, however, is hard to always assure especially in the case where operations of addition, deletion and migration of VMs may be very frequent in the cloud environment. Hence, it would be better if the overlay solution could support both the ingress replication procedure and the multicast tree procedure so as to allow for tradeoffs between bandwidth usage and state maintenance on a per tenant basis according to the particular conditions of each tenant.

2) in section 4.5.2, multicast support is listed as a criteria to consider when deciding where the NVE processing boundary happens. In addition, "routing protocol" and "packet replication capability" are listed as two sub-items of this criteria. It is no doubt that the server-based overly will more heavily rely on the multicast capability in the core network compared to the network-based overly because the former means more overlay edge nodes that may need to receive multicast/broadcast/unknown unicast traffic. Hence, I suggest adding "multicast group capacity in the core" as an additional sub-item of this criteria. For example, If the multicast group capacity in the core is large enough, it's OK to put the boundary on servers. Otherwise, it'd better not to do that if possible.

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Balus,
> Florin Stelian (Florin)
> 发送时间: 2012年3月13日 3:15
> 收件人: Thomas Narten; [email-masked]
> 抄送: LASSERRE, MARC (MARC)
> 主题: Re: [nvo3] Paris IETF and a new version of draft-lasserre-nvo3-framework
> 
> Hi Thomas,
> 
> We just submitted version 01 for draft-lasserre-nvo3-framework. Please use
> http://www.ietf.org/id/draft-lasserre-nvo3-framework-01.txt for the agenda so
> that people read this version.
> We received quite a bit of comments so there are significant updates that
> improved in our opinion readability and content.
> 
> Florin
> 
> > Thomas Narten

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Fri, 23 Mar 2012 13:46:19 +0100

Hi Xiaohu,

Thanks for your feedback. See my comments below.

Marc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Friday, March 23, 2012 11:02 AM
To: Balus, Florin Stelian (Florin); Thomas Narten; [email-masked]
Cc: LASSERRE, MARC (MARC)
Subject: Re: [nvo3] Paris IETF and a new version of draft-lasserre-nvo3-framework

Hi Florin,

[ML] Agreed, the draft does mention that both options are applicable. It is up to specific solutions drafts to address such details.

[ML] Server-based overlay might end up requiring too much (S,G) to manage, as opposed to network-based overlay. In fact, some large DCs do not enable multicast for server-based overlays for this reason.

Best regards,
Xiaohu