Subject: [nvo3] Question on Scope

From: James Kempf <[email-masked]>
Date: Fri, 13 Jul 2012 18:50:59 -0400

Hi,

Sorry, I've just started tuning in to this list.

I've been looking through the drafts and it seems they mostly are focusing on the case where the top of rack switch is the endpoint for the virtual network (see for example draft-kompella or draft-gu). As draft-gu points out, that is because the alternative - where the endpoint is on the server - doesn't require a protocol.

But isn't this already addressed by the IEEE 802.1qbg and 802.1qbh WGs? Is there something at Layer 3 that needs to be done that these protocols don't address? 

			jak

---

From: "Pat Thaler" <[email-masked]>
Date: Sat, 14 Jul 2012 01:10:34 +0000

James,

There are issues that are independent of where the virtual network end point is. See the NVGRE and VXLAN IDs for some examples. Items such as how the mapping tables for internal to encapsulation addresses are populated and maintained. Learning will do for smaller instances but there are concerns about scaling. There is end to end work that needs to be done in addition to the end node to switch/router problem.

This is perhaps a harder problem so there aren't as many drafts on it yet. 

I don't see overlap between NVO and IEEE Std 802.1BR (the work that started out as 802.1Qbh is in this standard). 

IEEE Std 802.1Qbg specifies the VDP protocol which may be useful for the switch (or router) virtual network end point case. We  have discussed that some information beyond that currently specified for the VDP TLVs may be needed. E.g. IP addresses instead of or in addition to MAC addresses. So it is possible that the final conclusion could be to ask 802.1 to extend the information in those TLVs. The extra information that we have discussed so far would be appropriate for the filter info field and there is a format selection byte for that field with 4 formats currently defined in the standard so it's an area that would be relatively easy to extend. There are also other proposals and we aren't close to the point of deciding on solutions. 

The Working Group is still evaluating the problem space and understanding the gaps.

Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James Kempf
Sent: Friday, July 13, 2012 3:51 PM
To: [email-masked]
Subject: [nvo3] Question on Scope

Hi,

			jak
_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3