Subject: [nvo3] (no subject)

From: James Kempf <[email-masked]>
Date: Tue, 24 Jul 2012 16:43:32 -0400

I had a question on something in draft-kompella:

>In some cases, the lNVE is co-resident with the server
>   hosting the VM; in other cases, the lNVE is separate (distributed
>   lNVE).  The latter case is the one of interest in this document.

Is there any product/prototype currently under development which anyone is aware of where there is an L3 (not L2) lNVE that falls into the latter case?

		jak

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 24 Jul 2012 14:09:10 -0700

Hi James,

On Tue, Jul 24, 2012 at 1:43 PM, James Kempf <[email-masked]>wrote:

> Is there any product/prototype currently under development which anyone is
> aware of where there is an L3 (not L2) lNVE that falls into the latter case?
>

Anyone's boxes that do IP VPNs (RFC 4364) could in principle be used as an
L3 lNVE.  However, they vary in their ability to comply with other
requirements of the data center environment.

If you view E-VPNs as L3-ish, that adds to the list.

Kireeti.

>                 jak
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

-- 
Kireeti

---

From: James Kempf <[email-masked]>
Date: Tue, 24 Jul 2012 17:21:41 -0400

Hi Kireeti,

I don't think you've answered my question. My question was whether there is any product or prototype currently that has a distributed lNVE.

If I ask the same question about a localized lNVE, I get the following:

OVS/Nicira (um, I mean VMWare :-) NVP
Cisco Nexus 1000V and VMWare ESX
VMWare ESX Server Virtual Switch
VSphere Distributed Virtual Switch (the control plane is distributed, not the NVE termination point).

I'd like to see the same list of products or prototypes for a distributed lNVE.

        jak

________________________________
From: Kireeti Kompella [mailto:[email-masked]]
Sent: Tuesday, July 24, 2012 2:09 PM
To: James Kempf
Cc: [email-masked]
Subject: Re: [nvo3] (no subject)

Hi James,

On Tue, Jul 24, 2012 at 1:43 PM, James Kempf <[email-masked]<mailto:[email-masked]>> wrote:

Anyone's boxes that do IP VPNs (RFC 4364) could in principle be used as an L3 lNVE.  However, they vary in their ability to comply with other requirements of the data center environment.

Kireeti.

                jak
_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

--
Kireeti

---

From: James Kempf <[email-masked]>
Date: Tue, 24 Jul 2012 17:25:27 -0400

Sorry, for VSphere, I meant that the control plane is centralized, but the NVE termination points are localized on the server.

        jak

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of James Kempf
Sent: Tuesday, July 24, 2012 2:22 PM
To: Kireeti Kompella
Cc: [email-masked]
Subject: Re: [nvo3] (no subject)

Hi Kireeti,

        jak

Hi James,

Kireeti.

                jak

--
Kireeti

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Jul 2012 00:06:01 +0200

Hi James,

I think actually Kireeti has precisely answered your question. L3VPN 
model addresses very well the L3 virtualization requirement IMHO.

Of course I do agree with those who say that PE should reside on the 
hypervisor rather then TOR. So rather then asking for yet another 
proprietary virtualization protocol you could consider perhaps using a 
solution which is standards based yet allow flexible creation of virtual 
topologies for the tenant interconnects (both intra and inter data center).

Best regards,
R.

> Hi Kireeti,
> I don't think you've answered my question. My question was whether there
> is any product or prototype currently that has a distributed lNVE.
>     ------------------------------------------------------------------------
>     *From:* Kireeti Kompella [mailto:[email-masked]]
>     *Sent:* Tuesday, July 24, 2012 2:09 PM
>     *To:* James Kempf
>     *Cc:* [email-masked]
>     *Subject:* Re: [nvo3] (no subject)
>
>     Hi James,
>
>     On Tue, Jul 24, 2012 at 1:43 PM, James Kempf
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Is there any product/prototype currently under development which
>         anyone is aware of where there is an L3 (not L2) lNVE that falls
>         into the latter case?
>
>
>     Anyone's boxes that do IP VPNs (RFC 4364) could in principle be used
>     as an L3 lNVE.  However, they vary in their ability to comply with
>     other requirements of the data center environment.
>
>         [email-masked] <mailto:[email-masked]>

---

From: James Kempf <[email-masked]>
Date: Tue, 24 Jul 2012 18:17:26 -0400

Hi Robert,

Hmm, perhaps I still wasn't clear enough.

I want to know *who* is going to use a protocol between the server an an L3 d-lNVE? Who has got product/prototype that needs such a protocol, standardized or not? You don't need to be explicit if you are concerned about revealing future product plans, just a coy raising of a hand. 

I don't see anyone in cloud space right now who has any such product/prototype/concept for upcoming implementation with an L3 d-lNVE. Now, that doesn't mean that there isn't someone, but there are multiple NVO3 drafts out there based on this concept, and I assume that someone must have something cooking to devote so much text writing and email time to discussing it.

If not, then I think the WG would be better to spend its time on discussing protocols for architectures that are deployed or have some hope of deployment.

		jak

> -----Original Message-----
> From: Robert Raszuk [mailto:[email-masked]] 
> Sent: Tuesday, July 24, 2012 3:06 PM
> To: James Kempf
> Cc: Kireeti Kompella; [email-masked]
> I think actually Kireeti has precisely answered your 
> question. L3VPN model addresses very well the L3 
> virtualization requirement IMHO.
> 
> Of course I do agree with those who say that PE should reside 
> on the hypervisor rather then TOR. So rather then asking for 
> yet another proprietary virtualization protocol you could 
> consider perhaps using a solution which is standards based 
> yet allow flexible creation of virtual topologies for the 
> tenant interconnects (both intra and inter data center).
> 
> Best regards,
> R.
> 
> > Hi Kireeti,
> > I don't think you've answered my question. My question was whether 
> > there is any product or prototype currently that has a 
> distributed lNVE.
> > VSphere Distributed Virtual Switch (the control plane is 
> distributed, 
> > not the NVE termination point).
>  >
> >     <[email-masked] 
> <mailto:[email-masked]>> wrote:
> >

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 25 Jul 2012 01:34:04 +0000

Hi Jak,

Actually we have developed that L3 NVE on our NE40E router products according to Virtual Subnet (http://tools.ietf.org/html/draft-xu-virtual-subnet-08) and we are still improving it based on the experiment results. At present, we use ARP to notify the VM attachment event so that the L3VPN PE upon receiving that gratuitous ARP packet from the moved VM could update the corresponding host route in the associated VRF and advertise that host route to remote PE routers accordingly. 

If you need more detailed information on that, please feel free to contact me.

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 James
> Kempf
> 发送时间: 2012年7月25日 6:17
> 收件人: [email-masked]
> 抄送: Kireeti Kompella; [email-masked]
> 主题: Re: [nvo3] (no subject)
> 
> Hi Robert,
> 
> I want to know *who* is going to use a protocol between the server an an L3
> d-lNVE? Who has got product/prototype that needs such a protocol,
> standardized or not? You don't need to be explicit if you are concerned about
> revealing future product plans, just a coy raising of a hand.
> 
> I don't see anyone in cloud space right now who has any such
> product/prototype/concept for upcoming implementation with an L3 d-lNVE.
> Now, that doesn't mean that there isn't someone, but there are multiple NVO3
> drafts out there based on this concept, and I assume that someone must have
> something cooking to devote so much text writing and email time to discussing
> it.
> 
> If not, then I think the WG would be better to spend its time on discussing
> protocols for architectures that are deployed or have some hope of
> deployment.
> 
> 		jak
>

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Wed, 25 Jul 2012 02:08:39 +0000

Hi Jak,
An NVE that is built as part of a device supporting IEEE Std 802.1BR Port Extension could potentially be an example of the use of a protocol between the server hypervisor and an distributed NVE. IMHO, both hypervisor and TOR based solutions are valid and important solutions that must be supported.
Regards,
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Tuesday, July 24, 2012 6:34 PM
To: James Kempf; [email-masked]
Cc: Kireeti Kompella; [email-masked]
Subject: Re: [nvo3] (no subject)

Hi Jak,

Best regards,
Xiaohu

> I want to know *who* is going to use a protocol between the server an 
> an L3 d-lNVE? Who has got product/prototype that needs such a 
> protocol, standardized or not? You don't need to be explicit if you 
> are concerned about revealing future product plans, just a coy raising of a hand.
> 
> Now, that doesn't mean that there isn't someone, but there are 
> multiple NVO3 drafts out there based on this concept, and I assume 
> that someone must have something cooking to devote so much text 
> writing and email time to discussing it.
> 
> If not, then I think the WG would be better to spend its time on 
> discussing protocols for architectures that are deployed or have some 
> hope of deployment.
> 
> 		jak
> 
> > proprietary virtualization protocol you could consider perhaps using 
> > a solution which is standards based yet allow flexible creation of 
> > virtual topologies for the tenant interconnects (both intra and 
> > inter data center).
> >
> > Best regards,
> > R.
> >
> > > Hi Kireeti,
> > > OVS/Nicira (um, I mean VMWare :-) NVP Cisco Nexus 1000V and VMWare 
> > > ESX VMWare ESX Server Virtual Switch VSphere Distributed Virtual 
> > > Switch (the control plane is
> > distributed,

---

From: James Kempf <[email-masked]>
Date: Wed, 25 Jul 2012 12:44:04 -0400

Ok, thanx. Seems like there are some realistic use cases.

		jak 

> From: Xuxiaohu [mailto:[email-masked]] 
> Subject: re: [nvo3] (no subject)
> 
> Hi Jak,
> 
> Actually we have developed that L3 NVE on our NE40E router 
> products according to Virtual Subnet 
> (http://tools.ietf.org/html/draft-xu-virtual-subnet-08) and 
> we are still improving it based on the experiment results. At 
> present, we use ARP to notify the VM attachment event so that 
> the L3VPN PE upon receiving that gratuitous ARP packet from 
> the moved VM could update the corresponding host route in the 
> associated VRF and advertise that host route to remote PE 
> routers accordingly. 
> 
> question. L3VPN 
> > > >          >   hosting the VM; in other cases, the lNVE 
> is separate
> > > >         (distributed
> > > >          >   lNVE).  The latter case is the one of 
> interest in this
> > > >         document.
> > > >

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 31 Jul 2012 17:22:25 +0000

Why is there an "end station", an "end system" and an "end device" ?

In the MEF "VNID" means "Virtual Network Interface Demarcation" - can a different term be used here ?

Y(J)S