Subject: [nvo3] You presentation on VM mobility...

From: David Allan I <[email-masked]>
Date: Tue, 31 Jul 2012 13:45:09 -0400

HI Linda:

You said that even with a 24 bit tag in the core, VM mobility would make it difficult to genuinely achieve more than 4K VLANs....

I have to admit that flies in the face of my understanding of both tagging and scaling. Could you clarify WHY you believe this to be true?

Much thanks
Dave

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 31 Jul 2012 18:15:36 +0000

David,

In the absence of VM mobility, it is easier for Overlay network to make the 12-bits VID locally significant by using core's 24 bits ID (VNID) to provide >4K's isolation.

When applications (e.g. firewall) sit on multiple subnets,  those VMs Guest OSs do send VID encoded data frames. When those VMs move, the same VID used by the VMs will appear in different NVEs, making those 12-bits VID globally significant.

Linda

From: David Allan I [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 12:45 PM
To: Linda Dunbar
Cc: [email-masked]
Subject: You presentation on VM mobility...

HI Linda:

Much thanks
Dave

---

From: David Allan I <[email-masked]>
Date: Tue, 31 Jul 2012 16:02:48 -0400

HI Linda:

Collisions in unmodified VM administered tags IMO cannot be avoided which if left along would result in the problem you describe. But that is what S-tags are for. Network administered tag value inferred from customer tag information. When mapping into a larger network (e..g S-tag->I-SID), the S-tag can still retain local significance.  Hence the only limitaton is if there is a requirement for more than 4094 VLANs at a local attachment point to the larger network. The network itself can scale to the full 2**24 tags.

cheers
Dave

________________________________
From: Linda Dunbar [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 11:16 AM
To: David Allan I
Cc: [email-masked]
Subject: RE: You presentation on VM mobility...

David,

Linda

HI Linda:

Much thanks
Dave

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 31 Jul 2012 23:08:28 +0000

David,

If there is an entity between VMs and NVE to add the S-tag, then the problem is solved. When such entity is available, VID swapping can also be used to solve the problem. So  S-tag is not the only solution.

My purpose of stating those subtle issues is to make NVo3 aware of the need to either "swap" the VID from VMs or "add" another tag when VMs send VID encoded data frames.

Linda

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Tuesday, July 31, 2012 3:03 PM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] You presentation on VM mobility...

HI Linda:

cheers
Dave

Linda

HI Linda:

Much thanks
Dave

---

From: David Allan I <[email-masked]>
Date: Tue, 31 Jul 2012 19:16:47 -0400

OK, prehaps rephrasing this would help, as that certainly did not come across the way it was presented.

thanks
Dave

________________________________
From: Linda Dunbar [mailto:[email-masked]]
Sent: Tuesday, July 31, 2012 4:08 PM
To: David Allan I
Cc: [email-masked]
Subject: RE: You presentation on VM mobility...

David,

Linda

HI Linda:

cheers
Dave

Linda

HI Linda:

Much thanks
Dave