Subject: [nvo3] Security framework

From: Melinda Shore <[email-masked]>
Date: Tue, 31 Jul 2012 10:26:16 -0800

As I mentioned earlier I am not particularly a fan of getting
a security framework out in front of a protocol framework.  While
security needs to be designed in from the outset, it also needs
to be closely coupled to the actual mechanisms being used.

I'm also concerned about the whole "trusted network" thing.  I
think that if you're going to continue to hang onto it (and I'd
really rather that you did not), you should probably explain in the
document that one of your starting assumptions is that there
are no insider threats.

Melinda

---

From: Randy Bush <[email-masked]>
Date: Tue, 31 Jul 2012 13:37:12 -0700

> I'm also concerned about the whole "trusted network" thing.  I think
> that if you're going to continue to hang onto it (and I'd really
> rather that you did not), you should probably explain in the document
> that one of your starting assumptions is that there are no insider
> threats.

isn't that in the mandatory santa claus section?  </sarcasm>

i have been amazed that, in 2012, i am seeing one document after another
document, in many wgs, which makes naive assumptions about security or
ignore the issue entirely.  if microsoft can absorb the basic security
lesson, surely the ietf can.

randy

---

From: joel jaeggli <[email-masked]>
Date: Tue, 31 Jul 2012 13:53:02 -0700

> document that one of your starting assumptions is that there

I'm reasonably certain that assuming the underlying network is trusted 
doesn't meet the segmentation requirements of  a number of datacenter 
applications in either single or multi-tennant deployments.
> Melinda
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

---

From: Benson Schliesser <[email-masked]>
Date: Tue, 31 Jul 2012 14:00:36 -0700

> applications in either single or multi-tennant deployments.

Agreed. But perhaps it might be useful to compare / contrast with 
existing datacenter networks. For example, how do people think about 
trust in 802.1q networks or MPLS networks or etc, and how does the NVO3 
context differ?

Cheers,
-Benson

---

From: [email-masked]
Date: Wed, 1 Aug 2012 05:08:44 +0800

yinxing> In my view, we need to analyze the security threats and 
requirements systematically, and then identify defensive techniques. 
It will help the design of the protocol.

yinxing>Sometimes byzantine attack is possible. It may be more
acceptable to analyze possible attackes before making some assumptions.

------------
Yinxing Wei

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Tue, 31 Jul 2012 13:16:25 -0800

> requirements systematically, and then identify defensive techniques.

As I said, I don't know how it's possible to be systematic about
a thing that doesn't exist.  I understand that you're trying to
stick a stake in the ground but, well.

> acceptable to analyze possible attackes before making some assumptions.

Insider threats are not inherently "byzantine."  They are, however,
"common."

Melinda

---

From: [email-masked]
Date: Wed, 1 Aug 2012 05:22:17 +0800

Agreed. It is a good idea to do some comparisons

Benson Schliesser <[email-masked]> 
发件人:  [email-masked]
2012/08/01 05:00

收件人
joel jaeggli <[email-masked]>
抄送
Melinda Shore <[email-masked]>, [email-masked]
主题
Re: [nvo3] Security framework

Cheers,
-Benson