Subject: Re: [nvo3] Poll for WG adoption: draft-lasserre-nvo3-framework-03.txt

From: Doug Hanks <[email-masked]>
Date: Sun, 2 Sep 2012 21:17:47 -0700

support

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 4 Sep 2012 17:40:55 +0000

Marc, et al,

I have a few questions on the draft, hope you can clarify:

1.      What does it mean by NVE being embedded in an End Station (as quoted from the document)?

NVE could be implemented as part of a virtual switch
within a hypervisor, a physical switch or router, a Network Service
Appliance or even be embedded within an End Station.

Do you mean a Guest OS which send IP frame directly? If yes, why need extra layer of IP encapsulation?

2.      VN Context vs. VNID: do you mean that encapsulation header includes field for VN context in addition to VNID? Why need both fields?

3.      Definition to "Virtual Data Center or Virtual DC": when you say "Managed by a single tenant, Virtual DC can contain multiple VNs and multiple Tenant End System..", is the "single tenant" in the sentence one of the "multiple Tenant" in the sentence?

Could  it be more clear to remove the phrase "Managed by a single tenant"?

Other comments:

*        2.1 Generic Reference Model:

The Figure 3 depicts all the Tenant End Systems being directly connected to NV Edge, make the network looks like closed communication pattern.

When applications in DC communicate with peers somewhere else, the NVE function might be on gateway, which connects to remote peers via Internet or secure VPN. I suggest to have a dotted line behind one or two "NV Edge" to show that some Tenant End Systems are connected to NV Edge via another network (like Internet or secure IPSec or VPN).

When "VM-a" talk to remote peer "b" and  "b" is in another DC which doesn't have NVo3 encapsulation, Then the NVE for "b" is on the Gateway of DC where "VM-a" is hosted.  In this scenario the "b" doesn't connect to its NVE via Ethernet. So the statement on P11 "either directly or via a switched network (typically

Ethernet)" is not true all the time.

*        3.1.5.1  Auto-provisioning/service discovery:

Your description states that "NVEs being able to select appropriate VNI based on state information provided by external entities".

Then it is not really "auto-provisioning". It should be classified as  "static provisioning".

"A mechanism for communicating this information between Tenant End Systems and the local NVE" can be one way, other approaches should be possible too.

It is necessary to consider the scenario that  "Tenant End Systems" doesn't have any capability to communicate with NVE. Then external controller has to communicate with the NVE for any new ES being added/removed.

*        3.2 Service Overlay Topologies:

I am confused of this intent of this section. Your second paragraph states that mesh connection between NVEs.

Since it is Layer 3 that interconnect NVEs, we should not assume that NVEs are only one hop away from each other.

*        4.1 Pros & Cons:

Should add a point that Overlay push the burden to edge devices (i.e. NVEs). For NVEs on gateway routers in DC, managing the mapping between End stations and tunnels can be challenging.

Linda Dunbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, August 29, 2012 11:01 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-lasserre-nvo3-framework-03.txt

This email begins a poll to help gauge consensus to adopt draft-lasserre-nvo3-framework-03.txt as an NVO3 working group document.

Since this is the second call for adoption, and only a few changes were requested during the last call for adoption, we will be running this call for 10 days, only.

If you support adoption of draft-lasserre-nvo3-framework-03.txt, please reply to this thread with 'support'.

If you do not support adoption, please reply to this thread with 'do not support', and state your reasons.

This poll will close on Friday 7th September 2012.

Regards

Matthew & Benson

---

From: Selvam Ramanathan <[email-masked]>
Date: Wed, 5 Sep 2012 18:46:31 -0400

Support 

Regards , 
Selvam 

On Aug 29, 2012, at 9:01 AM, "Bocci, Matthew (Matthew)" <[email-masked]> wrote:

> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: Truman Boyes <[email-masked]>
Date: Thu, 6 Sep 2012 10:08:38 -0400

Support

On Wed, Aug 29, 2012 at 12:01 PM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

> This email begins a poll to help gauge consensus to
> adopt draft-lasserre-nvo3-framework-03.txt as an NVO3 working group
> document.
>
> Since this is the second call for adoption, and only a few changes were
> requested during the last call for adoption, we will be running this call
> for 10 days, only.
>

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 7 Sep 2012 18:38:55 +0000

Support.

From: <Bocci>, "Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 29, 2012 9:01 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] Poll for WG adoption: draft-lasserre-nvo3-framework-03.txt

Regards

Matthew & Benson

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Mon, 10 Sep 2012 12:08:02 +0200

This email closes the poll for WG adoption. There is clear consensus to adopt this draft.

Please could the editors upload a new version of the draft with the name draft-ietf-nvo3-framework-00.

I have not seen any other comments on the text in the draft, so please do not make any other changes to this version.

Regards

Matthew and Benson

On 07/09/2012 19:38, "Larry Kreeger (kreeger)" <[email-masked]<mailto:[email-masked]>> wrote:

Support.

Regards

Matthew & Benson

---

From: Lucy yong <[email-masked]>
Date: Mon, 10 Sep 2012 15:01:51 +0000

Hi Matthew and Benson,

I made some comments on 8/14 and Linda Dunbar also made some comments recently. We did not see any response on the comments yet.

We support this work to be adopted as WG draft and continue to work on the text.

Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Monday, September 10, 2012 5:08 AM
To: [email-masked]
Subject: Re: [nvo3] Poll for WG adoption: draft-lasserre-nvo3-framework-03.txt

Regards

Matthew and Benson

Support.

Regards

Matthew & Benson