Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane

From: "Yves Hertoghs (yhertogh)" <[email-masked]>
Date: Mon, 1 Oct 2012 13:01:12 +0000

Maria,

Are you referring to the fact that you can 'route' (i.e. swap mac-headers) both intra- and intersubnet traffic (via some proxy arp tricks and constrained L2 forwarding between host and NVE).

If yes then indeed we don't need IRB, but would only need to route IP (both intra and inter subnet) and bridge non-IP.  Subnet broadcasts and Link Local multicast within the subnet can be made to work at the IP level as well.  

Yves

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of NAPIERALA, MARIA H
Sent: Friday, September 28, 2012 23:17
To: John E Drake; Henderickx, Wim (Wim); Luyuan Fang (lufang); Bitar, Nabil N; Fedyk, Donald (Don); [email-masked]
Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane

In L3VPN there is only one type of forwarding and there is no distinction needed between intra- and inter-subnet traffic.

Maria

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of John E Drake
> Sent: Friday, September 28, 2012 5:06 PM
> To: NAPIERALA, MARIA H; John E Drake; Henderickx, Wim (Wim); Luyuan 
> Fang (lufang); Bitar, Nabil N; Fedyk, Donald (Don); [email-masked]
> Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane
> 
> Maria,
> 
> This is what you said in the email to which I initially responded:
> 
> " Since layer 3 can address both intra-subnet and inter-subnet IP 
> communication by a uniform forwarding (i.e., there is no difference in 
> forwarding between those two), the question is why to introduce a 
> complication of mixing L2 and L3 forwarding in the *same* solution."
> 
> Since the text you quote, below, clearly contradicts your text, above, 
> I would assert that you are arguing with yourself in public and that 
> you lost.
> 
> Yours irrespectively,
> 
> John
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > NAPIERALA, MARIA H
> > Sent: Friday, September 28, 2012 1:50 PM
> > To: John E Drake; Henderickx, Wim (Wim); Luyuan Fang (lufang); 
> > Bitar, Nabil N; Fedyk, Donald (Don); [email-masked]
> > Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane
> >
> > John,
> >
> > Let me quote from the document (section 5):
> >
> >   "MES(es) should be able to distinguish between intra-CUG/intra-
> subnet
> > and
> >    inter-CUG/inter-subnet traffic originated by that VM (in order to
> >    apply MAC-based forwarding to the former and IP-based forwarding
> to
> >    the latter)."
> >
> > (section 6.1):
> >
> >   "When a MES imports an E-VPN route into a particular EVI, and this
> >    route is associated with a VM that is not part of the L2-based CUG
> >    associated with the E-VPN of that EVI, the MES creates IP
> forwarding
> >    state to forward traffic to the IP address present in the NLRI of 
> > the
> >    route towards the Next Hop, as specified in the route."
> >
> > Maria
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On
> Behalf
> > > Of John E Drake
> > > Sent: Friday, September 28, 2012 4:23 PM
> > > To: NAPIERALA, MARIA H; John E Drake; Henderickx, Wim (Wim); 
> > > Luyuan Fang (lufang); Bitar, Nabil N; Fedyk, Donald (Don); 
> > > [email-masked]
> > > Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane
> > >
> > > Maria,
> > >
> > > I had seen that email and I helped Yakov with the draft it
> > references.
> > >
> > > Because you think the section in question bolsters your argument, 
> > > I think it is painfully clear that you haven't read the section, 
> > > or
> the
> > > draft for that matter.
> > >
> > > Yours irrespectively,
> > >
> > > John
> > >
> > >
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]] On
> > Behalf
> > > Of
> > > > NAPIERALA, MARIA H
> > > > Sent: Friday, September 28, 2012 1:05 PM
> > > > To: John E Drake; Henderickx, Wim (Wim); Luyuan Fang (lufang); 
> > > > Bitar, Nabil N; Fedyk, Donald (Don); [email-masked]
> > > > Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane
> > > >
> > > > Let me refer you the following e-mail (attached) in case you
> missed
> > > it.
> > > >
> > > > Maria
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: John E Drake [mailto:[email-masked]]
> > > > > Sent: Friday, September 28, 2012 3:38 PM
> > > > > To: NAPIERALA, MARIA H; Henderickx, Wim (Wim); Luyuan Fang
> > > (lufang);
> > > > > Bitar, Nabil N; Fedyk, Donald (Don); [email-masked]
> > > > > Subject: RE: [nvo3] draft-drake-nvo3-evpn-control-plane
> > > > >
> > > > > Comment inline.
> > > > >
> > > > > Yours irrespectively,
> > > > >
> > > > > John
> > > > >
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: [email-masked] [mailto:[email-masked]] 
> > > > > > On
> > > > Behalf
> > > > > Of
> > > > > > NAPIERALA, MARIA H
> > > > > > Sent: Friday, September 28, 2012 9:54 AM
> > > > > > To: Henderickx, Wim (Wim); Luyuan Fang (lufang); Bitar, 
> > > > > > Nabil
> > N;
> > > > > Fedyk,
> > > > > > Donald (Don); [email-masked]
> > > > > > Subject: Re: [nvo3] draft-drake-nvo3-evpn-control-plane
> > > > > >
> > > > > > Since layer 3 can address both intra-subnet and inter-subnet
> IP
> > > > > > communication by a uniform forwarding (i.e., there is no
> > > difference
> > > > > in
> > > > > > forwarding between those two), the question is why to
> introduce
> > > > > > a complication of mixing L2 and L3 forwarding in the *same*
> > > solution.
> > > > >
> > > > > JD:  Maria, did you invent some new technology that you're not
> > > > telling
> > > > > anyone about?
> > > > >
> > >
> > >
> > > _______________________________________________
> > > nvo3 mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/nvo3
> > _______________________________________________
> > nvo3 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/nvo3
> 
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Tue, 2 Oct 2012 13:39:15 +0000

Yves,

> Maria,
> 
> Are you referring to the fact that you can 'route' (i.e. swap mac-
> headers) both intra- and intersubnet traffic (via some proxy arp tricks
> and constrained L2 forwarding between host and NVE).

Yes, NVE would implement proxy ARP for all the addresses on the subnet. 
> 
> If yes then indeed we don't need IRB, but would only need to route IP
> (both intra and inter subnet) and bridge non-IP.  Subnet broadcasts and
> Link Local multicast within the subnet can be made to work at the IP
> level as well.

Thanks for clarifying.

> To: John E Drake; Henderickx, Wim (Wim); Luyuan Fang (lufang); Bitar,
> Nabil N; Fedyk, Donald (Don); [email-masked]
> In L3VPN there is only one type of forwarding and there is no
> distinction needed between intra- and inter-subnet traffic.
> 
> Maria
>