Subject: Re: [nvo3] Consensus call and IPR check on draft-rekhter-nvo3-vm-mobility-issues-03.txt

From: Florin Balus <[email-masked]>
Date: Mon, 3 Dec 2012 10:49:32 -0800

I support adoption of the text, the draft is well written. ... and I am not
a co-author. :)

On Thu, Nov 29, 2012 at 9:52 AM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

> There have been a number of requests for the WG to adopt draft-rekhter-nvo3-vm-mobility-issues-03.txt
> as a working group draft. There has also been some discussion on the list
> and in Atlanta as to whether VM mobility requirements and problem statement
> issues should be addressed in a stand alone draft or as a part of the
> existing problem statement. There are also a number of other drafts
> addressing this issue, so if draft-rekhter is adopted as a stand alone
> working group document, then that will provide the base working group
> document into which any additional text would be added.
>
> In order to help the chairs determine how to progress on this issue,
> please can you indicate to the list:
>
>
>    - Do you support adoption of this draft as-is (yes/no)?
>    - If no, would you support adoption of this draft with changes, and if
>    so, what (e.g. more Layer 3 content)?
>    - If no, should all of the VM mobility problem statement be added to
>    the NVO3 problem statement draft?
>
>
> Coincidentally, we are also polling for knowledge of any IPR that applies
> to this draft, to ensure that IPR has been disclosed in compliance with
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
> If you are listed as a document author or contributor, please respond to
> this email whether or not you are aware of any relevant IPR. The draft
> will not be adopted until a response has been received from each author
> and contributor.
> If you are on the NVO3 WG email list but are not listed as an author or
> contributor, then please explicitly respond only if you are aware of any
> IPR that has not yet been disclosed in conformance with IETF rules.
>
> This call for consensus will close on Thursday 13th December 2012.
>
> Best regards
>
> Matthew and Benson
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>
>

---

From: <[email-masked]>
Date: Mon, 10 Dec 2012 16:47:07 +0000

I support adoption of draft-rekhter-nvo3-vm-mobility-issues.

-Thomas

2012-11-29, Bocci, Matthew (Matthew):
There have been a number of requests for the WG to adopt draft-rekhter-nvo3-vm-mobility-issues-03.txt as a working group draft. There has also been some discussion on the list and in Atlanta as to whether VM mobility requirements and problem statement issues should be addressed in a stand alone draft or as a part of the existing problem statement. There are also a number of other drafts addressing this issue, so if draft-rekhter is adopted as a stand alone working group document, then that will provide the base working group document into which any additional text would be added.

In order to help the chairs determine how to progress on this issue, please can you indicate to the list:

  *   Do you support adoption of this draft as-is (yes/no)?
  *   If no, would you support adoption of this draft with changes, and if so, what (e.g. more Layer 3 content)?
  *   If no, should all of the VM mobility problem statement be added to the NVO3 problem statement draft?

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
If you are listed as a document author or contributor, please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.
If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Best regards

Matthew and Benson

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Thomas Narten <[email-masked]>
Date: Mon, 10 Dec 2012 12:26:56 -0500

Chairs, WG:

I would like to better understand what the "end goal" is in asking for
WG adoption of vm-mobility. By adopting the document, there is a
strong presumption the WG will (eventually) send it to the IESG for
publication.

Strictly speaking, it is not at all obvious to me which charter item
deliverable vm-mobility applies to (it certainly isn't one of the 6
listed in the charter).  I think it takes a pretty broad reading of
the charter to say this document is "in scope". I have the concern
that such a reading implies that a whole lot of other "related"
documents will also then have to be taken on as WG documents. This
could easily lead to a plethora of documents.

Before adopting this (or other documents) I think the WG should get a
little more clear about what types of documents the WG will adopt
going forward and which it will not.  What is the criteria? Will we
take on anything the WG says we should adopt, regardless of what the
charter says, and regardless of overlap among drafts?

That said, I do think there is useful stuff in this document, but that
is also the case for other non-WG documents.  With regards to the
document itself, there are other documents that relate to the same
general topic, including (at least):

       draft-kompella-nvo3-server2nve-01.txt
       draft-gu-nvo3-tes-nve-mechanism-01.txt

Is the intention to merge the above into vm-mobility? Or to have yet
more documents that cover similar ground? And if the intention is to
merge them, wouldn't it be better to start with that upfront, before
adopting one document as a WG document? 

Generally speaking, I share Joel's concern that having more documents
is not necessary a good thing, especially when a lot of them end up
repeating some of the same material.

Thomas

---

From: John E Drake <[email-masked]>
Date: Mon, 10 Dec 2012 19:43:06 +0000

Thomas,

I thought Matthew's email was very clear.  What part of it did you not understand?

Perhaps it would be helpful to everyone for you to recast your comments in the form of a reply to Matthew's email.  What do you think? 

Irrespectively Yours,

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Thomas Narten
> Sent: Monday, December 10, 2012 9:27 AM
> To: Bocci, Matthew (Matthew)
> Cc: [email-masked]
> Subject: Re: [nvo3] Consensus call and IPR check on draft-rekhter-nvo3-
> vm-mobility-issues-03.txt
> 
> Chairs, WG:
> 
> WG adoption of vm-mobility. By adopting the document, there is a strong
> presumption the WG will (eventually) send it to the IESG for
> publication.
> 
> listed in the charter).  I think it takes a pretty broad reading of the
> charter to say this document is "in scope". I have the concern that
> such a reading implies that a whole lot of other "related"
> little more clear about what types of documents the WG will adopt going
> forward and which it will not.  What is the criteria? Will we take on
> anything the WG says we should adopt, regardless of what the charter
> says, and regardless of overlap among drafts?
>

---

From: Thomas Narten <[email-masked]>
Date: Mon, 10 Dec 2012 15:40:44 -0500

Hi John.

I read Matthew's note quite carefully. Nowhere does it assert that the
document is in-scope per the charter. Indeed, he carefully
side-steps that question and does not assert it is in scope.

By default, I'm opposed to accepting any document as a WG document
where:

1) It is not clear how it fits into the charter and broader goals of
the WG.

2) It is unclear how it relates to other existing documents with
overlapping material.

3) It is not clear what the intention and scope of the final document
is that the WG is developing with the intention of sending to the
IESG. I.e., the WG should first say "we need a document of type X that
covers X, Y, and Z". Given such an understanding, one can ask whether
a candidate document is a good starting point.  Adopting a document
first, and then figuring out what it needs to contain second is
backwards process.

BTW, this is my general view on WG documents. It is not NVO3 specific
and is not a reflection on the particular document under
discussion. We will likely need to have the same discussion about
other documents that folk are asking the WG to adopt.

Thomas

---

From: John E Drake <[email-masked]>
Date: Mon, 10 Dec 2012 22:07:31 +0000

Comments inline.

> Sent: Monday, December 10, 2012 12:41 PM
> To: John E Drake
> Cc: Bocci, Matthew (Matthew); [email-masked]
> document is in-scope per the charter. Indeed, he carefully side-steps
> that question and does not assert it is in scope.

JD:  A call for WG adoption does not typically include a statement from the WG chairs as to whether the subject draft is within the scope of the WG's charter.  It is up to the WG to decide this.
 
> 1) It is not clear how it fits into the charter and broader goals of

JD:  The draft describes the issues associated with VM Mobility.  This is clearly within the scope of the charter and addresses the fact that the existing problem statement draft is particularly weak on this topic. 

> 2) It is unclear how it relates to other existing documents with

JD:  Matthew's note was asking the WG's opinion on this question.
 
> is that the WG is developing with the intention of sending to the IESG.
> I.e., the WG should first say "we need a document of type X that covers
> X, Y, and Z". Given such an understanding, one can ask whether a
> candidate document is a good starting point.  Adopting a document

JD:  You are mischaracterizing Matthew's note, which is asking the WG's opinion as to whether the draft should be a standalone document or whether its material should be incorporated into another document.

> and is not a reflection on the particular document under discussion. We
> will likely need to have the same discussion about other documents that
> folk are asking the WG to adopt.
> 
> Thomas
>

---

From: Melinda Shore <[email-masked]>
Date: Mon, 10 Dec 2012 13:28:18 -0900

On 12/10/12 1:07 PM, John E Drake wrote:
> JD:  The draft describes the issues associated with VM Mobility.
> This is clearly within the scope of the charter and addresses the
> fact that the existing problem statement draft is particularly weak
> on this topic.

This is my sense, as well, and while it may not (and is not) be the
highest priority piece of work facing the working group right now,
it's still relevant.  I'd be fine with either folding text into
the existing problem statement draft or with keeping the document
separate for the time being, with a goal of eventually folding it
in.  I'm less thrilled about the possibility of publishing it as
a separate RFC (and here I agree with Thomas that it could be
confusing to the reader if we do that), and not sure at all what
it would mean to drop it entirely.

Melinda

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Wed, 19 Dec 2012 12:33:16 +0100

Following the recent Call for Adoption discussion, the chairs believe there is consensus to adopt draft-rekhter-nvo3-vm-mobility-issues-03.txt as a NVO3 working group document.

However, the chairs are concerned that there are other drafts that contain related text. We would like to see discussion on the list about whether this text should be included or abandoned. We do not intend to adopt multiple WG drafts on the same topic.

Please can the authors of draft-rekhter upload a new version of the document with the name changed to draft-ietf-nvo3-vm-mobility-issues-00.txt.

Please can participants review this draft, and comment on the list if you believe there is additional draft material that should be incorporated, providing an explicit pointer to that material. We would like to see discussion on this list so that we can see whether or not there is consensus to include it.

We then expect the editors of draft-ietf-nvo3-vm-mobility-issues-00.txt to reflect that consensus in a new version of the draft, as needed.

Best regards,

Matthew and Benson

On 29/11/2012 17:52, "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>> wrote:

Best regards

Matthew and Benson