Subject: Re: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 13 Dec 2012 12:05:06 +0100

This WG poll for adoption is now closed. There is consensus to adopt this draft as an NVO3 working group draft. Could the authors please upload a new version of the draft, with the name draft-ietf-nvo3-dataplane-requirements-00.

There was one set of comments from Lucy during the WG adoption poll. Please can the authors respond to these on the list and address any resulting changes in v01 of the draft.

Best regards

Matthew

On 28/11/2012 16:16, "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>> wrote:

This email begins a two week poll to help the chairs judge if there is consensus  to adopt draft-bl-nvo3-dataplane-requirements-03.txt as an NVO3 working group draft.

Please respond to this email on the list with 'support' or 'do not support'.

Please also send any comments on the draft to the NVO3 list.

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor, please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

This poll closes on Wednesday 12th December 2012.

Regards

Matthew and Benson

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Thu, 13 Dec 2012 14:32:50 +0100

Lucy,

Before posting the WG version, see my comments below.

Thanks,
Marc

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Thursday, November 29, 2012 12:55 AM
To: Bocci, Matthew (Matthew); [email-masked]
Cc: [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

I support the action, but have some comment and suggestions to this version.

*         There is no single word  about tenant system mobility. Suggest adding a section within section 3.9  to address tenant system mobility. For example,  it should point out that, although the data plane learning can be used to learn source MAC addresses as described in section 3.2.1, the mechanism may not meet the tenant system mobility requirements. In this case,  when a tenant system moves, some frames with the destination MAC as the tenant system are forwarded to the old associated NVE.  Other VM mobility and reachbility can be described as well.

Will do so in the next revision.

*         Suggest to add a sub-section in section 3.3.2 to describe tunneling encapsulation. One requirement is that all the NVEs that are the member of a VNI MUST support a  tunneling encapsulation.  One option requirement is that all the NVEs that are the member of a VNI MAY support more than one tunneling encapsulation. In this case, an ingress NVE MUST use the egress NVE supported encapsulation to encapsulate the frame/packets before sending to the remote NVE.

This section specified alrady that IP tunneling is a MUST and that MPLS is a MAY. It is not a requirement to support multiple simultaneous encapsulations. If it is the case, it is up to solutions draft to address how  this would be negociated.

*         Section 3.6 Hierarchical NVE.  The text is very weak and without any requirement on it. It is not clear which function that hub NVE need to perform and which spoke NVE need to perform. For example, should hub NVE perform the encapsulation or should spoke NVE do it?  Furthermore, the last sentence does not apply to here at all.  Suggest either removing the section or stating out clearly what are the requirements for Hierarchical NVE.

Will beef up this section in a next revision.

*         Section 3.2.1 states about using data plane learning and point out that multiple overlay tunnels may exist.  But it does not state out any requirement to load balance over multiple overlay tunnels. For example, if there are two overlay tunnels between two NVEs, one NVE learns MAC associated with one overlay tunnel, can the NVE use another overlay tunnel to send the fame with the MAC to remote NVE? Suggest adding related requirement in the section.

Section 3.4.2 deals extensively with load balancing.

*         Section 3.2.2 starts with "L3 VNIs" and Section 3.2.1 starts with "an L2 VNI". is this intentional to illustrate the difference  between L2 overlay and L3 overlay or a typo?

Each section describes L2 and L3 VNIs respectively. Not sure what you mean here...

*         Section 3.3, suggest use tenant payload. There is no definition of customer in this document.

*         In section 1.2, some team already defined in the framework document. Should not restate here.

I would like to see these to be addressed in next version.

Cheers,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Wednesday, November 28, 2012 10:16 AM
To: [email-masked]
Subject: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Regards

Matthew and Benson

---

From: Lucy yong <[email-masked]>
Date: Thu, 13 Dec 2012 17:24:58 +0000

Hi Matthew,

Congrats on the WG progress on this.  Besides my comment on the mailing list, we just upload a draft for the framework and data plane requirement additions.  http://datatracker.ietf.org/doc/draft-yong-nvo3-frwk-dpreq-addition

This draft suggests adding  1) a new NVE service type, i.e. L2-3 NVE, 2)  NVE functions for TS mobility. If we can get consensus on these additions, the new version should reflect these additions too.

Welcome the comment  and discussion on the mailing list regarding these additions

Thanks,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Thursday, December 13, 2012 5:05 AM
To: Bocci, Matthew (Matthew); [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Best regards

Matthew

Regards

Matthew and Benson

---

From: Lucy yong <[email-masked]>
Date: Thu, 13 Dec 2012 17:53:17 +0000

Marc,

Please see below.

From: LASSERRE, MARC (MARC) [mailto:[email-masked]]
Sent: Thursday, December 13, 2012 7:33 AM
To: Lucy yong; Bocci, Matthew (Matthew); [email-masked]
Cc: [email-masked]
Subject: RE: [nvo3] Poll for adoption and IPR check: draft-bl-nvo3-dataplane-requirements-03.txt

Lucy,

Thanks,
Marc

[Lucy] very good. Look forward to seeing the new version. BTW, hope some text in our new draft helps.

[Lucy] I mean the encapsulation semantics. You can have NVGRE, VLAN, GRE, etc,  they all use IP tunnel, but different encapsulation semantics.

[Lucy] look forward to seeing it.

[Lucy] section 3.4.2 describes about load balancing in underlying networks that have ECMP. Section 3.2.1 implies that the multiple overlay tunnels may exist, i.e. two overlay tunnels between two NVEs. Do we allow this? If yes, my statement above  is valid. If not, the text in doc. should be clear.

[Lucy] OK, it seems a typo.  suggest making the text consistent in the two section.  Use either an L2 VNI/L3VNI or L2VNIs/L3VNIs in two sections.

[Lucy] any though on this suggestion?

[Lucy] hope to address this in next version.

Regards,

Lucy

Cheers,
Lucy

Regards

Matthew and Benson