Subject: Re: [nvo3] Multi-subnet VNs - should be a new service type?

From: [email-masked]
Date: Fri, 28 Dec 2012 09:39:19 +0800

Does Lucy refer to the scenario that, if host_A requests MAC of host_B 
which resides in the same switched network, the default gateway should not 
reply such ARP request, otherwise host_A will receive ARP reply both from 
host_B and default gateway.

Lizhong

> 
> Re: [nvo3] Multi-subnet VNs - should be a new service type?
> 
> Certainly. But how it that an issue?
> -- 
> Jakob Heitz.
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> Lucy yong
> Sent: Thursday, December 27, 2012 3:20 PM
> To: Jakob Heitz; Black, David
> Cc: [email-masked]
> Subject: Re: [nvo3] Multi-subnet VNs - should be a new service type?

> A host may get an arp request via the switched network and reply 
> with its MAC address if IP address matches.
> This is current host be behavior.
> Lucy
> 
> From: Jakob Heitz [mailto:[email-masked]] 
> Sent: Thursday, December 27, 2012 5:18 PM
> To: Lucy yong; Black, David
> Cc: [email-masked]
> Subject: RE: Multi-subnet VNs - should be a new service type?
> 
> Multicast traffic is not at issue.
> You said:
> This will have an issue if VAP of EVPN are via a switched network
> What is the issue?
> -- 
> Jakob Heitz
> 
> 
> 
> From: Lucy yong [mailto:[email-masked]] 
> Sent: Thursday, December 27, 2012 3:04 PM
> To: Jakob Heitz; Black, David
> Cc: [email-masked]
> Subject: RE: Multi-subnet VNs - should be a new service type?
> 
> 
> From: Jakob Heitz [mailto:[email-masked]] 
> Sent: Thursday, December 27, 2012 3:25 PM
> To: Lucy yong; Black, David
> Cc: [email-masked]
> Subject: RE: Multi-subnet VNs - should be a new service type?
> 
> What is the issue?
> 
> Are you referring to the case where a network
> is connected to multiple EVPN PEs in a multihoming
> arrangement?
> [Lucy] no, for multihoming case, there is designated forwarder to 
> forward multicast traffic. 
> 
> If that is the case, then I think the EVPN draft is
> not clear. It should point out that an EVI acting as
> standby in an active-standby topology can not act
> as Default Gateway.
> -- 
> Jakob Heitz.
> 
> 
> 
> From: Lucy yong [mailto:[email-masked]] 
> Sent: Thursday, December 27, 2012 11:06 AM
> To: Jakob Heitz; Black, David
> Cc: [email-masked]
> Subject: RE: Multi-subnet VNs - should be a new service type?
> This will have an issue if VAP of EVPN are via a switched network. 
> Need to modify the ARP response schema.
> 
> Lucy 
> 
> From: Jakob Heitz [mailto:[email-masked]] 
> Sent: Thursday, December 27, 2012 12:58 PM
> To: Lucy yong; Black, David
> Cc: [email-masked]
> Subject: RE: Multi-subnet VNs - should be a new service type?
> 
> The Default Gateway feature of EVPN helps to avoid tromboning.
> http://tools.ietf.org/html/draft-ietf-l2vpn-evpn-02, Sec. 11.1.
> Every PE responds to the ARP request for the default router
> and every PE will route packets with the destination MAC of the
> default router.
> -- 
> Jakob Heitz. x25475. 510-566-2901 
> 
>

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 28 Dec 2012 02:16:06 +0000

Default Gateway responds to ARP request for the default gateway,
not to an ARP request for any host.

An EVPN PE should respond to an ARP request if it knows
that the IP address being requested exists on a different
ethernet segment than the one on which the ARP request arrived.

--
Jakob Heitz.

________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 27, 2012 5:39 PM
To: Jakob Heitz; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Multi-subnet VNs - should be a new service type?

Does Lucy refer to the scenario that, if host_A requests MAC of host_B which resides in the same switched network, the default gateway should not reply such ARP request, otherwise host_A will receive ARP reply both from host_B and default gateway.

Lizhong

---

From: Lizhong Jin<[email-masked]>
Date: Fri, 28 Dec 2012 14:22:24 +0800

> ethernet segment than the one on which the ARP request arrived.
[Lizhong] Yes, and the precondition is the PE knows that the IP address 
being requested exists on a different ethernet segment. This is the 
different schema with current practice. And I agree this issue could be 
solved. Let's see if this is the case Lucy refers to.

Lizhong

> 
> Does Lucy refer to the scenario that, if host_A requests MAC of 
> host_B which resides in the same switched network, the default 
> gateway should not reply such ARP request, otherwise host_A will 
> receive ARP reply both from host_B and default gateway. 
> 
> Lizhong 
> 
> >

---

From: Lucy yong <[email-masked]>
Date: Fri, 28 Dec 2012 17:38:30 +0000

This is the issue I refer to and agree that can be solved. The key is what standard rule to have, so that vendor device can interwork together.

Cheers,
Lucy

From: Lizhong Jin [mailto:[email-masked]]
Sent: Friday, December 28, 2012 12:22 AM
To: Jakob Heitz
Cc: [email-masked]; Lucy yong; [email-masked]
Subject: RE: Multi-subnet VNs - should be a new service type?

> ethernet segment than the one on which the ARP request arrived.
[Lizhong] Yes, and the precondition is the PE knows that the IP address being requested exists on a different ethernet segment. This is the different schema with current practice. And I agree this issue could be solved. Let's see if this is the case Lucy refers to.

Lizhong

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 28 Dec 2012 17:57:19 +0000

When an EVPN PE responds to an ARP request,
it does not respond with its own MAC address,
but with the MAC address from the BGP MAC route.

Are you suggesting that the EVPN PE respond with
it's own MAC address? What would be the point?

--
Jakob Heitz.

________________________________
From: Lucy yong [mailto:[email-masked]]
Sent: Friday, December 28, 2012 9:39 AM
To: Lizhong Jin; Jakob Heitz
Cc: [email-masked]; [email-masked]
Subject: RE: Multi-subnet VNs - should be a new service type?

Cheers,
Lucy

Lizhong

---

From: Lucy yong <[email-masked]>
Date: Fri, 28 Dec 2012 18:09:43 +0000

I do not know how to answer you now. Basically, if EVPN just performs Ethernet service, it should not response the ARP message, the end system or router response.  We have to be clear what is default gateway role in EVPN.

Lucy

From: Jakob Heitz [mailto:[email-masked]]
Sent: Friday, December 28, 2012 11:57 AM
To: Lucy yong; Lizhong Jin
Cc: [email-masked]; [email-masked]
Subject: RE: Multi-subnet VNs - should be a new service type?

--
Jakob Heitz.

Cheers,
Lucy

Lizhong