Subject: Re: [nvo3] the request to adopt draft-mity-nvo3-use-case-04 as nvo3 WG document

From: [email-masked]
Date: Wed, 5 Dec 2012 10:33:07 +0800

Hi Lucy,

I'm confused with "in this case, WAN PE is aware of VxLAN, i.e. VxLAN ID 
will be used between DCGW and WAN PE to identify tenant virtual network. "

Will VxLAN ID still exist outside of DC Virtual Network? 

Thank you!

Regards,
Yuxia 

[email-masked] 写于 2012-11-30 01:49:04:

> Hi Bhargav,
> 
> Thank you for the support and feedback.
> 
> Since this is the use case draft, it just focuses on the general use
> cases, not particular solution. There may be multiple solutions to 
> apply one use case and we do not intend to suggestion any solution 
> for a use case. In the case we need to give an example to explain 
> the use case, we should state out clearly that it is just an example.
> 
> Section 4.2 intends to describe the use case for a DC virtual 
> network and an external user network are connected via a WAN VPN. It
> gives one example how to make DC virtual network and WAN VPN 
> interworking via a local LAN, which is like rfc4364 option A. 
> Therefore, in this example, PE is not aware of VxLAN ID, DC GW will 
> map VxLAN ID to a local VLAN (ID). Since the VLAN ID is just local 
> between PE and CE, it should not be an issue of 12bits. However, you
> can also use rfc4364 option B to implement this use case, where DCGW
> and WAN PE acts as an ASBR in two ASes, in this case, WAN PE is 
> aware of VxLAN, i.e. VxLAN ID will be used between DCGW and WAN PE 
> to identify tenant virtual network. Other solutions can be implemented 
too.
> 
> We will fix the text in next version to make clear between a use 
> case and an example to describe the case.
> 
> Regards,
> Lucy 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, November 29, 2012 8:54 AM
> > To: Lucy yong; [email-masked]; [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: RE: the request to adopt draft-mity-nvo3-use-case-04 as nvo3
> > WG document
> > 
> > Hi Lucy,
> > 
> > 
> > 
> > Support this draft and have a comment WRT section 4.2 *DC virtual
> > network and WAN VPN Interconnection*
> > 
> > 
> > 
> > The draft suggests to use VRF-LITE mechanism between PE2 and NVE2,
> > where VLAN is used to identfiy a customer/tenant. VxLAN is used in DC
> > networks to identify a tenant which is 24 bit where as VLAN is 12 bit.
> > Does the draft suggest to use VLAN or VxLAN between PE-CE?. If it were
> > VxLAN, should not PE be VxLAN aware ?
> > 
> > 
> > 
> > Thanks
> > Bhargav
> > 
> > ________________________________
> > From: [email-masked] [[email-masked]] On Behalf Of Lucy
> > yong [[email-masked]]
> > Sent: Wednesday, November 28, 2012 11:41 AM
> > To: Matthew Bocci; Benson Schliesser
> > Cc: [email-masked]; [email-masked]
> > Subject: [nvo3] the request to adopt draft-mity-nvo3-use-case-04 as
> > nvo3 WG document
> > 
> > Hi Matthew and Benson,
> > 
> > In IETF 85 meeting, there is a good consent in keeping this draft as
> > individual WG document and move it along with the
> > problem/framework/requirement drafts. We, co-authors, would like see 
it
> > being adopted as WG doc. now.
> > 
> > Regards,
> > Lucy
> > 
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: Lucy yong <[email-masked]>
Date: Wed, 5 Dec 2012 17:53:13 +0000

If VXLAN ID are global unique, PE will be aware of VXLAN ID. If VXLAN ID is not global unique, it can be just used in DC, and is mapped to the ID in WAN so there are one-one mapping.

Again, there are several possible solutions for the use case in the draft, I do not want to discuss individual solutions in this context.
Lucy

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, December 04, 2012 8:33 PM
To: Lucy yong
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Re: [nvo3] the request to adopt draft-mity-nvo3-use-case-04 as nvo3 WG document

Hi Lucy,

I'm confused with "in this case, WAN PE is aware of VxLAN, i.e. VxLAN ID will be used between DCGW and WAN PE to identify tenant virtual network. "

Thank you!

Regards,
Yuxia

[email-masked] 写于 2012-11-30 01:49:04:

> to identify tenant virtual network. Other solutions can be implemented too.
>
> > problem/framework/requirement drafts. We, co-authors, would like see it