Subject: [nvo3] Comment on draft-gu-nvo3-virt-edge-auto-discovery

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Thu, 24 Jul 2014 18:22:33 +0000

Greetings:
It appears that the protocol introduced in draft-gu-nvo3-virt-edge-auto-discovery largely duplicates the work that was done in IEEE with VDP.  I would like to solicit the authors' view of potentially using VDP for this purpose.

Thanks!
Joe Pelissier

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 24 Jul 2014 16:48:25 -0700

I had the same comment/concern after listening to the presentation.

One thing that I found significantly different from the VDP approach (which
I am not sure that I can agree with as being the right approach, simply
because it doesn't seem secure) is that, with this scheme, the VM directly
discovers/registers with the NVE; in the case of the VDP approach, it is
the hypervisor which does the registration.

Anoop

On Thu, Jul 24, 2014 at 11:22 AM, Joe Pelissier (jopeliss) <
[email-masked]> wrote:

>  Greetings:
>
> It appears that the protocol introduced in
> draft-gu-nvo3-virt-edge-auto-discovery largely duplicates the work that was
> done in IEEE with VDP.  I would like to solicit the authors' view of
> potentially using VDP for this purpose.
>
>
>
> Thanks!
>
> Joe Pelissier
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>
>

---

From: [email-masked]
Date: Fri, 25 Jul 2014 23:08:14 +0800

Hi,

Thanks for your comments.

VDP and NVE auto-discovery all can be used as VM-NVE protocol, so 
something looks like.

But VNE auto-discovery has  some different features/functions, for 
example, get VM('s network parameters) configured automatically,
e.g. with VNE auto-discovery, VM can obtain its IP address and/or VLAN-ID 
from NVE/networkside.

Thanks!

Zhongyu

"Joe Pelissier (jopeliss)" <[email-masked]> 
发件人:  "nvo3" <[email-masked]>
2014-07-25 02:22

收件人
"[email-masked]" <[email-masked]>
抄送

主题
[nvo3] Comment on draft-gu-nvo3-virt-edge-auto-discovery

Greetings:
It appears that the protocol introduced in 
draft-gu-nvo3-virt-edge-auto-discovery largely duplicates the work that 
was done in IEEE with VDP.  I would like to solicit the authors’ view of 
potentially using VDP for this purpose.
 
Thanks!
Joe Pelissier_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: [email-masked]
Date: Fri, 25 Jul 2014 23:09:50 +0800

Hi,

Thanks!

Zhongyu Gu

收件人

主题

Greetings:
 
Thanks!

---

From: [email-masked]
Date: Fri, 25 Jul 2014 23:32:52 +0800

We have the same secure concern.

So typically NVE auto-discovery shall be used with some authentication 
measures and it owns some security supporting features, for example 
Session-ID field.

Presentation time limited, pls refer to the draft itself for further info.

Thanks!

Zhongyu

Anoop Ghanwani <[email-masked]> 
发件人:  "nvo3" <[email-masked]>
2014-07-25 07:48

收件人
"Joe Pelissier (jopeliss)" <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: [nvo3] Comment on draft-gu-nvo3-virt-edge-auto-discovery

One thing that I found significantly different from the VDP approach 
(which I am not sure that I can agree with as being the right approach, 
simply because it doesn't seem secure) is that, with this scheme, the VM 
directly discovers/registers with the NVE; in the case of the VDP 
approach, it is the hypervisor which does the registration.

Anoop

Thanks!
Joe Pelissier