Subject: [nvo3] DRAFT Charter Update for Discussion

From: Benson Schliesser <[email-masked]>
Date: Fri, 8 Aug 2014 19:53:37 -0400

Dear NVO3 Contributors -

As discussed during the NVO3 meeting at IETF-90 in Toronto, the chairs have been drafting a new / revised charter for the WG. The latest draft charter text is below for your review.

Frankly, we suspect that some of the wording could be further improved to be more clear and/or precise. With that in mind we ask for your help - please let us know if something seems unclear or if you have suggestions for better wording.

If you have feedback please post it to the list for discussion within the next 2 weeks.

Thanks,
-Benson & Matthew

An NVO3 solution, also known as a Data Center Virtual Private Network (DCVPN),
is a set of protocols and/or protocol extensions that address the issues
described by draft-ietf-nvo3-overlay-problem-statement consistent with the
approach described by draft-ietf-nvo3-framework.

NVO3 will document DCVPN requirements for both control plane protocol(s) and
data plane encapsulation format(s), as well as management, operational,
maintenance, troubleshooting, security and OAM protocol requirements.
Additionally, NVO3 will document common use-cases for DCVPN solutions.

Consistent with the documents described above, the NVO3 WG will document an
architecture for DCVPNs within a data center environment based on the following
architectural design points:
-   A logically centralized NVA control plane
-   Support for an underlay IP data plane between NVEs

Based on this architecture the NVO3 WG will develop one or more NVO3 solutions.
This may include documenting applicability of existing protocols, contributing
to the development of protocol extensions by other WGs and/or SDOs, and/or
developing new protocols as appropriate.

Solutions and/or protocols that were developed outside of the IETF, but not
developed by another SDO, and that have multiple interoperable implementations
may be adopted by the NVO3 WG for further development, based on WG consensus,
if requested by the authors .

If the NVO3 WG anticipates the adoption of the technologies of another SDO,
such as the IEEE, as part of any DCVPN solution, it will liaise with that SDO
to ensure the compatibility of the approach.

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 13 Aug 2014 12:41:44 -0700

Just a reminder that Matthew and I are looking for feedback on the draft
text of a new NVO3 charter. Can it be that we wrote a charter so perfect
there are no comments..?

The draft charter text is quoted in my email below. For reference it can
also be found at
http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140808.txt

Cheers,
-Benson & Matthew

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]

Dear NVO3 Contributors -

As discussed during the NVO3 meeting at IETF-90 in Toronto, the chairs have
been drafting a new / revised charter for the WG. The latest draft charter
text is below for your review.

Frankly, we suspect that some of the wording could be further improved to
be more clear and/or precise. With that in mind we ask for your help -
please let us know if something seems unclear or if you have suggestions
for better wording.

If you have feedback please post it to the list for discussion within the
next 2 weeks.

Thanks,
-Benson & Matthew

An NVO3 solution, also known as a Data Center Virtual Private Network
(DCVPN),
is a set of protocols and/or protocol extensions that address the issues
described by draft-ietf-nvo3-overlay-problem-statement consistent with the
approach described by draft-ietf-nvo3-framework.

architecture for DCVPNs within a data center environment based on the
following

Based on this architecture the NVO3 WG will develop one or more NVO3
solutions.
This may include documenting applicability of existing protocols,
contributing
to the development of protocol extensions by other WGs and/or SDOs, and/or
developing new protocols as appropriate.

Solutions and/or protocols that were developed outside of the IETF, but not
developed by another SDO, and that have multiple interoperable
implementations
may be adopted by the NVO3 WG for further development, based on WG
consensus,
if requested by the authors .

If the NVO3 WG anticipates the adoption of the technologies of another SDO,
such as the IEEE, as part of any DCVPN solution, it will liaise with that
SDO
to ensure the compatibility of the approach.

---

From: Tom Herbert <[email-masked]>
Date: Wed, 13 Aug 2014 13:31:25 -0700

> text of a new NVO3 charter. Can it be that we wrote a charter so perfect
Maybe just a request for clarification...

Unless I am misreading this, it seems to me that the intent is to
create a packaged solution for data centers that combines data plane,
control, and architecture. I think these are actually very separate
facets and should really be mostly separate tracks. I would liken this
to how IP, routing protocols, and our current data center architecture
has evolved. These were never defined together and so the dependencies
between them have always been quite minimal. This has allowed us to
completely change one part with redoing the rest of world (e.g.
IPv4->IPv6, decentralized routing to open flow,..).

It might also be nice to clarify a little more what the ultimate
output is of the WG. I assume the tangible output here would be
standardized data plane protocol(s) and control plane protocol(s).
Architecture is nice to provide a context for the protocols, but not
really something that can be standardized in itself. Every existing DC
already has an existing architecture (even before virtualization), it
is much more likely that we'd want to adapt and leverage the existing
architecture as much as possible rather than change the whole world to
accommodate NV-- which I guess is another way of saying data plane,
control plane, architecture need to be considered independently.

Hope this helps :-)

Tom

> Frankly, we suspect that some of the wording could be further improved to be
> more clear and/or precise. With that in mind we ask for your help - please
> let us know if something seems unclear or if you have suggestions for better
> wording.
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 13 Aug 2014 23:39:11 +0000

Benson & Matthew,

The proposed charter is so general that there is not much to pick on. Yes, you have done a great job drafting it.

So the NVO3 is now DCVPN? Since the underlay is IP, will it become another L3VPN?

Linda

From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Wednesday, August 13, 2014 2:42 PM
To: [email-masked]
Subject: [nvo3] Fwd: DRAFT Charter Update for Discussion

Just a reminder that Matthew and I are looking for feedback on the draft text of a new NVO3 charter. Can it be that we wrote a charter so perfect there are no comments..?

The draft charter text is quoted in my email below. For reference it can also be found at http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140808.txt

Cheers,
-Benson & Matthew

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 14 Aug 2014 10:07:54 +0000

Tom

Thanks for your comments.

The intention is not to try to impose an architecture on data centers. The
architecture really provides a context in which the data and control plane
protocols operate, and helps to define the scope of what we can define, or
what new protocols we need to define in NVO3. If you look at other Wgs
defining VPN-like technologies (L3VPN, L3VPN, PWE3, etc), they all have
frameworks or architectures that do this. Ideally the architecture should
actually help in describing modularity, in that different control/data
plane protocols could be slotted in to provide different capabilities, as
required.

Regards

Matthew

---

From: "Fedyk, Don" <[email-masked]>
Date: Thu, 14 Aug 2014 16:19:51 +0000

The first paragraph seems a little sparse.  One would have to read the problem statement and framework to determine the scope.

My suggestion is expanding something like this:

An NVO3 solution, also known as a Data Center Virtual Private Network (DCVPN), is a set of protocols and/or protocol extensions that address providing both Layer 2 and Layer 3 Services within and between DCVPNs. The issues addressed include virtualization, multi-tenancy, multi-site, mobility, optimization, management and security as described by draft-ietf-nvo3-overlay-problem-statement consistent with the approach described by draft-ietf-nvo3-framework.

I’d also suggest expanding NVA and NVE acronyms.

Cheers,
Don

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: Lucy yong <[email-masked]>
Date: Thu, 14 Aug 2014 16:45:32 +0000

Hi Benson and Matthew,

The charter text is in general and good.

I suggest that the charter also includes the solutions for a virtual network, i.e. DCVPN, spanning multiple DCs and a virtual network interconnecting to another virtual network in DC(s) and an external network.

Thanks,
Lucy

Cheers,
-Benson & Matthew

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 10:45:33 -0700

Hi, Tom. Thanks for the comments.

Just to reiterate / add to Matthew's response: The architecture meant to
describe how the control and data plane protocols relate, not apply to the
datacenter in some broader sense. Maybe it's reasonable to think of this in
terms similar to how IP addressing is coherent across both the IP header
and routing protocols... In the overlay DCVPN we have some kind of mapping
system that ties the planes together, and this would be described by the
architecture.

That being said, assuming this description makes sense to you, do you have
any specific suggestions for improving the charter text? If our intention
wasn't made clear by the charter that we proposed then, by all means, we're
open to improvements.

Thanks,
-Benson

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 10:57:16 -0700

Hi, Linda.

On Wed, Aug 13, 2014 at 4:39 PM, Linda Dunbar <[email-masked]>
wrote:

>  The proposed charter is so general that there is not much to pick on.
> Yes, you have done a great job drafting it.
>
>
I'm not sure if you're serious, or teasing me / being sarcastic, but either
way I guess it puts a smile on my face. ;)

>  So the NVO3 is now DCVPN? Since the underlay is IP, will it become

Somebody else asked me a similar question privately, so I want to make sure
it's clear...

The term "NVO3" refers to a working group. The term "DCVPN" refers to the
category of solutions for providing multi-tenancy, etc in a DC environment.
There are possibly many technical approaches to designing a DCVPN. Some of
those approaches might be based on protocols like BGP, MPLS, etc, which are
developed in other WGs. As proposed in the new charter, NVO3 does not own
the scope / charter for all work on DCVPNs. Rather, the proposed NVO3
charter is meant to narrow our focus to a specific type of DCVPN:
overlay-based with a logically centralized control plane.

That being said, is that not clear from the text that we proposed? Is there
some specific way that it could be improved?

Cheers,
-Benson

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 11:01:03 -0700

Hi, Don. Thanks for the specific, constructive feedback.

The sparseness was an intentional choice aimed at making the charter more
concise. But I'm perfectly comfortable admitting that I may have taken it
too far... Your proposed text seems like a pretty good improvement to me.

I'd be interested in hearing feedback from other participants here.

Cheers,
-Benson

On Thu, Aug 14, 2014 at 9:19 AM, Fedyk, Don <[email-masked]> wrote:

>  The first paragraph seems a little sparse.  One would have to read the
> problem statement and framework to determine the scope.
>
>
>
> (DCVPN), is a set of protocols and/or protocol extensions *that address
> providing both Layer 2 and Layer 3 Services within and between DCVPNs.* *The
> issues addressed include virtualization, multi-tenancy, multi-site,
> mobility, optimization, management and security* *as* described by
> draft-ietf-nvo3-overlay-problem-statement consistent with the approach
> described by draft-ietf-nvo3-framework.
>
>
>
> From: *Benson Schliesser* <[email-masked]>
> As discussed during the NVO3 meeting at IETF-90 in Toronto, the chairs
> have been drafting a new / revised charter for the WG. The latest draft
> charter text is below for your review.
>

---

From: Tom Herbert <[email-masked]>
Date: Thu, 14 Aug 2014 11:11:00 -0700

On Thu, Aug 14, 2014 at 10:45 AM, Benson Schliesser
<[email-masked]> wrote:
> terms similar to how IP addressing is coherent across both the IP header and
> routing protocols... In the overlay DCVPN we have some kind of mapping
I guess my real question was: will the output of nvo3 be a proposed
set of standard data and/or control plane protocols for network
virtualization. Assuming that, I like Don's suggested wording in
describing DCVPN as "a set of protocols and/or protocol extensions."

Thanks,
Tom

> Thanks,
> -Benson
>
>
>
>
> On Thu, Aug 14, 2014 at 3:07 AM, Bocci, Matthew (Matthew)
> <[email-masked]> wrote:
>>
>> Tom
>>
>> >>have

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 11:28:53 -0700

Thanks, Lucy.

Personally, I agree that this would be a valuable part of a NVO3 solution.
As a WG chair, I think we may need to focus our work in multiple phases...
Can you suggest specific text that might help with this goal in the charter?

Cheers,
-Benson

On Thu, Aug 14, 2014 at 9:45 AM, Lucy yong <[email-masked]> wrote:

> I suggest that the charter also includes the solutions for a virtual
> network, i.e. DCVPN, spanning multiple DCs and a virtual network
> interconnecting to another virtual network in DC(s) and an external network.
>
>
>
> Thanks,
>
> Lucy
>
>
>
> *From:* nvo3 [mailto:[email-masked]] *On Behalf Of *Benson
> Schliesser
>
> *Sent:* Wednesday, August 13, 2014 2:42 PM
> *To:* [email-masked]
> *Subject:* [nvo3] Fwd: DRAFT Charter Update for Discussion
>
>
>

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 11:38:00 -0700

Hi, Tom.

The proposed charter that Matthew and I posted says "An NVO3 solution, also
known as a Data Center Virtual Private Network (DCVPN), is a set of
protocols and/or protocol extensions..." (see
http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140808.txt)

I'm glad to hear that you like Don's improvement to the wording. I agree
that it adds context that is useful. Is there something additional that we
should say, to be more specific about the work product / output of the WG?

Note that after we re-charter, we will need to come up with a revised set
of milestones that help us achieve the charter's goals. Those milestones
can be much more specific than the charter text, of course - we don't want
the charter capturing our goal at the level of milestones... But if the
charter itself isn't clear about the high-level goals then we should fix
that first.

Cheers,
-Benson

On Thu, Aug 14, 2014 at 11:11 AM, Tom Herbert <[email-masked]> wrote:

> and
> >> >> Frankly, we suspect that some of the wording could be further
> improved
> >> >>to be
> >> >> described by draft-ietf-nvo3-overlay-problem-statement consistent
> with
> >> >>the
> >> >> Solutions and/or protocols that were developed outside of the IETF,
> but
> >> >>not
> >> >> If the NVO3 WG anticipates the adoption of the technologies of
> another
> >> >>SDO,

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 14 Aug 2014 18:57:01 +0000

Benson,

I like your elaboration: a specific type of DCVPN: overlay-based with a logically centralized control plane.
It would be great if this explanation can be included in the Charter, something like:

“An NVO3 solution is to address a specific type of Data Center Virtual Private Network (DCVPN) that is overlay-based with a logically centralized control plane. The NVO3 WG will develop a set of protocols and/or protocol extensions that address the issues
described by draft-ietf-nvo3-overlay-problem-statement consistent with the
approach described by draft-ietf-nvo3-framework.”

Linda

From: Benson Schliesser [mailto:[email-masked]]
Sent: Thursday, August 14, 2014 12:57 PM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

On Wed, Aug 13, 2014 at 4:39 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
The proposed charter is so general that there is not much to pick on. Yes, you have done a great job drafting it.

I'm not sure if you're serious, or teasing me / being sarcastic, but either way I guess it puts a smile on my face. ;)

Somebody else asked me a similar question privately, so I want to make sure it's clear...

The term "NVO3" refers to a working group. The term "DCVPN" refers to the category of solutions for providing multi-tenancy, etc in a DC environment. There are possibly many technical approaches to designing a DCVPN. Some of those approaches might be based on protocols like BGP, MPLS, etc, which are developed in other WGs. As proposed in the new charter, NVO3 does not own the scope / charter for all work on DCVPNs. Rather, the proposed NVO3 charter is meant to narrow our focus to a specific type of DCVPN: overlay-based with a logically centralized control plane.

That being said, is that not clear from the text that we proposed? Is there some specific way that it could be improved?

Cheers,
-Benson

---

From: Lucy yong <[email-masked]>
Date: Thu, 14 Aug 2014 19:00:39 +0000

Benson,
Please fine the proposed additional text in the charter text.

Based on this architecture the NVO3 WG will develop one or more NVO3 solutions, the solutions for a DCVPN spanning over multiple DCs, and the solutions for a DCVPN interconnecting to another DCVPN in DC(s) and an external network. This may include documenting applicability of existing protocols, contributing to the development of protocol extensions by other WGs and/or SDOs, and/or

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 14 Aug 2014 12:08:05 -0700

Hi, Linda.

I think we captured the same idea in paragraphs 3 and 4 of the proposed
charter. (See
http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140808.txt
for reference.) Are you suggesting that we also add those ideas to the
first paragraph? I think that could be a good idea, but I'd like to do it
in a concise way.

If so, could you please look at the text from Don Fedyk (see
https://mailarchive.ietf.org/arch/msg/nvo3/Z_vhgIF_rWz92VxuuZ1pMXjfaUo) and
suggest how to improve it with these ideas?

Thanks,
-Benson

On Thu, Aug 14, 2014 at 11:57 AM, Linda Dunbar <[email-masked]>
wrote:

> *From:* Benson Schliesser [mailto:[email-masked]]
> *Sent:* Thursday, August 14, 2014 12:57 PM
> *To:* Linda Dunbar
> *Cc:* [email-masked]
> *Subject:* Re: [nvo3] Fwd: DRAFT Charter Update for Discussion
>
>
>
> Hi, Linda.
>
>
>
> I'm not sure if you're serious, or teasing me / being sarcastic, but
> either way I guess it puts a smile on my face. ;)
>
>
>
> That being said, is that not clear from the text that we proposed? Is
> there some specific way that it could be improved?
>
>
>
> Cheers,
>
> -Benson
>
>
>
>
>
>
>

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 14 Aug 2014 19:28:02 +0000

Benson,

IMHO, the description of the type of DCVPN to be addressed by NVO3 should be in the first paragraph. What you had in paragraphs 3&4 are  the deliverables by NVO3.

It is not clear what does the term “within or between  DCVPN”  mean in Don’s proposal of “address providing both Layer 2 and Layer 3 Services within and between DCVPNs” within and between DCVPNs”.

Linda

From: Benson Schliesser [mailto:[email-masked]]
Sent: Thursday, August 14, 2014 2:08 PM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

I think we captured the same idea in paragraphs 3 and 4 of the proposed charter. (See http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140808.txt for reference.) Are you suggesting that we also add those ideas to the first paragraph? I think that could be a good idea, but I'd like to do it in a concise way.

If so, could you please look at the text from Don Fedyk (see https://mailarchive.ietf.org/arch/msg/nvo3/Z_vhgIF_rWz92VxuuZ1pMXjfaUo) and suggest how to improve it with these ideas?

Thanks,
-Benson

On Thu, Aug 14, 2014 at 11:57 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Benson,

Linda

From: Benson Schliesser [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, August 14, 2014 12:57 PM
To: Linda Dunbar
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

Cheers,
-Benson

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Thu, 14 Aug 2014 21:03:52 +0000

It may be a bit pedantic (but probably no more so than the argument that had it briefly so named), I think "also known as a Data Center Virtual Private Network (DCVPN)" is unnecessary.  Otherwise, for accuracy, I'd suggest "known for less than a week as" or "fleetingly referred to as".   And that's my real point, nobody is really lost over that moniker.  It had a short and useless life.

From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 13, 2014 3:41 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] Fwd: DRAFT Charter Update for Discussion

Cheers,
-Benson & Matthew

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 14 Aug 2014 22:24:24 +0000

Hi Benson,

What you say below seems important enough the articulate in the charter.  Namely, that NVO3 is not tasked with developing DCVPN solutions based on BGP and MPLS, which will be handled by a different WG.

I'm wondering if the term "DCVPN" is confusing enough to not use it.  I know it was in the original NVO3 charter, but I always felt it was there to keep the door open for L2VPN/L3VPN based solutions.  I don't believe we use "DCVPN" very much in the current WG documents.  We mainly use the term Virtual Network (VN).  Should we use VN in the charter instead?

Thanks, Larry

From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 14, 2014 10:57 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

Cheers,
-Benson

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 14 Aug 2014 22:31:29 +0000

Agree with what Larry said. It is nice to have the clear description on the type of DCVPN that NVO3 is to address, but it can give people the impression that it is a subset of L3VPN.

Linda

From: Larry Kreeger (kreeger) [mailto:[email-masked]]
Sent: Thursday, August 14, 2014 5:24 PM
To: Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 14 Aug 2014 22:32:36 +0000

Hi Benson,

I do think Don's additional text is useful.  I am a little bit concerned with the word "mobility" since I often hear it used in relation to mobile devices (e.g. cell phones).  The problem statement mostly discusses "virtual machine mobility", so I would be more comfortable with that.

Also, "multi-site" seems to be a new expansion of scope and may run up against solutions coming from the L2VPN/L3VPN WG.  Rather than taking that on, perhaps it is better to cover how NVO3 solutions can interwork with L2VPN/L3VPN solutions.

Thanks, Larry

From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 14, 2014 11:01 AM
To: "Fedyk, Don" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

The sparseness was an intentional choice aimed at making the charter more concise. But I'm perfectly comfortable admitting that I may have taken it too far... Your proposed text seems like a pretty good improvement to me.

Cheers,
-Benson

On Thu, Aug 14, 2014 at 9:19 AM, Fedyk, Don <[email-masked]<mailto:[email-masked]>> wrote:
The first paragraph seems a little sparse.  One would have to read the problem statement and framework to determine the scope.

An NVO3 solution, also known as a Data Center Virtual Private Network (DCVPN), is a set of protocols and/or protocol extensions that address providing both Layer 2 and Layer 3 Services within and between DCVPNs.The issues addressed include virtualization, multi-tenancy, multi-site, mobility, optimization, management and securityas described by draft-ietf-nvo3-overlay-problem-statement consistent with the approach described by draft-ietf-nvo3-framework.

Cheers,
Don

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Aug 2014 01:11:04 +0000

I fully agree that how NVO3 solutions can interwork with L2VPN/L3VPN solutions should be covered.

Best regards,
Xiaohu

From: nvo3 [mailto:[email-masked]] On Behalf Of Larry Kreeger (kreeger)
Sent: Friday, August 15, 2014 6:33 AM
To: Benson Schliesser; Fedyk, Don
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Benson,

Thanks, Larry

Cheers,
-Benson

I'd also suggest expanding NVA and NVE acronyms.

Cheers,
Don
---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Aug 2014 01:21:54 +0000

Hi Larry,

Could you please explain to us what's the real difference between VPN and VN?

Best regards,
Xiaohu

From: nvo3 [mailto:[email-masked]] On Behalf Of Larry Kreeger (kreeger)
Sent: Friday, August 15, 2014 6:24 AM
To: Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 15 Aug 2014 02:08:22 +0000

Hi Xiaohu,

In practice, there really isn't much difference in the services of a VN vs a VPN.  My concern is just the perception of what the term VPN already means in the industry.  I don't think we want people to have preconceived notions about what a DCVPN is, e.g. an MPLS VPN running within a DC.

 - Larry

From: Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 14, 2014 6:21 PM
To: Larry Kreeger <[email-masked]<mailto:[email-masked]>>, Benson Schliesser <[email-masked]<mailto:[email-masked]>>, Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

Could you please explain to us what’s the real difference between VPN and VN?

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Aug 2014 02:52:41 +0000

Hi Larry,

The term VPN is a generic term which could be interpreted as IPsec VPN, SSL VPN and MPLS-based VPN etc. If some people have a mistaken perception of the term VPN, their mistaken perception should be corrected.

Best regards,
Xiaohu

From: Larry Kreeger (kreeger) [mailto:[email-masked]]
Sent: Friday, August 15, 2014 10:08 AM
To: Xuxiaohu; Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 15 Aug 2014 02:57:28 +0000

Hi Xiaohu,

An NVO3 VN is not an IPSec VPN nor an SSL VPN either.  All the types of VPNs you mention are typically used over the WAN/Internet and/or involve encryption for privacy of the internet.  I use a VPN to connect into my company from my home.  The company end of the VPN is probably located in a data center.  Does that make it a DCVPN?

 - Larry

Date: Thursday, August 14, 2014 7:52 PM

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Aug 2014 03:17:03 +0000

Hi Larry,

IMO, DCVPN is just a particular VPN which is deployed in the DC environment and may have some special requirements on the VPN technologies. The perception that the MPLS-based VPN technology should only be used over the WAN or the Internet is mistaken and therefore should be corrected. Could you please explain the technical reasons why the MPLS-based VPN technologies could not be deployed within the DC? Could you please explain why the MPLS-over-IP based encapsulations could not be used within the DC?

Best regards,
Xiaohu

From: Larry Kreeger (kreeger) [mailto:[email-masked]]
Sent: Friday, August 15, 2014 10:57 AM
To: Xuxiaohu; Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Fedyk, Don" <[email-masked]>
Date: Fri, 15 Aug 2014 11:29:57 +0000

+1
I'm good with Larry's suggestions.  It might be time for another draft incorporating the changes to comment on.

Don

From: Larry Kreeger (kreeger) [mailto:[email-masked]]
Sent: Thursday, August 14, 2014 6:33 PM
To: Benson Schliesser; Fedyk, Don
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Benson,

Thanks, Larry

Cheers,
-Benson

Cheers,
Don
---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
Date: Fri, Aug 8, 2014 at 4:53 PM
Subject: DRAFT Charter Update for Discussion
To: [email-masked]<mailto:[email-masked]>

Dear NVO3 Contributors -

Thanks,
-Benson & Matthew

---

From: "Reith, Lothar" <[email-masked]>
Date: Fri, 15 Aug 2014 14:15:30 +0000

Hi Larry,

in my view the key point of DCVPN is meeting DC requirements "multi-tenancy" and "endpoint mobility" (or "VM mobility" if that makes it clearer, with particular requirements regarding the VM-motion time, e.g. measured in milliseconds, not minutes or days to move an endpoint -within a datacenter or even across datacenters).

All the traditional VPNs mentioned do not support network endpoint mobility (in the sense of being able to move a VM while running an application, also known as live migration of a VM).

So DCVPN is fine with me. Alternatively one could consider calling it a EMVN (Endpoint Mobility Virtual Network), to make it really clear what it is all about.

Lothar

Von: nvo3 [mailto:[email-masked]] Im Auftrag von Larry Kreeger (kreeger)
Gesendet: Freitag, 15. August 2014 04:57
An: Xuxiaohu; Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Betreff: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Fri, 15 Aug 2014 14:47:26 +0000

That was not his original argument.  His argument was that the presence of the term DC-VPN causes confusion with work that should be covered in another WG (even in the proposed re-organization where these are grouped under BESS, L2VPN and L3VPN remain separate from NVO3 and what you have described is L2VPN and L3VPN).  If anything, I think your response amplifies and validates his comment.

When people commonly use the terms "VXLAN VPN" or "NV-GRE VPN", there might be some point to this useless argument … but since not all overlays are commonly called VPNs and those that are have their own WG …let's keep that nomenclature there.

If you feel that there are any specific requirements for the technologies you underscore, perhaps they can be addressed in those workgroups since the bulk of related work for them resides there.

From: Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 14, 2014 11:17 PM
To: "Larry Kreeger (kreeger)" <[email-masked]<mailto:[email-masked]>>, Benson Schliesser <[email-masked]<mailto:[email-masked]>>, Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: Thomas Narten <[email-masked]>
Date: Fri, 15 Aug 2014 14:38:46 -0400

At Thu, 14 Aug 2014 22:24:24 +0000, Larry Kreeger (kreeger) wrote:

> I'm wondering if the term "DCVPN" is confusing enough to not use it.  I know
> it was in the original NVO3 charter, but I always felt it was there to keep
> the door open for L2VPN/L3VPN based solutions.  I don't believe we use "DCVPN"
> very much in the current WG documents.  We mainly use the term Virtual Network
> (VN).  Should we use VN in the charter instead?

Strongly agree. This effort has never really used the DCVPN
terminology and it is not (IMO) a natural fit. None of our documents
use it and I never hear the term used. The terminology was proposed
when we were initially chartered and we should accept that it hasn't
stuck.

Going back to the very beginning of this effort, it has always been
about Network Virtualization (emphasis on those two words). It was
never about "VPNs", though clearly what is being done overlaps with
VPN technology. 

Moreover, the key driver for this work (i.e., the reason for doing it)
is the goal of virtualizing networking in a DC analagous to how server
virtualization has virtualized physical machines. All the key
requirements for NVO3 come from the desire to virtualize in a DC. The
charter really should capture that directly.

Thomas

---

From: Osama Zia <[email-masked]>
Date: Fri, 15 Aug 2014 19:34:18 +0000

Hi Brenson,

This statement An NVO3 solution, also known as a Data Center Virtual Private 
Network (DCVPN), does not seem to imply your response The term "NVO3" refers 
to a working group. The term "DCVPN" refers to the category of solutions for 
providing multi-tenancy, etc in a DC environment.

To me it looks like NVO3 and DCVPN are the same thing. Can we instead use your 
response in the opening line?

Regards,

Osama

From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, August 14, 2014 10:57 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

On Wed, Aug 13, 2014 at 4:39 PM, Linda Dunbar <[email-masked] 
<mailto:[email-masked]> > wrote:

The proposed charter is so general that there is not much to pick on. Yes, you 
have done a great job drafting it.

 So the NVO3 is now DCVPN? Since the underlay is IP, will it become another 
L3VPN?

The term "NVO3" refers to a working group. The term "DCVPN" refers to the 
category of solutions for providing multi-tenancy, etc in a DC environment. 
There are possibly many technical approaches to designing a DCVPN. Some of 
those approaches might be based on protocols like BGP, MPLS, etc, which are 
developed in other WGs. As proposed in the new charter, NVO3 does not own the 
scope / charter for all work on DCVPNs. Rather, the proposed NVO3 charter is 
meant to narrow our focus to a specific type of DCVPN: overlay-based with a 
logically centralized control plane.

Cheers,

-Benson

---

From: Osama Zia <[email-masked]>
Date: Fri, 15 Aug 2014 19:36:45 +0000

Hi,

I will copy the definition of VN from
http://tools.ietf.org/id/draft-ietf-nvo3-framework-09.txt

Virtual Network (VN): A VN is a logical abstraction of a physical

   network that provides L2 or L3 network services to a set of Tenant

   Systems. A VN is also known as a Closed User Group (CUG).

I think the difference between VN and VPN is the context. For example, I
have not come across a definition of VPN in context of abstraction. I would
agree to use VN instead of VPN. This will also be consistent with the
terminology in other drafts. 

Regards,

Osama

From: nvo3 [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Thursday, August 14, 2014 8:17 PM
To: Larry Kreeger (kreeger); Benson Schliesser; Linda Dunbar
Cc: [email-masked]
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

IMO, DCVPN is just a particular VPN which is deployed in the DC environment
and may have some special requirements on the VPN technologies. The
perception that the MPLS-based VPN technology should only be used over the
WAN or the Internet is mistaken and therefore should be corrected. Could you
please explain the technical reasons why the MPLS-based VPN technologies
could not be deployed within the DC? Could you please explain why the
MPLS-over-IP based encapsulations could not be used within the DC?

Best regards,

Xiaohu

Cc: [email-masked] <mailto:[email-masked]> 

Hi Xiaohu,

An NVO3 VN is not an IPSec VPN nor an SSL VPN either.  All the types of VPNs
you mention are typically used over the WAN/Internet and/or involve
encryption for privacy of the internet.  I use a VPN to connect into my
company from my home.  The company end of the VPN is probably located in a
data center.  Does that make it a DCVPN?

 - Larry

From: Xuxiaohu <[email-masked] <mailto:[email-masked]> >
Date: Thursday, August 14, 2014 7:52 PM
To: Larry Kreeger <[email-masked] <mailto:[email-masked]> >, Benson
Schliesser <[email-masked] <mailto:[email-masked]> >, Linda
Dunbar <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

The term VPN is a generic term which could be interpreted as IPsec VPN, SSL
VPN and MPLS-based VPN etc. If some people have a mistaken perception of the
term VPN, their mistaken perception should be corrected.

Best regards,

Xiaohu

Cc: [email-masked] <mailto:[email-masked]> 

Hi Xiaohu,

In practice, there really isn't much difference in the services of a VN vs a
VPN.  My concern is just the perception of what the term VPN already means
in the industry.  I don't think we want people to have preconceived notions
about what a DCVPN is, e.g. an MPLS VPN running within a DC.

 - Larry

From: Xuxiaohu <[email-masked] <mailto:[email-masked]> >
Date: Thursday, August 14, 2014 6:21 PM
To: Larry Kreeger <[email-masked] <mailto:[email-masked]> >, Benson
Schliesser <[email-masked] <mailto:[email-masked]> >, Linda
Dunbar <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> >
Subject: RE: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

Could you please explain to us what's the real difference between VPN and
VN? 

Best regards,

Xiaohu

From: nvo3 [mailto:[email-masked]] On Behalf Of Larry Kreeger
(kreeger)
Sent: Friday, August 15, 2014 6:24 AM
To: Benson Schliesser; Linda Dunbar
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Benson,

What you say below seems important enough the articulate in the charter.
Namely, that NVO3 is not tasked with developing DCVPN solutions based on BGP
and MPLS, which will be handled by a different WG.

I'm wondering if the term "DCVPN" is confusing enough to not use it.  I know
it was in the original NVO3 charter, but I always felt it was there to keep
the door open for L2VPN/L3VPN based solutions.  I don't believe we use
"DCVPN" very much in the current WG documents.  We mainly use the term
Virtual Network (VN).  Should we use VN in the charter instead?

Thanks, Larry

From: Benson Schliesser <[email-masked]
<mailto:[email-masked]> >
Date: Thursday, August 14, 2014 10:57 AM
To: Linda Dunbar <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi, Linda.

The proposed charter is so general that there is not much to pick on. Yes,
you have done a great job drafting it.

Cheers,

-Benson

---

From: Lucy yong <[email-masked]>
Date: Fri, 15 Aug 2014 19:40:53 +0000

This is about selecting a name for the framework and architecture developed in NVO3 WG. 
Whether we call it DCVPN or DCVN, or some other name, it means that framework. I am fine to use one or another as long as it clearly states that binding.

Lucy

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Friday, August 15, 2014 1:39 PM
To: [email-masked]
Subject: [nvo3] DCVPN terminology

At Thu, 14 Aug 2014 22:24:24 +0000, Larry Kreeger (kreeger) wrote:

> I'm wondering if the term "DCVPN" is confusing enough to not use it.  
> I know it was in the original NVO3 charter, but I always felt it was 
> there to keep the door open for L2VPN/L3VPN based solutions.  I don't believe we use "DCVPN"
> very much in the current WG documents.  We mainly use the term Virtual 
> Network (VN).  Should we use VN in the charter instead?

Strongly agree. This effort has never really used the DCVPN terminology and it is not (IMO) a natural fit. None of our documents use it and I never hear the term used. The terminology was proposed when we were initially chartered and we should accept that it hasn't stuck.

Going back to the very beginning of this effort, it has always been about Network Virtualization (emphasis on those two words). It was never about "VPNs", though clearly what is being done overlaps with VPN technology. 

Moreover, the key driver for this work (i.e., the reason for doing it) is the goal of virtualizing networking in a DC analagous to how server virtualization has virtualized physical machines. All the key requirements for NVO3 come from the desire to virtualize in a DC. The charter really should capture that directly.

Thomas

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 15 Aug 2014 21:01:32 +0000

Yes, exactly Ken.  We are not discussing whether or not MPLS could be deployed inside a DC.  The new Routing Area reorg moves work in that area out of NVO3.  This is why we should remove any remaining baggage leftover from it from the new NVO3 charter.

Thanks, Larry

From: "Ken Gray (kegray)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, August 15, 2014 7:47 AM
To: Xuxiaohu <[email-masked]<mailto:[email-masked]>>, Larry Kreeger <[email-masked]<mailto:[email-masked]>>, Benson Schliesser <[email-masked]<mailto:[email-masked]>>, Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Fwd: DRAFT Charter Update for Discussion

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Xiaohu,

 - Larry

Hi Larry,

Best regards,
Xiaohu

Hi Benson,

Thanks, Larry

Hi, Linda.

Cheers,
-Benson

---

From: "Anton Ivanov (antivano)" <[email-masked]>
Date: Sat, 16 Aug 2014 05:18:09 +0000

+1

If it is just VN, then from a terminology standpoint this also covers DC 
VN/Cloud extension to customer LAN. It also captures the requirements of 
DC VN to DC Edge device, etc.

If it is called DCVPN, from a terminology standpoint, it is DC only and 
VPN only. Limiting to this will orphan a large number of use cases 
including some which are already covered in the architecture/framework 
documents.

A.

---

From: Alia Atlas <[email-masked]>
Date: Mon, 18 Aug 2014 17:41:42 -0400

Benson,

This is a good start.  I will provide more detailed comments as well, but
at a high level.

a) Please keep description of the problem in the charter so that a casual
reader doesn't need to hunt down
the NVO3 RFCs.   I don't think that the motivations have significantly
changed.

b) Narrowing the scope to a single datacenter for solutions is, IMHO,
important to getting a protocol solution done in the next year.  There can
be text along the lines of "the current scope is intra-datacenter....
future work may include inter-datacenter".

c) Requirements are a "may develop to help the protocol solutions work" -
not a gating item except for data-plane encapsulation where diversity of
encapsulation causes significant issues (as seen).

d) I'd prefer focus on the logically centralized control-plane with some
description of what control protocols to support that are needed.  If that
has to wait until the associated architecture has good consensus, I hope
that we're heading there soon.

Thanks,
Alia

On Thu, Aug 14, 2014 at 3:08 PM, Benson Schliesser <[email-masked]>
wrote:

> https://mailarchive.ietf.org/arch/msg/nvo3/Z_vhgIF_rWz92VxuuZ1pMXjfaUo)
> and suggest how to improve it with these ideas?
>
> Thanks,
> -Benson
>
>
>
>
>

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 21 Aug 2014 17:08:12 -0700

It sounds like what is being conveyed by "centralized NVA control plane" is
that the NVO3 WG doesn't want to bother with how redundancy is achieved
for the NVA (i.e. we don't want to worry about the clustering protocol
regardless
of whether that is accomplished using BGP or something else).  If so, I
think
it would be better to state that explicitly.

Everything else needed to complete the solution is in scope --
encapsulation,
NVA-to-NVE control protocol, multicast handling, etc., and there may be
more than one solution specified for each of these.  The only other big
"if" is
whether or not we attempt to solve the inter-DC problem.  Do I have that
right?

Anoop