Subject: [nvo3] Third Draft Charter Update for Discussion

From: Benson Schliesser <[email-masked]>
Date: Wed, 27 Aug 2014 21:14:14 -0400

Dear NVO3 Contributors -

We’ve made a small adjustment to the text of the draft charter, based on feedback over the past couple days. Below is the latest version for your review.

Cheers,
-Benson & Matthew

http://svn.tools.ietf.org/svn/wg/nvo3/charter-ietf-nvo3-01-rev-20140827.txt

An NVO3 solution is a set of protocols and/or protocol extensions that enable
network virtualization within a data center (DC) environment using an IP-based
overlay approach. It provides layer 2 and/or layer 3 services for virtual
networks enabling multi-tenancy, workload mobility, optimization, management,
and security, addressing the issues described in the problem statement and
consistent with the framework previously produced by the NVO3 WG.

The NVO3 WG will develop solutions for network virtualization based on the
following architectural tenets:
 - Support for an IP-based underlay data plane
 - A logically centralized control plane for network virtualization
Network virtualization approaches that do not adhere to these tenets are
explicitly outside of the scope of the NVO3 WG.

In pursuit of the solutions described above, the NVO3 WG will document an
architecture for network virtualization within a data center environment.

The NVO3 WG may produce requirements for a network virtualization control
plane, and will select, extend, and/or develop one or more control plane
protocols to support the architecture. Such protocols are expected to fulfill
the communication requirements between an End Device and Network Virtualization
Edge (NVE), and between an NVE and the Network Virtualization Authority (NVA).
The internal mechanisms and protocols of a logically centralized NVA are
explicitly out of scope of the NVO3 WG.  Architectural issues raised by
coexistence of multiple logically centralized control planes in the same data
center may be considered by the WG.  Inter-DC mechanisms are not in scope of
the NVO3 WG at this time.

The NVO3 WG may produce requirements for network virtualization data planes
based on encapsulation of virtual network traffic over an IP-based underlay
data plane. Such requirements should consider OAM and security. Based on these
requirements the WG will select, extend, and/or develop one or more data plane
encapsulation format(s).

Additionally, the WG may document common use-cases for NVO3 solutions.

The working group may choose to adopt a protocol or data encapsulation that was
previously worked on outside the IETF as the basis for the WG's work.  If the
NVO3 WG anticipates the adoption of the technologies of another SDO as part of
the selected protocols or data encapsulation, the NVO3 WG will first liaise
with that SDO.

BGP-based solutions to network virtualization within a data center environment
will be developed in the BGP-Enabled Services (BESS) WG.

MILESTONES

Done - Problem Statement submitted for IESG review
Done - Framework document submitted for IESG review
TBD - Architecture submitted for IESG review
TBD - End Device to NVE Control Plane Protocol Adopted by WG
TBD - NVE to NVA Control Plane Protocol Adopted by WG
TBD - NVE Data Plane Protocol Adopted by WG
TBD - End Device to NVE Control Plane Protocol Submitted for IESG review
TBD - NVA to NVA Control Plane Protocol Submitted for IESG review
TBD - NVE Data Plane Protocol Submitted for IESG review
TBD - Recharter or close WG

OPTIONAL DOCUMENTS
(we intend to produce these if they're helpful to the WG, but are not obliged
to do so)

Control Plane Requirements
Data Plane Requirements
Use-cases

---

From: Lucy yong <[email-masked]>
Date: Thu, 28 Aug 2014 20:52:47 +0000

Hi Benson,

The charter should include the solutions for a NVO3 virtual network interconnecting with a bridge (IEEE802.1Q) based virtual network and NVO3 virtual network interconnecting with another NV03 virtual network in a DC environment. 

Both are useful cases in a DC. 

Thanks,
Lucy 

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Wednesday, August 27, 2014 8:14 PM
To: [email-masked]
Subject: [nvo3] Third Draft Charter Update for Discussion

Dear NVO3 Contributors -

We've made a small adjustment to the text of the draft charter, based on feedback over the past couple days. Below is the latest version for your review.

Cheers,
-Benson & Matthew

An NVO3 solution is a set of protocols and/or protocol extensions that enable network virtualization within a data center (DC) environment using an IP-based overlay approach. It provides layer 2 and/or layer 3 services for virtual networks enabling multi-tenancy, workload mobility, optimization, management, and security, addressing the issues described in the problem statement and consistent with the framework previously produced by the NVO3 WG.

The NVO3 WG will develop solutions for network virtualization based on the following architectural tenets:
 - Support for an IP-based underlay data plane
 - A logically centralized control plane for network virtualization Network virtualization approaches that do not adhere to these tenets are explicitly outside of the scope of the NVO3 WG.

In pursuit of the solutions described above, the NVO3 WG will document an architecture for network virtualization within a data center environment.

The NVO3 WG may produce requirements for a network virtualization control plane, and will select, extend, and/or develop one or more control plane protocols to support the architecture. Such protocols are expected to fulfill the communication requirements between an End Device and Network Virtualization Edge (NVE), and between an NVE and the Network Virtualization Authority (NVA).
The internal mechanisms and protocols of a logically centralized NVA are explicitly out of scope of the NVO3 WG.  Architectural issues raised by coexistence of multiple logically centralized control planes in the same data center may be considered by the WG.  Inter-DC mechanisms are not in scope of the NVO3 WG at this time.

The NVO3 WG may produce requirements for network virtualization data planes based on encapsulation of virtual network traffic over an IP-based underlay data plane. Such requirements should consider OAM and security. Based on these requirements the WG will select, extend, and/or develop one or more data plane encapsulation format(s).

The working group may choose to adopt a protocol or data encapsulation that was previously worked on outside the IETF as the basis for the WG's work.  If the
NVO3 WG anticipates the adoption of the technologies of another SDO as part of the selected protocols or data encapsulation, the NVO3 WG will first liaise with that SDO.

BGP-based solutions to network virtualization within a data center environment will be developed in the BGP-Enabled Services (BESS) WG.

MILESTONES

Done - Problem Statement submitted for IESG review Done - Framework document submitted for IESG review TBD - Architecture submitted for IESG review TBD - End Device to NVE Control Plane Protocol Adopted by WG TBD - NVE to NVA Control Plane Protocol Adopted by WG TBD - NVE Data Plane Protocol Adopted by WG TBD - End Device to NVE Control Plane Protocol Submitted for IESG review TBD - NVA to NVA Control Plane Protocol Submitted for IESG review TBD - NVE Data Plane Protocol Submitted for IESG review TBD - Recharter or close WG

OPTIONAL DOCUMENTS
(we intend to produce these if they're helpful to the WG, but are not obliged to do so)

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 28 Aug 2014 23:08:36 +0000

Benson and Matthew: 

Suggestion of the wording: 

It would be more clear to have the third paragraph on "In pursuit of the solutions.." right after the bullets under "The NVO3 WG will develop..." because it is a very important deliverable of the WG.  

Instead of "In pursuit..", I would suggest the following wording:

" To have a common baseline for all the solutions to be developed by NVO3, the NVO3 WG will prioritize finishing the architecture document for network virtualization within a data center environment" (because it is already an WG draft. By the way I just noticed NVO3 architecture draft has expired). 

Some suggestions on the MILESTONES:

I think application specific multicast is an important area, especially for data centers whose underlay IP network don't support PIM or traditional L3 multicast schemes. Many data centers fall into this category. Another important area is seamless VM mobility in Data Center environment to avoid sub-optimal routing, as described by draft-ietf-nvo3-vm-mobility-issues-03.txt. 

Therefore, I think the following items need to be added to the MILESTONES:

- VM mobility issues in DC environment submitted for IESG review
 
- Framework & solutions for Application Specific Multicast Adopted by WG. 

Thanks, Linda 

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Wednesday, August 27, 2014 8:14 PM
To: [email-masked]
Subject: [nvo3] Third Draft Charter Update for Discussion

Dear NVO3 Contributors -

Cheers,
-Benson & Matthew

MILESTONES

OPTIONAL DOCUMENTS

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 28 Aug 2014 23:00:39 -0400

Hi, Lucy.

> Both are useful cases in a DC. 

I agree these are useful cases. And I think they’re already covered by the proposed charter.

Both of the cases you describe would require some kind of NVE that acts as a gateway, and some kind of support in a control plane that makes the gateway functionality work. The proposed charter already provides for work in those areas.

Cheers,
-Benson

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 28 Aug 2014 23:44:24 -0400

Hi, Linda.

> It would be more clear to have the third paragraph on "In pursuit of the solutions.." right after the bullets under "The NVO3 WG will develop..." because it is a very important deliverable of the W…

The 2nd paragraph, including those two bullets regarding architectural tenets, is meant to elaborate on the scope of the WG and define our work at the highest level. The 3rd through 6th (inclusive) paragraphs are meant to define specific areas of work: architecture, control plane, data plane, and use cases.

I don’t think that merging paragraph 2 and 3 would change the meaning of the text. But it might reduce the clarity, by mixing two purposes together in a single paragraph. I would rather keep them separate as is done in the latest proposed charter text.

> " To have a common baseline for all the solutions to be developed by NVO3, the NVO3 WG will prioritize finishing the architecture document for network virtualization within a data center environmen…

One of the goals of this recharter, which is agreed upon by the chairs and our ADs, is to get away from serialized process. In other words, we specifically want to get away from waiting for high-level documents before allowing more specific work on solutions. Rather, we do want for work on each specific area of work (architecture, control plane, data plane, and use cases) to proceed in parallel.

> I think application specific multicast is an important area, especially for data centers whose underlay IP network don't support PIM or traditional L3 multicast schemes. Many data centers fall into this category.

I don’t particularly like the phrase “application specific multicast”, but I think I understand what you mean by it. And I agree with your statement that it’s an important area for the WG to address. I also think that multicast traffic can be taken into account when documenting the data and control plane protocols already enumerated in the milestones. It isn’t clear to me that there is any reason to call it out specifically, nor what such a milestone would look like.

> Another important area is seamless VM mobility in Data Center environment to avoid sub-optimal routing, as described by draft-ietf-nvo3-vm-mobility-issues-03.txt. 

If there is WG consensus to publish the mobility issues draft then we can do so. We don’t have to specifically create a milestone for it. That being said, if there is still significant work to-be-done on the draft then the chairs will probably want to create a milestone (just for the sake of good practice, transparency, etc).

I think we should decide how to handle this based on a WG discussion about the draft, instead of binding it to the rechartering. It might be worthwhile to have a brief presentation on the draft at the 11-Sep virtual interim meeting - can one of the authors lead this?

Cheers,
-Benson

---

From: Lucy yong <[email-masked]>
Date: Fri, 29 Aug 2014 14:15:06 +0000

Benson,

I kindly agree that current text does not exclude these use cases and glad that we are in sync.

Thanks,
Lucy 

-----Original Message-----
From: Benson Schliesser [mailto:[email-masked]] 
Sent: Thursday, August 28, 2014 10:01 PM
To: Lucy yong
Cc: [email-masked]
Subject: Re: [nvo3] Third Draft Charter Update for Discussion

Hi, Lucy.

> Both are useful cases in a DC. 

I agree these are useful cases. And I think they're already covered by the proposed charter.

Cheers,
-Benson

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 29 Aug 2014 15:51:12 +0000

Benson, 

Thanks for the reply. Comments inserted below:

-----Original Message-----

> I think application specific multicast is an important area, especially for data centers whose underlay IP network don't support PIM or traditional L3 multicast schemes. Many data centers fall into…

I don't particularly like the phrase "application specific multicast", 

[Linda] It is about the non ARP/ND related multicast (or the multicast initiated by clients). 

but I think I understand what you mean by it. And I agree with your statement that it's an important area for the WG to address. I also think that multicast traffic can be taken into account when documenting the data and control plane protocols already enumerated in the milestones. It isn't clear to me that there is any reason to call it out specifically, nor what such a milestone would look like.

[Linda] The entire charter didn't even mention application initiated multicast. It is wrong. NVA can eliminate (or reduce) ARP/ND related broadcast/multicast, but not application initiated multicast.

The current proposed MILESTONES have separate deliverables for WG adoption and FOR IESG review, and very detailed categories being explicitly spelled out. Therefore, at minimum, should have one line on the  protocols to handle hosts/applications initiated multicast. 

Linda

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 29 Aug 2014 16:41:23 +0000

Benson, 

More comments to your reply on VM mobility:

-----Original Message-----

> Another important area is seamless VM mobility in Data Center environment to avoid sub-optimal routing, as described by draft-ietf-nvo3-vm-mobility-issues-03.txt. 

If there is WG consensus to publish the mobility issues draft then we can do so. We don't have to specifically create a milestone for it. That being said, if there is still significant work to-be-done on the draft then the chairs will probably want to create a milestone (just for the sake of good practice, transparency, etc).

[Linda] The mobility draft is to address an important area of VM mobility in Data Centers, which the WG had adopted to become WG draft long time ago. We sent request for WG Last call many months ago. But there hasn't been any action. Since the MILESTONEs have separate items for IESG Review and WG adoption for many drafts, it is necessary to list VM Mobility as well. 

Thanks Linda

Cheers,
-Benson

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 29 Aug 2014 15:06:58 -0700

Benson,

Please see in line prefixed with [ag].

Anoop

On Fri, Aug 29, 2014 at 8:51 AM, Linda Dunbar <[email-masked]>
wrote:

> > I think application specific multicast is an important area, especially
> for data centers whose underlay IP network don't support PIM or traditional
> L3 multicast schemes. Many data centers fall into this category.
>

> [ag] Perhaps we can refer to this as "multicast applications other than
ARP/ND."

>  but I think I understand what you mean by it. And I agree with your
> statement that it's an important area for the WG to address. I also think
> that multicast traffic can be taken into account when documenting the data
> and control plane protocols already enumerated in the milestones. It isn't
> clear to me that there is any reason to call it out specifically, nor what
> such a milestone would look like.
>
> [Linda] The entire charter didn't even mention application initiated
> multicast. It is wrong. NVA can eliminate (or reduce) ARP/ND related
> broadcast/multicast, but not application initiated multicast.
>
> The current proposed MILESTONES have separate deliverables for WG adoption
> and FOR IESG review, and very detailed categories being explicitly spelled
> out. Therefore, at minimum, should have one line on the  protocols to
> handle hosts/applications initiated multicast.

[ag] I agree with Linda here.  While it sounds like there is agreement that
the problem needs to be addressed by the working group, it would be useful
to at least have an explicit mention of multicast somewhere in the charter.
 Perhaps we could change the following line from:
"The NVO3 WG will develop solutions for network virtualization based on the
following architectural tenets:"
to:
"The NVO3 WG will develop solutions for network virtualization covering
both unicast and multicast traffic handling based on the
following architectural tenets:"

Anoop

---

From: Lucy yong <[email-masked]>
Date: Fri, 29 Aug 2014 22:28:21 +0000

"The NVO3 WG will develop solutions for network virtualization covering both unicast and multicast traffic handling based on the following architectural tenets:"

Support this suggestion.

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Friday, August 29, 2014 5:07 PM
To: Linda Dunbar
Cc: Benson Schliesser; [email-masked]
Subject: Re: [nvo3] Third Draft Charter Update for Discussion

Benson,

Anoop

On Fri, Aug 29, 2014 at 8:51 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Benson,

-----Original Message-----
From: Benson Schliesser [mailto:[email-masked]<mailto:[email-masked]>]

[ag] Perhaps we can refer to this as "multicast applications other than ARP/ND."

[ag] I agree with Linda here.  While it sounds like there is agreement that the problem needs to be addressed by the working group, it would be useful to at least have an explicit mention of multicast somewhere in the charter.  Perhaps we could change the following line from:
"The NVO3 WG will develop solutions for network virtualization based on the
following architectural tenets:"
to:
"The NVO3 WG will develop solutions for network virtualization covering both unicast and multicast traffic handling based on the
following architectural tenets:"

Anoop

---

From: Benson Schliesser <[email-masked]>
Date: Fri, 29 Aug 2014 22:35:32 -0400

Hi, Linda -

(I’ve changed the message Subject to better reflect this topic.)

> [Linda] The mobility draft is to address an important area of VM mobility in Data Centers, which the WG had adopted to become WG draft long time ago. We sent request for WG Last call many months ag…

I see two related questions here. First is the question about whether we need to create a milestone for the VM Mobility draft. Second is whether it is ready for last call.

On the first topic, I don’t see value in debating this, but I will explain my decision. I consider the VM Mobility draft to be a “companion” to the Problem Statement. And I assert that if it is complete (or nearly complete) then a milestone is unnecessary from a management tracking perspective. Thus, we do not need another milestone specifically for a VM Mobility Issues document unless the WG feels that it needs more work, material changes, etc.

On the second topic, personally I agree with you that the VM Mobility Issues draft should be last-called soon. However, I’ve had some private feedback that I’d like to see discussed on the list before we take that step. Specifically, a couple people commented that the draft is unnecessary, questioning whether it adds materially to what is already captured in the Problem Statement. I’m not endorsing this point of view, but nor am I challenging it.

Thus, in my last message I submitted a request for you to present the draft at the upcoming interim meeting, to give us a chance to discuss this feedback. I’m also happy to discus this here on the mailing list. But I’d like to see some kind of response before making a decision to last-call the draft.

Thanks,
-Benson

---

From: Benson Schliesser <[email-masked]>
Date: Fri, 29 Aug 2014 22:55:40 -0400

Hi, Linda and Anoop -

(I’ve changed the message Subject to more accurately describe this topic.)

On Aug 29, 2014, at 6:06 PM, Anoop Ghanwani <[email-masked]> wrote:

> following architectural tenets:”

I’m not opposed to mentioning multicast in the charter, but t wouldn’t be my preferred choice.

The way that I think about it, multicast support is an appropriate topic for the requirements drafts. And it should be discussed in the architecture draft, as well as any solutions drafts where it might be applicable. But it would be sub-optimal to load the charter with a discussion of the various types of traffic that might be found in the overlay: broadcast, known and unknown unicast, multicast supporting network protocols (such as address resolution etc), multicast on behalf of applications (“application specific multicast”), etc.

The current charter text does not exclude work on multicast, which is good. And I don’t see any reason to explicitly call it out as a unique topic separate from the architecture, control plane, data plane, and use cases. If I’m missing something please help me understand. Otherwise I’d prefer to leave the proposed charter text as-is.

Cheers,
-Benson

---

From: ramki Krishnan <[email-masked]>
Date: Sat, 30 Aug 2014 14:22:42 -0700

Hi Benson,

[ag] "The NVO3 WG will develop solutions for network virtualization covering both unicast and multicast traffic handling based on the following architectural tenets:"

I agree with Linda's observation and support Anoop's suggestion for the modified charter text.

Thanks,
Ramki

From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Friday, August 29, 2014 7:56 PM
To: [email-masked]
Subject: [nvo3] Multicast issues draft

Hi, Linda and Anoop -

(I've changed the message Subject to more accurately describe this topic.)

On Aug 29, 2014, at 6:06 PM, Anoop Ghanwani <[email-masked]<mailto:[email-masked]>> wrote:

I'm not opposed to mentioning multicast in the charter, but t wouldn't be my preferred choice.

The way that I think about it, multicast support is an appropriate topic for the requirements drafts. And it should be discussed in the architecture draft, as well as any solutions drafts where it might be applicable. But it would be sub-optimal to load the charter with a discussion of the various types of traffic that might be found in the overlay: broadcast, known and unknown unicast, multicast supporting network protocols (such as address resolution etc), multicast on behalf of applications ("application specific multicast"), etc.

The current charter text does not exclude work on multicast, which is good. And I don't see any reason to explicitly call it out as a unique topic separate from the architecture, control plane, data plane, and use cases. If I'm missing something please help me understand. Otherwise I'd prefer to leave the proposed charter text as-is.

Cheers,
-Benson

---

From: Linda Dunbar <[email-masked]>
Date: Sun, 31 Aug 2014 13:21:47 +0000

+1. Support.

Linda

From: Lucy yong
Sent: Friday, August 29, 2014 5:28 PM
To: Anoop Ghanwani; Linda Dunbar
Cc: Benson Schliesser; [email-masked]
Subject: RE: [nvo3] Third Draft Charter Update for Discussion

Support this suggestion.

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Friday, August 29, 2014 5:07 PM
To: Linda Dunbar
Cc: Benson Schliesser; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] Third Draft Charter Update for Discussion

Benson,

Anoop

-----Original Message-----

Anoop

---

From: Haoweiguo <[email-masked]>
Date: Mon, 1 Sep 2014 00:27:14 +0000

Yes, i also agree that NVO3 charter should clearly include the description for multicast traffic handling. It is an important part in NVO3 solution.

Thanks

weiguo

________________________________
发件人: Linda Dunbar [[email-masked]]
发送时间: 2014年8月31日 21:21
收件人: Lucy yong; Anoop Ghanwani; Linda Dunbar
抄送: Benson Schliesser; [email-masked]
主题: Re: [nvo3] Third Draft Charter Update for Discussion

+1. Support.

Linda

From: Lucy yong

Support this suggestion.

Lucy

Benson,

Anoop

-----Original Message-----

Anoop