Subject: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

From: Liyizhou <[email-masked]>
Date: Tue, 28 Apr 2015 02:07:35 +0000

Hi folks,

We are going to send a liaison to IEEE 802.1 to bring their attention to ietf-nvo3-hpvr2nve-cp-req draft and to suggest the work to extend VDP protocol based on the consensus reached during Dallas meeting.

Chairs asked me to post the proposed text here for your review.

Thanks a lot,

Yizhou

-----------

Liaison Statement： NVO3 Liaison to IEEE 802.1

From: Matthew Bocci and Benson Schliesser
(Co-Chairs, IETF NVO3 Working Group)

To: Glenn Parsons (Chair, IEEE 802.1 Working Group)<mailto:[email-masked]>

Cc:
Ron Bonica<mailto:[email-masked]> (IETF NVO3 Technical Advisor)
Eric Gray<mailto:[email-masked]> (IETF Liaison to IEEE 802.1)
Alia Atlas<mailto:[email-masked]> (IETF Area Director for NVO3)
Dan Romascanu (IETF Liaison to the IEEE SA)<mailto:[email-masked]>
Jari Arkko<mailto:[email-masked]> (Chair, IETF)
Pat Thaler<mailto:[email-masked]> (Chair, IEEE 802.1 DCB Task Group)
Paul Nickolich (Chair, IEEE 802)<mailto:[email-masked]>

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

The IETF NVO3 Working Group has been developing the requirements for a Control Plane Protocol between server Hypervisors and Network Virtual Edge (NVE) devices in virtualized overlay networks. The current draft can be found at http://datatracker.ietf.org/doc/draft-ietf-nvo3-hpvr2nve-cp-req/.

This requirements document suggests extending the VDP (VSI Discovery and Configuration Protocol) protocol specified by IEEE Std 802.1Qbg as a solution. We would particularly welcome IEEE 802.1 Working Group’s review of Section 5 of the draft. That section compares the conceptually similar terms in NVO3 and the VDP context. It also summarizes the potential technical extension work required for VDP to be used as the control plane protocol between the hypervisor and NVE.

In view of the progress of this work, we would like to suggest IEEE 802.1 Working Group to use that draft as a base requirement reference for VDP extensions in the aforementioned context. Please note that the status of this draft in the IETF, that it is a “Working Group draft”, indicates that the Working Group considers it an appropriate starting point but it is still subject to change. While a determination has not yet been made that there is technical consensus on all the details of the draft, there is consensus on basing the Hypervisor to NVE protocol on VDP with appropriate extensions.

Sincerely Yours,

Matthew Bocci & Benson Schliesser
IETF NVO3 Working Group Co-Chairs

---

From: [email-masked]
Date: Wed, 29 Apr 2015 10:55:20 +0800

Hi Yizhou and all,

This is a formal liaison to IEEE, so it should cover all possible 
extension consideration in NVO3. 
The following are two more consideration.

Firstly, as you may know, we posted a message: 
http://www.ietf.org/mail-archive/web/nvo3/current/msg04418.html. In it, we 
discussed and concluded it's possible to extend VDP to realize the VN 
automatic provisioning.

Secondly, we wonder if VDP suitable for all the usage scenarios in NVO3, 
especially for the typical Hypervisor/NVE-ToR/NVE scenario, because it is 
different from VDP/EVB architecture (Hypervisor/EVB station - ToR/EVB 
Bridge). For example, when some VMs/VNs reside in Hypervisor/NVE and at 
the same time other VMs/VNs(VMs belong to the same Hypervisor) reside in 
ToR/NVE, results in Hypervisor works as EVB station while working as EVB 
brige simultaneously. If this understanding is right, it’s critical to 
VDP extension.

Of course, these points are not discussed before in NVO3.
If possible, please take them into account here.

Thanks in advance!

Zhongyu

Liyizhou <[email-masked]> 
发件人:  "nvo3" <[email-masked]>
2015/04/28 10:07

收件人
"[email-masked]" <[email-masked]>, 
抄送
Pat Thaler <[email-masked]>, Liyizhou <[email-masked]>
主题
[nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi folks,
 
We are going to send a liaison to IEEE 802.1 to bring their attention to 
ietf-nvo3-hpvr2nve-cp-req draft and to suggest the work to extend VDP 
protocol based on the consensus reached during Dallas meeting. 

Thanks a lot,
 
Yizhou

-----------

 
To: Glenn Parsons (Chair, IEEE 802.1 Working Group)
 
Cc: 
Ron Bonica (IETF NVO3 Technical Advisor)
Eric Gray (IETF Liaison to IEEE 802.1)
Alia Atlas (IETF Area Director for NVO3)
Dan Romascanu (IETF Liaison to the IEEE SA)
Jari Arkko (Chair, IETF)
Pat Thaler (Chair, IEEE 802.1 DCB Task Group)
Paul Nickolich (Chair, IEEE 802)
 
Purpose: For action
 
Attachments: (none)
 
Body:
Dear Glenn,
 
The IETF NVO3 Working Group has been developing the requirements for a 
Control Plane Protocol between server Hypervisors and Network Virtual Edge 
(NVE) devices in virtualized overlay networks. The current draft can be 
found at http://datatracker.ietf.org/doc/draft-ietf-nvo3-hpvr2nve-cp-req/. 

This requirements document suggests extending the VDP (VSI Discovery and 
Configuration Protocol) protocol specified by IEEE Std 802.1Qbg as a 
solution. We would particularly welcome IEEE 802.1 Working Group’s review 
of Section 5 of the draft. That section compares the conceptually similar 
terms in NVO3 and the VDP context. It also summarizes the potential 
technical extension work required for VDP to be used as the control plane 
protocol between the hypervisor and NVE.
 
In view of the progress of this work, we would like to suggest IEEE 802.1 
Working Group to use that draft as a base requirement reference for VDP 
extensions in the aforementioned context. Please note that the status of 
this draft in the IETF, that it is a “Working Group draft”, indicates 
that the Working Group considers it an appropriate starting point but it 
is still subject to change. While a determination has not yet been made 
that there is technical consensus on all the details of the draft, there 
is consensus on basing the Hypervisor to NVE protocol on VDP with 
appropriate extensions.
 
Sincerely Yours,
 
Matthew Bocci & Benson Schliesser
IETF NVO3 Working Group Co-Chairs
 _______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Liyizhou <[email-masked]>
Date: Wed, 29 Apr 2015 09:38:42 +0000

Hi Zhongyu,

Thanks for pointing out you would like to see the VDP extension work in previous emails.

For the use case you brought up, I am not too sure why such a scenario is required and has not seen any discussions on it. It would be good if consensus to be reached on adding such use case to architecture or use case document before it is taken into consideration in liaison.

Thanks,
Yizhou

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 10:55 AM
To: Liyizhou
Cc: Liyizhou; [email-masked]; nvo3; Pat Thaler
Subject: 答复: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi Yizhou and all,

This is a formal liaison to IEEE, so it should cover all possible extension consideration in NVO3.
The following are two more consideration.

Firstly, as you may know, we posted a message: http://www.ietf.org/mail-archive/web/nvo3/current/msg04418.html. In it, we discussed and concluded it's possible to extend VDP to realize the VN automatic provisioning.

Secondly, we wonder if VDP suitable for all the usage scenarios in NVO3, especially for the typical Hypervisor/NVE-ToR/NVE scenario, because it is different from VDP/EVB architecture (Hypervisor/EVB station - ToR/EVB Bridge). For example, when some VMs/VNs reside in Hypervisor/NVE and at the same time other VMs/VNs(VMs belong to the same Hypervisor) reside in ToR/NVE, results in Hypervisor works as EVB station while working as EVB brige simultaneously. If this understanding is right, it’s critical to VDP extension.

Thanks in advance!

Zhongyu

Liyizhou <[email-masked]<mailto:[email-masked]>>
发件人:  "nvo3" <[email-masked]<mailto:[email-masked]>>

2015/04/28 10:07

收件人

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,

抄送

Pat Thaler <[email-masked]<mailto:[email-masked]>>, Liyizhou <[email-masked]<mailto:[email-masked]>>

主题

Hi folks,

Thanks a lot,

Yizhou

-----------

Cc:

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

Sincerely Yours,

[email-masked]<mailto:[email-masked]>

---

From: Lucy yong <[email-masked]>
Date: Wed, 29 Apr 2015 20:26:58 +0000

I agree with Yizhou. Don’t know why operators want to configure that way. An NVE is either co-located or at external for a server, not per VM base. Split-NVE is a special design for co-located case, i.e. offloading. VDP usage for an external NVE and split-NVE are the same.

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Liyizhou
Sent: Wednesday, April 29, 2015 4:39 AM
To: [email-masked]
Cc: Pat Thaler; [email-masked]; nvo3
Subject: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi Zhongyu,

Thanks,
Yizhou

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 10:55 AM
To: Liyizhou
Cc: Liyizhou; [email-masked]<mailto:[email-masked]>; nvo3; Pat Thaler
Subject: 答复: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi Yizhou and all,

Thanks in advance!

Zhongyu

2015/04/28 10:07

收件人

抄送

主题

Hi folks,

Thanks a lot,

Yizhou

-----------

Cc:

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

Sincerely Yours,

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Wed, 29 Apr 2015 23:42:21 +0000

Yes, to be clear, the previous terminology of External NVE was changed to Split-NVE at the urging of Thomas Narten.  It is the same architecture/functionality.  Thomas felt the name change better reflected that their was some knowledge within the End Device of the External NVE that needed to be signaled.  This awareness within the End Device was dubbed tNVE (tenant NVE), while the External NVE was dubbed nNVE (network NVE).  If this naming change is causing more harm than good, then perhaps we should change it back.

 - Larry

From: Lucy yong <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 29, 2015 1:26 PM
To: Liyizhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Pat Thaler <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, nvo3 <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Liyizhou
Sent: Wednesday, April 29, 2015 4:39 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Pat Thaler; [email-masked]<mailto:[email-masked]>; nvo3
Subject: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi Zhongyu,

Thanks,
Yizhou

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 10:55 AM
To: Liyizhou
Cc: Liyizhou; [email-masked]<mailto:[email-masked]>; nvo3; Pat Thaler
Subject: 答复: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Hi Yizhou and all,

Thanks in advance!

Zhongyu

2015/04/28 10:07

收件人

抄送

主题

Hi folks,

Thanks a lot,

Yizhou

-----------

Cc:

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

Sincerely Yours,

---

From: [email-masked]
Date: Thu, 30 Apr 2015 15:18:22 +0800

The terminology is ok. 

The scenario please refer to the following picture. VN2, for example, 
needs more processing for QoS or/and ACL etc. been deployed in TOR/NVE. In 
this case, refers to EVB architecture(ER, S-VLAN component, C-VLAN 
component), should all VN1 and VN2's VDP messages be terminated in 
Hypervisor/NVE(tNVE), or all forwarded to ToR/NVE(nNVE)? It seems some 
filter mechanism needed to intercept VN1's VDP messages for local 
processing, while forward VN2's VDP messages to ToR/NVE for processing 
there.

This is our concerns.

Thanks!
Zhongyu

"Larry Kreeger (kreeger)" <[email-masked]> 
发件人:  "nvo3" <[email-masked]>
2015/04/30 07:42

收件人
Lucy yong <[email-masked]>, Liyizhou <[email-masked]>, 
"[email-masked]" <[email-masked]>, 
抄送
Pat Thaler <[email-masked]>, "[email-masked]" <[email-masked]>, nvo3 
<[email-masked]>
主题
Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Yes, to be clear, the previous terminology of External NVE was changed to 
Split-NVE at the urging of Thomas Narten.  It is the same 
architecture/functionality.  Thomas felt the name change better reflected 
that their was some knowledge within the End Device of the External NVE 
that needed to be signaled.  This awareness within the End Device was 
dubbed tNVE (tenant NVE), while the External NVE was dubbed nNVE (network 
NVE).  If this naming change is causing more harm than good, then perhaps 
we should change it back.

 - Larry

From: Lucy yong <[email-masked]>
Date: Wednesday, April 29, 2015 1:26 PM
To: Liyizhou <[email-masked]>, "[email-masked]" <
[email-masked]>
Cc: Pat Thaler <[email-masked]>, "[email-masked]" <[email-masked]>, 
nvo3 <[email-masked]>
Subject: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension 
work

I agree with Yizhou. Don’t know why operators want to configure that way. 
An NVE is either co-located or at external for a server, not per VM base. 
Split-NVE is a special design for co-located case, i.e. offloading. VDP 
usage for an external NVE and split-NVE are the same.
 
Lucy
 
Subject: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension 
work
 
Hi Zhongyu,
 
Thanks for pointing out you would like to see the VDP extension work in 
previous emails.
 
For the use case you brought up, I am not too sure why such a scenario is 
required and has not seen any discussions on it. It would be good if 
consensus to be reached on adding such use case to architecture or use 
case document before it is taken into consideration in liaison.
 
Thanks,
Yizhou

From:[email-masked] [mailto:[email-masked]] 
Sent: Wednesday, April 29, 2015 10:55 AM
To: Liyizhou
Cc: Liyizhou; [email-masked]; nvo3; Pat Thaler
Subject: 答复: [nvo3] proposed liaison text to IEEE 802.1 for VDP 
extension work
 
Hi Yizhou and all,

Thanks in advance!

Zhongyu 

收件人

Hi folks,

  
Thanks a lot,
  
Yizhou 

-----------

  
  
Cc: 
  
Purpose: For action 
  
Attachments: (none) 
  
Body: 
Dear Glenn, 

  
  
Sincerely Yours,

---

From: Liyizhou <[email-masked]>
Date: Thu, 30 Apr 2015 09:37:17 +0000

As Larry and Lucy pointed out, the figure was not what split NVE meant. Split NVE refers to encap/decap offloaded to an external network equipment regardless of VN as framework/architecture document defines.
It is a new architecture which is not addressed in current framework/use case/arch document. Talking about the structure itself, in what case people want to do such mixture configuration?

If talking about the liaison, I do not think we need to make any changes to the current liaison text based on that now.

Thanks,
Yizhou

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, April 30, 2015 3:18 PM
To: Larry Kreeger (kreeger); Lucy yong; Liyizhou
Cc: Liyizhou; Lucy yong; [email-masked]; nvo3; Pat Thaler
Subject: 答复: Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

The terminology is ok.

The scenario please refer to the following picture. VN2, for example, needs more processing for QoS or/and ACL etc. been deployed in TOR/NVE. In this case, refers to EVB architecture(ER, S-VLAN component, C-VLAN component), should all VN1 and VN2's VDP messages be terminated in Hypervisor/NVE(tNVE), or all forwarded to ToR/NVE(nNVE)? It seems some filter mechanism needed to intercept VN1's VDP messages for local processing, while forward VN2's VDP messages to ToR/NVE for processing there.

This is our concerns.

Thanks!
Zhongyu

"Larry Kreeger (kreeger)" <[email-masked]<mailto:[email-masked]>>
发件人:  "nvo3" <[email-masked]<mailto:[email-masked]>>

2015/04/30 07:42

收件人

Lucy yong <[email-masked]<mailto:[email-masked]>>, Liyizhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,

抄送

Pat Thaler <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, nvo3 <[email-masked]<mailto:[email-masked]>>

主题

 - Larry

Lucy

Hi Zhongyu,

Thanks,
Yizhou

Hi Yizhou and all,

Thanks in advance!

Zhongyu

2015/04/28 10:07

收件人

抄送

主题

Hi folks,

Thanks a lot,

Yizhou

-----------

Cc:

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

Sincerely Yours,

https://www.ietf.org/mailman/listinfo/nvo3_______________________________________________

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 30 Apr 2015 10:38:34 +0100

Yizhou is correct that our liaison statement needs to reflect nvo3
consensus. Please feel free to continue discussing this topic to see if
consensus emerges. But also keep in mind that we can always send additional
liaisons in the future in order to collaborate further with our colleagues
working in IEEE.

Thanks,
-Benson

On Wednesday, April 29, 2015, Liyizhou <[email-masked]> wrote:

> consensus to be reached on adding such use case to architecture or use case
> document before it is taken into consideration in liaison.
>
>
>
> Thanks,
>
> Yizhou
>
>
>
>
>
> *From:* [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');> [mailto:
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* Wednesday, April 29, 2015 10:55 AM
> *To:* Liyizhou
> *Cc:* Liyizhou; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; nvo3; Pat Thaler
> *Subject:* 答复: [nvo3] proposed liaison text to IEEE 802.1 for VDP
> extension work
>
>
>
> Hi Yizhou and all,
>
> http://www.ietf.org/mail-archive/web/nvo3/current/msg04418.html. In it,
> we discussed and concluded it's possible to extend VDP to realize the VN
> automatic provisioning.
>
> Bridge). For example, when some VMs/VNs reside in Hypervisor/NVE and at the
> same time other VMs/VNs(VMs belong to the same Hypervisor) reside in
> brige simultaneously. If this understanding is right, it’s critical to VDP
> extension.
>
>    *Liyizhou <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>*
> 发件人:  "nvo3" <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> 2015/04/28 10:07
>
> 收件人
>
> "[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>" <
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>,
>
> 抄送
>
> Pat Thaler <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Liyizhou <
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> 主题
>
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> Cc:
> Ron Bonica <javascript:_e(%7B%7D,'cvml',[email-masked]');>* (IETF
> NVO3 Technical Advisor)*
> Eric Gray <javascript:_e(%7B%7D,'cvml',[email-masked]');>* (IETF
> Liaison to IEEE 802.1)*
> Alia Atlas <javascript:_e(%7B%7D,'cvml',[email-masked]');>* (IETF
> Area Director for NVO3)*
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> Jari Arkko <javascript:_e(%7B%7D,'cvml',[email-masked]');>*
> (Chair, IETF)*
> Pat Thaler <javascript:_e(%7B%7D,'cvml',[email-masked]');>*
> (Chair, IEEE 802.1 DCB Task Group)*
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> Purpose: For action
>
> Attachments: (none)
>
> Body:
> Dear Glenn,
>
> this draft in the IETF, that it is a “Working Group draft”, indicates that
> the Working Group considers it an appropriate starting point but it is
> still subject to change. While a determination has not yet been made that
> there is technical consensus on all the details of the draft, there is
> consensus on basing the Hypervisor to NVE protocol on VDP with appropriate
> extensions.
>
> Sincerely Yours,
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>

---

From: Lucy yong <[email-masked]>
Date: Thu, 30 Apr 2015 14:13:06 +0000

ZhongYu,

Not sure if operator is interested in such configuration. Even yes, for this configuration, VN1’s NVE is on end device, i.e. co-located, so VDP is not needed for VN1 at all; Hypervisor will perform the mapping and encapsulation for VN1 traffic.  VDP only handles VMs associated to VN2.

Lucy

Sent: Thursday, April 30, 2015 2:18 AM

The terminology is ok.

This is our concerns.

Thanks!
Zhongyu

2015/04/30 07:42

收件人

抄送

主题

 - Larry

Lucy

Hi Zhongyu,

Thanks,
Yizhou

Hi Yizhou and all,

Thanks in advance!

Zhongyu

2015/04/28 10:07

收件人

抄送

主题

Hi folks,

Thanks a lot,

Yizhou

-----------

Cc:

Purpose: For action

Attachments: (none)

Body:
Dear Glenn,

Sincerely Yours,

---

From: [email-masked]
Date: Fri, 1 May 2015 09:11:45 +0800

Agree.

Thanks

Benson Schliesser <[email-masked]> 
发件人:  "nvo3" <[email-masked]>
2015/04/30 17:38

收件人
Liyizhou <[email-masked]>, 
抄送
Pat Thaler <[email-masked]>, "[email-masked]" <[email-masked]>, 
"[email-masked]" <[email-masked]>, nvo3 
<[email-masked]>
主题
Re: [nvo3] proposed liaison text to IEEE 802.1 for VDP extension work

Yizhou is correct that our liaison statement needs to reflect nvo3 
consensus. Please feel free to continue discussing this topic to see if 
consensus emerges. But also keep in mind that we can always send 
additional liaisons in the future in order to collaborate further with our 
colleagues working in IEEE. 

Thanks,
-Benson

 
 
Thanks,
Yizhou

Hi Yizhou and all, 

Thanks in advance! 

Zhongyu 

收件人

Hi folks, 

  
Thanks a lot, 
  
Yizhou 

----------- 

  
  
Cc: 
  
Purpose: For action 
  
Attachments: (none) 
  
Body: 
Dear Glenn, 

  
  
Sincerely Yours,