Subject: [nvo3] NVo3 May 22 2015 interim meeting minutes uploaded

From: Sam Aldrin <[email-masked]>
Date: Sun, 24 May 2015 23:49:23 -0700

Minutes are now uploaded.
They could be found at 
<https://www.ietf.org/proceedings/interim/2015/05/22/nvo3/minutes/minutes-interim-2015-nvo3-9 <https://www.ietf.org/proceedings/interim/2015/05/22/nvo3/minutes/minutes-interim-2015-nvo3-9>>

Thanks to Sue and Matt for taking notes.

Do let me know if there need any changes or corrections.

cheers
-sam

---

From: Lucy yong <[email-masked]>
Date: Tue, 26 May 2015 14:50:24 +0000

Here are the points I made at the last in the NVO3 interim meeting.

*         NVO3 architecture decouples control plane and data plane, but NVE and NVA functions integrate VN layer and VN transport layer together. NVA does inner/outer mapping and NVEs perform the lookup and tunnel functions. This has difference from traditional VPNs technology where control plane and data plane couples but VN layer and VN transport layer are separated at the architecture.

*         In NVO3, there are tunnel trace and underlay path trace. Tunnel trace is the tunnel endpoint trace including tunnel stitching case. Underlay path trace is the path from ingress NVE to egress NVE including each underlay intermediate hops.  The end-to-end path in overlay relates to tunnel trace only.  We need separate two traces clearly.

Lucy
From: nvo3 [mailto:[email-masked]] On Behalf Of Sam Aldrin
Sent: Monday, May 25, 2015 1:49 AM
To: [email-masked]
Cc: NVO3 Working Group
Subject: [nvo3] NVo3 May 22 2015 interim meeting minutes uploaded

Minutes are now uploaded.
They could be found at
<https://www.ietf.org/proceedings/interim/2015/05/22/nvo3/minutes/minutes-interim-2015-nvo3-9>

cheers
-sam

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 26 May 2015 11:11:19 -0400

Lucy:

I'm sorry I missed this in the notes.   I'm sure Sam will update the
charter. 

Sue 

From: nvo3 [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Tuesday, May 26, 2015 10:50 AM
To: Sam Aldrin; [email-masked]
Cc: NVO3 Working Group
Subject: Re: [nvo3] NVo3 May 22 2015 interim meeting minutes uploaded

.         NVO3 architecture decouples control plane and data plane, but NVE
and NVA functions integrate VN layer and VN transport layer together. NVA
does inner/outer mapping and NVEs perform the lookup and tunnel functions.
This has difference from traditional VPNs technology where control plane and
data plane couples but VN layer and VN transport layer are separated at the
architecture. 

.         In NVO3, there are tunnel trace and underlay path trace. Tunnel
trace is the tunnel endpoint trace including tunnel stitching case. Underlay
path trace is the path from ingress NVE to egress NVE including each
underlay intermediate hops.  The end-to-end path in overlay relates to
tunnel trace only.  We need separate two traces clearly.

Lucy

They could be found at 

<https://www.ietf.org/proceedings/interim/2015/05/22/nvo3/minutes/minutes-in
terim-2015-nvo3-9>

cheers

-sam

---

From: IETF <[email-masked]>
Date: Tue, 26 May 2015 19:54:29 -0700

You have to be specific on where you made those points and changes needs to be applied.
As none of the note takes captured, unless provided exact locations you made those comments, they cannot be automagically integrated/merged. 

Having said that, couldn’t parse one of the sentences. could you clarify?
See below.

> On May 26, 2015, at 7:50 AM, Lucy yong <[email-masked]> wrote:
> 
> ·         NVO3 architecture decouples control plane and data plane, but NVE and NVA functions integrate VN layer and VN transport layer together. NVA does inner/outer mapping and NVEs perform the lookup and tunnel functions. This has difference from traditional VPNs technology where control plane and data plane couples but VN layer and VN transport layer are separated at the architecture.
What does it mean by, CP and DP couples but VN layer and VN transport are separated at the architecture?

> ·         In NVO3, there are tunnel trace and underlay path trace. Tunnel trace is the tunnel endpoint trace including tunnel stitching case. Underlay path trace is the path from ingress NVE to egress NVE including each underlay intermediate hops.  The end-to-end path in overlay relates to tunnel trace only.  We need separate two traces clearly.
>  
> Lucy

---

From: Lucy yong <[email-masked]>
Date: Wed, 27 May 2015 15:45:10 +0000

In Traditional VPN implementation, PE [RFC4364] has control plane and data plane functions and runs MP-BGP protocol, i.e. PE is one entity for both at VN layer. This is what I mean control plane and data plane couple.  LSP tunnel b/w PEs is VN transport layer that is established separately via different control protocol, i.e. LSP tunnel implementation is independent of VN layer implementation.

NVO3 architecture decouples control plane and data plane, NVA for control plane and NVE for data plane. NVA maintains inner/outer mapping, which is binding VN layer (inner) and VN transport layer (outer) together. NVE as one entity performs encapsulation/tunnel functions based on the mapping info, i.e. one entity does both VN layer and VN transport layer functions.

Will this clarify my point?

Lucy

From: IETF [mailto:[email-masked]]
Sent: Tuesday, May 26, 2015 9:54 PM
To: Lucy yong
Cc: [email-masked]; NVO3 Working Group
Subject: Re: [nvo3] NVo3 May 22 2015 interim meeting minutes uploaded

On May 26, 2015, at 7:50 AM, Lucy yong <[email-masked]<mailto:[email-masked]>> wrote:

Here are the points I made at the last in the NVO3 interim meeting.
•         NVO3 architecture decouples control plane and data plane, but NVE and NVA functions integrate VN layer and VN transport layer together. NVA does inner/outer mapping and NVEs perform the lookup and tunnel functions. This has difference from traditional VPNs technology where control plane and data plane couples but VN layer and VN transport layer are separated at the architecture.
What does it mean by, CP and DP couples but VN layer and VN transport are separated at the architecture?

•         In NVO3, there are tunnel trace and underlay path trace. Tunnel trace is the tunnel endpoint trace including tunnel stitching case. Underlay path trace is the path from ingress NVE to egress NVE including each underlay intermediate hops.  The end-to-end path in overlay relates to tunnel trace only.  We need separate two traces clearly.

Lucy
From: nvo3 [mailto:[email-masked]] On Behalf Of Sam Aldrin
Sent: Monday, May 25, 2015 1:49 AM
To: [email-masked]<mailto:[email-masked]>
Cc: NVO3 Working Group
Subject: [nvo3] NVo3 May 22 2015 interim meeting minutes uploaded

cheers
-sam