Subject: [nvo3] OpenOverlayRouter released!

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Thu, 4 Feb 2016 17:26:56 +0100

Hi all,

We would like to announce the first release of OpenOverlayRouter (OOR -
spelled "double-O-R"), an open-source project, under the Apache 2.0
License, to instantiate programmable overlays. OOR is edge-oriented and
multiplatform (Android, Linux and OpenWRT) with the aim to offer a flexible
and easy-to-deploy overlay infrastructure. OOR is based on the former
LISPmob.org code.

* Who can use it *

OOR is intended for end-users looking for easy multihoming, companies with
strong presence at the edge, startups interested in overlay solutions and
researchers exploring new scenarios.

* Supported protocols *

OOR is interoperable with OpenDaylight and supports several protocols for
both the data and control plane. On the control plane, it supports NETCONF
for provisioning and management and LISP for operational state exchange. On
the data plane, it supports IPv4 and IPv6 overlays with LISP and VXLAN-GPE
encapsulations. The roadmap includes L2 overlays, further encapsulations
and support for SFC headers.

* Code *

You can find all the details and get the code at:
http://openoverlayrouter.org/

Thanks!
The OpenOverlayRouter team

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 5 Feb 2016 05:54:44 +0000

Is this a proper kind of  message on  IETF mailing lists?

________________________________
From: nvo3 <[email-masked]> on behalf of Alberto Rodriguez-Natal <[email-masked]>
Sent: Thursday, February 4, 2016 6:26 PM
To: [email-masked] list; [email-masked]; SDN IRTF list; [email-masked]; [email-masked]
Subject: [nvo3] OpenOverlayRouter released!

Hi all,

We would like to announce the first release of OpenOverlayRouter (OOR - spelled "double-O-R"), an open-source project, under the Apache 2.0 License, to instantiate programmable overlays. OOR is edge-oriented and multiplatform (Android, Linux and OpenWRT) with the aim to offer a flexible and easy-to-deploy overlay infrastructure. OOR is based on the former LISPmob.org code.

* Who can use it *

OOR is intended for end-users looking for easy multihoming, companies with strong presence at the edge, startups interested in overlay solutions and researchers exploring new scenarios.

* Supported protocols *

OOR is interoperable with OpenDaylight and supports several protocols for both the data and control plane. On the control plane, it supports NETCONF for provisioning and management and LISP for operational state exchange. On the data plane, it supports IPv4 and IPv6 overlays with LISP and VXLAN-GPE encapsulations. The roadmap includes L2 overlays, further encapsulations and support for SFC headers.

* Code *

You can find all the details and get the code at:
http://openoverlayrouter.org/<http://webdefence.global.blackspider.com/urlwrap/?q=AXicJcqxDcJADABAS0zAIv95kQYqOmoooXIei7zk2JHjvMgejMQMzBMEV992A7cPwOsNYLw0qQuT1TBg4aziphyyDjCn9nQ5X3OT9mnXAjI9Ue5koWKRqXcqcqRcnJh-v3cfDzHqSKKVjHExnf371R4R_la7aigo&Z>

Thanks!

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 5 Feb 2016 14:23:38 +0000

Sasha,

It seems to me to be extremely relevant and very proper, as we want more open source software connections with the IETF.
https://www.ietf.org/meeting/91/2014.11.13_DWard-IETF-91.pdf <https://www.ietf.org/meeting/91/2014.11.13_DWard-IETF-91.pdf>
https://www.internetsociety.org/publications/ietf-journal-march-2015/open-standards-open-source-open-loop <https://www.internetsociety.org/publications/ietf-journal-march-2015/open-standards-open-source-open-loop>

“Within the IETF, we face numerous issues around our own life cycle. […] What does the subject matter of popular, network-centric OSS projects imply might be missing at the IETF?”

“How to Make the IETF Relevant in this Environment

• Fix, change, or reinvent the liaison process because it will be critical to collaboration with OSS projects. In fact, don’t even use the liaison process as a model.
• Embrace Open Source projects.”

Thanks,

— Carlos.

> On Feb 5, 2016, at 12:54 AM, Alexander Vainshtein <[email-masked]> wrote:
> 
> From: nvo3 <[email-masked] <mailto:[email-masked]>> on behalf of Alberto Rodriguez-Natal <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]> list; [email-masked] <mailto:[email-masked]>; SDN IRTF list; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> We would like to announce the first release of OpenOverlayRouter (OOR - spelled "double-O-R"), an open-source project, under the Apache 2.0 License, to instantiate programmable overlays. OOR is edge-oriented and multiplatform (Android, Linux and OpenWRT) with the aim to offer a flexible and easy-to-deploy overlay infrastructure. OOR is based on the former LISPmob.org <http://lispmob.org/> code.
> 
> 
> * Who can use it *
> 
> http://openoverlayrouter.org/ <http://webdefence.global.blackspider.com/urlwrap/?q=AXicJcqxDcJADABAS0zAIv95kQYqOmoooXIei7zk2JHjvMgejMQMzBMEV992A7cPwOsNYLw0qQuT1TBg4aziphyyDjCn9nQ5X3OT9mnXAjI9Ue5koWKRqXcqcqRcnJh-v3cfDzHqSKKVjHExnf371R4R_la7aigo&Z>
> 
> 
> Thanks!
> _______________________________________________
> nvo3 mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/nvo3 <https://www.ietf.org/mailman/listinfo/nvo3>

---

From: Anton Ivanov <[email-masked]>
Date: Fri, 5 Feb 2016 14:34:49 +0000

+1

Last time I checked IETF moto was "Rough consensus and running code".

I see nothing wrong with announcements related to the second half of the 
moto on the working group lists. It is proper and fitting.

In fact we need more of that, so that is clear which drafts and 
proposals have working interoperable implementations.

After all, once upon a time, there used to be a precondition for 
something to be considered a standard, namely: "Does it have more than 2 
interoperable independent implementations".

A.

On 05/02/16 14:23, Carlos Pignataro (cpignata) wrote:
> Sasha,
>
> It seems to me to be extremely relevant and very proper, as we want 
> more open source software connections with the IETF.
> https://www.ietf.org/meeting/91/2014.11.13_DWard-IETF-91.pdf
> https://www.internetsociety.org/publications/ietf-journal-march-2015/open-standards-open-source-open-loop
>
> /“Within the IETF, we face numerous issues around our own life cycle. 
> […] What does the subject matter of popular, network-centric OSS 
> projects imply might be missing at the IETF?”/
> /
> /
> /“How to Make the IETF Relevant in this Environment/
> /
> /
> /• Fix, change, or reinvent the liaison process because it will be 
> critical to collaboration with OSS projects. In fact, don’t even use 
> the liaison process as a model.
> /
> /• Embrace Open Source projects.”/
>
> Thanks,
>
> — Carlos.
>
>
>> On Feb 5, 2016, at 12:54 AM, Alexander Vainshtein 
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> ------------------------------------------------------------------------
>> *From:*nvo3 <[email-masked] <mailto:[email-masked]>> on 
>> behalf of Alberto Rodriguez-Natal <[email-masked] 
>> <mailto:[email-masked]>>
>> *Sent:*Thursday, February 4, 2016 6:26 PM
>> *To:[email-masked] <mailto:[email-masked]>list;[email-masked] 
>> <mailto:[email-masked]>; SDN IRTF list;[email-masked] 
>> <mailto:[email-masked]>;[email-masked] <mailto:[email-masked]>
>> *Subject:*[nvo3] OpenOverlayRouter released!
>> Hi all,
>>
>> We would like to announce the first release of OpenOverlayRouter (OOR 
>> - spelled "double-O-R"), an open-source project, under the Apache 2.0 
>> License, to instantiate programmable overlays. OOR is edge-oriented 
>> and multiplatform (Android, Linux and OpenWRT) with the aim to offer 
>> a flexible and easy-to-deploy overlay infrastructure. OOR is based on 
>> the formerLISPmob.org <http://lispmob.org/>code.
>>
>>
>> * Who can use it *
>>
>> OOR is intended for end-users looking for easy multihoming, companies 
>> with strong presence at the edge, startups interested in overlay 
>> solutions and researchers exploring new scenarios.
>>
>>
>> * Supported protocols *
>>
>> OOR is interoperable with OpenDaylight and supports several protocols 
>> for both the data and control plane. On the control plane, it 
>> supports NETCONF for provisioning and management and LISP for 
>> operational state exchange. On the data plane, it supports IPv4 and 
>> IPv6 overlays with LISP and VXLAN-GPE encapsulations. The roadmap 
>> includes L2 overlays, further encapsulations and support for SFC headers.
>>
>>
>> * Code *
>>
>> <http://webdefence.global.blackspider.com/urlwrap/?q=AXicJcqxDcJADABAS0zAIv95kQYqOmoooXIei7zk2JHjvMgejMQMzBMEV992A7cPwOsNYLw0qQuT1TBg4aziphyyDjCn9nQ5X3OT9mnXAjI9Ue5koWKRqXcqcqRcnJh-v3cfDzHqSKKVjHExnf371R4R_la7aigo&Z>
>>
>>
>> Thanks!
>> https://www.ietf.org/mailman/listinfo/nvo3
>
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 5 Feb 2016 09:53:21 -0500

+1 Carlos, and Running Code has *always* been of interest here.
Al

From: Nfvrg [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Friday, February 05, 2016 9:24 AM
To: Alexander Vainshtein
Cc: SDN IRTF list; [email-masked] list; [email-masked]; [email-masked]; [email-masked]; Alberto Rodriguez-Natal
Subject: Re: [Nfvrg] [nvo3] OpenOverlayRouter released!

Sasha,

Thanks,

— Carlos.

On Feb 5, 2016, at 12:54 AM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:

________________________________
From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of Alberto Rodriguez-Natal <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, February 4, 2016 6:26 PM
To: [email-masked]<mailto:[email-masked]> list; [email-masked]<mailto:[email-masked]>; SDN IRTF list; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [nvo3] OpenOverlayRouter released!

Hi all,

We would like to announce the first release of OpenOverlayRouter (OOR - spelled "double-O-R"), an open-source project, under the Apache 2.0 License, to instantiate programmable overlays. OOR is edge-oriented and multiplatform (Android, Linux and OpenWRT) with the aim to offer a flexible and easy-to-deploy overlay infrastructure. OOR is based on the former LISPmob.org<http://lispmob.org/> code.

* Who can use it *

* Supported protocols *

* Code *

Thanks!
The OpenOverlayRouter team
_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 5 Feb 2016 15:08:36 +0000

Well said Carlos!  Code FTW!

On Feb 5, 2016, at 9:23 AM, Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:

Sasha,

Thanks,

— Carlos.

Hi all,

* Who can use it *

* Supported protocols *

* Code *

Thanks!

---

From: Sharon <[email-masked]>
Date: Fri, 5 Feb 2016 08:39:13 -0800

++
Overlays probably the most sustainable artifact of network virtualization trend.
Good to distill distinct overlay notions into practical code base combining them.
Further build from there in parallel to formal interface standardization.

--szb

> On Feb 5, 2016, at 6:53 AM, MORTON, ALFRED C (AL) <[email-masked]> wrote:
>

---

From: "Susan Hares" <[email-masked]>
Date: Sun, 7 Feb 2016 19:41:40 -0500

+1 to Al and Carlos.  Running code has and should be of interest in IETF. 

Sue 

From: sfc [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Friday, February 05, 2016 9:53 AM
To: Carlos Pignataro (cpignata); Alexander Vainshtein
Cc: SDN IRTF list; [email-masked] list; [email-masked]; [email-masked]; [email-masked]; Alberto Rodriguez-Natal
Subject: Re: [sfc] [nvo3] OpenOverlayRouter released!

Al

Sasha,

Thanks,

— Carlos.

  _____  

Hi all,

* Who can use it *

* Supported protocols *

* Code *

Thanks!

_______________________________________________
nvo3 mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/nvo3> https://www.ietf.org/mailman/listinfo/nvo3