Subject: Re: [nvo3] Mail regarding draft-ietf-nvo3-arch

From: "Black, David" <[email-masked]>
Date: Mon, 7 Mar 2016 03:35:29 +0000

Hello Saumya,

> This one is specific to deal with problem of "non-unique/duplicate NVE identifiers" configured either due to erroneous configuration OR

To err is human - and that's one of a myriad of possible configuration mistakes ... listing all of them seems pointless.

> OR In case of two Distinct NVO3 data-center networks connected over a DCI/WAN gateway to each other as mentioned in section "9. Federated NVAs"

That's actually covered in Section 9:

"IP-G would then decapsulate received traffic
   from one NV Domain, translate it appropriately for the other domain
   and re-encapsulate the packet for delivery."

> *          Some more elaboration required in section "9.1. Inter-NVA Peering" on what kind of filters/mappings for ensuring this uniqueness

As section 9.1 says:

"   To support peering between different NVAs, an inter-NVA protocol is
   needed.  The inter-NVA protocol defines what information is exchanged
   between NVAs."

If you have such a protocol design or design framework, please "send draft" to the WG, as how to design such a protocol is outside the current scope of the architecture draft (IMHO).

Thanks, --David

From: Saumya Dikshit (sadikshi) [mailto:[email-masked]]
Sent: Sunday, February 14, 2016 2:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: Mail regarding draft-ietf-nvo3-arch

Hello Authors,

I have a query if the following needs a specific mention as a requirement or as a potential problem in the nvo3 architecture document:

This one is specific to deal with problem of "non-unique/duplicate NVE identifiers" configured either due to erroneous configuration OR
In case of two Distinct NVO3 data-center networks connected over a DCI/WAN gateway to each other as mentioned in section "9. Federated NVAs"

  *   Is there a requirement where-in this problem can to be explicitly mapped to in any of the architecture requirements in the document.
  *   Some more elaboration required in section "9.1. Inter-NVA Peering" on what kind of filters/mappings for ensuring this uniqueness
  *   This one is specific as the next hop (Overlay tunnel end-point) related information is duplicated.
Thanks
Saumya.

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 7 Mar 2016 05:26:33 +0000

Hi David,

Thanks for clarifying. All my queries were in relation to problem statement "identifying and resolving non-unique/duplicate NVE identifiers", as observed in few vendor deployments.
I think this will require end to end support between NVA<->NVE and NVA<->NVA with respect to any (extensions to existing or new) control protocol.

Regards,
Saumya.

From: <Black>, David <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 7, 2016 at 9:05 AM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Black, David" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Mail regarding draft-ietf-nvo3-arch

Hello Saumya,

As section 9.1 says:

Thanks, --David

From: Saumya Dikshit (sadikshi) [mailto:[email-masked]]
Sent: Sunday, February 14, 2016 2:07 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Mail regarding draft-ietf-nvo3-arch

Hello Authors,