Subject: [nvo3] Document shepherd comments on draft-ietf-nvo3-mcast-framework-04

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thu, 5 May 2016 09:59:15 +0000

Authors

I think this draft is mostly good to progress, but I have a few comments that I think should be addressed before I forward it to the IESG for publication.
I have also forwarded the draft to the chairs of the MBONED working group to see if it needs further review and will wait for their response before proceeding.

Here are my comments:

(1) Title:
“A Framework for Multicast in NVO3”
Please expand NVO3 in the title. Similar to the architecture draft, this might be better as “A Framework for Multicast in Data Centre Network Virtualisation Overlays (NVO3)”.

(2) Throughout: Please make sure you expand acronyms on first use, throughout, e.g. mDNS in the Introduction.

(3) Section 3, first paragraph.
This references STT. It might be better to reference the encapsulations that have been adopted by the working group (GUE, GENEVE, and VXLAN-GPE)  rather than an individual draft submission.

(4) Section 3.4, last paragraph:
S/main/maintain

(5) Section 9, References
You have split these into Normative and Informative references. However, you draft is informational, so I am not sure it makes sense to have any normative references. Further, you have included information documents such as the NVO3 architecture as normative references.
Please also include the full draft reference and version you are referencing (e.g. draft-ietf-nvo3-arch-03) rather than just the title of a draft.

(6) ID-Nits
Please can you run ID-Nits on the draft and clear any relevant errors and warnings.

Regards

Matthew

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 5 May 2016 17:19:52 -0700

Matthew,

Many thanks for the review/comments.  Please see inline.

Anoop

On Thu, May 5, 2016 at 2:59 AM, Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> Authors
>
> I think this draft is mostly good to progress, but I have a few comments
> that I think should be addressed before I forward it to the IESG for
> publication.
> I have also forwarded the draft to the chairs of the MBONED working group
> to see if it needs further review and will wait for their response before
> proceeding.
>
> Here are my comments:
>
> (1) Title:
> Please expand NVO3 in the title. Similar to the architecture draft, this
> might be better as “A Framework for Multicast in Data Centre
> Network Virtualisation Overlays (NVO3)”.
>

Will do.

(As an aside, why do we have a "3" in the acronym when it doesn't appear
anywhere in the expansion?  I know it's kind of late to be asking that. :))

>
> (2) Throughout: Please make sure you expand acronyms on first use,
> throughout, e.g. mDNS in the Introduction.
>
> Will do.

> This references STT. It might be better to reference the encapsulations
> that have been adopted by the working group (GUE, GENEVE, and VXLAN-GPE)
>  rather than an individual draft submission.
>
> I will add them.

> Will fix.

> You have split these into Normative and Informative references. However,
> you draft is informational, so I am not sure it makes sense to have any
> normative references. Further, you have included information documents such
> as the NVO3 architecture as normative references.
>

This follows from what the guidance from the IESG:
https://www.ietf.org/iesg/statement/normative-informative.html
Within an RFC, references to other documents fall into two general
categories: "normative" and "informative". Normative references specify
documents that must be read to _understand_ or implement the technology in
the new RFC, or whose technology must be present for the technology in the
new RFC to work.

Have the authors misinterpreted the IESG guidance?

> Please also include the full draft reference and version you are
> referencing (e.g. draft-ietf-nvo3-arch-03) rather than just the title of a
> draft.
>
>
Will do.

(6) ID-Nits
> Will do.

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Mon, 9 May 2016 10:09:45 +0000

Anoop

The ‘3’ in NVO3 comes from the original title we used during the BoF, which was 'Network Virtualization over Layer 3’. The ‘3’ then subesequently stuck.

Regards

Matthew

From: <[email-masked]<mailto:[email-masked]>> on behalf of EXT Anoop Ghanwani <[email-masked]<mailto:[email-masked]>>
Date: Friday, 6 May 2016 at 01:19
To: Matthew Bocci <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Benson Schliesser <[email-masked]<mailto:[email-masked]>>, NVO3 <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Document shepherd comments on draft-ietf-nvo3-mcast-framework-04

Matthew,

Anoop

On Thu, May 5, 2016 at 2:59 AM, Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Authors

Here are my comments:

(1) Title:

Will do.

(As an aside, why do we have a "3" in the acronym when it doesn't appear anywhere in the expansion?  I know it's kind of late to be asking that. :))

Will do.

I will add them.

Will fix.

Within an RFC, references to other documents fall into two general categories: "normative" and "informative". Normative references specify documents that must be read to _understand_ or implement the technology in the new RFC, or whose technology must be present for the technology in the new RFC to work.

Will do.

(6) ID-Nits

Will do.

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 9 May 2016 22:28:29 -0700

Hi Matthew,

Thanks for the clarification.  We have submitted -05
https://tools.ietf.org/html/draft-ietf-nvo3-mcast-framework-05
to address your comments.

Let us know if it looks good to proceed.

Thanks,
Anoop

On Mon, May 9, 2016 at 3:09 AM, Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> Anoop
>
> The ‘3’ in NVO3 comes from the original title we used during the BoF,
> which was 'Network Virtualization over Layer 3’. The ‘3’ then subesequently
> stuck.
>
> Regards
>
> Matthew
>
>
>
> From: <[email-masked]> on behalf of EXT Anoop Ghanwani <
> [email-masked]>
> To: Matthew Bocci <[email-masked]>
> Cc: "[email-masked]" <
> [email-masked]>, Benson Schliesser <
> [email-masked]>, NVO3 <[email-masked]>

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Fri, 13 May 2016 09:39:34 +0000

Anoop

Thanks for the new version.

Just a heads up that, as suggested previously, we have asked MBONED to review the draft. They will send any comments to the NVO3 working group list.

Best regards

Matthew

Date: Tuesday, 10 May 2016 at 06:28

Hi Matthew,

Thanks,
Anoop

On Mon, May 9, 2016 at 3:09 AM, Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Anoop

Regards

Matthew

Matthew,

Anoop

Here are my comments:

(1) Title:

Will do.

Will do.

I will add them.

Will fix.

Will do.

(6) ID-Nits

Will do.

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 13 May 2016 11:46:04 -0700

Hi Matthew,

Is there a timeline that the MBONED folks are working with?

Thanks,
Anoop

On Fri, May 13, 2016 at 2:39 AM, Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> Just a heads up that, as suggested previously, we have asked MBONED to
> review the draft. They will send any comments to the NVO3 working group
> list.
>
> Best regards
>
> Matthew
>
>>> I have also forwarded the draft to the chairs of the MBONED working
>>> group to see if it needs further review and will wait for their response
>>> before proceeding.
>>>
>>> Here are my comments:
>>>
>>> (1) Title: