Subject: [nvo3] Mirja Kühlewind's Discuss on draft-ietf-nvo3-mcast-framework-10: (with DISCUSS)

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 09 Oct 2017 08:57:07 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-nvo3-mcast-framework-10: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-nvo3-mcast-framework/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Based on the feedback provided by the tsv-art review (Thanks Colin!) I would
like to see a paragraph or short section that discusses how replication as used
in section 3.2 and 3.3 can impact multicast congestion control and also
provides a pointer to draft-ietf-tsvwg-ecn-encap-guidelines-09 in case ECN is
supported in the NVO network which can likely be the case in data center
scenarios.

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 9 Oct 2017 21:34:59 +0000

Mirja,

Actually sending more copies of the same packet, especially multicast packets, rarely cause congestion.
Congestion only occurs when links’ utilization reach close to 100% as most switches/routers today can handle wire speed forwarding. The rule of thumb of deploying network is 50% link utilization, especially in data center where links can be added very easily.

In addition, Application based multicast is less than 2% of total traffic. Anyway, to make Collin happy, I already inserted one sentence in the following original paragraph (in purple) in -10 version which has been uploaded:

      “This method requires multiple copies of the same packet to all NVEs that participate in the VN.  If, for example, a tenant subnet is spread across 50 NVEs, the packet would have to be replicated 50 times at the source NVE.  Obviously, this approach creates more traffic to the network that can cause congestion when the network load is high. This also creates an issue with the forwarding performance of the NVE.”

ECN for NVO3 network is totally different subject. It will take a lot to describe ECN clearly for NVO3 network. To the least, it is not even clear of the scenario, use cases, and implication for ECN for NVO3.

Therefore, we don’t believe it is within the scope of this draft to discuss or reference ECN for this draft.

Linda Dunbar

-----Original Message-----
From: Mirja Kühlewind [mailto:[email-masked]]
Sent: Monday, October 09, 2017 10:57 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; Sam Aldrin <[email-masked]>; Matthew Bocci <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Mirja Kühlewind's Discuss on draft-ietf-nvo3-mcast-framework-10: (with DISCUSS)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Based on the feedback provided by the tsv-art review (Thanks Colin!) I would like to see a paragraph or short section that discusses how replication as used in section 3.2 and 3.3 can impact multicast congestion control and also provides a pointer to draft-ietf-tsvwg-ecn-encap-guidelines-09 in case ECN is supported in the NVO network which can likely be the case in data center scenarios.

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Tue, 10 Oct 2017 09:00:28 +0200

Hi Linda,

the point is not that this may cause congestion or to make NVO3 ECN enabled. The points are that if packet replication is used that may break some assumption that the congestion control that is already in use for multicast traffic makes (see Colins mail). On ECN there is actually nothing specific about using ECN in an NVO3 network; you can probably just do it. However if you use tunneling it’s good to point people at draft-ietf-tsvwg-ecn-encap-guidelines-09. That’s all.

Maybe you can go back to Colin and ask him to propose some short text.

Mirja

> Am 09.10.2017 um 23:34 schrieb Linda Dunbar <[email-masked]>:
> 
> Mirja, 
>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 10 Oct 2017 19:51:53 +0000

Collin, 

Per Mirja, can you provide a sentence to explain the following? 
-  If there is no congestion caused by replication by the NVE for multicast frame, how is ECN impacted? 
- Is the impact only specific to the replication for multicast data frame or is the impact same to uni-cast data frame as well?

Thanks, Linda

-----Original Message-----
From: Mirja Kuehlewind (IETF) [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2017 2:00 AM
To: Linda Dunbar <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; Matthew Bocci <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Mirja Kühlewind's Discuss on draft-ietf-nvo3-mcast-framework-10: (with DISCUSS)

Hi Linda,

Mirja

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 13 Oct 2017 16:06:14 +0000

Mirja,

I haven't got feedback from Collin on the proper wording to be inserted.

Do you think if adding the following sentence (in purple) to Section 3.2 will be good enough?

      “This method requires multiple copies of the same packet to all NVEs that participate in the VN.  If, for example, a tenant subnet is spread across 50 NVEs, the packet would have to be replicated 50 times at the source NVE.  Obviously, this approach creates more traffic to the network that can cause congestion when the network load is high. This also creates an issue with the forwarding performance of the NVE.
       In addition, if ECN is enabled, NVEs should following the guidelines described in [ECN-ENCAP].”

Please let us know as soon as possible, so we can upload the new version to move the draft forward.

Thank you. Linda

-----Original Message-----
From: Linda Dunbar
Sent: Tuesday, October 10, 2017 2:52 PM
To: 'Mirja Kuehlewind (IETF)' <[email-masked]>; 'Colin Perkins' <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; Matthew Bocci <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Mirja Kühlewind's Discuss on draft-ietf-nvo3-mcast-framework-10: (with DISCUSS)

Collin,

Thanks, Linda

-----Original Message-----
From: Mirja Kuehlewind (IETF) [mailto:[email-masked]]
Sent: Tuesday, October 10, 2017 2:00 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Matthew Bocci <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Mirja Kühlewind's Discuss on draft-ietf-nvo3-mcast-framework-10: (with DISCUSS)

Hi Linda,

Mirja

> Am 09.10.2017 um 23:34 schrieb Linda Dunbar <[email-masked]<mailto:[email-masked]>>:
>
> Mirja,
>
> To: The IESG <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>; Sam Aldrin <[email-masked]<mailto:[email-masked]>>; Matthew Bocci <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>