Subject: [nvo3] I: New Version Notification for draft-fmm-nvo3-pm-alt-mark-01.txt

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 2 Mar 2018 09:38:20 +0000

Hi All,
We have refreshed this draft on Alternate Marking application in NVO3 and updated the reference to RFC8321. 

Feedbacks are always welcome.

Thanks,

Giuseppe

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] 
Inviato: venerdì 2 marzo 2018 10:28
A: Gregory Mirsky; Fioccola Giuseppe; Tal Mizrahi; Greg Mirsky
Oggetto: New Version Notification for draft-fmm-nvo3-pm-alt-mark-01.txt

A new version of I-D, draft-fmm-nvo3-pm-alt-mark-01.txt has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.

Name:		draft-fmm-nvo3-pm-alt-mark
Revision:	01
Title:		Performance Measurement (PM) with Alternate Marking in Network Virtualization Overlays (NVO3)
Document date:	2018-03-02
Group:		Individual Submission
Pages:		11
URL:            https://www.ietf.org/internet-drafts/draft-fmm-nvo3-pm-alt-mark-01.txt
Status:         https://datatracker.ietf.org/doc/draft-fmm-nvo3-pm-alt-mark/
Htmlized:       https://tools.ietf.org/html/draft-fmm-nvo3-pm-alt-mark-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-fmm-nvo3-pm-alt-mark-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-fmm-nvo3-pm-alt-mark-01

Abstract:
   This document describes how the alternate marking method can be used
   for performance measurement method in a Network Virtualization
   Overlays (NVO3) Domain.  The description aims to be general for NVO3
   encapsulations, but is focused to Geneve, recommended by the NVO3
   design team [I-D.ietf-nvo3-encap].

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: [email-masked] (Dale R. Worley)
Date: Sun, 04 Mar 2018 10:45:10 -0500

> and updated the reference to RFC8321. 

I was reading somewhere (and it must have ultimately been linked from
NVO3) of a scheme that provided the benefits of two-bit marking, but
used only one bit.  The concept was that in the middle of each block of
packets with a single value of the L bit, a single packet has the bit
inverted:

0 0 0 0 0 1 0 0 0 0 0 1 1 1 1 1 0 1 1 1 1 1 0 0 0 0 0 1 0 0 0 0 0 1 1 ...

The idea being that examining the stream of packets, as long as the loss
rate is low, the packets with the inverted bit can be identified because
all of the nearby packets have the opposite L value, and the observed L
bit values decomposed into the effective L and D bits:

Lobs: 0 0 0 0 0 1 0 0 0 0 0 1 1 1 1 1 0 1 1 1 1 1 0 0 0 0 0 1 0 0 0 0 0 1 1 ...

Leff: 0 0 0 0 0 0 0 0 0 0 0 1 1 1 1 1 1 1 1 1 1 1 0 0 0 0 0 0 0 0 0 0 0 1 1 ...

Deff: 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0 ...

>From there, processing works as in two-bit marking.

If this works in practice, it would be advantageous because it requires
only one bit from each packet, and such bits are always in short
supply.  In the case of Geneve, there are 6 bits currently reserved, and
it would be helpful if PM marking only consumed 16% of them.

Dale

---

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 28 Mar 2018 08:47:35 +0000

Hi Dale,
Sorry for my late reply!
That's right! The possibility you mention is described in draft-mizrahi-ippm-compact-alternate-marking.
In the next version we can update the document with a new section about the multiplexing marking alternative that is certainly preferred if only 1 bit can be used.

Best Regards,

Giuseppe 

-----Messaggio originale-----
Da: Dale R. Worley [mailto:[email-masked]] 
Inviato: domenica 4 marzo 2018 16:45
A: Fioccola Giuseppe
Cc: [email-masked]; [email-masked]
Oggetto: Re: [nvo3] I: New Version Notification for draft-fmm-nvo3-pm-alt-mark-01.txt

I was reading somewhere (and it must have ultimately been linked from
NVO3) of a scheme that provided the benefits of two-bit marking, but used only one bit.  The concept was that in the middle of each block of packets with a single value of the L bit, a single packet has the bit
inverted:

The idea being that examining the stream of packets, as long as the loss rate is low, the packets with the inverted bit can be identified because all of the nearby packets have the opposite L value, and the observed L bit values decomposed into the effective L and D bits:

>From there, processing works as in two-bit marking.

If this works in practice, it would be advantageous because it requires only one bit from each packet, and such bits are always in short supply.  In the case of Geneve, there are 6 bits currently reserved, and it would be helpful if PM marking only consumed 16% of them.

Dale