Subject: [nvo3] I-D Action: draft-ietf-nvo3-geneve-06.txt

From: [email-masked]
Date: Mon, 05 Mar 2018 15:39:44 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Virtualization Overlays WG of the IETF.

        Title           : Geneve: Generic Network Virtualization Encapsulation
        Authors         : Jesse Gross
                          Ilango Ganga
                          T. Sridhar
	Filename        : draft-ietf-nvo3-geneve-06.txt
	Pages           : 26
	Date            : 2018-03-05

Abstract:
   Network virtualization involves the cooperation of devices with a
   wide variety of capabilities such as software and hardware tunnel
   endpoints, transit fabrics, and centralized control clusters.  As a
   result of their role in tying together different elements in the
   system, the requirements on tunnels are influenced by all of these
   components.  Flexibility is therefore the most important aspect of a
   tunnel protocol if it is to keep pace with the evolution of the
   system.  This draft describes Geneve, a protocol designed to
   recognize and accommodate these changing capabilities and needs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nvo3-geneve/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-nvo3-geneve-06
https://datatracker.ietf.org/doc/html/draft-ietf-nvo3-geneve-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nvo3-geneve-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Tue, 6 Mar 2018 00:20:28 +0000

Hi All,

We refreshed draft-ietf-nvo3-geneve with few changes as noted below:
1. Clarification to text on the option length field
2. Updated the references

Regards,
Ilango

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, March 5, 2018 3:40 PM
To: [email-masked]
Cc: [email-masked]
Subject: [nvo3] I-D Action: draft-ietf-nvo3-geneve-06.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 7 Mar 2018 21:12:14 +0000

Hi Ilango,

During the RFC8300 last call process, and the associated secdir review, Eric (cc’d here) raised significant concerns wrt the lack of mandatory integrity protection as specified in BCP72.  RFC8300’s editors worked closely with him, Kathleen, the chairs and Alia to insert appropriate language to help educate the reader about these risks.  

Geneve's architecture seems similar enough to RFC8300's that similar concerns will likely be raised so I wanted to mention them prior to last call.

Thanks
Paul

> On Mar 5, 2018, at 7:20 PM, Ganga, Ilango S <[email-masked]> wrote:
> 
> Hi All,
>

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Fri, 9 Mar 2018 22:29:27 +0000

Hi Paul,

Thank you for bringing this to our attention. We are somewhat aware of the concerns raised during the RFC8300 last call process. We will review RFC8300 security consideration section and add any appropriate text as applicable to Geneve. 

Regards,
Ilango

-----Original Message-----
From: Paul Quinn (paulq) [mailto:[email-masked]] 
Sent: Wednesday, March 7, 2018 1:12 PM
To: Ganga, Ilango S <[email-masked]>
Cc: [email-masked]; Carlos Pignataro (cpignata) <[email-masked]>; Elzur, Uri <[email-masked]>; Joel M. Halpern <[email-masked]>; Jim Guichard <[email-masked]>; Alia Atlas <[email-masked]>; Eric Rescorla <[email-masked]>; Kathleen Moriarty <[email-masked]>
Subject: Re: [nvo3] I-D Action: draft-ietf-nvo3-geneve-06.txt

Hi Ilango,

Thanks
Paul

> 1. Clarification to text on the option length field 2. Updated the 
> references
> 
> Regards,
> Ilango
> 
>