Subject: [OAUTH-WG] DPoP 03 - introspection - token_type?

From: Vladimir Dzhuvinov <[email-masked]>
Date: Sun, 15 Aug 2021 19:02:45 +0300

The token introspection RFC defines the optional "token_type" member and 
I just noticed that draft-ietf-oauth-dpop-03 doesn't mention it.

https://datatracker.ietf.org/doc/html/rfc7662#section-2.2

Would it be sensible to mention that if the "token_type" gets set in a 
introspection response, it must be "DPoP"?

https://datatracker.ietf.org/doc/html/draft-ietf-oauth-dpop-03#section-6.2

Vladimir

-- 
Vladimir Dzhuvinov

---

From: Justin Richer <[email-masked]>
Date: Mon, 16 Aug 2021 11:45:52 +0000

Yes, it should be. Good catch. 

-Justin
________________________________________
From: OAuth [[email-masked]] on behalf of Vladimir Dzhuvinov [[email-masked]]
Sent: Sunday, August 15, 2021 12:02 PM
To: [email-masked]
Subject: [OAUTH-WG] DPoP 03 - introspection - token_type?

Vladimir

--
Vladimir Dzhuvinov

---

From: Brian Campbell <[email-masked]>
Date: Mon, 16 Aug 2021 16:20:50 -0600

Yeah, I believe that logically follows from the definition of token_type in
introspection and RFC 6749.

Do y'all think it needs to be mentioned in DPoP though? I'm not sure, to be
honest.

On Mon, Aug 16, 2021 at 5:46 AM Justin Richer <[email-masked]> wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Justin Richer <[email-masked]>
Date: Tue, 17 Aug 2021 10:58:13 -0400

I think it can be a really simple mention as suggested here. I put it in a pull request:

https://github.com/danielfett/draft-dpop/pull/72 <https://github.com/danielfett/draft-dpop/pull/72>

I was actually surprised to see that the `token_type` value wasn’t already required to be DPoP (case insensitive) so I added that, too.

 — Justin

> On Aug 16, 2021, at 6:20 PM, Brian Campbell <[email-masked]> wrote:
> 
> Yeah, I believe that logically follows from the definition of token_type in introspection and RFC 6749. 
> 
> Do y'all think it needs to be mentioned in DPoP though? I'm not sure, to be honest. 
> 
> 
> 
> On Mon, Aug 16, 2021 at 5:46 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
> From: OAuth [[email-masked] <mailto:[email-masked]>] on behalf of Vladimir Dzhuvinov [[email-masked] <mailto:[email-masked]>]
> To: [email-masked] <mailto:[email-masked]>
> https://datatracker.ietf.org/doc/html/rfc7662#section-2.2 <https://datatracker.ietf.org/doc/html/rfc7662#section-2.2>
> 
> https://datatracker.ietf.org/doc/html/draft-ietf-oauth-dpop-03#section-6.2 <https://datatracker.ietf.org/doc/html/draft-ietf-oauth-dpop-03#section-6.2>
> 
> Vladimir
> 
> --
> Vladimir Dzhuvinov
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Brian Campbell <[email-masked]>
Date: Tue, 17 Aug 2021 09:27:30 -0600

Thanks Justin.

On Tue, Aug 17, 2021 at 8:58 AM Justin Richer <[email-masked]> wrote:

> https://github.com/danielfett/draft-dpop/pull/72
>
> I was actually surprised to see that the `token_type` value wasn’t already
> required to be DPoP (case insensitive) so I added that, too.
>
>  — Justin
>
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited.
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*
>
>
>